]> git.pld-linux.org Git - packages/SearchAndRescue.git/blob - SearchAndRescue.spec
- really pass our flags (flags.patch)
[packages/SearchAndRescue.git] / SearchAndRescue.spec
1 #
2 # TODO:
3 #       - fix default paths
4 #
5 # Conditional build:
6 %bcond_with     libY    # build with libY
7 %bcond_with     jsw     # uild with joystick support
8 #
9 %define         shortname       searchandrescue
10 %define         data_ver        1.0.0
11 Summary:        Search And Rescue - Linux flight simulator
12 Summary(pl.UTF-8):      Search And Rescue - symulator lotu śmigłowca
13 Name:           SearchAndRescue
14 Version:        1.1.0
15 Release:        0.1
16 License:        GPL v2+
17 Group:          X11/Applications/Games
18 Source0:        http://downloads.sourceforge.net/searchandrescue/Program/%{name}-%{version}.tar.gz
19 # Source0-md5:  f785d5968a8c3f57b021d40953ac4d32
20 Source1:        http://downloads.sourceforge.net/searchandrescue/Data_Files/%{name}-data-%{data_ver}.tar.gz
21 # Source1-md5:  da92f5fa7587cc0a712706d01b2f59f1
22 Patch0:         %{name}-flags.patch
23 URL:            http://searchandrescue.sourceforge.net/
24 BuildRequires:  OpenGL-devel
25 %{?with_liby:BuildRequires:     libY-devel}
26 %{?with_jsw:BuildRequires:      libjsw-devel}
27 BuildRequires:  xorg-xserver-server-devel
28 Requires:       OpenGL
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
32
33 %description
34 Linux flight simulator.
35
36 %description -l pl.UTF-8
37 Symulator lotu śmigłowcem.
38
39 %prep
40 %setup -q -n %{shortname}_%{version}
41 %patch0 -p1
42
43 %build
44 ./configure Linux \
45         --prefix=%{_prefix}
46
47 %{__make} \
48         LDFLAGS="%{rpmldflags}" \
49         OPTCFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
50         OPTCPPFLAGS="%{rpmcxxflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
55
56 %{__make} install \
57         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
58         GAMES_DIR=$RPM_BUILD_ROOT%{_bindir} \
59         MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man6 \
60         SHARE_GAMES_DIR=$RPM_BUILD_ROOT%{_datadir} \
61         SHADE_ICONS_DIR=$RPM_BUILD_ROOT%{_pixmapsdir}
62
63 # unpack data files
64 tar xvf %{SOURCE1} -C $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS INSTALL README
72 %attr(755,root,root) %{_bindir}/*
73 %{_datadir}/games/%{shortname}
74 %{_pixmapsdir}/SearchAndRescue.xpm
75 %{_mandir}/man6/*
This page took 0.294388 seconds and 4 git commands to generate.