]> git.pld-linux.org Git - packages/SearchAndRescue.git/blob - SearchAndRescue.spec
- restore one TODO (default paths are not fixed yet)
[packages/SearchAndRescue.git] / SearchAndRescue.spec
1 #
2 # TODO:
3 #       - fix default paths
4 #
5 # Conditional build:
6 %bcond_with     libY    # build with libY
7 %bcond_with     jsw     # uild with joystick support
8 #
9 %define         shortname       searchandrescue
10 Summary:        Search And Rescue - Linux flight simulator
11 Summary(pl.UTF-8):      Search And Rescue - symulator lotu śmigłowca
12 Name:           SearchAndRescue
13 Version:        1.0.0
14 Release:        0.1
15 License:        GPL v2+
16 Group:          X11/Applications/Games
17 Source0:        http://downloads.sourceforge.net/searchandrescue/Program/%{name}-%{version}.tar.gz
18 # Source0-md5:  3197fe440472e27d36477daaba3b1023
19 Source1:        http://downloads.sourceforge.net/searchandrescue/Data_Files/%{name}-data-%{version}.tar.gz
20 # Source1-md5:  da92f5fa7587cc0a712706d01b2f59f1
21 URL:            http://searchandrescue.sourceforge.net/
22 BuildRequires:  OpenGL-devel
23 %{?with_liby:BuildRequires:     libY-devel}
24 %{?with_jsw:BuildRequires:      libjsw-devel}
25 BuildRequires:  xorg-xserver-server-devel
26 Requires:       OpenGL
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 Linux flight simulator.
33
34 %description -l pl.UTF-8
35 Symulator lotu śmigłowcem.
36
37 %prep
38 %setup -q -n %{shortname}_%{version}
39
40 %build
41 ./configure Linux --prefix=%{_prefix}
42 %{__make} \
43         LDFLAGS="%{rpmldflags}" OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
48
49 %{__make} install \
50         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
51         GAMES_DIR=$RPM_BUILD_ROOT%{_bindir} \
52         MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man6 \
53         SHARE_GAMES_DIR=$RPM_BUILD_ROOT%{_datadir} \
54         SHADE_ICONS_DIR=$RPM_BUILD_ROOT%{_pixmapsdir}
55
56 # unpack data files
57 tar xvf %{SOURCE1} -C $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS INSTALL README
65 %attr(755,root,root) %{_bindir}/*
66 %{_datadir}/games/%{shortname}
67 #%%{_iconsdir}/SearchAndRescue.xpm
68 %{_mandir}/man6/*
This page took 0.034873 seconds and 4 git commands to generate.