]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- Release 5.
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.2
20 Release:        5
21 License:        LGPL
22 Group:          X11/Libraries
23 Group(de):      X11/Libraries
24 Group(es):      X11/Bibliotecas
25 Group(fr):      X11/Librairies
26 Group(pl):      X11/Biblioteki
27 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
28 Patch0:         %{name}-byteorder.patch
29 Patch1:         %{name}-fixlibs.patch
30 URL:            http://www.libsdl.org/
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 %{!?_without_esound:BuildRequires:      esound-devel}
34 %{!?_without_arts:BuildRequires:        arts-devel}
35 BuildRequires:  gtk+-devel >= 1.2.1
36 BuildRequires:  XFree86-devel >= 4.0.2
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  perl-modules
39 %ifnarch sparc sparc64
40 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
41 %endif
42 %{?_with_svgalib:BuildRequires: svgalib-devel}
43 %{?_with_aalib:BuildRequires:   aalib-devel}
44 %{?_with_ggi:BuildRequires:     libggi-devel}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _prefix         /usr/X11R6
48 %define         _mandir         %{_prefix}/man
49
50 %description
51 SDL (Simple DirectMedia Layer) is a library that allows you portable,
52 low level access to a video framebuffer, audio output, mouse, and
53 keyboard. It can support both windowed and DGA modes of XFree86, and
54 it is designed to be portable - applications linked with SDL can also
55 be built on Win32 and BeOS.
56
57 %description -l pl
58 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
59 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
60 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
61 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
62 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
63
64 %description -l pt_BR
65 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de baixo
66 nível a áudio, teclado, mouse e vídeo em várias plataformas.
67
68 Essa biblioteca é usada por alguns jogos.
69
70 %package devel
71 Summary:        SDL - Header files
72 Summary(pl):    SDL - Pliki nag³ówkowe
73 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
74 Group:          X11/Libraries
75 Group(de):      X11/Libraries
76 Group(es):      X11/Bibliotecas
77 Group(fr):      X11/Librairies
78 Group(pl):      X11/Biblioteki
79 Requires:       %{name} = %{version}
80 %ifnarch sparc sparc64
81 %{!?_without_alsa:Requires:     alsa-lib-devel}
82 %endif
83 %{!?_without_esound:Requires:   esound-devel}
84 %{!?_without_arts:Requires:     arts-devel}
85
86 %description devel
87 SDL - Header files.
88
89 %description -l pl devel
90 SDL - Pliki nag³ówkowe.
91
92 %description -l pt_BR devel
93 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros recursos para o
94 desenvolvimento de aplicativos com SDL.
95
96 %package static
97 Summary:        SDL - static libraries
98 Summary(pl):    SDL - biblioteki statyczne
99 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
100 Group:          X11/Libraries
101 Group(de):      X11/Libraries
102 Group(es):      X11/Bibliotecas
103 Group(fr):      X11/Librairies
104 Group(pl):      X11/Biblioteki
105 Requires:       %{name}-devel = %{version}
106
107 %description static
108 SDL - static libraries.
109
110 %description -l pl static
111 SDL - biblioteki statyczne.
112
113 %description -l pt_BR static
114 Biblioteca estática para desenvolvimento de aplicações com a SDL.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119 %patch1 -p1
120
121 %build
122 aclocal
123 autoconf
124 automake -a -c
125 %configure \
126 %ifnarch sparc sparc64
127         %{!?_without_alsa:--enable-alsa} \
128 %endif
129         --enable-nasm \
130         --enable-pthreads \
131         --enable-pthread-sem \
132         --with-x \
133         --enable-video-x11-vm \
134         --enable-video-x11-dga \
135         --enable-video-x11-mtrr \
136         --enable-video-x11-dgamouse \
137         --enable-video-opengl \
138         %{!?_without_esound:--enable-esd} \
139         %{!?_without_arts:--enable-arts} \
140         %{?_with_svga:--enable-video-svga} \
141         %{?_with_aalib:--enable-video-aalib} \
142         %{?_with_ggi:--enable-video-ggi}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT \
149         m4datadir=%{_aclocaldir}
150
151 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
152
153 gzip -9nf BUGS CREDITS README TODO WhatsNew
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/lib*.so.*.*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
168 %attr(755,root,root) %{_bindir}/sdl-config
169 %attr(755,root,root) %{_libdir}/lib*.so
170 %attr(755,root,root) %{_libdir}/lib*.la
171 %{_libdir}/libSDLmain.a
172 %{_includedir}/SDL
173 %{_aclocaldir}/*
174 %{_mandir}/man3/*
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
This page took 0.056235 seconds and 4 git commands to generate.