]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(es):    Simple DirectMedia Layer
16 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
17 Summary(pt_BR): Simple DirectMedia Layer
18 Name:           SDL
19 Version:        1.2.3
20 Release:        3
21 License:        LGPL
22 Group:          X11/Libraries
23 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
24 Patch0:         %{name}-byteorder.patch
25 Patch1:         %{name}-fixlibs.patch
26 Patch2:         %{name}-amfix.patch
27 Patch3:         %{name}-lpthread.patch
28 URL:            http://www.libsdl.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{!?_without_esound:BuildRequires:      esound-devel}
32 %{!?_without_arts:BuildRequires:        arts-devel}
33 BuildRequires:  gtk+-devel >= 1.2.1
34 BuildRequires:  XFree86-devel >= 4.0.2
35 BuildRequires:  OpenGL-devel
36 BuildRequires:  perl-modules
37 BuildRequires:  nasm
38 %ifnarch sparc sparc64
39 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
40 %endif
41 %{?_with_svgalib:BuildRequires: svgalib-devel}
42 %{?_with_aalib:BuildRequires:   aalib-devel}
43 %{?_with_ggi:BuildRequires:     libggi-devel}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _prefix         /usr/X11R6
47 %define         _mandir         %{_prefix}/man
48
49 %description
50 SDL (Simple DirectMedia Layer) is a library that allows you portable,
51 low level access to a video framebuffer, audio output, mouse, and
52 keyboard. It can support both windowed and DGA modes of XFree86, and
53 it is designed to be portable - applications linked with SDL can also
54 be built on Win32 and BeOS.
55
56 %description -l pl
57 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
58 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
59 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
60 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
61 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
62
63 %description -l pt_BR
64 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
65 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
66
67 Essa biblioteca é usada por alguns jogos.
68
69 %package devel
70 Summary:        SDL - Header files
71 Summary(pl):    SDL - Pliki nag³ówkowe
72 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 %ifnarch sparc sparc64
76 %{!?_without_alsa:Requires:     alsa-lib-devel}
77 %endif
78 %{!?_without_esound:Requires:   esound-devel}
79 %{!?_without_arts:Requires:     arts-devel}
80 Requires:       XFree86-devel >= 4.0.2
81
82 %description devel
83 SDL - Header files.
84
85 %description -l pl devel
86 SDL - Pliki nag³ówkowe.
87
88 %description -l pt_BR devel
89 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
90 recursos para o desenvolvimento de aplicativos com SDL.
91
92 %package static
93 Summary:        SDL - static libraries
94 Summary(pl):    SDL - biblioteki statyczne
95 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
96 Group:          X11/Libraries
97 Requires:       %{name}-devel = %{version}
98
99 %description static
100 SDL - static libraries.
101
102 %description -l pl static
103 SDL - biblioteki statyczne.
104
105 %description -l pt_BR static
106 Biblioteca estática para desenvolvimento de aplicações com a SDL.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112 %patch2 -p1
113 %patch3 -p1
114
115 %build
116 rm missing
117 libtoolize --copy --force
118 aclocal
119 autoconf
120 # Another hack
121 cp src/hermes/Makefile.in Makefile.in.ok
122 automake -a -c --foreign
123 cp Makefile.in.ok src/hermes/Makefile.in
124 %configure \
125 %ifnarch sparc sparc64
126         %{!?_without_alsa:--enable-alsa} \
127 %endif
128         --disable-nasm \
129         --enable-pthreads \
130         --enable-pthread-sem \
131         --with-x \
132         --enable-video-x11-vm \
133         --enable-video-x11-dga \
134         --enable-video-x11-mtrr \
135         --enable-video-x11-dgamouse \
136         --enable-video-opengl \
137         %{!?_without_esound:--enable-esd} \
138         %{!?_without_arts:--enable-arts} \
139         %{?_with_svga:--enable-video-svga} \
140         %{?_with_aalib:--enable-video-aalib} \
141         %{?_with_ggi:--enable-video-ggi}
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT \
148         m4datadir=%{_aclocaldir}
149
150 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
151
152 gzip -9nf BUGS CREDITS README TODO WhatsNew
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/lib*.so.*.*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
167 %attr(755,root,root) %{_bindir}/sdl-config
168 %attr(755,root,root) %{_libdir}/lib*.so
169 %attr(755,root,root) %{_libdir}/lib*.la
170 %{_libdir}/libSDLmain.a
171 %{_includedir}/SDL
172 %{_aclocaldir}/*
173 %{_mandir}/man3/*
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/lib*.a
This page took 0.070175 seconds and 4 git commands to generate.