]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- added am18 patch (sdl.m4 quotation fix)
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 %bcond_with     aalib           # with aalib graphics support
4 %bcond_with     directfb        # with DirectFB graphics support
5 %bcond_with     ggi             # with GGI graphics support
6 %bcond_with     nas             # with NAS audio support
7 %bcond_with     svga            # with svgalib graphics support
8 %bcond_without  alsa            # without ALSA audio support
9 %bcond_without  arts            # without aRts audio support
10 %bcond_without  esd             # without EsounD audio support
11 #
12 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
13 Summary(es):    Simple DirectMedia Layer
14 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
15 Summary(pt_BR): Simple DirectMedia Layer
16 Summary(ru):    Simple DirectMedia Layer
17 Summary(uk):    Simple DirectMedia Layer
18 Summary(zh_CN): SDL (Simple DirectMedia Layer) Generic APIs - ÓÎÏ·/¶àýÌå¿â
19 Name:           SDL
20 Version:        1.2.6
21 Release:        4
22 License:        LGPL
23 Group:          X11/Libraries
24 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
25 # Source0-md5:  9011f147f23ec535515291d0c9c6904c
26 Patch0:         %{name}-byteorder.patch
27 Patch1:         %{name}-fixlibs.patch
28 Patch2:         %{name}-amfix.patch
29 Patch3:         %{name}-lpthread.patch
30 Patch4:         %{name}-no_rpath_in_sdl-config.patch
31 Patch5:         %{name}-lt15.patch
32 Patch6:         %{name}-dlopen-acfix.patch
33 Patch7:         %{name}-mmx-constraints.patch
34 Patch8:         %{name}-am18.patch
35 URL:            http://www.libsdl.org/
36 %{?with_directfb:BuildRequires: DirectFB-devel >= 0.9.15}
37 BuildRequires:  OpenGL-devel
38 BuildRequires:  XFree86-devel >= 4.0.2
39 %{?with_aalib:BuildRequires:    aalib-devel}
40 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
41 %{?with_arts:BuildRequires:     artsc-devel >= 1.1}
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 %{?with_esd:BuildRequires:      esound-devel >= 0.2.8}
45 %{?with_ggi:BuildRequires:      libggi-devel}
46 BuildRequires:  libtool >= 2:1.4d
47 %{?with_nas:BuildRequires:      nas-devel}
48 %ifarch %{ix86}
49 BuildRequires:  nasm
50 %endif
51 BuildRequires:  perl-modules
52 %{?with_directfb:BuildRequires: pkgconfig >= 0.7}
53 %{?with_svgalib:BuildRequires:  svgalib-devel >= 1.4.0}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 SDL (Simple DirectMedia Layer) is a library that allows you portable,
58 low level access to a video framebuffer, audio output, mouse, and
59 keyboard. It can support both windowed and DGA modes of XFree86, and
60 it is designed to be portable - applications linked with SDL can also
61 be built on Win32 and BeOS.
62
63 %description -l pl
64 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
65 przeno¶ny, niskopoziomowy dostêp do bufora ramki video, wyj¶cia audio,
66 myszy oraz klawiatury. Mo¿e obs³ugiwaæ zarówno okienkowy tryb XFree86
67 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
68 konsolidowane z SDL mo¿na równie¿ budowaæ w systemach Win32 i BeOS.
69
70 %description -l pt_BR
71 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
72 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
73
74 Essa biblioteca é usada por alguns jogos.
75
76 %package devel
77 Summary:        SDL - Header files
78 Summary(pl):    SDL - Pliki nag³ówkowe
79 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
80 Summary(ru):    æÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ, ÉÓÐÏÌØÚÕÀÝÉÈ SDL
81 Summary(uk):    æÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL
82 Summary(zh_CN): SDL (Simple DirectMedia Layer) ¿ª·¢¿â
83 Group:          X11/Development/Libraries
84 Requires:       %{name} = %{version}
85 Requires:       XFree86-devel >= 4.0.2
86 %{?with_alsa:Requires:  alsa-lib-devel}
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 SDL - Header files.
91
92 %description devel -l pl
93 SDL - Pliki nag³ówkowe.
94
95 %description devel -l pt_BR
96 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
97 recursos para o desenvolvimento de aplicativos com SDL.
98
99 %description devel -l ru
100 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
101 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
102
103 %description devel -l uk
104 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
105 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
106
107 %package static
108 Summary:        SDL - static libraries
109 Summary(pl):    SDL - biblioteki statyczne
110 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
111 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ SDL
112 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ SDL
113 Group:          X11/Development/Libraries
114 Requires:       %{name}-devel = %{version}
115
116 %description static
117 SDL - static libraries.
118
119 %description static -l pl
120 SDL - biblioteki statyczne.
121
122 %description static -l pt_BR
123 Biblioteca estática para desenvolvimento de aplicações com a SDL.
124
125 %description static -l ru
126 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ,
127 ÉÓÐÏÌØÚÕÀÝÉÈ SDL.
128
129 %description static -l uk
130 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
131 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ SDL.
132
133 %package examples
134 Summary:        SDL - example programs
135 Summary(pl):    SDL - programy przyk³adowe
136 Group:          X11/Development/Libraries
137 Requires:       %{name}-devel = %{version}
138
139 %description examples
140 SDL - example programs.
141
142 %description examples -l pl
143 SDL - przyk³adowe programy.
144
145 %prep
146 %setup -q
147 %patch0 -p1
148 %patch1 -p1
149 %patch2 -p1
150 %patch3 -p1
151 %patch4 -p1
152 %patch5 -p1
153 %patch6 -p1
154 %patch7 -p1
155 %patch8 -p1
156
157 # get COPY_ARCH_SRC, remove the rest
158 head -n 16 acinclude.m4 > acinclude.tmp
159 mv -f acinclude.tmp acinclude.m4
160
161 find . -type d -name CVS -print | xargs rm -rf {} \;
162
163 %build
164 %{__libtoolize}
165 %{__aclocal}
166 %{__automake}
167 %{__autoconf}
168 CPPFLAGS="-DALSA_PCM_OLD_HW_PARAMS_API"
169 %configure \
170 %ifarch %{ix86}
171         --enable-nasm \
172 %else
173         --disable-nasm \
174 %endif
175         --enable-pthreads \
176         --enable-pthread-sem \
177         --with-x \
178         --enable-dga \
179         %{?with_aalib:--enable-video-aalib} \
180         --enable-video-dga \
181         %{?with_directfb:--enable-video-directfb} \
182         --enable-video-fbcon \
183         %{?with_ggi:--enable-video-ggi} \
184         --enable-video-opengl \
185         %{?with_svga:--enable-video-svga} \
186         --enable-video-x11-dgamouse \
187         --enable-video-x11-vm \
188         --enable-video-x11-xv \
189         %{!?with_alsa:--disable-alsa} \
190         %{!?with_arts:--disable-arts} \
191         %{!?with_esd:--disable-esd} \
192         %{!?with_nas:--disable-nas}
193
194 # automake chooses to use CXXLINK because of seen unused C++ sources
195 # (which are for BeOS and MacOS+QTopia, not Linux)
196 %{__make} \
197         CXXLINK="\$(LINK)"
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
202
203 %{__make} install \
204         DESTDIR=$RPM_BUILD_ROOT \
205         m4datadir=%{_aclocaldir}
206
207 install test/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
208
209 rm -rf docs/man3 docs/{Makefile*,.cvsignore} docs/html/{Makefile*,.cvsignore}
210
211 %clean
212 rm -rf $RPM_BUILD_ROOT
213
214 %post   -p /sbin/ldconfig
215 %postun -p /sbin/ldconfig
216
217 %files
218 %defattr(644,root,root,755)
219 %doc BUGS CREDITS README TODO WhatsNew
220 %attr(755,root,root) %{_libdir}/lib*.so.*.*
221
222 %files devel
223 %defattr(644,root,root,755)
224 %doc docs.html docs
225 %attr(755,root,root) %{_bindir}/sdl-config
226 %attr(755,root,root) %{_libdir}/lib*.so
227 %{_libdir}/lib*.la
228 %{_libdir}/libSDLmain.a
229 %{_includedir}/SDL
230 %{_aclocaldir}/*
231 %{_mandir}/man3/*
232
233 %files examples
234 %defattr(644,root,root,755)
235 %{_examplesdir}/%{name}-%{version}
236
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libSDL.a
This page took 0.04268 seconds and 4 git commands to generate.