]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- changed req for main subpkg in static subpkg to devel
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
16 Name:           SDL
17 Version:        1.2.2
18 Release:        4
19 License:        LGPL
20 Group:          X11/Libraries
21 Group(de):      X11/Libraries
22 Group(es):      X11/Bibliotecas
23 Group(fr):      X11/Librairies
24 Group(pl):      X11/Biblioteki
25 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
26 Patch0:         %{name}-byteorder.patch
27 Patch1:         %{name}-fixlibs.patch
28 URL:            http://www.libsdl.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{!?_without_esound:BuildRequires:      esound-devel}
32 %{!?_without_arts:BuildRequires:        arts-devel}
33 BuildRequires:  gtk+-devel >= 1.2.1
34 BuildRequires:  XFree86-devel >= 4.0.2
35 BuildRequires:  OpenGL-devel
36 BuildRequires:  perl-modules
37 %ifnarch sparc sparc64
38 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
39 %endif
40 %{?_with_svgalib:BuildRequires: svgalib-devel}
41 %{?_with_aalib:BuildRequires:   aalib-devel}
42 %{?_with_ggi:BuildRequires:     libggi-devel}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _prefix         /usr/X11R6
46 %define         _mandir         %{_prefix}/man
47
48 %description
49 SDL (Simple DirectMedia Layer) is a library that allows you portable,
50 low level access to a video framebuffer, audio output, mouse, and
51 keyboard. It can support both windowed and DGA modes of XFree86, and
52 it is designed to be portable - applications linked with SDL can also
53 be built on Win32 and BeOS.
54
55 %description -l pl
56 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
57 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
58 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
59 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
60 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
61
62 %package devel
63 Summary:        SDL - Header files
64 Summary(pl):    SDL - Pliki nag³ówkowe
65 Group:          X11/Libraries
66 Group(de):      X11/Libraries
67 Group(es):      X11/Bibliotecas
68 Group(fr):      X11/Librairies
69 Group(pl):      X11/Biblioteki
70 Requires:       %{name} = %{version}
71 %{!?_without_esound:Requires:   esound-devel}
72 %{!?_without_arts:Requires:     arts-devel}
73
74 %description devel
75 SDL - Header files.
76
77 %description -l pl devel
78 SDL - Pliki nag³ówkowe.
79
80 %package static
81 Summary:        SDL - static libraries
82 Summary(pl):    SDL - biblioteki statyczne
83 Group:          X11/Libraries
84 Group(de):      X11/Libraries
85 Group(es):      X11/Bibliotecas
86 Group(fr):      X11/Librairies
87 Group(pl):      X11/Biblioteki
88 Requires:       %{name}-devel = %{version}
89
90 %description static
91 SDL - static libraries.
92
93 %description -l pl static
94 SDL - biblioteki statyczne.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 aclocal
103 autoconf
104 automake -a -c
105 %configure \
106 %ifnarch sparc sparc64
107         %{!?_without_alsa:--enable-alsa} \
108 %endif
109         --enable-nasm \
110         --enable-pthreads \
111         --enable-pthread-sem \
112         --with-x \
113         --enable-video-x11-vm \
114         --enable-video-x11-dga \
115         --enable-video-x11-mtrr \
116         --enable-video-x11-dgamouse \
117         --enable-video-opengl \
118         %{!?_without_esound:--enable-esd} \
119         %{!?_without_arts:--enable-arts} \
120         %{?_with_svga:--enable-video-svga} \
121         %{?_with_aalib:--enable-video-aalib} \
122         %{?_with_ggi:--enable-video-ggi}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         m4datadir=%{_aclocaldir}
130
131 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
132
133 gzip -9nf BUGS CREDITS README TODO WhatsNew
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/lib*.so.*.*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
148 %attr(755,root,root) %{_bindir}/sdl-config
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %attr(755,root,root) %{_libdir}/lib*.la
151 %{_libdir}/libSDLmain.a
152 %{_includedir}/SDL
153 %{_aclocaldir}/*
154 %{_mandir}/man3/*
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.70871 seconds and 4 git commands to generate.