]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- release 3,
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha
11 %define _without_arts 1
12 %endif
13
14 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
15 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
16 Name:           SDL
17 Version:        1.2.2
18 Release:        3
19 License:        LGPL
20 Group:          X11/Libraries
21 Group(de):      X11/Libraries
22 Group(es):      X11/Bibliotecas
23 Group(fr):      X11/Librairies
24 Group(pl):      X11/Biblioteki
25 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
26 Patch0:         %{name}-byteorder.patch
27 Patch1:         %{name}-fixlibs.patch
28 URL:            http://www.libsdl.org/
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 %{!?_without_esound:BuildRequires:      esound-devel}
32 %{!?_without_arts:BuildRequires:        arts-devel}
33 BuildRequires:  gtk+-devel >= 1.2.1
34 BuildRequires:  XFree86-devel >= 4.0.2
35 BuildRequires:  OpenGL-devel
36 %ifnarch sparc sparc64
37 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
38 %endif
39 %{?_with_svgalib:BuildRequires: svgalib-devel}
40 %{?_with_aalib:BuildRequires:   aalib-devel}
41 %{?_with_ggi:BuildRequires:     libggi-devel}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _prefix         /usr/X11R6
45 %define         _mandir         %{_prefix}/man
46
47 %description
48 SDL (Simple DirectMedia Layer) is a library that allows you portable,
49 low level access to a video framebuffer, audio output, mouse, and
50 keyboard. It can support both windowed and DGA modes of XFree86, and
51 it is designed to be portable - applications linked with SDL can also
52 be built on Win32 and BeOS.
53
54 %description -l pl
55 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
56 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
57 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
58 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
59 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
60
61 %package devel
62 Summary:        SDL - Header files
63 Summary(pl):    SDL - Pliki nag³ówkowe
64 Group:          X11/Libraries
65 Group(de):      X11/Libraries
66 Group(es):      X11/Bibliotecas
67 Group(fr):      X11/Librairies
68 Group(pl):      X11/Biblioteki
69 Requires:       %{name} = %{version}
70 %{!?_without_esound:Requires:   esound-devel}
71 %{!?_without_arts:Requires:     arts-devel}
72
73 %description devel
74 SDL - Header files.
75
76 %description -l pl devel
77 SDL - Pliki nag³ówkowe.
78
79 %package static
80 Summary:        SDL - static libraries
81 Summary(pl):    SDL - biblioteki statyczne
82 Group:          X11/Libraries
83 Group(de):      X11/Libraries
84 Group(es):      X11/Bibliotecas
85 Group(fr):      X11/Librairies
86 Group(pl):      X11/Biblioteki
87 Requires:       %{name} = %{version}
88
89 %description static
90 SDL - static libraries.
91
92 %description -l pl static
93 SDL - biblioteki statyczne.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99
100 %build
101 aclocal
102 autoconf
103 automake -a -c
104 %configure \
105 %ifnarch sparc sparc64
106         %{!?_without_alsa:--enable-alsa} \
107 %endif
108         --enable-nasm \
109         --enable-pthreads \
110         --enable-pthread-sem \
111         --with-x \
112         --enable-video-x11-vm \
113         --enable-video-x11-dga \
114         --enable-video-x11-mtrr \
115         --enable-video-x11-dgamouse \
116         --enable-video-opengl \
117         %{!?_without_esound:--enable-esd} \
118         %{!?_without_arts:--enable-arts} \
119         %{?_with_svga:--enable-video-svga} \
120         %{?_with_aalib:--enable-video-aalib} \
121         %{?_with_ggi:--enable-video-ggi}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         m4datadir=%{_aclocaldir}
129
130 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
131
132 gzip -9nf BUGS CREDITS README TODO WhatsNew
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
147 %attr(755,root,root) %{_bindir}/sdl-config
148 %attr(755,root,root) %{_libdir}/lib*.so
149 %attr(755,root,root) %{_libdir}/lib*.la
150 %{_libdir}/libSDLmain.a
151 %{_includedir}/SDL
152 %{_aclocaldir}/*
153 %{_mandir}/man3/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.069119 seconds and 4 git commands to generate.