]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
- removed not needed requirement for gtk+-devel
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha ppc
11 %define _without_arts 1
12 %endif
13
14 %ifarch ppc
15 %define _without_alsa   1
16 %endif
17
18 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
19 Summary(es):    Simple DirectMedia Layer
20 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
21 Summary(pt_BR): Simple DirectMedia Layer
22 Name:           SDL
23 Version:        1.2.3
24 Release:        4
25 License:        LGPL
26 Group:          X11/Libraries
27 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
28 Patch0:         %{name}-byteorder.patch
29 Patch1:         %{name}-fixlibs.patch
30 Patch2:         %{name}-amfix.patch
31 Patch3:         %{name}-lpthread.patch
32 URL:            http://www.libsdl.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 %{!?_without_esound:BuildRequires:      esound-devel}
36 %{!?_without_arts:BuildRequires:        arts-devel}
37 BuildRequires:  XFree86-devel >= 4.0.2
38 BuildRequires:  OpenGL-devel
39 BuildRequires:  perl-modules
40 BuildRequires:  nasm
41 %ifnarch sparc sparc64
42 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
43 %endif
44 %{?_with_svgalib:BuildRequires: svgalib-devel}
45 %{?_with_aalib:BuildRequires:   aalib-devel}
46 %{?_with_ggi:BuildRequires:     libggi-devel}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _prefix         /usr/X11R6
50 %define         _mandir         %{_prefix}/man
51
52 %description
53 SDL (Simple DirectMedia Layer) is a library that allows you portable,
54 low level access to a video framebuffer, audio output, mouse, and
55 keyboard. It can support both windowed and DGA modes of XFree86, and
56 it is designed to be portable - applications linked with SDL can also
57 be built on Win32 and BeOS.
58
59 %description -l pl
60 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
61 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
62 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
63 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
64 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
65
66 %description -l pt_BR
67 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
68 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
69
70 Essa biblioteca é usada por alguns jogos.
71
72 %package devel
73 Summary:        SDL - Header files
74 Summary(pl):    SDL - Pliki nag³ówkowe
75 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
76 Group:          X11/Libraries
77 Requires:       %{name} = %{version}
78 %ifnarch sparc sparc64
79 %{!?_without_alsa:Requires:     alsa-lib-devel}
80 %endif
81 %{!?_without_esound:Requires:   esound-devel}
82 %{!?_without_arts:Requires:     arts-devel}
83 Requires:       XFree86-devel >= 4.0.2
84
85 %description devel
86 SDL - Header files.
87
88 %description -l pl devel
89 SDL - Pliki nag³ówkowe.
90
91 %description -l pt_BR devel
92 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
93 recursos para o desenvolvimento de aplicativos com SDL.
94
95 %package static
96 Summary:        SDL - static libraries
97 Summary(pl):    SDL - biblioteki statyczne
98 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
99 Group:          X11/Libraries
100 Requires:       %{name}-devel = %{version}
101
102 %description static
103 SDL - static libraries.
104
105 %description -l pl static
106 SDL - biblioteki statyczne.
107
108 %description -l pt_BR static
109 Biblioteca estática para desenvolvimento de aplicações com a SDL.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117
118 %build
119 rm missing
120 libtoolize --copy --force
121 aclocal
122 autoconf
123 # Another hack
124 cp src/hermes/Makefile.in Makefile.in.ok
125 automake -a -c --foreign
126 cp Makefile.in.ok src/hermes/Makefile.in
127 %configure \
128 %ifarch %{ix86}
129         --enable-nasm \
130 %else
131         --disable-nasm \
132 %endif
133         --enable-pthreads \
134         --enable-pthread-sem \
135         --with-x \
136         --enable-dga \
137         --enable-video-dga \
138         --enable-video-x11-dgamouse \
139         --enable-video-x11-vm \
140         --enable-video-x11-xv \
141         --enable-video-opengl \
142         --enable-video-fbcon \
143         %{?_with_svga:--enable-video-svga} \
144         %{?_with_aalib:--enable-video-aalib} \
145         %{?_with_ggi:--enable-video-ggi} \
146 %ifnarch sparc sparc64
147         %{!?_without_alsa:--enable-alsa} \
148 %endif
149         %{!?_without_esound:--enable-esd} \
150         %{!?_without_arts:--enable-arts}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT \
157         m4datadir=%{_aclocaldir}
158
159 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
160
161 gzip -9nf BUGS CREDITS README TODO WhatsNew
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %files
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/lib*.so.*.*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
176 %attr(755,root,root) %{_bindir}/sdl-config
177 %attr(755,root,root) %{_libdir}/lib*.so
178 %attr(755,root,root) %{_libdir}/lib*.la
179 %{_libdir}/libSDLmain.a
180 %{_includedir}/SDL
181 %{_aclocaldir}/*
182 %{_mandir}/man3/*
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/lib*.a
This page took 0.071595 seconds and 4 git commands to generate.