]> git.pld-linux.org Git - packages/SDL.git/blob - SDL.spec
a3ebdbdba49e533e4f14a1978bd69a662371cf71
[packages/SDL.git] / SDL.spec
1 #
2 # Conditional build:
3 # _without_alsa - without ALSA support
4 # _without_esound - without esound support
5 # _without_arts - without arts support
6 # _with_svga - with svgalib support
7 # _with_aalib - with aalib support
8 # _with_ggi - with GGI support
9 #
10 %ifarch alpha ppc
11 %define _without_arts 1
12 %endif
13
14 %ifarch ppc
15 %define _without_alsa   1
16 %endif
17
18 Summary:        SDL (Simple DirectMedia Layer) - Game/Multimedia Library
19 Summary(es):    Simple DirectMedia Layer
20 Summary(pl):    SDL (Simple DirectMedia Layer) - Biblioteka do gier/multimediów
21 Summary(pt_BR): Simple DirectMedia Layer
22 Name:           SDL
23 Version:        1.2.3
24 Release:        3
25 License:        LGPL
26 Group:          X11/Libraries
27 Source0:        http://www.libsdl.org/release/%{name}-%{version}.tar.gz
28 Patch0:         %{name}-byteorder.patch
29 Patch1:         %{name}-fixlibs.patch
30 Patch2:         %{name}-amfix.patch
31 Patch3:         %{name}-lpthread.patch
32 URL:            http://www.libsdl.org/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 %{!?_without_esound:BuildRequires:      esound-devel}
36 %{!?_without_arts:BuildRequires:        arts-devel}
37 BuildRequires:  gtk+-devel >= 1.2.1
38 BuildRequires:  XFree86-devel >= 4.0.2
39 BuildRequires:  OpenGL-devel
40 BuildRequires:  perl-modules
41 BuildRequires:  nasm
42 %ifnarch sparc sparc64
43 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
44 %endif
45 %{?_with_svgalib:BuildRequires: svgalib-devel}
46 %{?_with_aalib:BuildRequires:   aalib-devel}
47 %{?_with_ggi:BuildRequires:     libggi-devel}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _prefix         /usr/X11R6
51 %define         _mandir         %{_prefix}/man
52
53 %description
54 SDL (Simple DirectMedia Layer) is a library that allows you portable,
55 low level access to a video framebuffer, audio output, mouse, and
56 keyboard. It can support both windowed and DGA modes of XFree86, and
57 it is designed to be portable - applications linked with SDL can also
58 be built on Win32 and BeOS.
59
60 %description -l pl
61 SDL (Simple DirectMedia Layer) jest bibliotek± udostêpniaj±c±
62 przeno¶ny, niskopoziomowy dostep do bufora ramki video, wyj¶cia audio,
63 myszy oraz klawiatury, Moze obs³ugiwaæ zarówno okienkowy tryb XFree86
64 jak i DGA. Konstruuj±c j± miano na uwadze przeno¶no¶æ: aplikacje
65 konsolidowane z SDL mo¿na równie¿ budowac w systemach Win32 i BeOS.
66
67 %description -l pt_BR
68 Esse é o Simple DirectMedia Layer, uma API genérica que dá acesso de
69 baixo nível a áudio, teclado, mouse e vídeo em várias plataformas.
70
71 Essa biblioteca é usada por alguns jogos.
72
73 %package devel
74 Summary:        SDL - Header files
75 Summary(pl):    SDL - Pliki nag³ówkowe
76 Summary(pt_BR): Bibliotecas e arquivos de cabeçalho para aplicações SDL
77 Group:          X11/Libraries
78 Requires:       %{name} = %{version}
79 %ifnarch sparc sparc64
80 %{!?_without_alsa:Requires:     alsa-lib-devel}
81 %endif
82 %{!?_without_esound:Requires:   esound-devel}
83 %{!?_without_arts:Requires:     arts-devel}
84 Requires:       XFree86-devel >= 4.0.2
85
86 %description devel
87 SDL - Header files.
88
89 %description -l pl devel
90 SDL - Pliki nag³ówkowe.
91
92 %description -l pt_BR devel
93 Esse pacote contém bibliotecas, arquivos de cabeçalho e outros
94 recursos para o desenvolvimento de aplicativos com SDL.
95
96 %package static
97 Summary:        SDL - static libraries
98 Summary(pl):    SDL - biblioteki statyczne
99 Summary(pt_BR): Biblioteca estática para desenvolvimento de aplicações com a SDL
100 Group:          X11/Libraries
101 Requires:       %{name}-devel = %{version}
102
103 %description static
104 SDL - static libraries.
105
106 %description -l pl static
107 SDL - biblioteki statyczne.
108
109 %description -l pt_BR static
110 Biblioteca estática para desenvolvimento de aplicações com a SDL.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117 %patch3 -p1
118
119 %build
120 rm missing
121 libtoolize --copy --force
122 aclocal
123 autoconf
124 # Another hack
125 cp src/hermes/Makefile.in Makefile.in.ok
126 automake -a -c --foreign
127 cp Makefile.in.ok src/hermes/Makefile.in
128 %configure \
129 %ifnarch sparc sparc64
130         %{!?_without_alsa:--enable-alsa} \
131 %endif
132         --disable-nasm \
133         --enable-pthreads \
134         --enable-pthread-sem \
135         --with-x \
136         --enable-video-x11-vm \
137         --enable-video-x11-dga \
138         --enable-video-x11-mtrr \
139         --enable-video-x11-dgamouse \
140         --enable-video-opengl \
141         %{!?_without_esound:--enable-esd} \
142         %{!?_without_arts:--enable-arts} \
143         %{?_with_svga:--enable-video-svga} \
144         %{?_with_aalib:--enable-video-aalib} \
145         %{?_with_ggi:--enable-video-ggi}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT \
152         m4datadir=%{_aclocaldir}
153
154 rm -rf docs/man3 docs/Makefile* docs/html/Makefile*
155
156 gzip -9nf BUGS CREDITS README TODO WhatsNew
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %files
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/lib*.so.*.*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %doc {BUGS,CREDITS,README,TODO,WhatsNew}.gz docs.html docs
171 %attr(755,root,root) %{_bindir}/sdl-config
172 %attr(755,root,root) %{_libdir}/lib*.so
173 %attr(755,root,root) %{_libdir}/lib*.la
174 %{_libdir}/libSDLmain.a
175 %{_includedir}/SDL
176 %{_aclocaldir}/*
177 %{_mandir}/man3/*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/lib*.a
This page took 0.056174 seconds and 3 git commands to generate.