]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
- drop init.patch; fixed pre/post scripts with new init script
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - fix the method rxstarck is installed
3 #  - use bconds
4 #  - create subpackages
5
6 Summary:        Rexx interpreter
7 Summary(pl):    Interpreter jêzyka REXX
8 Name:           Regina
9 Version:        3.3
10 Release:        0.1
11 License:        GPL
12 Group:          Applications
13 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
14 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
15 Source1:        %{name}.init
16 Patch0:         %{name}-makefileinfix.patch
17 URL:            http://regina-rexx.sourceforge.net
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  rpmbuild(macros) >= 1.228
21 Requires(post,preun):   /sbin/chkconfig
22 Provides:       rexx
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Regina is a Rexx interpreter that has been ported to most Unix
27 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
28 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
29 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
30 programming language that was designed to be easy to use for
31 inexperienced programmers yet powerful enough for experienced users.
32 It is also a language ideally suited as a macro language for other
33 applications.
34
35 There are two major goals for Regina:
36
37     - become 100% compliant with the ANSI Standard.
38     - be available on as many platforms as possible
39
40 %description -l pl
41 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
42 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
43 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
44 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
45 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
46 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
47 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
48 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
49
50 Dwa g³ówne cele tego internretera, to
51  - Stuprocentowa kompatybilno¶æ ze standardemi ANSI
52  - dostêpno¶æ na jak najwiêkszej liczbie platform
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 %build
59 ./configure
60 %{__make} \
61         CC="%{__cc}" \
62         CFLAGS="%{rpmcflags}"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_mandir}/man1}
67 %{__make} install \
68     DESTDIR=$RPM_BUILD_ROOT
69 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/rxstack
70 install $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1 $RPM_BUILD_ROOT%{_mandir}/man1/
71 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
72 rm -f $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 /sbin/chkconfig --add rxstack
79
80 %preun
81 if [ "$1" = "0" ] ; then
82         %service rxstack stop
83         /sbin/chkconfig --del rxstack
84 fi
85
86 %files
87 %defattr(644,root,root,755)
88 %doc COPYING-LIB README* demo
89 %attr(755,root,root) %{_bindir}/*
90 %attr(754,root,root) /etc/rc.d/init.d/rxstack
91 %attr(644,root,root) %{_includedir}/rexxsaa.h
92 %attr(755,root,root) %{_prefix}/lib/*
93 %attr(755,root,root) %{_datadir}/regina/*.rexx
94 %{_datadir}/regina/*.mtb
95 %{_mandir}/man1/regina.1*
This page took 0.068765 seconds and 4 git commands to generate.