]> git.pld-linux.org Git - packages/Regina.git/blob - Regina.spec
957f180e57c8decc04d1bedf35a055cca53c6442
[packages/Regina.git] / Regina.spec
1 # TODO:
2 #  - fix the method rxstarck is installed
3 #  - use bconds
4 #  - create subpackages
5
6 Summary:        Rexx interpreter
7 Summary(pl):    Interpreter jêzyka REXX
8 Name:           Regina
9 Version:        3.3
10 Release:        0.1
11 License:        GPL
12 Group:          Applications
13 Source0:        http://dl.sourceforge.net/regina-rexx/%{name}-REXX-%{version}.tar.gz
14 # Source0-md5:  bdb85f57cbe3e7f9b45aea329cd7752e
15 Patch0:         %{name}-makefileinfix.patch
16 Patch1:         %{name}-init.patch
17 URL:            http://regina-rexx.sourceforge.net
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  mawk
23 BuildRequires:  rpmbuild(macros) >= 1.228
24 Requires(post,preun):   /sbin/chkconfig
25 Provides:       libregina.so
26 Provides:       libregina.so(REXXSAA_API)
27 Provides:       libregina.so(regina_2.0)
28 Provides:       rexx
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Regina is a Rexx interpreter that has been ported to most Unix
33 platforms (Linux, FreeBSD, Solaris, AIX, HP-UX, etc.) and also to
34 OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x, QNX6.x BeOS,
35 MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition. Rexx is a
36 programming language that was designed to be easy to use for
37 inexperienced programmers yet powerful enough for experienced users.
38 It is also a language ideally suited as a macro language for other
39 applications.
40
41 There are two major goals for Regina:
42
43     - become 100% compliant with the ANSI Standard.
44     - be available on as many platforms as possible
45
46 %description -l pl
47 Regina jest interpreterem jêzyka REXX, który zosta³ ju¿ przeniesiony
48 na wiêkszo¶æ Unixowych platform (Linux, FreeBSD, Solaris, AIX, HP-UX,
49 itp.) a tak¿e OS/2, eCS, DOS, Win9x/Me/NT/2k/XP, Amiga, AROS, QNX4.x,
50 QNX6.x, BeOS, MacOS X, EPOC32, AtheOS, OpenVMS, SkyOS and OpenEdition.
51 Rexx jest jêzykiem programowania, który zosta³ zaprojektowany, by byæ
52 prostym w u¿yciu przez niedo¶wiadczonych programistów oraz
53 wystarczaj±co u¿ytecznym, by byæ u¿ywanym przez do¶wiadczonych.
54 Idealnie sprawdza siê jako jêzyk pisania makr dla innych aplikacji
55
56 Dwa g³ówne cele tego internretera, to
57  - Stuprocentowa kompatybilno¶æ ze standardemi ANSI
58  - dostêpno¶æ na jak najwiêkszej liczbie platform
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p0
64
65 %build
66 ./configure
67 %{__make} \
68         CC="%{__cc}" \
69         CFLAGS="%{rpmcflags}"
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_mandir}/man1}
74 %{__make} install \
75     DESTDIR=$RPM_BUILD_ROOT
76 install $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack $RPM_BUILD_ROOT/etc/rc.d/init.d/
77 install $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1 $RPM_BUILD_ROOT%{_mandir}/man1/
78 rm -f $RPM_BUILD_ROOT%{_prefix}/etc/rc.d/init.d/rxstack
79 rm -f $RPM_BUILD_ROOT%{_prefix}/man/man1/regina.1
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 /sbin/chkconfig --add rxstack
86
87 %preun
88 if [ "$1" = "0" ] ; then
89         %service rxstack stop
90         /sbin/chkconfig --del rxstack
91 fi
92
93 %files
94 %defattr(644,root,root,755)
95 %doc COPYING-LIB README* demo
96 %attr(755,root,root) %{_bindir}/*
97 %attr(754,root,root) /etc/rc.d/init.d/rxstack
98 %attr(644,root,root) %{_includedir}/rexxsaa.h
99 %attr(755,root,root) %{_prefix}/lib/*
100 %attr(755,root,root) %{_datadir}/regina/*.rexx
101 %{_datadir}/regina/*.mtb
102 %{_mandir}/man1/regina.1*
This page took 0.108554 seconds and 3 git commands to generate.