]> git.pld-linux.org Git - packages/R.git/blob - R.spec
70b277c3daad001a4963858964c0aaea70f0b8cc
[packages/R.git] / R.spec
1 # TODO:
2 # - move perl R libraries to standard perl location
3 #
4 # Conditional build:
5 %bcond_without  gnome   # without GNOME support
6 #
7 Summary:        A language for data analysis and graphics
8 Summary(pl):    Jêzyk do analizy danych oraz grafiki
9 Name:           R
10 Version:        2.0.1
11 Release:        0.1
12 License:        Mixed (distributable), mostly GPL
13 Group:          Development/Languages
14 # CRAN master site: ftp://cran.r-project.org/pub/R/src/
15 Source0:        ftp://stat.ethz.ch/R-CRAN/src/base/R-2/%{name}-%{version}.tar.gz
16 # Source0-md5:  fb47b1fdef4323031e24d541a2f36b2b
17 # Source0-size: 10676072
18 Source1:        %{name}.desktop
19 URL:            http://www.r-project.org/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  blas-devel
24 BuildRequires:  gcc-c++
25 BuildRequires:  gcc-g77
26 BuildRequires:  gettext-devel
27 BuildRequires:  libjpeg-devel >= 6b
28 BuildRequires:  libpng-devel >= 1.0.5
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool
31 BuildRequires:  libxml-devel
32 BuildRequires:  perl-base >= 1:5.6
33 BuildRequires:  readline-devel
34 BuildRequires:  tetex-latex
35 BuildRequires:  tetex-dvips
36 BuildRequires:  tetex-pdftex
37 BuildRequires:  zip
38 BuildRequires:  zlib >= 1.1.3
39 #BuildRequires: lpr
40 #Requires:      lpr
41 %{?with_gnome:BuildRequires:    gnome-libs-devel}
42 %{?with_gnome:BuildRequires:    ORBit-devel}
43 %{?with_gnome:BuildRequires:    libglade-gnome-devel}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 A system for statistical computation and graphics. R consists of a
48 language plus a run-time environment with graphics, a debugger, access
49 to certain system functions, and the ability to run programs stored in
50 script files.
51
52 The design of R has been heavily influenced by two existing languages:
53 Becker, Chambers & Wilks' S and Sussman's Scheme. Whereas the
54 resulting language is very similar in appearance to S, the underlying
55 implementation and semantics are derived from Scheme.
56
57 %description -l pl
58 System do obliczeñ statystycznych i grafiki. R sk³ada siê z jêzyka
59 oraz ¶rodowiska uruchomieniowego z grafik±, debuggerem, dostêpem do
60 niektórych funkcji systemowych oraz mo¿liwo¶ci± uruchamiania programów
61 zapisanych w skryptach.
62
63 Jêzyk R by³ zainspirowany dwoma istniej±cymi jêzykami: S (Beckera,
64 Chambersa i Wilksa) oraz Scheme (Sussmana). R jest podobny do S, ale
65 implementacja i semantyka wywodzi siê ze Scheme.
66
67 %package base
68 Summary:        The R base distribution
69 Summary(pl):    Podstawowa dystrybucja R
70 License:        GPL v2 / LGPL
71 Group:          Development/Languages
72 Requires(post): textutils
73 Requires(post): perl-base
74 Provides:       R-cran-base
75 Provides:       R-cran-datasets
76 Provides:       R-cran-grid
77 Provides:       R-cran-graphics
78 Provides:       R-cran-grDevices
79 Provides:       R-cran-methods
80 Provides:       R-cran-utils
81 Provides:       R-cran-tcltk
82 Provides:       R-cran-splines
83 Provides:       R-cran-stats
84 Provides:       R-cran-stats4
85 Provides:       R-cran-tools
86
87 %description base
88 R is a language and run-time environment for carrying out interactive
89 statistical data analysis. It is not entirely dissimilar to the S
90 language developed at AT&T Bell Laboratories (and now Lucent
91 Technologies). Indeed, S users will find the environment quite
92 familiar and a good deal of S software will run without change under
93 R.
94
95 %description base -l pl
96 R jest jêzykiem i ¶rodowiskiem uruchomieniowym do interaktywnej
97 analizy danych statystycznych. R nie jest ca³kowicie zgodny z jêzykiem
98 S opracowanym w AT&T Bell Laboratiories (a teraz Lucent Technologies),
99 mimo to u¿ytkownicy S zauwa¿± zbli¿one ¶rodowisko, a du¿a czê¶æ
100 oprogramowania w S bêdzie dzia³a³a bez zmian w R.
101
102 %package recommended
103 Summary:        Recommended contributed packages for the R language
104 Summary(pl):    Zalecane dodatkowe pakiety do jêzyka R
105 Group:          Development/Languages
106 Requires:       R-cran-KernSmooth
107 Requires:       R-cran-VR
108 Requires:       R-boot
109 Requires:       R-cran-cluster
110 Requires:       R-cran-foreign
111 Requires:       R-cran-lattice
112 Requires:       R-cran-mgcv
113 Requires:       R-cran-nlme
114 Requires:       R-cran-rpart
115 Requires:       R-cran-survival
116 License:        GPL, free or free for non-commercial use
117 URL:            http://www.ci.tuwien.ac.at/R/
118 Requires(post,postun):  R-base
119 Requires(post,postun):  perl-base
120 Requires(post,postun):  textutils
121 Requires:       R-base = %{version}-%{release}
122
123 %description recommended
124 Packages which extend the capabilities of the R base distribution and
125 are distributed on the Comprehensive R Archive Network (CRAN).
126
127 %description recommended -l pl
128 Pakiety rozszerzaj±ce mo¿liwo¶ci podstawowej dystrybucji jêzyka R,
129 dystrubuowane w archiwum CRAN (Comprehensive R Archive Network).
130
131 %prep
132 %setup -q
133
134 # These files have the path for Perl hard-coded as /usr/local/bin/perl
135 # We need to remove them to avoid dependency problems
136 rm -f ./doc/keyword-test.orig ./etc/undoc/R-funs.orig ./etc/undoc/extrExamp.orig
137
138 %build
139 %{__aclocal} -I m4
140 %{__autoconf}
141 cp -f /usr/share/automake/config.* .
142 %configure \
143         --with%{!?with_gnome:out}-gnome \
144         --enable-R-shlib \
145         --enable-linux-lfs \
146         --with-zlib \
147         --with-bzlib \
148         --with-pcre \
149         --without-recommended-packages
150
151 %{__make}
152 %{__make} check
153 %{__make} docs
154 %{__make} help
155 %{__make} html
156 %{__make} info
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/R,%{_includedir},%{_desktopdir}}
161
162 %{__make} install \
163         rhome=$RPM_BUILD_ROOT%{_libdir}/R \
164         mandir=$RPM_BUILD_ROOT%{_mandir} \
165         bindir=$RPM_BUILD_ROOT%{_bindir} \
166         
167
168 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
169
170 find $RPM_BUILD_ROOT%{_libdir}/R -name 'Makefile*' -exec rm -f {} \;
171 mv $RPM_BUILD_ROOT%{_libdir}/R/lib/libR*.so $RPM_BUILD_ROOT%{_libdir}
172 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/include $RPM_BUILD_ROOT%{_includedir}/R
173 ln -sf %{_includedir}/R $RPM_BUILD_ROOT%{_libdir}/R/include
174 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
175 sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/%{name}
176 ln -sf %{_libdir}/%{name}/bin/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 (cd %{_libdir}/R/library; umask 022; cat */CONTENTS > ../doc/html/search/index.txt
183  R_HOME=%{_libdir}/R ../bin/Rcmd perl ../share/perl/build-help.pl --htmllist)
184 /sbin/ldconfig
185
186 %postun -p /sbin/ldconfig
187
188 %files base
189 %defattr(644,root,root,755)
190 %doc COPYRIGHTS FAQ NEWS README RESOURCES THANKS Y2K
191
192 %{_mandir}/man1/R.1*
193 %attr(755,root,root) %{_bindir}/R
194 %dir %{_libdir}/R
195 %{_libdir}/R/afm
196 %attr(755,root,root) %{_libdir}/R/bin
197 %attr(755,root,root) %{_libdir}/libR*.so
198 %{_libdir}/R/etc
199 %{_libdir}/R/include
200 %{_includedir}/R
201 %{_libdir}/R/share
202 %{_libdir}/R/AUTHORS
203 %dir %{_libdir}/R/library
204 # %{_libdir}/R/doc %except %{_libdir}/R/doc/html/{packages.html,search/index.txt}
205 %dir %{_libdir}/R/doc
206 %{_libdir}/R/doc/[KRm]*
207 %dir %{_libdir}/R/doc/html
208 %{_libdir}/R/doc/html/*.css
209 %{_libdir}/R/doc/html/[Ra-lr-u]*.html
210 %{_libdir}/R/doc/html/packages-head.html
211 %{_libdir}/R/doc/html/*.jpg
212 %dir %{_libdir}/R/doc/html/search
213 %{_libdir}/R/doc/html/search/[A-Z]*
214 %ghost %{_libdir}/R/doc/html/search/index.txt
215 %ghost %{_libdir}/R/doc/html/packages.html
216 %{_desktopdir}/*
217
218 %attr(755,root,root) %{_libdir}/%{name}/modules
219
220 %{_libdir}/%{name}/library/base
221 %{_libdir}/%{name}/library/datasets
222 %{_libdir}/%{name}/library/grid
223 %{_libdir}/%{name}/library/graphics
224 %{_libdir}/%{name}/library/grDevices
225 %{_libdir}/%{name}/library/methods
226 %{_libdir}/%{name}/library/utils
227 %{_libdir}/%{name}/library/tcltk
228 %{_libdir}/%{name}/library/splines
229 %{_libdir}/%{name}/library/stats
230 %{_libdir}/%{name}/library/stats4
231 %{_libdir}/%{name}/library/tools
232
233 %files recommended
This page took 0.043366 seconds and 3 git commands to generate.