]> git.pld-linux.org Git - packages/Producer.git/blob - Producer.spec
9cd0f20fa5c39489f9ebe90ffbb2bbfbd56f6a1a
[packages/Producer.git] / Producer.spec
1 %define fversion        %(echo %{version} | tr r - )
2 Summary:        Cross-platform library for OpenGL rendering
3 Summary(pl):    Wieloplatformowa biblioteka do renderingu OpenGL
4 Name:           Producer
5 Version:        0.8.5r3
6 Release:        1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://www.andesengineering.com/Producer/Download/%{name}-%{fversion}.tar.gz
10 # Source0-md5:  889c99c47a3af7d8df03fb5584919cbe
11 Source1:        %{name}.pc
12 Patch0:         %{name}-soname.patch
13 URL:            http://www.andesengineering.com/Producer/index.html
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  OpenThreads-devel
16 BuildRequires:  libstdc++-devel
17 Provides:       OpenProducer = %{version}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Open Producer (or simply Producer) is a cross-platform, C++ library
22 for managing OpenGL rendering contexts in a windowing system
23 independent manner. Producer provides a simple, yet powerfully
24 scalable approach for real-time 3D applications wishing to run within
25 a single window to large, multidisplay systems. Producer is highly
26 portable and has been tested on Linux, Windows, Mac OSX, Solaris and
27 IRIX. Producer works on all Unix based OS's (including Mac OSX)
28 through the X11 Windowing system, and through the native win32 on
29 Windows. Producer is written with productivity, performance and
30 scalability in mind by adhering to industry standard and employing
31 advanced software engineering practices. Software developers wishing
32 to produce 3D rendering software that can display on a desktop, and
33 move to a large system or clustered system of displays by simply
34 changing a configuration file, can depend on Open Producer to handle
35 all the complexity for them.
36
37 %description -l pl
38 Open Producer (lub po prostu Producer) jest wieloplatformow±
39 bibliotek± C++ do zarz±dzania renderingiem OpenGL. Producer udostêpnia
40 prost±, ale skalowaln± mo¿liwo¶æ dla aplikacji czasu rzeczywistego 3D
41 od chc±cych uruchamiaæ siê w pojedynczym oknie a¿ do wielkich,
42 wieloekranowych systemów. Producer jest bardzo przeno¶ny i
43 przetestowany na Linuksie, Windows, MacOS X, Solarisie i IRIXie.
44 Producer dzia³a na wszystkich bazuj±cych na Uniksie systemach
45 (w³±czaj±c w to MacOS X) poprzez system okien X11 lub przez natywne
46 wywo³ania win32 na Windows. Producer by³ pisany z my¶l± o wydajno¶ci i
47 skalowalno¶ci uwzglêdniaj±c systemy produkcyjne. Autorzy
48 oprogramowania chc±cy tworzyæ aplikacje renderuj±ce 3D, które mog± siê
49 wy¶wietlaæ na ekranie lub przenie¶æ na wielki system lub klaster
50 systemów wy¶wietlaczy poprzez prost± zmianê plików konfiguracyjnych,
51 mog± polegaæ na Open Producer, ¿e obs³u¿y wszystko co jest potrzebne
52 dla nich.
53
54 %package devel
55 Summary:        Development files for Producer
56 Summary(pl):    Pliki programistyczne biblioteki Producer
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libstdc++-devel
60
61 %description devel
62 Development files for Producent.
63
64 %description devel -l pl
65 Biblioteki programistyczne biblioteki Producer.
66
67 %prep
68 %setup -q -n %{name}
69 %patch0 -p1
70
71 find -type d -name CVS |xargs rm -rf
72
73 %build
74 %{__make} \
75         CXX="%{__cxx} %{rpmcflags} -fPIC -fpermissive"
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81          INST_LOCATION=$RPM_BUILD_ROOT%{_prefix}
82 if [ "%{_libdir}" == "%{_prefix}/lib64" ]; then
83         mv $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
84 fi
85 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
86 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
87 install %{SOURCE1} $RPM_BUILD_ROOT%{_pkgconfigdir}/producer.pc
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/lib*.so.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc README.txt doc
102 %attr(755,root,root) %{_libdir}/lib*.so
103 %{_includedir}/%{name}
104 %{_pkgconfigdir}/*.pc
This page took 0.049684 seconds and 3 git commands to generate.