]> git.pld-linux.org Git - packages/Producer.git/blob - Producer.spec
7c67e0802040b24b16f6560953f03edeea5989d3
[packages/Producer.git] / Producer.spec
1 %define fversion        %(echo %{version} | tr r - )
2 Summary:        Cross-platform library for OpenGL rendering
3 Summary(pl):    Wieloplatformowa biblioteka do renderingu OpenGL
4 Name:           Producer
5 Version:        0.8.4r2
6 Release:        1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://www.andesengineering.com/Producer/Download/%{name}-%{fversion}.tar.gz
10 # Source0-md5:  9e14c27a0e927a19bb3666fa73755652
11 Patch0:         %{name}-soname.patch
12 URL:            http://www.andesengineering.com/Producer/index.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  OpenThreads-devel
15 BuildRequires:  libstdc++-devel
16 Provides:       OpenProducer = %{version}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Open Producer (or simply Producer) is a cross-platform, C++ library
21 for managing OpenGL rendering contexts in a windowing system
22 independent manner. Producer provides a simple, yet powerfully
23 scalable approach for real-time 3D applications wishing to run within
24 a single window to large, multidisplay systems. Producer is highly
25 portable and has been tested on Linux, Windows, Mac OSX, Solaris and
26 IRIX. Producer works on all Unix based OS's (including Mac OSX)
27 through the X11 Windowing system, and through the native win32 on
28 Windows. Producer is written with productivity, performance and
29 scalability in mind by adhering to industry standard and employing
30 advanced software engineering practices. Software developers wishing
31 to produce 3D rendering software that can display on a desktop, and
32 move to a large system or clustered system of displays by simply
33 changing a configuration file, can depend on Open Producer to handle
34 all the complexity for them.
35
36 %description -l pl
37 Open Producer (lub po prostu Producer) jest wieloplatformow±
38 bibliotek± C++ do zarz±dzania renderingiem OpenGL. Producer udostêpnia
39 prost±, ale skalowaln± mo¿liwo¶æ dla aplikacji czasu rzeczywistego 3D
40 od chc±cych uruchamiaæ siê w pojedynczym oknie a¿ do wielkich,
41 wieloekranowych systemów. Producer jest bardzo przeno¶ny i
42 przetestowany na Linuksie, Windows, MacOS X, Solarisie i IRIXie.
43 Producer dzia³a na wszystkich bazuj±cych na Uniksie systemach
44 (w³±czaj±c w to MacOS X) poprzez system okien X11 lub przez natywne
45 wywo³ania win32 na Windows. Producer by³ pisany z my¶l± o wydajno¶ci i
46 skalowalno¶ci uwzglêdniaj±c systemy produkcyjne. Autorzy
47 oprogramowania chc±cy tworzyæ aplikacje renderuj±ce 3D, które mog± siê
48 wy¶wietlaæ na ekranie lub przenie¶æ na wielki system lub klaster
49 systemów wy¶wietlaczy poprzez prost± zmianê plików konfiguracyjnych,
50 mog± polegaæ na Open Producer, ¿e obs³u¿y wszystko co jest potrzebne
51 dla nich.
52
53 %package devel
54 Summary:        Development files for Producer
55 Summary(pl):    Pliki programistyczne biblioteki Producer
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libstdc++-devel
59
60 %description devel
61 Development files for Producent.
62
63 %description devel -l pl
64 Biblioteki programistyczne biblioteki Producer.
65
66 %prep
67 %setup -q -n %{name}
68 %patch0 -p0
69
70 find -type d -name CVS |xargs rm -rf
71
72 %build
73 %{__make} \
74         CXX="%{__cxx} %{rpmcflags} -fPIC -fpermissive"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80          INST_LOCATION=$RPM_BUILD_ROOT%{_prefix}
81 if [ "%{_libdir}" == "%{_prefix}/lib64" ]; then
82         mv $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
83 fi
84 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/lib*.so.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %doc README.txt doc
96 %attr(755,root,root) %{_libdir}/lib*.so
97 %{_includedir}/%{name}
This page took 0.085029 seconds and 3 git commands to generate.