]> git.pld-linux.org Git - packages/Producer.git/blob - Producer.spec
57138df1dac95092d8c6a6aca3109ffbd4a95e2c
[packages/Producer.git] / Producer.spec
1 %define fversion        %(echo %{version} | tr r - )
2 Summary:        Cross-platform library for OpenGL rendering
3 Summary(pl):    Wieloplatformowa biblioteka do renderingu OpenGL
4 Name:           Producer
5 Version:        0.8.5r3
6 Release:        1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://www.andesengineering.com/Producer/Download/%{name}-%{fversion}.tar.gz
10 # Source0-md5:  889c99c47a3af7d8df03fb5584919cbe
11 Source1:        %{name}.pc
12 Patch0:         %{name}-soname.patch
13 URL:            http://www.andesengineering.com/Producer/index.html
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  OpenThreads-devel
16 BuildRequires:  XFree86-devel
17 BuildRequires:  libstdc++-devel
18 Provides:       OpenProducer = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Open Producer (or simply Producer) is a cross-platform, C++ library
23 for managing OpenGL rendering contexts in a windowing system
24 independent manner. Producer provides a simple, yet powerfully
25 scalable approach for real-time 3D applications wishing to run within
26 a single window to large, multidisplay systems. Producer is highly
27 portable and has been tested on Linux, Windows, Mac OSX, Solaris and
28 IRIX. Producer works on all Unix based OS's (including Mac OSX)
29 through the X11 Windowing system, and through the native win32 on
30 Windows. Producer is written with productivity, performance and
31 scalability in mind by adhering to industry standard and employing
32 advanced software engineering practices. Software developers wishing
33 to produce 3D rendering software that can display on a desktop, and
34 move to a large system or clustered system of displays by simply
35 changing a configuration file, can depend on Open Producer to handle
36 all the complexity for them.
37
38 %description -l pl
39 Open Producer (lub po prostu Producer) jest wieloplatformow±
40 bibliotek± C++ do zarz±dzania renderingiem OpenGL. Producer udostêpnia
41 prost±, ale skalowaln± mo¿liwo¶æ dla aplikacji czasu rzeczywistego 3D
42 od chc±cych uruchamiaæ siê w pojedynczym oknie a¿ do wielkich,
43 wieloekranowych systemów. Producer jest bardzo przeno¶ny i
44 przetestowany na Linuksie, Windows, MacOS X, Solarisie i IRIXie.
45 Producer dzia³a na wszystkich bazuj±cych na Uniksie systemach
46 (w³±czaj±c w to MacOS X) poprzez system okien X11 lub przez natywne
47 wywo³ania win32 na Windows. Producer by³ pisany z my¶l± o wydajno¶ci i
48 skalowalno¶ci uwzglêdniaj±c systemy produkcyjne. Autorzy
49 oprogramowania chc±cy tworzyæ aplikacje renderuj±ce 3D, które mog± siê
50 wy¶wietlaæ na ekranie lub przenie¶æ na wielki system lub klaster
51 systemów wy¶wietlaczy poprzez prost± zmianê plików konfiguracyjnych,
52 mog± polegaæ na Open Producer, ¿e obs³u¿y wszystko co jest potrzebne
53 dla nich.
54
55 %package devel
56 Summary:        Development files for Producer
57 Summary(pl):    Pliki programistyczne biblioteki Producer
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       OpenThreads-devel
61 Requires:       XFree86-devel
62 Requires:       libstdc++-devel
63
64 %description devel
65 Development files for Producent.
66
67 %description devel -l pl
68 Biblioteki programistyczne biblioteki Producer.
69
70 %prep
71 %setup -q -n %{name}
72 %patch0 -p1
73
74 find -type d -name CVS |xargs rm -rf
75
76 %build
77 %{__make} \
78         CXX="%{__cxx} %{rpmcflags} -fPIC -fpermissive"
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         INST_LOCATION=$RPM_BUILD_ROOT%{_prefix} \
85         INST_LIBS=$RPM_BUILD_ROOT%{_libdir}
86
87 ln -sf `basename $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.*` $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
88
89 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
90 sed -e 's,^libdir=.*,libdir=%{_libdir},' %{SOURCE1} >$RPM_BUILD_ROOT%{_pkgconfigdir}/producer.pc
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc README.txt doc
105 %attr(755,root,root) %{_libdir}/lib*.so
106 %{_includedir}/%{name}
107 %{_pkgconfigdir}/*.pc
This page took 0.02706 seconds and 3 git commands to generate.