]> git.pld-linux.org Git - packages/Perlbal.git/blob - Perlbal.spec
- release 2: added -test_15_webserver.patch
[packages/Perlbal.git] / Perlbal.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Perlbal - Reverse-proxy load balancer and webserver
8 #Summary(pl.UTF-8):     
9 Name:           Perlbal
10 Version:        1.59
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Perlbal-%{version}.tar.gz
16 # Source0-md5:  7d098abd4434b70f13638cdff3e2383a
17 Source1:        perlbal.init
18 Source2:        perlbal.sysconfig
19 Patch0:         %{name}-no_use_lib.patch
20 Patch1:         %{name}-test_15_webserver.patch
21 URL:            http://www.danga.com/perlbal/
22 Requires(post,preun):   /sbin/chkconfig
23 BuildRequires:  rpmbuild(macros) >= 1.228
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 %if %{with autodeps} || %{with tests}
27 BuildRequires:  perl-BSD-Resource
28 BuildRequires:  perl-Danga-Socket >= 1.44
29 BuildRequires:  perl-Sys-Syscall
30 BuildRequires:  perl-libwww
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define _noautoreq      'perl(Perlbal.*)'
36
37 %description
38 Perlbal is a single-threaded event-based server supporting HTTP load
39 balancing, web serving, and a mix of the two.
40
41 One of the defining things about Perlbal is that almost everything can
42 be configured or reconfigured on the fly without needing to restart
43 the software. A basic configuration file containing a management
44 port enables you to easily perform operations on a running instance
45 of Perlbal.
46
47 # %description -l pl.UTF-8
48 # TODO
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} pure_install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/perlbal
69 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/perlbal
70 cp -r conf $RPM_BUILD_ROOT%{_sysconfdir}/perlbal
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/chkconfig --add perlbal
77 %service perlbal restart
78
79 %preun
80 if [ "$1" = "0" ]; then
81         %service -q perlbal stop
82         /sbin/chkconfig --del perlbal
83 fi
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGES doc conf
88 %{perl_vendorlib}/*.pm
89 %{perl_vendorlib}/Perlbal/
90 %attr(755,root,root) %{_bindir}/*
91 %{_mandir}/man?/*
92 %attr(754,root,root) /etc/rc.d/init.d/perlbal
93 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/perlbal
94 %dir %{_sysconfdir}/perlbal
95 %attr(740,root,root) %{_sysconfdir}/perlbal/*
This page took 0.09134 seconds and 3 git commands to generate.