]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
- use x8664 macro
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support
4 %bcond_with     arts    # with aRts support
5 %bcond_without  doc     # don't build HTML documentation (from SGML source)
6 %bcond_without  esd     # without esd support
7 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
8                         # Currently broken.
9 #
10 # TODO:
11 # - remove zip BR?
12 #
13
14 #%%ifarch athlon pentium3 pentium4 %{x8664}
15 #%%define               with_mmx        1
16 #%%endif
17
18 Summary:        Open Audio Library
19 Summary(pl):    Otwarta Biblioteka D¼wiêku
20 Name:           OpenAL
21 Version:        0.0.7
22 %define snap    20041201
23 Release:        0.%{snap}.1
24 License:        LGPL
25 Group:          Libraries
26 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
27 # (without all Win and Mac stuff and demos)
28 Source0:        %{name}-linuxonly-%{snap}.tar.bz2
29 # Source0-md5:  1fbf3278f92469ab259b276d453bdec3
30 Patch0:         %{name}-prefix.patch
31 Patch1:         %{name}-info.patch
32 URL:            http://www.openal.org/
33 BuildRequires:  SDL-devel
34 %{?with_alsa:BuildRequires:     alsa-lib-devel}
35 %{?with_arts:BuildRequires:     artsc-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_doc:BuildRequires:      docbook-utils}
39 %{?with_esd:BuildRequires:      esound-devel}
40 %{?with_doc:BuildRequires:      gnome-doc-tools}
41 BuildRequires:  libvorbis-devel
42 %{?with_mmx:BuildRequires:      nasm}
43 BuildRequires:  smpeg-devel
44 BuildRequires:  texinfo
45 BuildRequires:  zip
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 OpenAL, the Open Audio Library, is a joint effort to create an open,
50 vendor-neutral, cross-platform API for interactive, primarily
51 spatialized audio. OpenAL's primary audience are application
52 developers and desktop users that rely on portable standards like
53 OpenGL, for games and other multimedia applications. OpenAL is already
54 supported by a number of hardware vendors and developers.
55
56 %description -l pl
57 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
58 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
59 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
60 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
61 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
62 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
63 dostarczycieli sprzêtu i programistów.
64
65 %package devel
66 Summary:        Headers for OpenAL
67 Summary(pl):    Pliki nag³ówkowe do OpenAL
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70
71 %description devel
72 Header files for OpenAL-based programs.
73
74 %description devel -l pl
75 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
76 OpenAL.
77
78 %package static
79 Summary:        OpenAL static library
80 Summary(pl):    Statyczna biblioteka OpenAL
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 OpenAL static library.
86
87 %description static -l pl
88 Biblioteka OpenAL do konsolidacji statycznej.
89
90 %prep
91 %setup -q -n openal
92 %patch0 -p1
93 %patch1 -p1
94
95 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?with_mmx:1}%{!?with_mmx:2}])' >> linux/acinclude.m4
96
97 %build
98 cd linux
99 cp -f /usr/share/automake/config.sub .
100 %{__aclocal}
101 %{__autoconf}
102 %{__autoheader}
103 %configure \
104         %{!?debug:--enable-optimization} \
105         %{?with_mmx:--enable-arch-asm} \
106         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
107         %{?with_arts:--enable-arts} \
108         %{?with_esd:--enable-esd} \
109         --enable-sdl \
110         --enable-vorbis \
111         --enable-smpeg \
112         --enable-capture \
113         --with-gcc=%{__cc}
114
115 %{__make}
116
117 cd ../docs
118 %{?with_doc:%{__make} full-html}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_infodir}
123
124 %{__make} -C linux install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %post devel
136 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
137
138 %postun devel
139 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
140
141 %files
142 %defattr(644,root,root,755)
143 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
144 %attr(755,root,root) %{_libdir}/lib*.so.*.*
145
146 %files devel
147 %defattr(644,root,root,755)
148 %doc linux/doc/LOKI* %{?with_doc:docs/oalspecs-full}
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %{_includedir}/AL
151 %{_infodir}/openal.info*
152
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/*.a
This page took 0.085269 seconds and 4 git commands to generate.