]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
291c282c9ba5d96e68f0fca46674eaf66e4a4669
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # _without_alsa         - without ALSA support
4 # _without_doc          - don't build HTML documentation (from SGML source)
5 # _with_mmx             - use MMX (won't run on non-MMX CPU)
6 #
7 # TODO:
8 # - remove zip bcond?
9 # - check %{name}-acfix.patch if it's still nedded, sorry
10 #   for the inconvenience, I'll do it if I can...
11 #
12 %ifarch athlon
13 %define         _with_mmx       1
14 %endif
15 %ifnarch i586 i686 athlon
16 %define         _with_mmx       0
17 %endif
18 Summary:        Open Audio Library
19 Summary(pl):    Otwarta Biblioteka D¼wiêku
20 Name:           OpenAL
21 Version:        0.0.6
22 %define snap    20030806
23 Release:        1.%{snap}.0.9
24 License:        LGPL
25 Group:          Libraries
26 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
27 # (without all Win and Mac stuff and demos)
28 Source0:        http://pb152.srem.sdi.tpnet.pl/pld/%{name}-linuxonly-%{snap}.tar.bz2
29 # Source0-md5:  4a5202f6cba291ae0a9af59410bdda88
30 Patch0:         %{name}-prefix.patch
31 Patch1:         %{name}-acfix.patch
32 Patch2:         %{name}-info.patch
33 URL:            http://opensource.creative.com/
34 BuildRequires:  SDL-devel
35 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{!?_without_doc:BuildRequires: docbook-utils}
39 %{!?_without_doc:BuildRequires: gnome-doc-tools}
40 BuildRequires:  libvorbis-devel
41 %{?_with_mmx:BuildRequires:     nasm}
42 BuildRequires:  smpeg-devel
43 BuildRequires:  texinfo
44 BuildRequires:  zip
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 OpenAL, the Open Audio Library, is a joint effort to create an open,
49 vendor-neutral, cross-platform API for interactive, primarily
50 spatialized audio. OpenAL's primary audience are application
51 developers and desktop users that rely on portable standards like
52 OpenGL, for games and other multimedia applications. OpenAL is already
53 supported by a number of hardware vendors and developers.
54
55 %description -l pl
56 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
57 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
58 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
59 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
60 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
61 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
62 dostarczycieli sprzêtu i programistów.
63
64 %package devel
65 Summary:        Headers for OpenAL
66 Summary(pl):    Pliki nag³ówkowe do OpenAL
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}
69
70 %description devel
71 Header files for OpenAL-based programs.
72
73 %description devel -l pl
74 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
75 OpenAL.
76
77 %package static
78 Summary:        OpenAL static library
79 Summary(pl):    Statyczna biblioteka OpenAL
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 OpenAL static library.
85
86 %description static -l pl
87 Biblioteka OpenAL do statycznego linkowania.
88
89 %prep
90 %setup -q -n openal
91 %patch0 -p1
92 #%%patch1 -p1
93 %patch2 -p1
94
95 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
96
97 %build
98 cd linux
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %configure \
103         %{!?debug:--enable-optimization} \
104         %{?_with_mmx:--enable-arch-asm} \
105         %{!?_without_alsa:--enable-alsa} \
106         --enable-sdl \
107         --enable-vorbis \
108         --enable-smpeg \
109         --enable-capture \
110         --with-gcc=%{__cc}                          
111
112 %{__make}
113
114 cd ../docs
115 %{!?_without_doc:%{__make} full-html}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_infodir}
120
121 cd linux
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %post devel
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %postun devel
137 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
138
139 %files
140 %defattr(644,root,root,755)
141 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_includedir}/AL
149 %{_infodir}/openal.info*
150
151 %files static
152 %defattr(644,root,root,755)
153 %attr(755,root,root)%{_libdir}/*.a
This page took 0.100636 seconds and 3 git commands to generate.