]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
1339ea75b5d05869ea9bcfcb31395b24939e99a9
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # TODO: 
4 # - Build stops at:
5 # arch/i386/x86_floatmul.c:86:74: warning: use of C99 long long integer constant
6 # arch/i386/x86_floatmul.c:89:74: warning: use of C99 long long integer constant
7 # arch/i386/x86_floatmul.c: In function `_alFloatMul':
8 #arch/i386/x86_floatmul.c:86: internal compiler error: in ix86_expand_binop_builtin, at config/i386/i386.c:13246
9 # Please submit a full bug report,
10 #
11 # - autoconf provides undefined macro....
12
13 %bcond_without  alsa    # without ALSA support
14 %bcond_with     arts    # with aRts support
15 %bcond_without  doc     # don't build HTML documentation (from SGML source)
16 %bcond_without  esd     # without esd support
17 %bcond_with     mmx     # use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
18
19 %define _branch Linux_Spec1-0
20
21 Summary:        Open Audio Library
22 Summary(pl):    Otwarta Biblioteka D¼wiêku
23 Name:           OpenAL
24 Version:        0.0.8
25 Release:        0.1
26 License:        LGPL
27 Group:          Libraries
28 Source0:        http://www.openal.org/openal_webstf/downloads/openal-%{version}.tar.gz
29 # Source0-md5:  641cf53761f35ee979f3e888614797a0
30 #Patch0:                %{name}-prefix.patch
31 #Patch1:                %{name}-info.patch
32 URL:            http://www.openal.org/
33 BuildRequires:  SDL-devel
34 %{?with_alsa:BuildRequires:     alsa-lib-devel}
35 %{?with_arts:BuildRequires:     artsc-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 %{?with_doc:BuildRequires:      docbook-utils}
39 %{?with_esd:BuildRequires:      esound-devel}
40 %{?with_doc:BuildRequires:      gnome-doc-tools}
41 BuildRequires:  libvorbis-devel
42 %{?with_mmx:BuildRequires:      nasm}
43 BuildRequires:  smpeg-devel
44 BuildRequires:  texinfo
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 OpenAL, the Open Audio Library, is a joint effort to create an open,
49 vendor-neutral, cross-platform API for interactive, primarily
50 spatialized audio. OpenAL's primary audience are application
51 developers and desktop users that rely on portable standards like
52 OpenGL, for games and other multimedia applications. OpenAL is already
53 supported by a number of hardware vendors and developers.
54
55 %description -l pl
56 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
57 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
58 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
59 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
60 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
61 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
62 dostarczycieli sprzêtu i programistów.
63
64 %package devel
65 Summary:        Headers for OpenAL
66 Summary(pl):    Pliki nag³ówkowe do OpenAL
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Header files for OpenAL-based programs.
72
73 %description devel -l pl
74 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
75 OpenAL.
76
77 %package static
78 Summary:        OpenAL static library
79 Summary(pl):    Statyczna biblioteka OpenAL
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 OpenAL static library.
85
86 %description static -l pl
87 Biblioteka OpenAL do konsolidacji statycznej.
88
89 %prep
90 %setup -q -n openal-%{version}
91 #%patch0 -p1
92 #%patch1 -p1
93
94 %build
95 cp -f /usr/share/automake/config.sub .
96 #%{__aclocal}
97 #%{__autoconf}
98 #%{__autoheader}
99 %configure \
100         %{?with_alsa:--enable-alsa --enable-alsa-dlopen} \
101         %{?with_arts:--enable-arts --enable-arts-dlopen} \
102         %{?with_esd:--enable-esd --enable-esd-dlopen} \
103         --enable-sdl \
104         --enable-vorbis \
105         --enable-smpeg \
106         --enable-capture \
107         --with-gcc=%{__cc}
108
109 %{__make}
110
111 cd ../docs/spec1-0
112 %{?with_doc:%{__make} full-html}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_infodir}
117
118 %{__make} -C linux install \
119         DESTLIB='$(DESTDIR)%{_libdir}' \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 install linux/doc/openal.info $RPM_BUILD_ROOT%{_infodir}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %post devel
131 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
132
133 %postun devel
134 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
135
136 %files
137 %defattr(644,root,root,755)
138 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
139 %attr(755,root,root) %{_libdir}/lib*.so.*.*
140
141 %files devel
142 %defattr(644,root,root,755)
143 %doc linux/doc/LOKI* %{?with_doc:docs/spec1-0/oalspecs-full docs/spec1-1/OpenAL1-1Spec.pdf}
144 %attr(755,root,root) %{_libdir}/lib*.so
145 %attr(755,root,root) %{_bindir}/*-config
146 %{_pkgconfigdir}/*
147 %{_includedir}/AL
148 %{_infodir}/openal.info*
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/*.a
This page took 0.030886 seconds and 3 git commands to generate.