]> git.pld-linux.org Git - packages/OpenAL.git/blob - OpenAL.spec
00dd11ba639626c61a50c28e1ae39a2a759504e7
[packages/OpenAL.git] / OpenAL.spec
1 #
2 # Conditional build:
3 # _without_alsa         - without ALSA support
4 # _without_doc          - don't build HTML documentation (from SGML source)
5 # _without_esd          - without esd support
6 # _with_mmx             - use MMX (makes sense on i[56]86 with MMX; won't run on non-MMX CPU)
7 #
8 # TODO:
9 # - remove zip bcond?
10 # - check %{name}-acfix.patch if it's still nedded, sorry
11 #   for the inconvenience, I'll do it if I can...
12 #
13 %ifarch athlon
14 %define         _with_mmx       1
15 %endif
16
17 %ifarch sparc
18 %define         _without_alsa   1
19 %endif
20
21
22 Summary:        Open Audio Library
23 Summary(pl):    Otwarta Biblioteka D¼wiêku
24 Name:           OpenAL
25 Version:        0.0.6
26 %define snap    20030806
27 Release:        1.%{snap}.0.10
28 License:        LGPL
29 Group:          Libraries
30 # from CVS :pserver:guest@opensource.creative.com:/usr/local/cvs-repository /openal
31 # (without all Win and Mac stuff and demos)
32 Source0:        http://pb152.srem.sdi.tpnet.pl/pld/%{name}-linuxonly-%{snap}.tar.bz2
33 # Source0-md5:  4a5202f6cba291ae0a9af59410bdda88
34 Patch0:         %{name}-prefix.patch
35 Patch1:         %{name}-acfix.patch
36 Patch2:         %{name}-info.patch
37 URL:            http://www.openal.org/
38 BuildRequires:  SDL-devel
39 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 %{!?_without_doc:BuildRequires: docbook-utils}
43 %{!?_without_esd:BuildRequires: esound-devel}
44 %{!?_without_doc:BuildRequires: gnome-doc-tools}
45 BuildRequires:  libvorbis-devel
46 %{?_with_mmx:BuildRequires:     nasm}
47 BuildRequires:  smpeg-devel
48 BuildRequires:  texinfo
49 BuildRequires:  zip
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 OpenAL, the Open Audio Library, is a joint effort to create an open,
54 vendor-neutral, cross-platform API for interactive, primarily
55 spatialized audio. OpenAL's primary audience are application
56 developers and desktop users that rely on portable standards like
57 OpenGL, for games and other multimedia applications. OpenAL is already
58 supported by a number of hardware vendors and developers.
59
60 %description -l pl
61 OpenAL, otwarta biblioteka d¼wiêku, to po³±czony wysi³ek w celu
62 stworzenia otwartego, niezale¿nego od producentów, miêdzyplatformowego
63 interfejsu projektowania aplikacji w czê¶ci obs³ugi d¼wiêku.
64 Biblioteka adresowana jest do twórców aplikacji i u¿ytkowników,
65 którzy wybieraj± przeno¶ne standardy, jak OpenGL, w grach i
66 aplikacjach multimedialnych. OpenAL posiada ju¿ wsparcie wielu
67 dostarczycieli sprzêtu i programistów.
68
69 %package devel
70 Summary:        Headers for OpenAL
71 Summary(pl):    Pliki nag³ówkowe do OpenAL
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header files for OpenAL-based programs.
77
78 %description devel -l pl
79 Pliki nag³ówkowe potrzebne przy budowaniu programów opartych na
80 OpenAL.
81
82 %package static
83 Summary:        OpenAL static library
84 Summary(pl):    Statyczna biblioteka OpenAL
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}
87
88 %description static
89 OpenAL static library.
90
91 %description static -l pl
92 Biblioteka OpenAL do konsolidacji statycznej.
93
94 %prep
95 %setup -q -n openal
96 %patch0 -p1
97 #%%patch1 -p1
98 %patch2 -p1
99
100 echo 'AC_DEFUN([AC_HAS_MMX],[$%{?_with_mmx:1}%{!?_with_mmx:2}])' >> linux/acinclude.m4
101
102 %build
103 cd linux
104 %{__aclocal}
105 %{__autoconf}
106 %{__autoheader}
107 %configure \
108         %{!?debug:--enable-optimization} \
109         %{?_with_mmx:--enable-arch-asm} \
110         %{!?_without_alsa:--enable-alsa} \
111         %{!?_without_esd:--enable-esd} \
112         --enable-sdl \
113         --enable-vorbis \
114         --enable-smpeg \
115         --enable-capture \
116         --with-gcc=%{__cc}
117
118 %{__make}
119
120 cd ../docs
121 %{!?_without_doc:%{__make} full-html}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_infodir}
126
127 cd linux
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install doc/openal.info $RPM_BUILD_ROOT%{_infodir}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %post devel
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %postun devel
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %files
146 %defattr(644,root,root,755)
147 %doc linux/{CREDITS,ChangeLog,NOTES,TODO}
148 %attr(755,root,root) %{_libdir}/lib*.so.*.*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %doc linux/doc/LOKI* %{!?_without_doc:docs/oalspecs-full}
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_includedir}/AL
155 %{_infodir}/openal.info*
156
157 %files static
158 %defattr(644,root,root,755)
159 %attr(755,root,root)%{_libdir}/*.a
This page took 0.050812 seconds and 3 git commands to generate.