]> git.pld-linux.org Git - packages/ORBit2.git/blob - ORBit2.spec
- fix building with with glib >= 2.30
[packages/ORBit2.git] / ORBit2.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        High-performance CORBA Object Request Broker
7 Summary(fr.UTF-8):      Requète d'Objects CORBA
8 Summary(pl.UTF-8):      Wysoko wydajny CORBA Object Request Broker
9 Name:           ORBit2
10 Version:        2.14.19
11 Release:        3
12 Epoch:          1
13 License:        GPL v2+/LGPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7082d317a9573ab338302243082d10d1
17 Patch0:         %{name}-pthread.patch
18 Patch1:         %{name}-build-fix.patch
19 URL:            http://projects.gnome.org/ORBit2/
20 BuildRequires:  autoconf >= 2.54
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  docbook-dtd412-xml
23 BuildRequires:  flex
24 BuildRequires:  glib2-devel >= 1:2.14.1
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.8}
26 BuildRequires:  indent
27 BuildRequires:  libIDL-devel >= 0.8.10
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig >= 1:0.18
30 BuildRequires:  rpmbuild(macros) >= 1.197
31 Requires:       glib2 >= 1:2.14.1
32 Requires:       libIDL >= 0.8.10
33 Provides:       linc = 1.1.1
34 Obsoletes:      ORBit2-automake
35 Obsoletes:      libORBit2_0
36 Obsoletes:      linc
37 Conflicts:      libbonobo < 2.3.2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 ORBit is a high-performance CORBA (Common Object Request Broker
42 Architecture) ORB (object request broker). It allows programs to send
43 requests and receive replies from other programs, regardless of the
44 locations of the two programs. CORBA is an architecture that enables
45 communication between program objects, regardless of the programming
46 language they're written in or the operating system they run on.
47
48 %description -l fr.UTF-8
49 ORBit est un ORB CORBA avec support pour le language C. Il permet a
50 des programmes d'envoyer des requètes et recevoir de réponses d'autres
51 programmes, indépendement de l'endroit ou sont les deux programmes.
52
53 %description -l pl.UTF-8
54 ORBit to wysokiej wydajności CORBA (Common Object Request Broker
55 Architecture) ORB (object request broker). Pozwala na wysyłanie próśb
56 i otrzymywanie odpowiedzi od innych programów bez znajomości położenia
57 tych dwóch programów.
58
59 %package apidocs
60 Summary:        ORBit API documentation
61 Summary(pl.UTF-8):      Dokumentacja API ORBit
62 Group:          Documentation
63 Requires:       gtk-doc-common
64
65 %description apidocs
66 ORBit API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API ORBit.
70
71 %package devel
72 Summary:        Header files, and utilities for ORBit
73 Summary(fr.UTF-8):      Librairies statiques et fichiers entête pour ORBit
74 Summary(pl.UTF-8):      Pliki nagłówkowe i użytki dla ORBit
75 Group:          Development/Libraries
76 Requires:       %{name} = %{epoch}:%{version}-%{release}
77 Requires:       glib2-devel >= 1:2.14.1
78 Requires:       indent
79 Requires:       libIDL-devel >= 0.8.10
80 Provides:       linc-devel = 1.1.1
81 Obsoletes:      libORBit2_0-devel
82 Obsoletes:      linc-devel
83
84 %description devel
85 devel ORBit is a high-performance CORBA ORB with support for the C
86 language. It allows programs to send requests and receive replies from
87 other programs, regardless of the locations of the two programs.
88
89 This package includes the header files and utilities neecessary to
90 write programs that use CORBA technology.
91
92 %description devel -l fr.UTF-8
93 Librairies statiques et fichiers entête requis pour le development ou
94 la compilation de programmes utilisant ORBit.
95
96 %description devel -l pl.UTF-8
97 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
98 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
99 programów bez znajomości położenia tych dwóch programów.
100
101 Ten pakiet zawiera pliki nagłówkowe oraz użytki potrzebne do pisania
102 programów używających technologi CORBA.
103
104 %package static
105 Summary:        Static libraries for ORBit
106 Summary(pl.UTF-8):      Biblioteki statyczne dla ORBit
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
109 Provides:       linc-static = 1.1.1
110 Obsoletes:      linc-static
111
112 %description static
113 ORBit is a high-performance CORBA ORB with support for the C language.
114 It allows programs to send requests and receive replies from other
115 programs, regardless of the locations of the two programs.
116
117 This package includes static libraries neecessary to write programs
118 statically linked that use CORBA technology.
119
120 %description static -l pl.UTF-8
121 ORBit to wysokiej wydajności CORBA ORB ze wsparciem dla języka C.
122 Pozwala na wysyłanie próśb i otrzymywanie odpowiedzi od innych
123 programów bez znajomości położenia tych dwóch programów.
124
125 Ten pakiet zawiera biblioteki statyczne potrzebne do pisania programów
126 skonsolidowanych statycznie używających technologii CORBA.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132
133 %if !%{with apidocs}
134 echo 'EXTRA_DIST=' > gtk-doc.make
135 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
136 %endif
137
138 %build
139 %{?with_apidocs:%{__gtkdocize}}
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoconf}
143 %{__autoheader}
144 %{__automake}
145 %configure \
146         --with-html-dir=%{_gtkdocdir} \
147         %{!?with_static_libs:--disable-static} \
148         %{?with_apidocs:--enable-gtk-doc}
149 %{__make} -j1
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153
154 %{__make} -j1 install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 # no static module - shut up check-files
158 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/Everything_module.{la,a}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS NEWS README
169 %attr(755,root,root) %{_bindir}/ior-decode-2
170 %attr(755,root,root) %{_bindir}/linc-cleanup-sockets
171 %attr(755,root,root) %{_bindir}/orbit-idl-2
172 %attr(755,root,root) %{_bindir}/typelib-dump
173 %attr(755,root,root) %{_libdir}/libORBit-2.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libORBit-2.so.0
175 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libORBit-imodule-2.so.0
177 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libORBitCosNaming-2.so.0
179 %dir %{_libdir}/orbit-2.0
180 %attr(755,root,root) %{_libdir}/orbit-2.0/Everything_module.so
181 %{_datadir}/idl/orbit-2.0
182
183 %if %{with apidocs}
184 %files apidocs
185 %defattr(644,root,root,755)
186 %{_gtkdocdir}/%{name}
187 %endif
188
189 %files devel
190 %defattr(644,root,root,755)
191 %doc ChangeLog
192 %attr(755,root,root) %{_bindir}/orbit2-config
193 %attr(755,root,root) %{_libdir}/libORBit-2.so
194 %attr(755,root,root) %{_libdir}/libORBit-imodule-2.so
195 %attr(755,root,root) %{_libdir}/libORBitCosNaming-2.so
196 %{_libdir}/libORBit-2.la
197 %{_libdir}/libORBit-imodule-2.la
198 %{_libdir}/libORBitCosNaming-2.la
199 %{_libdir}/libname-server-2.a
200 %{_includedir}/orbit-2.0
201 %{_pkgconfigdir}/ORBit-2.0.pc
202 %{_pkgconfigdir}/ORBit-CosNaming-2.0.pc
203 %{_pkgconfigdir}/ORBit-idl-2.0.pc
204 %{_pkgconfigdir}/ORBit-imodule-2.0.pc
205 %{_aclocaldir}/ORBit2.m4
206
207 %if %{with static_libs}
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libORBit-2.a
211 %{_libdir}/libORBit-imodule-2.a
212 %{_libdir}/libORBitCosNaming-2.a
213 %endif
This page took 0.048593 seconds and 3 git commands to generate.