]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- without demos bcond
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  demos   # don't build demos
8 %bcond_without  motif   # build static libGLw without Motif interface
9 %bcond_without  gallium
10 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
11 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
12 %bcond_with     static
13 #
14 # minimal supported xserver version
15 %define         xserver_ver     1.5.0
16 # glapi version (glapi tables in dri drivers and libglx must be in sync);
17 # set to current Mesa version on ABI break, when xserver tables get regenerated
18 # (until they start to be somehow versioned themselves)
19 %define         glapi_ver       7.1.0
20 #
21 Summary:        Free OpenGL implementation
22 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
23 Name:           Mesa
24 Version:        7.5
25 Release:        6%{?with_multigl:.mgl}
26 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
27 Group:          X11/Libraries
28 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
29 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
30 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
31 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
32 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
33 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
34 Patch0:         %{name}-realclean.patch
35 Patch1:         %{name}-noveau-abi-0.0.15.patch
36 Patch2:         %{name}-sparc64.patch
37 URL:            http://www.mesa3d.org/
38 BuildRequires:  expat-devel
39 %{?with_demos:BuildRequires:    glew-devel}
40 BuildRequires:  libdrm-devel >= 2.4.12-3
41 BuildRequires:  libselinux-devel
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool >= 2:1.4d
44 %{?with_motif:BuildRequires:    motif-devel}
45 BuildRequires:  rpmbuild(macros) >= 1.470
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  xorg-lib-libXdamage-devel
48 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
49 BuildRequires:  xorg-lib-libXt-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 BuildRequires:  xorg-proto-glproto-devel
52 BuildRequires:  xorg-proto-printproto-devel
53 BuildRequires:  xorg-util-makedepend
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %if %{without gallium}
57 %undefine       with_gallium_intel
58 %endif
59
60 %description
61 Mesa is a 3-D graphics library with an API which is very similar to
62 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
63 syntax or state machine, it is being used with authorization from
64 Silicon Graphics, Inc. However, the author does not possess an OpenGL
65 license from SGI, and makes no claim that Mesa is in any way a
66 compatible replacement for OpenGL or associated with SGI.
67
68 %description -l pl.UTF-8
69 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
70 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
71 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
72 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
73 OpenGL ani powiązana z SGI.
74
75 %package libGL
76 Summary:        Free Mesa3D implementation of libGL OpenGL library
77 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
78 License:        MIT
79 Group:          X11/Libraries
80 Requires:       libdrm >= 2.4.5
81 Provides:       OpenGL = 2.1
82 # reports version 1.3, but supports glXGetProcAddress() from 1.4
83 Provides:       OpenGL-GLX = 1.4
84 Obsoletes:      Mesa
85 Obsoletes:      Mesa-dri
86 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
87 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
88
89 %description libGL
90 Mesa is a 3-D graphics library with an API which is very similar to
91 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
92 syntax or state machine, it is being used with authorization from
93 Silicon Graphics, Inc. However, the author does not possess an OpenGL
94 license from SGI, and makes no claim that Mesa is in any way a
95 compatible replacement for OpenGL or associated with SGI.
96
97 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
98 specifications. It uses DRI for rendering.
99
100 %description libGL -l pl.UTF-8
101 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
102 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
103 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
104 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
105 OpenGL ani powiązana z SGI.
106
107 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
108 GLX 1.4. Używa DRI do renderowania.
109
110 %package libGL-devel
111 Summary:        Header files for Mesa3D libGL library
112 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
113 License:        MIT
114 Group:          X11/Development/Libraries
115 # loose dependency on libGL to use with other libGL binaries
116 Requires:       OpenGL >= 1.5
117 Requires:       xorg-lib-libX11-devel
118 Provides:       OpenGL-GLX-devel = 1.4
119 Provides:       OpenGL-devel = 2.1
120 Obsoletes:      Mesa-devel
121 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
122 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
123 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
124 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
125
126 %description libGL-devel
127 Header files for Mesa3D libGL library.
128
129 %description libGL-devel -l pl.UTF-8
130 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
131
132 %package libGL-static
133 Summary:        Static Mesa3D libGL library
134 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
135 License:        MIT
136 Group:          X11/Development/Libraries
137 Requires:       %{name}-libGL-devel = %{version}-%{release}
138 Provides:       OpenGL-static = 2.1
139 Obsoletes:      Mesa-static
140 Obsoletes:      X11-OpenGL-static < 1:7.0.0
141 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
142
143 %description libGL-static
144 Static Mesa3D libGL library. It uses software renderer.
145
146 %description libGL-static -l pl.UTF-8
147 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
148 renderingu.
149
150 %package libGLU
151 Summary:        SGI implementation of libGLU OpenGL library
152 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
153 License:        SGI Free Software License B v2.0 (MIT-like)
154 Group:          Libraries
155 # loose dependency on libGL.so.1 to use with other libGL binaries
156 Requires:       OpenGL >= 1.2
157 Provides:       OpenGL-GLU = 1.3
158 Obsoletes:      Mesa-devel
159 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
160 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
161
162 %description libGLU
163 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
164 1.3 specifications.
165
166 %description libGLU -l pl.UTF-8
167 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
168 specyfikację OpenGL GLU 1.3.
169
170 %package libGLU-devel
171 Summary:        Header files for SGI libGLU library
172 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
173 License:        SGI Free Software License B v2.0 (MIT-like)
174 Group:          Development/Libraries
175 Requires:       %{name}-libGLU = %{version}-%{release}
176 Requires:       OpenGL-devel >= 1.2
177 Requires:       libstdc++-devel
178 Provides:       OpenGL-GLU-devel = 1.3
179
180 %description libGLU-devel
181 Header files for SGI libGLU library.
182
183 %description libGLU-devel -l pl.UTF-8
184 Pliki nagłówkowe biblioteki SGI libGLU.
185
186 %package libGLU-static
187 Summary:        Static SGI libGLU library
188 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
189 License:        SGI Free Software License B v2.0 (MIT-like)
190 Group:          Development/Libraries
191 Requires:       %{name}-libGLU-devel = %{version}-%{release}
192 Provides:       OpenGL-GLU-static = 1.3
193
194 %description libGLU-static
195 Static SGI libGLU library.
196
197 %description libGLU-static -l pl.UTF-8
198 Statyczna biblioteka SGI libGLU.
199
200 %package libGLw
201 Summary:        SGI OpenGL Xt widgets library
202 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
203 License:        SGI MIT-like
204 Group:          Libraries
205 # loose dependency on libGL.so.1 to use with other libGL binaries
206 Requires:       OpenGL >= 1.1
207 Provides:       OpenGL-GLw
208
209 %description libGLw
210 SGI OpenGL Xt widgets library.
211
212 %description libGLU -l pl.UTF-8
213 Biblioteka SGI widgetów Xt dla OpenGL-a.
214
215 %package libGLw-devel
216 Summary:        Header files for SGI libGLw library
217 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
218 License:        SGI MIT-like
219 Group:          Development/Libraries
220 Requires:       %{name}-libGLw = %{version}-%{release}
221 Requires:       OpenGL-devel >= 1.2
222 Provides:       OpenGL-GLw-devel
223
224 %description libGLw-devel
225 Header files for SGI libGLw library.
226
227 %description libGLw-devel -l pl.UTF-8
228 Pliki nagłówkowe biblioteki SGI libGLw.
229
230 %package libGLw-static
231 Summary:        Static SGI libGLw library
232 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
233 License:        SGI MIT-like
234 Group:          Development/Libraries
235 Requires:       %{name}-libGLw-devel = %{version}-%{release}
236 Provides:       OpenGL-GLw-static
237
238 %description libGLw-static
239 Static SGI libGLw library.
240
241 %description libGLw-static -l pl.UTF-8
242 Statyczna biblioteka SGI libGLw.
243
244 %package libOSMesa
245 Summary:        OSMesa (off-screen renderer) library
246 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
247 License:        MIT
248 Group:          Libraries
249 # doesn't require base
250
251 %description libOSMesa
252 OSMesa (off-screen renderer) library.
253
254 %description libOSMesa -l pl.UTF-8
255 Biblioteka OSMesa (renderująca bitmapy w pamięci).
256
257 %package libOSMesa-devel
258 Summary:        Header file for OSMesa (off-screen renderer) library
259 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
260 License:        MIT
261 Group:          Development/Libraries
262 Requires:       %{name}-libOSMesa = %{version}-%{release}
263 # for <GL/gl.h> only
264 Requires:       OpenGL-devel
265
266 %description libOSMesa-devel
267 Header file for OSMesa (off-screen renderer) library.
268
269 %description libOSMesa-devel -l pl.UTF-8
270 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
271
272 %package libOSMesa-static
273 Summary:        Static OSMesa (off-screen renderer) library
274 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
275 License:        MIT
276 Group:          Development/Libraries
277 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
278 # this static build of OSMesa needs static non-dri Mesa implementation
279 Requires:       %{name}-libGL-static = %{version}-%{release}
280
281 %description libOSMesa-static
282 Static OSMesa (off-screen renderer) library.
283
284 %description libOSMesa-static -l pl.UTF-8
285 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
286
287 %package utils
288 Summary:        OpenGL utilities from Mesa3D
289 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
290 License:        MIT
291 Group:          X11/Applications/Graphics
292 # loose deps on libGL/libGLU
293
294 %description utils
295 OpenGL utilities from Mesa3D: glxgears and glxinfo.
296
297 %description utils -l pl.UTF-8
298 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
299
300 %package demos
301 Summary:        Mesa Demos source code
302 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
303 License:        various (MIT, SGI, GPL - see copyright notes in sources)
304 Group:          Development/Libraries
305 Requires:       OpenGL-devel
306
307 %description demos
308 Demonstration programs for the Mesa libraries in source code form.
309
310 %description demos -l pl.UTF-8
311 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
312
313 %package dri-driver-ati-mach64
314 Summary:        X.org DRI driver for ATI Mach64 card family
315 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
316 License:        MIT
317 Group:          X11/Libraries
318 Requires:       xorg-driver-video-mach64
319 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
320 Requires:       xorg-xserver-server >= %{xserver_ver}
321
322 %description dri-driver-ati-mach64
323 X.org DRI driver for ATI Mach64 card family.
324
325 %description dri-driver-ati-mach64 -l pl.UTF-8
326 Sterownik X.org DRI dla rodziny kart ATI Mach64.
327
328 %package dri-driver-ati-radeon-R100
329 Summary:        X.org DRI driver for ATI R100 card family
330 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
331 License:        MIT
332 Group:          X11/Libraries
333 Requires:       xorg-driver-video-ati
334 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
335 Requires:       xorg-xserver-server >= %{xserver_ver}
336 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
337
338 %description dri-driver-ati-radeon-R100
339 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
340
341 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
342 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
343
344 %package dri-driver-ati-radeon-R200
345 Summary:        X.org DRI driver for ATI R200 card family
346 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
347 License:        MIT
348 Group:          X11/Libraries
349 Requires:       xorg-driver-video-ati
350 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
351 Requires:       xorg-xserver-server >= %{xserver_ver}
352 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
353
354 %description dri-driver-ati-radeon-R200
355 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
356
357 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
358 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
359
360 %package dri-driver-ati-radeon-R300
361 Summary:        X.org DRI driver for ATI R300 card family
362 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
363 License:        MIT
364 Group:          X11/Libraries
365 Requires:       xorg-driver-video-ati
366 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
367 Requires:       xorg-xserver-server >= %{xserver_ver}
368 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
369
370 %description dri-driver-ati-radeon-R300
371 X.org DRI driver for ATI R300 card family.
372
373 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
374 Sterownik X.org DRI dla rodziny kart ATI R300.
375
376 %package dri-driver-ati-rage128
377 Summary:        X.org DRI driver for ATI Rage128 card family
378 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
379 License:        MIT
380 Group:          X11/Libraries
381 Requires:       xorg-driver-video-r128
382 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
383 Requires:       xorg-xserver-server >= %{xserver_ver}
384 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
385
386 %description dri-driver-ati-rage128
387 X.org DRI driver for ATI Rage128 card family.
388
389 %description dri-driver-ati-rage128 -l pl.UTF-8
390 Sterownik X.org DRI dla rodziny kart ATI Rage128.
391
392 %package dri-driver-ffb
393 Summary:        X.org DRI driver for Sun FFB card family
394 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
395 License:        MIT
396 Group:          X11/Libraries
397 Requires:       xorg-driver-video-sunffb
398 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
399 Requires:       xorg-xserver-server >= %{xserver_ver}
400
401 %description dri-driver-ffb
402 X.org DRI driver for SUN Creator3D and Elite3D card family.
403
404 %description dri-driver-ffb -l pl.UTF-8
405 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
406
407 %package dri-driver-glint
408 Summary:        X.org DRI driver for GLINT/Permedia card family
409 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
410 License:        MIT
411 Group:          X11/Libraries
412 Requires:       xorg-driver-video-glint
413 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
414 Requires:       xorg-xserver-server >= %{xserver_ver}
415 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
416
417 %description dri-driver-glint
418 X.org DRI driver for GLINT/Permedia card family.
419
420 %description dri-driver-glint -l pl.UTF-8
421 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
422
423 %package dri-driver-intel-i810
424 Summary:        X.org DRI driver for Intel i810 card family
425 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
426 License:        MIT
427 Group:          X11/Libraries
428 Requires:       xorg-driver-video-intel
429 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
430 Requires:       xorg-xserver-server >= %{xserver_ver}
431 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
432
433 %description dri-driver-intel-i810
434 X.org DRI driver for Intel i810 card family.
435
436 %description dri-driver-intel-i810 -l pl.UTF-8
437 Sterownik X.org DRI dla rodziny kart Intel i810.
438
439 %package dri-driver-intel-i915
440 Summary:        X.org DRI driver for Intel i915 card family
441 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
442 License:        MIT
443 Group:          X11/Libraries
444 Requires:       xorg-driver-video-intel
445 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
446 Requires:       xorg-xserver-server >= %{xserver_ver}
447 Obsoletes:      Mesa-dri-driver-intel-i830
448 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
449
450 %description dri-driver-intel-i915
451 X.org DRI driver for Intel i915 card family.
452
453 %description dri-driver-intel-i915 -l pl.UTF-8
454 Sterownik X.org DRI dla rodziny kart Intel i915.
455
456 %package dri-driver-intel-i965
457 Summary:        X.org DRI driver for Intel i965 card family
458 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
459 License:        MIT
460 Group:          X11/Libraries
461 Requires:       xorg-driver-video-intel
462 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
463 Requires:       xorg-xserver-server >= %{xserver_ver}
464 Obsoletes:      Mesa-dri-driver-intel-i830
465 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
466
467 %description dri-driver-intel-i965
468 X.org DRI driver for Intel i965 card family.
469
470 %description dri-driver-intel-i965 -l pl.UTF-8
471 Sterownik X.org DRI dla rodziny kart Intel i965.
472
473 %package dri-driver-matrox
474 Summary:        X.org DRI driver for Matrox G card family
475 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
476 License:        MIT
477 Group:          X11/Libraries
478 Requires:       xorg-driver-video-mga
479 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
480 Requires:       xorg-xserver-server >= %{xserver_ver}
481 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
482
483 %description dri-driver-matrox
484 X.org DRI drivers for Matrox G card family.
485
486 %description dri-driver-matrox -l pl.UTF-8
487 Sterowniki X.org DRI dla rodziny kart Matrox G.
488
489 %package dri-driver-nouveau
490 Summary:        X.org DRI driver for NVIDIA card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-nouveau
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497
498 %description dri-driver-nouveau
499 X.org DRI drivers for NVIDIA card family.
500
501 %description dri-driver-nouveau -l pl.UTF-8
502 Sterowniki X.org DRI dla rodziny kart NVIDIA.
503
504 %package dri-driver-s3virge
505 Summary:        X.org DRI driver for S3 Virge card family
506 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
507 License:        MIT
508 Group:          X11/Libraries
509 Requires:       xorg-driver-video-s3virge
510 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
511 Requires:       xorg-xserver-server >= %{xserver_ver}
512
513 %description dri-driver-s3virge
514 X.org DRI driver for S3 Virge card family.
515
516 %description dri-driver-s3virge -l pl.UTF-8
517 Sterownik X.org DRI dla rodziny kart S3 Virge.
518
519 %package dri-driver-savage
520 Summary:        X.org DRI driver for S3 Savage card family
521 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
522 License:        MIT
523 Group:          X11/Libraries
524 Requires:       xorg-driver-video-savage
525 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
526 Requires:       xorg-xserver-server >= %{xserver_ver}
527
528 %description dri-driver-savage
529 X.org DRI driver for S3 Savage card family.
530
531 %description dri-driver-savage -l pl.UTF-8
532 Sterownik X.org DRI dla rodziny kart S3 Savage.
533
534 %package dri-driver-sis
535 Summary:        X.org DRI driver for SiS card family
536 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
537 License:        MIT
538 Group:          X11/Libraries
539 Requires:       xorg-driver-video-sis
540 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
541 Requires:       xorg-xserver-server >= %{xserver_ver}
542 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
543
544 %description dri-driver-sis
545 X.org DRI driver for SiS card family.
546
547 %description dri-driver-sis -l pl.UTF-8
548 Sterownik X.org DRI dla rodziny kart SiS.
549
550 %package dri-driver-swrast
551 Summary:        X.org DRI software rasterizer driver
552 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
553 License:        MIT
554 Group:          X11/Libraries
555 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
556 Requires:       xorg-xserver-server >= %{xserver_ver}
557
558 %description dri-driver-swrast
559 X.org DRI software rasterizer driver.
560
561 %description dri-driver-swrast -l pl.UTF-8
562 Sterownik X.org DRI obsługujący rysowanie programowe.
563
564 %package dri-driver-tdfx
565 Summary:        X.org DRI driver for 3DFX Voodoo card family
566 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
567 License:        MIT
568 Group:          X11/Libraries
569 Requires:       Glide3-DRI
570 Requires:       xorg-driver-video-tdfx
571 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
572 Requires:       xorg-xserver-server >= %{xserver_ver}
573 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
574
575 %description dri-driver-tdfx
576 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
577 and Velocity 100/200).
578
579 %description dri-driver-tdfx -l pl.UTF-8
580 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
581 Banshee i Velocity 100/200).
582
583 %package dri-driver-trident
584 Summary:        X.org DRI driver for Trident card family
585 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
586 License:        MIT
587 Group:          X11/Libraries
588 Requires:       xorg-driver-video-trident
589 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
590 Requires:       xorg-xserver-server >= %{xserver_ver}
591
592 %description dri-driver-trident
593 X.org DRI drivers for Trident card family.
594
595 %description dri-driver-trident -l pl.UTF-8
596 Sterowniki X.org DRI dla rodziny kart Trident.
597
598 %package dri-driver-via-unichrome
599 Summary:        X.org DRI driver for VIA Unichrome card family
600 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
601 License:        MIT
602 Group:          X11/Libraries
603 Requires:       xorg-driver-video-openchrome
604 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
605 Requires:       xorg-xserver-server >= %{xserver_ver}
606
607 %description dri-driver-via-unichrome
608 X.org DRI driver for VIA Unichrome card family.
609
610 %description dri-driver-via-unichrome -l pl.UTF-8
611 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
612
613 %prep
614 %setup -q -b1 -a2
615 %patch0 -p0
616 %patch1 -p1
617 %patch2 -p1
618
619 # fix demos
620 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
621
622 %build
623 [ ! -f configure ] && ./autogen.sh
624
625 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
626 %if %{without gallium_intel}
627 i915 \
628 %endif
629 %ifarch sparc sparcv9 sparc64
630 ffb \
631 %endif
632 %ifarch %{ix86} %{x8664}
633 sis \
634 %endif
635 swrast tdfx unichrome"
636
637 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
638
639 common_flags="\
640         --enable-shared \
641         --enable-selinux \
642         --enable-pic \
643         --disable-egl \
644         --with%{!?with_demos:out}-demos"
645
646 # osmesa variants
647 %configure $common_flags \
648         --with-driver=osmesa \
649         --disable-asm \
650         --with-osmesa-bits=8
651 %{__make} \
652         SRC_DIRS=mesa
653 mv %{_lib} osmesa8
654 %{__make} clean
655
656 %configure $common_flags \
657         --with-driver=osmesa \
658         --disable-asm \
659         --with-osmesa-bits=16
660 %{__make} \
661         SRC_DIRS=mesa
662 mv %{_lib} osmesa16
663 %{__make} clean
664
665 %configure $common_flags \
666         --with-driver=osmesa \
667         --disable-asm \
668         --with-osmesa-bits=32
669 %{__make} \
670         SRC_DIRS=mesa
671 mv %{_lib} osmesa32
672 %{__make} clean
673
674 %configure $common_flags \
675         --enable-glu \
676         --enable-glw \
677         --disable-glut \
678 %if %{with gallium}
679         --enable-gallium \
680         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
681         --enable-gallium-nouveau \
682         --with-state-trackers=dri \
683 %else
684         --disable-gallium \
685 %endif
686         --with-driver=dri \
687         --with-dri-drivers=${dri_drivers} \
688         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
689
690 %{__make}
691 %{__make} -C progs/xdemos glxgears glxinfo
692 %if %{with demos}
693 %{__make} -C progs/demos
694 %endif
695
696 cd gl-manpages-*
697 %configure
698 %{__make}
699
700 %install
701 rm -rf $RPM_BUILD_ROOT
702
703 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
704
705 # libs without drivers
706 %{__make} install \
707         DESTDIR=$RPM_BUILD_ROOT
708
709 cd gl-manpages-*
710 %{__make} install \
711         DESTDIR=$RPM_BUILD_ROOT
712 cd ..
713
714 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
715
716 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
717 # work on copy to keep -bi --short-circuit working
718 rm -rf progs-clean
719 install -d progs-clean
720 for l in demos glsl osdemos redbook samples xdemos ; do
721         cp -a progs/$l progs-clean/$l
722         %{__make} -C progs-clean/$l clean
723         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
724 done
725 rm -rf progs-clean
726 for l in util images ; do
727         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
728 done
729 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
730
731 # strip out undesirable headers
732 olddir=$(pwd)
733 cd $RPM_BUILD_ROOT%{_includedir}/GL
734 rm [a-fh-np-wyz]*.h gg*.h glf*.h
735 cd $RPM_BUILD_ROOT%{_libdir}
736 cd $olddir
737
738 %if %{with multigl}
739 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
740
741 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
742 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
743
744 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
745 %endif
746
747 %clean
748 rm -rf $RPM_BUILD_ROOT
749
750 %post   libGL -p /sbin/ldconfig
751 %postun libGL -p /sbin/ldconfig
752
753 %post   libGLU -p /sbin/ldconfig
754 %postun libGLU -p /sbin/ldconfig
755
756 %post   libGLw -p /sbin/ldconfig
757 %postun libGLw -p /sbin/ldconfig
758
759 %files libGL
760 %defattr(644,root,root,755)
761 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
762 %if %{with multigl}
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
764 %dir %{_libdir}/Mesa
765 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
766 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
767 %else
768 %attr(755,root,root) %{_libdir}/libGL.so.*.*
769 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
770 # symlink for binary apps which fail to conform Linux OpenGL ABI
771 # (and dlopen libGL.so instead of libGL.so.1)
772 %attr(755,root,root) %{_libdir}/libGL.so
773 %endif
774
775 %files libGL-devel
776 %defattr(644,root,root,755)
777 %doc docs/*.spec
778 %if %{with multigl}
779 %attr(755,root,root) %{_libdir}/libGL.so
780 %endif
781 %dir %{_includedir}/GL
782 %{_includedir}/GL/gl.h
783 %{_includedir}/GL/glext.h
784 %{_includedir}/GL/gl_mangle.h
785 %{_includedir}/GL/glx.h
786 %{_includedir}/GL/glxext.h
787 %{_includedir}/GL/glx_mangle.h
788 %dir %{_includedir}/GL/internal
789 %{_includedir}/GL/internal/dri_interface.h
790 %{_pkgconfigdir}/dri.pc
791 %{_pkgconfigdir}/gl.pc
792 %{_mandir}/man3/gl[^uX]*.3gl*
793 %{_mandir}/man3/glX*.3gl*
794
795 %if %{with static}
796 %files libGL-static
797 %defattr(644,root,root,755)
798 %{_libdir}/libGL.a
799 %endif
800
801 %files libGLU
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
804 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
805
806 %files libGLU-devel
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libGLU.so
809 %{_includedir}/GL/glu.h
810 %{_includedir}/GL/glu_mangle.h
811 %{_pkgconfigdir}/glu.pc
812 %{_mandir}/man3/glu*.3gl*
813
814 %if %{with static}
815 %files libGLU-static
816 %defattr(644,root,root,755)
817 %{_libdir}/libGLU.a
818 %endif
819
820 %files libGLw
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
823 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
824
825 %files libGLw-devel
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_libdir}/libGLw.so
828 %{_includedir}/GL/GLwDrawA.h
829 %{_includedir}/GL/GLwDrawAP.h
830 %{_includedir}/GL/GLwMDrawA.h
831 %{_includedir}/GL/GLwMDrawAP.h
832 %{_pkgconfigdir}/glw.pc
833
834 %if %{with static}
835 %files libGLw-static
836 %defattr(644,root,root,755)
837 %{_libdir}/libGLw.a
838 %endif
839
840 %files libOSMesa
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
843 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
844
845 %files libOSMesa-devel
846 %defattr(644,root,root,755)
847 %attr(755,root,root) %{_libdir}/libOSMesa*.so
848 %{_includedir}/GL/osmesa.h
849
850 %if %{with static}
851 %files libOSMesa-static
852 %defattr(644,root,root,755)
853 %{_libdir}/libOSMesa*.a
854 %endif
855
856 %files utils
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_bindir}/glxgears
859 %attr(755,root,root) %{_bindir}/glxinfo
860
861 %files dri-driver-ati-mach64
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
864
865 %files dri-driver-ati-radeon-R100
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
868
869 %files dri-driver-ati-radeon-R200
870 %defattr(644,root,root,755)
871 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
872
873 %files dri-driver-ati-radeon-R300
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
876
877 %files dri-driver-ati-rage128
878 %defattr(644,root,root,755)
879 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
880
881 # sunffb (sparc only)
882 %ifarch sparc sparcv9 sparc64
883 %files dri-driver-ffb
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
886 %endif
887
888 # glint (requires update)
889 %if 0
890 %files dri-driver-glint
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
893 %endif
894
895 %files dri-driver-intel-i810
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
898
899 %files dri-driver-intel-i915
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
902
903 %files dri-driver-intel-i965
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
906
907 %files dri-driver-matrox
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
910
911 %if %{with gallium}
912 %files dri-driver-nouveau
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
916 %endif
917
918 %files dri-driver-s3virge
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
921
922 %files dri-driver-savage
923 %defattr(644,root,root,755)
924 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
925
926 %ifarch %{ix86} %{x8664}
927 %files dri-driver-sis
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
930 %endif
931
932 %files dri-driver-swrast
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
935
936 %files dri-driver-tdfx
937 %defattr(644,root,root,755)
938 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
939
940 %files dri-driver-trident
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
943
944 %files dri-driver-via-unichrome
945 %defattr(644,root,root,755)
946 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
947
948 %if %{with demos}
949 %files demos
950 %defattr(644,root,root,755)
951 %{_examplesdir}/%{name}-%{version}
952 %endif
This page took 0.113696 seconds and 4 git commands to generate.