]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- Obsoletes for X11-OpenGL* packages
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_with     glide   # with GLIDE (broken now)
8 %bcond_without  motif   # build static libGLw without Motif interface
9 #
10 Summary:        Free OpenGL implementation
11 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
12 Name:           Mesa
13 Version:        6.4.2
14 Release:        1
15 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
16 Group:          X11/Libraries
17 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
18 # Source0-md5:  7674d2c603b5834259e4e5a820cefd5b
19 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
20 # Source1-md5:  9cae1ab874af533ce356bd7dfe2e0bb0
21 Patch0:         %{name}-modules_dir.patch
22 URL:            http://www.mesa3d.org/
23 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
24 BuildRequires:  expat-devel
25 BuildRequires:  libdrm-devel >= 1.0.4-1.20051022
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool >= 2:1.4d
28 %{?with_motif:BuildRequires:    motif-devel}
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  xorg-lib-libXt-devel
31 BuildRequires:  xorg-lib-libXxf86vm-devel
32 BuildRequires:  xorg-proto-glproto-devel
33 BuildRequires:  xorg-util-makedepend
34 Obsoletes:      Mesa-dri
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # avoid XFree86-OpenGL* dependency
38 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
40
41 %define         _sysconfdir     /etc/X11
42
43 %description
44 Mesa is a 3-D graphics library with an API which is very similar to
45 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
46 syntax or state machine, it is being used with authorization from
47 Silicon Graphics, Inc. However, the author does not possess an OpenGL
48 license from SGI, and makes no claim that Mesa is in any way a
49 compatible replacement for OpenGL or associated with SGI.
50
51 %description -l pl
52 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
53 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
54 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
55 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
56 OpenGL ani powi±zana z SGI.
57
58 %package libGL
59 Summary:        Free Mesa3D implementation of libGL OpenGL library
60 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
61 License:        MIT
62 Group:          X11/Libraries
63 %{?with_glide:Requires: Glide3-DRI}
64 Provides:       OpenGL = 1.5
65 # reports version 1.3, but supports glXGetProcAddress() from 1.4
66 Provides:       OpenGL-GLX = 1.4
67 Obsoletes:      Mesa
68 Obsoletes:      X11-OpenGL-libGL
69 Obsoletes:      XFree86-OpenGL-libGL
70
71 %description libGL
72 Mesa is a 3-D graphics library with an API which is very similar to
73 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
74 syntax or state machine, it is being used with authorization from
75 Silicon Graphics, Inc. However, the author does not possess an OpenGL
76 license from SGI, and makes no claim that Mesa is in any way a
77 compatible replacement for OpenGL or associated with SGI.
78
79 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
80 specifications. It uses DRI for rendering.
81
82 %description libGL -l pl
83 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
84 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
85 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
86 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
87 OpenGL ani powi±zana z SGI.
88
89 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
90 GLX 1.4. U¿ywa DRI do renderowania.
91
92 %package libGL-devel
93 Summary:        Header files for Mesa3D libGL library
94 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
95 License:        MIT
96 Group:          X11/Development/Libraries
97 # loose dependency on libGL to use with other libGL binaries
98 Requires:       OpenGL >= 1.5
99 Requires:       xorg-lib-libX11-devel
100 Provides:       OpenGL-devel = 1.5
101 Provides:       OpenGL-GLX-devel = 1.4
102 Obsoletes:      Mesa-devel
103 Obsoletes:      X11-OpenGL-devel
104 Obsoletes:      X11-OpenGL-devel-base
105 Obsoletes:      XFree86-OpenGL-devel
106 Obsoletes:      XFree86-OpenGL-devel-base
107
108 %description libGL-devel
109 Header files for Mesa3D libGL library.
110
111 %description libGL-devel -l pl
112 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
113
114 %package libGL-static
115 Summary:        Static Mesa3D libGL library
116 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
117 License:        MIT
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-libGL-devel = %{version}-%{release}
120 Provides:       OpenGL-static = 1.5
121 Obsoletes:      Mesa-static
122 Obsoletes:      X11-OpenGL-static
123 Obsoletes:      XFree86-OpenGL-static
124
125 %description libGL-static
126 Static Mesa3D libGL library. It uses software renderer.
127
128 %description libGL-static -l pl
129 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
130 renderingu.
131
132 %package libGLU
133 Summary:        SGI implementation of libGLU OpenGL library
134 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
135 License:        SGI Free Software License B v1.1
136 Group:          Libraries
137 # loose dependency on libGL.so.1 to use with other libGL binaries
138 Requires:       OpenGL >= 1.2
139 Provides:       OpenGL-GLU = 1.3
140 Obsoletes:      Mesa-devel
141 Obsoletes:      X11-OpenGL-libs
142 Obsoletes:      XFree86-OpenGL-libs
143
144 %description libGLU
145 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
146 1.3 specifications.
147
148 %description libGLU -l pl
149 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
150 specyfikacjê OpenGL GLU 1.3.
151
152 %package libGLU-devel
153 Summary:        Header files for SGI libGLU library
154 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
155 License:        SGI Free Software License B v1.1
156 Group:          Development/Libraries
157 Requires:       %{name}-libGLU = %{version}-%{release}
158 Requires:       OpenGL-devel >= 1.2
159 Requires:       libstdc++-devel
160 Provides:       OpenGL-GLU-devel = 1.3
161
162 %description libGLU-devel
163 Header files for SGI libGLU library.
164
165 %description libGLU-devel -l pl
166 Pliki nag³ówkowe biblioteki SGI libGLU.
167
168 %package libGLU-static
169 Summary:        Static SGI libGLU library
170 Summary(pl):    Statyczna biblioteka SGI libGLU
171 License:        SGI Free Software License B v1.1
172 Group:          Development/Libraries
173 Requires:       %{name}-libGLU-devel = %{version}-%{release}
174 Provides:       OpenGL-GLU-static = 1.3
175
176 %description libGLU-static
177 Static SGI libGLU library.
178
179 %description libGLU-static -l pl
180 Statyczna biblioteka SGI libGLU.
181
182 %package libGLw
183 Summary:        SGI OpenGL Xt widgets library
184 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
185 License:        SGI MIT-like
186 Group:          Libraries
187 # loose dependency on libGL.so.1 to use with other libGL binaries
188 Requires:       OpenGL >= 1.1
189 Provides:       OpenGL-GLw
190
191 %description libGLw
192 SGI OpenGL Xt widgets library.
193
194 %description libGLU -l pl
195 Biblioteka SGI widgetów Xt dla OpenGL-a.
196
197 %package libGLw-devel
198 Summary:        Header files for SGI libGLw library
199 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
200 License:        SGI Free Software License B v1.1
201 Group:          Development/Libraries
202 Requires:       %{name}-libGLw = %{version}-%{release}
203 Requires:       OpenGL-devel >= 1.2
204 Provides:       OpenGL-GLw-devel
205
206 %description libGLw-devel
207 Header files for SGI libGLw library.
208
209 %description libGLw-devel -l pl
210 Pliki nag³ówkowe biblioteki SGI libGLw.
211
212 %package libGLw-static
213 Summary:        Static SGI libGLw library
214 Summary(pl):    Statyczna biblioteka SGI libGLw
215 License:        SGI Free Software License B v1.1
216 Group:          Development/Libraries
217 Requires:       %{name}-libGLw-devel = %{version}-%{release}
218 Provides:       OpenGL-GLw-static
219
220 %description libGLw-static
221 Static SGI libGLw library.
222
223 %description libGLw-static -l pl
224 Statyczna biblioteka SGI libGLw.
225
226 %package utils
227 Summary:        OpenGL utilities from Mesa3D
228 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
229 Group:          X11/Applications/Graphics
230 # loose deps on libGL/libGLU
231
232 %description utils
233 OpenGL utilities from Mesa3D: glxgears and glxinfo.
234
235 %description utils -l pl
236 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
237
238 %package demos
239 Summary:        Mesa Demos
240 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
241 Group:          Development/Libraries
242 Requires:       OpenGL-devel
243
244 %description demos
245 Demonstration programs for the Mesa libraries.
246
247 %description demos -l pl
248 Programy demonstracyjne dla bibliotek Mesa.
249
250 %package dri-driver-ati-mach64
251 Summary:        X.org DRI drivers
252 Summary(pl):    Sterowniki DRI dla X.org
253 Group:          X11/Libraries
254 Requires:       xorg-xserver-server
255
256 %description dri-driver-ati-mach64
257 X.org DRI drivers for ATI mach64 card family.
258
259 %description dri-driver-ati-mach64 -l pl
260 Sterowniki X.org DRI dla rodziny kart ATI mach64.
261
262 %package dri-driver-ati-radeon-R100
263 Summary:        X.org DRI drivers
264 Summary(pl):    Sterowniki DRI dla X.org
265 Group:          X11/Libraries
266 Requires:       xorg-xserver-server
267
268 %description dri-driver-ati-radeon-R100
269 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
270
271 %description dri-driver-ati-radeon-R100 -l pl
272 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
273
274 %package dri-driver-ati-radeon-R200
275 Summary:        X.org DRI drivers
276 Summary(pl):    Sterowniki DRI dla X.org
277 Group:          X11/Libraries
278 Requires:       xorg-xserver-server
279
280 %description dri-driver-ati-radeon-R200
281 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
282
283 %description dri-driver-ati-radeon-R200 -l pl
284 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
285
286 %package dri-driver-ati-radeon-R300
287 Summary:        X.org DRI drivers
288 Summary(pl):    Sterowniki DRI dla X.org
289 Group:          X11/Libraries
290 Requires:       xorg-xserver-server
291
292 %description dri-driver-ati-radeon-R300
293 X.org DRI drivers for ATI R300 card family.
294
295 %description dri-driver-ati-radeon-R300 -l pl
296 Sterowniki X.org DRI dla rodziny kart ATI R300.
297
298 %package dri-driver-ati-rage128
299 Summary:        X.org DRI drivers
300 Summary(pl):    Sterowniki DRI dla X.org
301 Group:          X11/Libraries
302 Requires:       xorg-xserver-server
303
304 %description dri-driver-ati-rage128
305 X.org DRI drivers for ATI rage128 card family.
306
307 %description dri-driver-ati-rage128 -l pl
308 Sterowniki X.org DRI dla rodziny kart ATI rage128.
309
310 %package dri-driver-ffb
311 Summary:        X.org DRI drivers
312 Summary(pl):    Sterowniki DRI dla X.org
313 Group:          X11/Libraries
314 Requires:       xorg-xserver-server
315
316 %description dri-driver-ffb
317 X.org DRI drivers for SUN Creator3D and Elite3D card family.
318
319 %description dri-driver-ffb -l pl
320 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
321
322 %package dri-driver-glint
323 Summary:        X.org DRI drivers
324 Summary(pl):    Sterowniki DRI dla X.org
325 Group:          X11/Libraries
326 Requires:       xorg-xserver-server
327
328 %description dri-driver-glint
329 X.org DRI drivers for GLINT/Permedia card family.
330
331 %description dri-driver-glint -l pl
332 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
333
334 %package dri-driver-intel-i810
335 Summary:        X.org DRI drivers
336 Summary(pl):    Sterowniki DRI dla X.org
337 Group:          X11/Libraries
338 Requires:       xorg-xserver-server
339
340 %description dri-driver-intel-i810
341 X.org DRI drivers for Intel i810 card family.
342
343 %description dri-driver-intel-i810 -l pl
344 Sterowniki X.org DRI dla rodziny kart i810.
345
346 %package dri-driver-intel-i830
347 Summary:        X.org DRI drivers
348 Summary(pl):    Sterowniki DRI dla X.org
349 Group:          X11/Libraries
350 Requires:       xorg-xserver-server
351
352 %description dri-driver-intel-i830
353 X.org DRI drivers for Intel i830 card family.
354
355 %description dri-driver-intel-i830 -l pl
356 Sterowniki X.org DRI dla rodziny kart i830.
357
358 %package dri-driver-intel-i915
359 Summary:        X.org DRI drivers
360 Summary(pl):    Sterowniki DRI dla X.org
361 Group:          X11/Libraries
362 Requires:       xorg-xserver-server
363
364 %description dri-driver-intel-i915
365 X.org DRI drivers for Intel i915 card family.
366
367 %description dri-driver-intel-i915 -l pl
368 Sterowniki X.org DRI dla rodziny kart i915.
369
370 %package dri-driver-matrox
371 Summary:        X.org DRI drivers
372 Summary(pl):    Sterowniki DRI dla X.org
373 Group:          X11/Libraries
374 Requires:       xorg-xserver-server
375
376 %description dri-driver-matrox
377 X.org DRI drivers for Matrox G card family.
378
379 %description dri-driver-matrox -l pl
380 Sterowniki X.org DRI dla rodziny kart Matrox G.
381
382 %package dri-driver-s3virge
383 Summary:        X.org DRI drivers
384 Summary(pl):    Sterowniki DRI dla X.org
385 Group:          X11/Libraries
386 Requires:       xorg-xserver-server
387
388 %description dri-driver-s3virge
389 X.org DRI drivers for S3 Virge card family.
390
391 %description dri-driver-s3virge -l pl
392 Sterowniki X.org DRI dla rodziny kart S3 Virge.
393
394 %package dri-driver-savage
395 Summary:        X.org DRI drivers
396 Summary(pl):    Sterowniki DRI dla X.org
397 Group:          X11/Libraries
398 Requires:       xorg-xserver-server
399
400 %description dri-driver-savage
401 X.org DRI drivers for S3 Savage card family.
402
403 %description dri-driver-savage -l pl
404 Sterowniki X.org DRI dla rodziny kart S3 Savage.
405
406 %package dri-driver-sis
407 Summary:        X.org DRI drivers
408 Summary(pl):    Sterowniki DRI dla X.org
409 Group:          X11/Libraries
410 Requires:       xorg-xserver-server
411
412 %description dri-driver-sis
413 X.org DRI drivers for SiS card family.
414
415 %description dri-driver-sis -l pl
416 Sterowniki X.org DRI dla rodziny kart SiS.
417
418 %package dri-driver-tdfx
419 Summary:        X.org DRI drivers
420 Summary(pl):    Sterowniki DRI dla X.org
421 Group:          X11/Libraries
422 Requires:       xorg-xserver-server
423
424 %description dri-driver-tdfx
425 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
426 and Velocity 100/200).
427
428 %description dri-driver-tdfx -l pl
429 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
430 Banshee and Velocity 100/200).
431
432 %package dri-driver-trident
433 Summary:        X.org DRI drivers
434 Summary(pl):    Sterowniki DRI dla X.org
435 Group:          X11/Libraries
436 Requires:       xorg-xserver-server
437
438 %description dri-driver-trident
439 X.org DRI drivers for Trident card family.
440
441 %description dri-driver-trident -l pl
442 Sterowniki X.org DRI dla rodziny kart Trident.
443
444 %package dri-driver-via-unichrome
445 Summary:        X.org DRI drivers
446 Summary(pl):    Sterowniki DRI dla X.org
447 Group:          X11/Libraries
448 Requires:       xorg-xserver-server
449
450 %description dri-driver-via-unichrome
451 X.org DRI drivers for VIA Unichrome card family.
452
453 %description dri-driver-via-unichrome -l pl
454 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
455
456 %prep
457 %setup -q -n Mesa-%{version} -b 1
458 %patch0 -p1
459
460 # fix demos
461 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
462
463 %ifnarch sparc sparcv9 sparc64
464 # for sunffb driver - useful on sparc only
465 sed -i -e 's/ ffb$//' configs/linux-dri
466 %endif
467
468 %build
469 %ifarch %{ix86}
470 targ=-x86
471 %else
472 targ=""
473 %endif
474
475 %{__make} linux${targ}-static \
476         CC="%{__cc}" \
477         CXX="%{__cxx}" \
478         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
479         XLIB_DIR=%{_libdir} \
480         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
481         SRC_DIRS="mesa glu glw" \
482         PROGRAM_DIRS=
483 mv -f lib lib-static
484 %{__make} clean
485
486 %{__make} linux-dri${targ} \
487         CC="%{__cc}" \
488         CXX="%{__cxx}" \
489         MKDEP=makedepend \
490         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
491         XLIB_DIR=%{_libdir} \
492         SRC_DIRS="glx/x11 mesa glu glw" \
493         PROGRAM_DIRS=
494
495 %{__make} -C progs/xdemos \
496         CC="%{__cc}" \
497         CXX="%{__cxx}" \
498         OPT_FLAGS="%{rpmcflags}" \
499         XLIB_DIR=%{_libdir} \
500         PROGS="glxgears" \
501         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
502
503 %{__make} -C progs/xdemos \
504         CC="%{__cc}" \
505         CXX="%{__cxx}" \
506         OPT_FLAGS="%{rpmcflags}" \
507         XLIB_DIR=%{_libdir} \
508         PROGS="glxinfo" \
509         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL -L../../lib-dri -lGLU"
510
511 mv -f lib lib-dri
512 %{__make} clean \
513         MKDEP=makedepend
514
515 %{__make} linux${targ} \
516         CC="%{__cc}" \
517         CXX="%{__cxx}" \
518         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
519         XLIB_DIR=%{_libdir} \
520         SRC_DIRS="mesa" \
521         PROGRAM_DIRS=
522
523 %install
524 rm -rf $RPM_BUILD_ROOT
525 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
526 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
527
528 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
529 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
530 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
531 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
532 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
533
534 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
535 for l in demos redbook samples xdemos ; do
536         %{__make} -C progs/$l clean
537 done
538 for l in demos redbook samples util xdemos images ; do
539         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
540 done
541 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
542
543 %clean
544 rm -rf $RPM_BUILD_ROOT
545
546 %post   libGL -p /sbin/ldconfig
547 %postun libGL -p /sbin/ldconfig
548
549 %post   libGLU -p /sbin/ldconfig
550 %postun libGLU -p /sbin/ldconfig
551
552 %post   libGLw -p /sbin/ldconfig
553 %postun libGLw -p /sbin/ldconfig
554
555 %files libGL
556 %defattr(644,root,root,755)
557 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
558 %attr(755,root,root) %{_libdir}/libGL.so.*.*
559 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
560 # symlink for binary apps which fail to conform Linux OpenGL ABI
561 # (and dlopen libGL.so instead of libGL.so.1)
562 %attr(755,root,root) %{_libdir}/libGL.so
563
564 %files libGL-devel
565 %defattr(644,root,root,755)
566 %doc docs/*.spec
567 %attr(755,root,root) %{_libdir}/libOSMesa.so
568 %dir %{_includedir}/GL
569 %{_includedir}/GL/gl.h
570 %{_includedir}/GL/glext.h
571 %{_includedir}/GL/gl_mangle.h
572 %{_includedir}/GL/glx.h
573 %{_includedir}/GL/glxext.h
574 %{_includedir}/GL/glx_mangle.h
575 %{_includedir}/GL/osmesa.h
576 %{_includedir}/GL/xmesa.h
577 %{_includedir}/GL/xmesa_x.h
578 %{_includedir}/GL/xmesa_xf86.h
579
580 %files libGL-static
581 %defattr(644,root,root,755)
582 %{_libdir}/libGL.a
583 %{_libdir}/libOSMesa.a
584
585 %files libGLU
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
588
589 %files libGLU-devel
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/libGLU.so
592 %{_includedir}/GL/glu.h
593 %{_includedir}/GL/glu_mangle.h
594
595 %files libGLU-static
596 %defattr(644,root,root,755)
597 %{_libdir}/libGLU.a
598
599 %files libGLw
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
602
603 %files libGLw-devel
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libGLw.so
606 %{_includedir}/GL/GLwDrawA.h
607 %{_includedir}/GL/GLwDrawAP.h
608 %{_includedir}/GL/GLwMDrawA.h
609 %{_includedir}/GL/GLwMDrawAP.h
610
611 %files libGLw-static
612 %defattr(644,root,root,755)
613 %{_libdir}/libGLw.a
614
615 %files utils
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/glxgears
618 %attr(755,root,root) %{_bindir}/glxinfo
619
620 %files dri-driver-ati-mach64
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
623
624 %files dri-driver-ati-radeon-R100
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
627
628 %files dri-driver-ati-radeon-R200
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
631
632 %files dri-driver-ati-radeon-R300
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
635
636 %files dri-driver-ati-rage128
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
639
640 # sunffb (sparc only)
641 %ifarch sparc sparcv9 sparc64
642 %files dri-driver-ffb
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
645 %endif
646
647 # glint (requires update)
648 %if 0
649 %files dri-driver-glint
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
652 %endif
653
654 %files dri-driver-intel-i810
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
657
658 %files dri-driver-intel-i830
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
661
662 %files dri-driver-intel-i915
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
665
666 %files dri-driver-matrox
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
669
670 %files dri-driver-s3virge
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
673
674 %files dri-driver-savage
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
677
678 %files dri-driver-sis
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
681
682 %files dri-driver-tdfx
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
685
686 %files dri-driver-trident
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
689
690 %files dri-driver-via-unichrome
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
693
694 %files demos
695 %defattr(644,root,root,755)
696 %{_examplesdir}/%{name}-%{version}
This page took 0.072856 seconds and 4 git commands to generate.