]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR: python-modules
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.19
25 %define         dri2proto_ver   1.99.3
26 #
27 Summary:        Free OpenGL implementation
28 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
29 Name:           Mesa
30 Version:        7.8.1
31 Release:        1%{?with_multigl:.mgl}
32 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
33 Group:          X11/Libraries
34 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
35 # Source0-md5:  25ec15f8e41fde6d206118cc786dbac4
36 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
37 # Source1-md5:  9ef47f911869657c6bf2f43ebce86b61
38 Patch0:         %{name}-realclean.patch
39 Patch1:         %{name}-tgsi_dump.patch
40 URL:            http://www.mesa3d.org/
41 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  expat-devel
45 #%%{?with_demos:BuildRequires:  glew-devel}
46 BuildRequires:  libdrm-devel >= %{libdrm_ver}
47 BuildRequires:  libselinux-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtool >= 2:1.4d
50 %{?with_motif:BuildRequires:    motif-devel}
51 BuildRequires:  pixman-devel
52 BuildRequires:  pkgconfig
53 BuildRequires:  python
54 BuildRequires:  python-modules
55 BuildRequires:  rpmbuild(macros) >= 1.470
56 BuildRequires:  sed >= 4.0
57 BuildRequires:  xorg-lib-libXdamage-devel
58 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
59 BuildRequires:  xorg-lib-libXt-devel
60 BuildRequires:  xorg-lib-libXxf86vm-devel
61 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
62 BuildRequires:  xorg-proto-glproto-devel >= 1.4.11
63 BuildRequires:  xorg-util-makedepend
64 BuildRequires:  xorg-xserver-server-devel
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %if %{without gallium}
68 %undefine       with_gallium_intel
69 %endif
70
71 %description
72 Mesa is a 3-D graphics library with an API which is very similar to
73 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
74 syntax or state machine, it is being used with authorization from
75 Silicon Graphics, Inc. However, the author does not possess an OpenGL
76 license from SGI, and makes no claim that Mesa is in any way a
77 compatible replacement for OpenGL or associated with SGI.
78
79 %description -l pl.UTF-8
80 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
81 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
82 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
83 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
84 OpenGL ani powiązana z SGI.
85
86 %package libGL
87 Summary:        Free Mesa3D implementation of libGL OpenGL library
88 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
89 License:        MIT
90 Group:          X11/Libraries
91 Requires:       libdrm >= %{libdrm_ver}
92 Provides:       OpenGL = 2.1
93 # reports version 1.3, but supports glXGetProcAddress() from 1.4
94 Provides:       OpenGL-GLX = 1.4
95 Obsoletes:      Mesa
96 Obsoletes:      Mesa-dri
97 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
98 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
99
100 %description libGL
101 Mesa is a 3-D graphics library with an API which is very similar to
102 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
103 syntax or state machine, it is being used with authorization from
104 Silicon Graphics, Inc. However, the author does not possess an OpenGL
105 license from SGI, and makes no claim that Mesa is in any way a
106 compatible replacement for OpenGL or associated with SGI.
107
108 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
109 specifications. It uses DRI for rendering.
110
111 %description libGL -l pl.UTF-8
112 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
113 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
114 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
115 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
116 OpenGL ani powiązana z SGI.
117
118 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
119 GLX 1.4. Używa DRI do renderowania.
120
121 %package libGL-devel
122 Summary:        Header files for Mesa3D libGL library
123 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
124 License:        MIT
125 Group:          X11/Development/Libraries
126 # loose dependency on libGL to use with other libGL binaries
127 Requires:       OpenGL >= 1.5
128 Requires:       libdrm-devel >= %{libdrm_ver}
129 Requires:       xorg-lib-libX11-devel
130 Requires:       xorg-lib-libXdamage-devel
131 Requires:       xorg-lib-libXext-devel
132 Requires:       xorg-lib-libXxf86vm-devel
133 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
134 Suggests:       OpenGL-doc-man
135 Provides:       OpenGL-GLX-devel = 1.4
136 Provides:       OpenGL-devel = 2.1
137 Obsoletes:      Mesa-devel
138 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
139 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
140 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
141 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
142
143 %description libGL-devel
144 Header files for Mesa3D libGL library.
145
146 %description libGL-devel -l pl.UTF-8
147 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
148
149 %package libGL-static
150 Summary:        Static Mesa3D libGL library
151 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
152 License:        MIT
153 Group:          X11/Development/Libraries
154 Requires:       %{name}-libGL-devel = %{version}-%{release}
155 Provides:       OpenGL-static = 2.1
156 Obsoletes:      Mesa-static
157 Obsoletes:      X11-OpenGL-static < 1:7.0.0
158 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
159
160 %description libGL-static
161 Static Mesa3D libGL library. It uses software renderer.
162
163 %description libGL-static -l pl.UTF-8
164 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
165 renderingu.
166
167 %package libGLU
168 Summary:        SGI implementation of libGLU OpenGL library
169 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
170 License:        SGI Free Software License B v2.0 (MIT-like)
171 Group:          Libraries
172 # loose dependency on libGL.so.1 to use with other libGL binaries
173 Requires:       OpenGL >= 1.2
174 Provides:       OpenGL-GLU = 1.3
175 Obsoletes:      Mesa-devel
176 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
177 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
178
179 %description libGLU
180 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
181 1.3 specifications.
182
183 %description libGLU -l pl.UTF-8
184 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
185 specyfikację OpenGL GLU 1.3.
186
187 %package libGLU-devel
188 Summary:        Header files for SGI libGLU library
189 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
190 License:        SGI Free Software License B v2.0 (MIT-like)
191 Group:          Development/Libraries
192 Requires:       %{name}-libGLU = %{version}-%{release}
193 Requires:       OpenGL-devel >= 1.2
194 Requires:       libstdc++-devel
195 Provides:       OpenGL-GLU-devel = 1.3
196
197 %description libGLU-devel
198 Header files for SGI libGLU library.
199
200 %description libGLU-devel -l pl.UTF-8
201 Pliki nagłówkowe biblioteki SGI libGLU.
202
203 %package libGLU-static
204 Summary:        Static SGI libGLU library
205 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
206 License:        SGI Free Software License B v2.0 (MIT-like)
207 Group:          Development/Libraries
208 Requires:       %{name}-libGLU-devel = %{version}-%{release}
209 Provides:       OpenGL-GLU-static = 1.3
210
211 %description libGLU-static
212 Static SGI libGLU library.
213
214 %description libGLU-static -l pl.UTF-8
215 Statyczna biblioteka SGI libGLU.
216
217 %package libGLw
218 Summary:        SGI OpenGL Xt widgets library
219 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
220 License:        SGI MIT-like
221 Group:          Libraries
222 # loose dependency on libGL.so.1 to use with other libGL binaries
223 Requires:       OpenGL >= 1.1
224 Provides:       OpenGL-GLw
225
226 %description libGLw
227 SGI OpenGL Xt widgets library.
228
229 %description libGLU -l pl.UTF-8
230 Biblioteka SGI widgetów Xt dla OpenGL-a.
231
232 %package libGLw-devel
233 Summary:        Header files for SGI libGLw library
234 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
235 License:        SGI MIT-like
236 Group:          Development/Libraries
237 Requires:       %{name}-libGLw = %{version}-%{release}
238 Requires:       OpenGL-devel >= 1.2
239 Provides:       OpenGL-GLw-devel
240
241 %description libGLw-devel
242 Header files for SGI libGLw library.
243
244 %description libGLw-devel -l pl.UTF-8
245 Pliki nagłówkowe biblioteki SGI libGLw.
246
247 %package libGLw-static
248 Summary:        Static SGI libGLw library
249 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
250 License:        SGI MIT-like
251 Group:          Development/Libraries
252 Requires:       %{name}-libGLw-devel = %{version}-%{release}
253 Provides:       OpenGL-GLw-static
254
255 %description libGLw-static
256 Static SGI libGLw library.
257
258 %description libGLw-static -l pl.UTF-8
259 Statyczna biblioteka SGI libGLw.
260
261 %package libOSMesa
262 Summary:        OSMesa (off-screen renderer) library
263 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
264 License:        MIT
265 Group:          Libraries
266 # doesn't require base
267
268 %description libOSMesa
269 OSMesa (off-screen renderer) library.
270
271 %description libOSMesa -l pl.UTF-8
272 Biblioteka OSMesa (renderująca bitmapy w pamięci).
273
274 %package libOSMesa-devel
275 Summary:        Header file for OSMesa (off-screen renderer) library
276 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
277 License:        MIT
278 Group:          Development/Libraries
279 Requires:       %{name}-libOSMesa = %{version}-%{release}
280 # for <GL/gl.h> only
281 Requires:       OpenGL-devel
282
283 %description libOSMesa-devel
284 Header file for OSMesa (off-screen renderer) library.
285
286 %description libOSMesa-devel -l pl.UTF-8
287 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
288
289 %package libOSMesa-static
290 Summary:        Static OSMesa (off-screen renderer) library
291 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
292 License:        MIT
293 Group:          Development/Libraries
294 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
295 # this static build of OSMesa needs static non-dri Mesa implementation
296 Requires:       %{name}-libGL-static = %{version}-%{release}
297
298 %description libOSMesa-static
299 Static OSMesa (off-screen renderer) library.
300
301 %description libOSMesa-static -l pl.UTF-8
302 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
303
304 %package utils
305 Summary:        OpenGL utilities from Mesa3D
306 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
307 License:        MIT
308 Group:          X11/Applications/Graphics
309 # loose deps on libGL/libGLU
310
311 %description utils
312 OpenGL utilities from Mesa3D: glxgears and glxinfo.
313
314 %description utils -l pl.UTF-8
315 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
316
317 %package demos
318 Summary:        Mesa Demos source code
319 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
320 License:        various (MIT, SGI, GPL - see copyright notes in sources)
321 Group:          Development/Libraries
322 Requires:       OpenGL-devel
323
324 %description demos
325 Demonstration programs for the Mesa libraries in source code form.
326
327 %description demos -l pl.UTF-8
328 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
329
330 %package dri-driver-ati-mach64
331 Summary:        X.org DRI driver for ATI Mach64 card family
332 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
333 License:        MIT
334 Group:          X11/Libraries
335 Requires:       xorg-driver-video-mach64
336 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
337 Requires:       xorg-xserver-server >= %{xserver_ver}
338
339 %description dri-driver-ati-mach64
340 X.org DRI driver for ATI Mach64 card family.
341
342 %description dri-driver-ati-mach64 -l pl.UTF-8
343 Sterownik X.org DRI dla rodziny kart ATI Mach64.
344
345 %package dri-driver-ati-radeon-R100
346 Summary:        X.org DRI driver for ATI R100 card family
347 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
348 License:        MIT
349 Group:          X11/Libraries
350 Requires:       xorg-driver-video-ati
351 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
352 Requires:       xorg-xserver-server >= %{xserver_ver}
353 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
354
355 %description dri-driver-ati-radeon-R100
356 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
357
358 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
359 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
360
361 %package dri-driver-ati-radeon-R200
362 Summary:        X.org DRI driver for ATI R200 card family
363 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
364 License:        MIT
365 Group:          X11/Libraries
366 Requires:       xorg-driver-video-ati
367 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
368 Requires:       xorg-xserver-server >= %{xserver_ver}
369 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
370
371 %description dri-driver-ati-radeon-R200
372 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
373
374 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
375 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
376
377 %package dri-driver-ati-radeon-R300
378 Summary:        X.org DRI driver for ATI R300 card family
379 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
380 License:        MIT
381 Group:          X11/Libraries
382 Requires:       xorg-driver-video-ati
383 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
384 Requires:       xorg-xserver-server >= %{xserver_ver}
385 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
386
387 %description dri-driver-ati-radeon-R300
388 X.org DRI driver for ATI R300 card family.
389
390 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
391 Sterownik X.org DRI dla rodziny kart ATI R300.
392
393 %package dri-driver-ati-radeon-R600
394 Summary:        X.org DRI driver for ATI R600 card family
395 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
396 License:        MIT
397 Group:          X11/Libraries
398 Requires:       radeon-ucode
399 Requires:       xorg-driver-video-ati
400 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
401 Requires:       xorg-xserver-server >= %{xserver_ver}
402
403 %description dri-driver-ati-radeon-R600
404 X.org DRI driver for ATI R600 card family.
405
406 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
407 Sterownik X.org DRI dla rodziny kart ATI R600.
408
409 %package dri-driver-ati-rage128
410 Summary:        X.org DRI driver for ATI Rage128 card family
411 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
412 License:        MIT
413 Group:          X11/Libraries
414 Requires:       xorg-driver-video-r128
415 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
416 Requires:       xorg-xserver-server >= %{xserver_ver}
417 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
418
419 %description dri-driver-ati-rage128
420 X.org DRI driver for ATI Rage128 card family.
421
422 %description dri-driver-ati-rage128 -l pl.UTF-8
423 Sterownik X.org DRI dla rodziny kart ATI Rage128.
424
425 %package dri-driver-ffb
426 Summary:        X.org DRI driver for Sun FFB card family
427 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
428 License:        MIT
429 Group:          X11/Libraries
430 Requires:       xorg-driver-video-sunffb
431 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
432 Requires:       xorg-xserver-server >= %{xserver_ver}
433
434 %description dri-driver-ffb
435 X.org DRI driver for SUN Creator3D and Elite3D card family.
436
437 %description dri-driver-ffb -l pl.UTF-8
438 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
439
440 %package dri-driver-glint
441 Summary:        X.org DRI driver for GLINT/Permedia card family
442 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
443 License:        MIT
444 Group:          X11/Libraries
445 Requires:       xorg-driver-video-glint
446 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
447 Requires:       xorg-xserver-server >= %{xserver_ver}
448 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
449
450 %description dri-driver-glint
451 X.org DRI driver for GLINT/Permedia card family.
452
453 %description dri-driver-glint -l pl.UTF-8
454 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
455
456 %package dri-driver-intel-i810
457 Summary:        X.org DRI driver for Intel i810 card family
458 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
459 License:        MIT
460 Group:          X11/Libraries
461 Requires:       xorg-driver-video-intel
462 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
463 Requires:       xorg-xserver-server >= %{xserver_ver}
464 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
465
466 %description dri-driver-intel-i810
467 X.org DRI driver for Intel i810 card family.
468
469 %description dri-driver-intel-i810 -l pl.UTF-8
470 Sterownik X.org DRI dla rodziny kart Intel i810.
471
472 %package dri-driver-intel-i915
473 Summary:        X.org DRI driver for Intel i915 card family
474 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
475 License:        MIT
476 Group:          X11/Libraries
477 Requires:       xorg-driver-video-intel
478 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
479 Requires:       xorg-xserver-server >= %{xserver_ver}
480 Obsoletes:      Mesa-dri-driver-intel-i830
481 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
482
483 %description dri-driver-intel-i915
484 X.org DRI driver for Intel i915 card family.
485
486 %description dri-driver-intel-i915 -l pl.UTF-8
487 Sterownik X.org DRI dla rodziny kart Intel i915.
488
489 %package dri-driver-intel-i965
490 Summary:        X.org DRI driver for Intel i965 card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-intel
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497 Obsoletes:      Mesa-dri-driver-intel-i830
498 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
499
500 %description dri-driver-intel-i965
501 X.org DRI driver for Intel i965 card family.
502
503 %description dri-driver-intel-i965 -l pl.UTF-8
504 Sterownik X.org DRI dla rodziny kart Intel i965.
505
506 %package dri-driver-matrox
507 Summary:        X.org DRI driver for Matrox G card family
508 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
509 License:        MIT
510 Group:          X11/Libraries
511 Requires:       xorg-driver-video-mga
512 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
513 Requires:       xorg-xserver-server >= %{xserver_ver}
514 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
515
516 %description dri-driver-matrox
517 X.org DRI drivers for Matrox G card family.
518
519 %description dri-driver-matrox -l pl.UTF-8
520 Sterowniki X.org DRI dla rodziny kart Matrox G.
521
522 %package dri-driver-nouveau
523 Summary:        X.org DRI driver for NVIDIA card family
524 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
525 License:        MIT
526 Group:          X11/Libraries
527 Requires:       xorg-driver-video-nouveau
528 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
529 Requires:       xorg-xserver-server >= %{xserver_ver}
530
531 %description dri-driver-nouveau
532 X.org DRI drivers for NVIDIA card family.
533
534 %description dri-driver-nouveau -l pl.UTF-8
535 Sterowniki X.org DRI dla rodziny kart NVIDIA.
536
537 %package dri-driver-savage
538 Summary:        X.org DRI driver for S3 Savage card family
539 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
540 License:        MIT
541 Group:          X11/Libraries
542 Requires:       xorg-driver-video-savage
543 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
544 Requires:       xorg-xserver-server >= %{xserver_ver}
545
546 %description dri-driver-savage
547 X.org DRI driver for S3 Savage card family.
548
549 %description dri-driver-savage -l pl.UTF-8
550 Sterownik X.org DRI dla rodziny kart S3 Savage.
551
552 %package dri-driver-sis
553 Summary:        X.org DRI driver for SiS card family
554 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
555 License:        MIT
556 Group:          X11/Libraries
557 Requires:       xorg-driver-video-sis
558 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
559 Requires:       xorg-xserver-server >= %{xserver_ver}
560 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
561
562 %description dri-driver-sis
563 X.org DRI driver for SiS card family.
564
565 %description dri-driver-sis -l pl.UTF-8
566 Sterownik X.org DRI dla rodziny kart SiS.
567
568 %package dri-driver-swrast
569 Summary:        X.org DRI software rasterizer driver
570 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
571 License:        MIT
572 Group:          X11/Libraries
573 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
574 Requires:       xorg-xserver-server >= %{xserver_ver}
575
576 %description dri-driver-swrast
577 X.org DRI software rasterizer driver.
578
579 %description dri-driver-swrast -l pl.UTF-8
580 Sterownik X.org DRI obsługujący rysowanie programowe.
581
582 %package dri-driver-tdfx
583 Summary:        X.org DRI driver for 3DFX Voodoo card family
584 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
585 License:        MIT
586 Group:          X11/Libraries
587 Requires:       Glide3-DRI
588 Requires:       xorg-driver-video-tdfx
589 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
590 Requires:       xorg-xserver-server >= %{xserver_ver}
591 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
592
593 %description dri-driver-tdfx
594 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
595 and Velocity 100/200).
596
597 %description dri-driver-tdfx -l pl.UTF-8
598 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
599 Banshee i Velocity 100/200).
600
601 %package dri-driver-via-unichrome
602 Summary:        X.org DRI driver for VIA Unichrome card family
603 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
604 License:        MIT
605 Group:          X11/Libraries
606 Requires:       xorg-driver-video-openchrome
607 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
608 Requires:       xorg-xserver-server >= %{xserver_ver}
609
610 %description dri-driver-via-unichrome
611 X.org DRI driver for VIA Unichrome card family.
612
613 %description dri-driver-via-unichrome -l pl.UTF-8
614 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
615
616 %package dri-driver-vmwgfx
617 Summary:        X.org DRI driver for VMware
618 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
619 License:        MIT
620 Group:          X11/Libraries
621 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
622 Requires:       xorg-xserver-server >= %{xserver_ver}
623
624 %description dri-driver-vmwgfx
625 X.org DRI driver for VMWare.
626
627 %description dri-driver-vmwgfx -l pl.UTF-8
628 Sterownik X.org DRI dla VMware.
629
630 %prep
631 %setup -q -b1
632 %patch0 -p0
633 %patch1 -p1
634
635 # fix demos
636 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
637
638 %build
639 autoreconf --install
640 #%{__aclocal}
641 #%{__autoconf}
642
643 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
644 %if %{without gallium_intel}
645 i915 \
646 %endif
647 %ifarch sparc sparcv9 sparc64
648 ffb \
649 %endif
650 %ifarch %{ix86} %{x8664}
651 sis \
652 %endif
653 swrast tdfx unichrome"
654
655 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
656
657 common_flags="\
658         --enable-shared \
659         --enable-selinux \
660         --enable-pic \
661         --enable-glx-tls \
662         --disable-glut \
663         --disable-os-mesa \
664         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
665         --with%{!?with_demos:out}-demos"
666
667 osmesa_common_flags="\
668         --with-driver=osmesa \
669         --disable-asm \
670         --disable-glu"
671
672 %if %{with osmesa}
673 # osmesa variants
674 %configure $common_flags $osmesa_common_flags \
675         --with-osmesa-bits=8
676 %{__make}
677 mv %{_lib} osmesa8
678 %{__make} clean
679
680 %configure $common_flags $osmesa_common_flags \
681         --with-osmesa-bits=16
682 %{__make}
683 mv %{_lib} osmesa16
684 %{__make} clean
685
686 %configure $common_flags $osmesa_common_flags \
687         --with-osmesa-bits=32
688 %{__make}
689 mv %{_lib} osmesa32
690 %{__make} clean
691 %endif
692
693 %configure $common_flags \
694 %if %{with gallium}
695         --enable-gallium \
696         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
697         --enable-gallium-svga \
698         --enable-gallium-nouveau \
699         --with-state-trackers=dri,xorg,glx \
700 %else
701         --disable-gallium \
702 %endif
703         --with-driver=dri \
704         --with-dri-drivers=${dri_drivers} \
705         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
706
707 %{__make}
708 %{__make} -C progs/xdemos glxgears glxinfo
709 %if %{with demos}
710 %{__make} -C progs/demos
711 %endif
712
713 %install
714 rm -rf $RPM_BUILD_ROOT
715
716 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
717
718 # libs without drivers
719 %{__make} install \
720         DESTDIR=$RPM_BUILD_ROOT
721
722 %if %{with osmesa}
723 rm -f osmesa*/libGLEW.*
724 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
725 %endif
726
727 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
728 # work on copy to keep -bi --short-circuit working
729 rm -rf progs-clean
730 install -d progs-clean
731 for l in demos glsl osdemos redbook samples xdemos ; do
732         cp -a progs/$l progs-clean/$l
733         %{__make} -C progs-clean/$l clean
734         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
735 done
736 rm -rf progs-clean
737 for l in util images ; do
738         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
739 done
740 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
741
742 # strip out undesirable headers
743 olddir=$(pwd)
744 cd $RPM_BUILD_ROOT%{_includedir}/GL
745 rm [a-fh-np-wyz]*.h glf*.h
746 cd $RPM_BUILD_ROOT%{_libdir}
747 cd $olddir
748
749 %if %{with multigl}
750 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
751
752 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
753 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
754
755 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
756 %endif
757
758 %clean
759 rm -rf $RPM_BUILD_ROOT
760
761 %post   libGL -p /sbin/ldconfig
762 %postun libGL -p /sbin/ldconfig
763
764 %post   libGLU -p /sbin/ldconfig
765 %postun libGLU -p /sbin/ldconfig
766
767 %post   libGLw -p /sbin/ldconfig
768 %postun libGLw -p /sbin/ldconfig
769
770 %files libGL
771 %defattr(644,root,root,755)
772 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
773 %if %{with multigl}
774 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
775 %dir %{_libdir}/Mesa
776 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
777 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
778 %else
779 %attr(755,root,root) %{_libdir}/libGL.so.*.*
780 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
781 # symlink for binary apps which fail to conform Linux OpenGL ABI
782 # (and dlopen libGL.so instead of libGL.so.1)
783 %attr(755,root,root) %{_libdir}/libGL.so
784 %endif
785
786 %files libGL-devel
787 %defattr(644,root,root,755)
788 %doc docs/*.spec
789 %if %{with multigl}
790 %attr(755,root,root) %{_libdir}/libGL.so
791 %endif
792 %dir %{_includedir}/GL
793 %{_includedir}/GL/gl.h
794 %{_includedir}/GL/glext.h
795 %{_includedir}/GL/gl_mangle.h
796 %{_includedir}/GL/glx.h
797 %{_includedir}/GL/glxext.h
798 %{_includedir}/GL/glx_mangle.h
799 %dir %{_includedir}/GL/internal
800 %{_includedir}/GL/internal/dri_interface.h
801 %{_pkgconfigdir}/dri.pc
802 %{_pkgconfigdir}/gl.pc
803
804 %if %{with static}
805 %files libGL-static
806 %defattr(644,root,root,755)
807 %{_libdir}/libGL.a
808 %endif
809
810 %files libGLU
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
814
815 %files libGLU-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLU.so
818 %{_includedir}/GL/glu.h
819 %{_includedir}/GL/glu_mangle.h
820 %{_pkgconfigdir}/glu.pc
821
822 %if %{with static}
823 %files libGLU-static
824 %defattr(644,root,root,755)
825 %{_libdir}/libGLU.a
826 %endif
827
828 %files libGLw
829 %defattr(644,root,root,755)
830 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
831 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
832
833 %files libGLw-devel
834 %defattr(644,root,root,755)
835 %attr(755,root,root) %{_libdir}/libGLw.so
836 %{_includedir}/GL/GLwDrawA.h
837 %{_includedir}/GL/GLwDrawAP.h
838 %{_includedir}/GL/GLwMDrawA.h
839 %{_includedir}/GL/GLwMDrawAP.h
840 %{_pkgconfigdir}/glw.pc
841
842 %if %{with static}
843 %files libGLw-static
844 %defattr(644,root,root,755)
845 %{_libdir}/libGLw.a
846 %endif
847
848 %if %{with osmesa}
849 %files libOSMesa
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
852 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
853
854 %files libOSMesa-devel
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_libdir}/libOSMesa*.so
857 %{_includedir}/GL/osmesa.h
858
859 %if %{with static}
860 %files libOSMesa-static
861 %defattr(644,root,root,755)
862 %{_libdir}/libOSMesa*.a
863 %endif
864 %endif
865
866 %files utils
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_bindir}/glxgears
869 %attr(755,root,root) %{_bindir}/glxinfo
870
871 %files dri-driver-ati-mach64
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
874
875 %files dri-driver-ati-radeon-R100
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
878
879 %files dri-driver-ati-radeon-R200
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
882
883 %files dri-driver-ati-radeon-R300
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
886
887 %files dri-driver-ati-radeon-R600
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
890
891 %files dri-driver-ati-rage128
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
894
895 # sunffb (sparc only)
896 %ifarch sparc sparcv9 sparc64
897 %files dri-driver-ffb
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
900 %endif
901
902 # glint (requires update)
903 %if 0
904 %files dri-driver-glint
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
907 %endif
908
909 %files dri-driver-intel-i810
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
912
913 %files dri-driver-intel-i915
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
916
917 %files dri-driver-intel-i965
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
920
921 %files dri-driver-matrox
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
924
925 %if %{with gallium}
926 %files dri-driver-nouveau
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
930 %endif
931
932 %files dri-driver-savage
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
935
936 %ifarch %{ix86} %{x8664}
937 %files dri-driver-sis
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
940 %endif
941
942 %files dri-driver-swrast
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
945
946 %files dri-driver-tdfx
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
949
950 %files dri-driver-via-unichrome
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
953
954 %if %{with gallium}
955 %files dri-driver-vmwgfx
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/vmwgfx_drv.so
958 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
959 %endif
960
961 %if %{with demos}
962 %files demos
963 %defattr(644,root,root,755)
964 %{_examplesdir}/%{name}-%{version}
965 %endif
This page took 0.089276 seconds and 4 git commands to generate.