]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- xlibize ;)
[packages/Mesa.git] / Mesa.spec
1 #
2 %bcond_with     glide   # with GLIDE
3 #
4 Summary:        Free OpenGL implementation
5 Summary(pl):    Bezp³atna implementacja standardu OpenGL
6 Name:           Mesa
7 Version:        6.0.1
8 Release:        1
9 License:        MIT (core), LGPL (MesaGLU), SGI (GLU,libGLw) and others - see COPYRIGHT file
10 Group:          X11/Libraries
11 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
12 # Source0-md5:  b7f14088c5c2f14490d2739a91102112
13 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
14 # Source1-md5:  dd6aadfd9ca8e1cfa90c6ee492bc6f43
15 Patch0:         %{name}-libGLw.patch
16 URL:            http://www.mesa3d.org/
17 %ifarch %{ix86} alpha
18 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
19 %{?with_glide:Requires: Glide3-DRI}
20 %endif
21 #BuildRequires: XFree86-devel
22 BuildRequires:  libXmu-devel
23 BuildRequires:  libXp-devel
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 BuildRequires:  libtool >= 2:1.4d
27 BuildRequires:  motif-devel
28 BuildRequires:  perl-devel
29 Provides:       OpenGL
30 Obsoletes:      XFree86-OpenGL-core
31 Obsoletes:      XFree86-OpenGL-libs
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # avoid XFree86-OpenGL* dependency
35 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
37
38 %define         _sysconfdir     /etc/X11
39
40 %description
41 Mesa is a 3-D graphics library with an API which is very similar to
42 that of OpenGL*. To the extent that Mesa utilizes the OpenGL command
43 syntax or state machine, it is being used with authorization from
44 Silicon Graphics, Inc. However, the author makes no claim that Mesa is
45 in any way a compatible replacement for OpenGL or associated with
46 Silicon Graphics, Inc. Those who want a licensed implementation of
47 OpenGL should contact a licensed vendor. This software is distributed
48 under the terms of the GNU Library General Public License, see the
49 LICENSE file for details.
50
51 - OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
52
53 %description -l pl
54 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standardu
55 OpenGL(*).
56
57 - OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics,
58   Inc.
59
60 %package devel
61 Summary:        Development environment for Mesa
62 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 #Requires:      XFree86-devel
66 Requires:       libX11-devel
67 Requires:       libXp-devel
68 Provides:       OpenGL-devel
69 Obsoletes:      XFree86-OpenGL-devel
70
71 %description devel
72 Header files and documentation needed for development.
73
74 %description devel -l pl
75 Pliki nag³ówkowe i dokumentacja do Mesy.
76
77 %package static
78 Summary:        Mesa static libraries
79 Summary(pl):    Biblioteki statyczne Mesy
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82 Provides:       OpenGL-static
83 Obsoletes:      XFree86-OpenGL-static
84
85 %description static
86 The static version of the Mesa libraries.
87
88 %description static -l pl
89 Biblioteki statyczne Mesy.
90
91 %package demos
92 Summary:        Mesa Demos
93 Summary(pl):    Demonstracje mo¿liwo¶ci bibliotek Mesa
94 Group:          Development/Libraries
95 Requires:       OpenGL-devel
96
97 %description demos
98 Demonstration programs for the Mesa libraries.
99
100 %description demos -l pl
101 Programy demonstracyjne dla bibliotek Mesa.
102
103 %prep
104 %setup -q -n Mesa-%{version} -b 1
105 %patch0 -p1
106
107 # fix demos
108 %{__perl} -pi -e "s,\.\./images/,%{_examplesdir}/Mesa/images/,g" progs/demos/*
109
110 %build
111 # runtime detection, so safe to enable
112 ASM=
113 # asm is currently broken
114 #%ifarch %{ix86}
115 #ASM="$ASM -DUSE_X86_ASM"
116 #%endif
117 #%ifarch i586 i686 k6 athlon
118 #ASM="$ASM -DUSE_MMX_ASM"
119 #%endif
120 #%ifarch i686 athlon
121 #ASM="$ASM -DUSE_SSE_ASM"
122 #%endif
123 #%ifarch sparc sparc64 sparcv9
124 #ASM="$ASM -DUSE_SPARC_ASM"
125 #%endif
126
127 %{__make} linux-static \
128         OPTFLAGS="%{rpmcflags} $ASM"
129 mv -f lib lib-static
130 %{__make} clean
131 %{__make} linux \
132         OPTFLAGS="%{rpmcflags} $ASM"
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/GL,%{_mandir}/man3,%{_examplesdir}/Mesa}
137
138 cp -df lib-static/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
139 cp -df lib/lib[GO]* $RPM_BUILD_ROOT%{_libdir}
140 cp -rf include/GL/{gl*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
141 rm -f $RPM_BUILD_ROOT%{_includedir}/GL/glut*
142
143 for l in demos redbook samples xdemos ; do
144         %{__make} -C progs/$l -f Makefile.X11 realclean
145 done
146 for l in demos redbook samples util xdemos images ; do
147         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/Mesa/$l
148 done
149 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/Mesa/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(644,root,root,755)
159 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
160 %attr(755,root,root) %{_libdir}/libGL*.so.*.*
161 %attr(755,root,root) %{_libdir}/libGL.so
162 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %doc docs/*.spec
167 %attr(755,root,root) %{_libdir}/libGLU.so
168 %attr(755,root,root) %{_libdir}/libOSMesa.so
169 %{_libdir}/libGLw.a
170 %dir %{_includedir}/GL
171 %{_includedir}/GL/GLwDrawA.h
172 %{_includedir}/GL/GLwDrawAP.h
173 %{_includedir}/GL/GLwMDrawA.h
174 %{_includedir}/GL/GLwMDrawAP.h
175 %{_includedir}/GL/gl.h
176 %{_includedir}/GL/glext.h
177 %{_includedir}/GL/gl_mangle.h
178 %{_includedir}/GL/glu.h
179 %{_includedir}/GL/glu_mangle.h
180 %{_includedir}/GL/glx.h
181 %{_includedir}/GL/glxext.h
182 %{_includedir}/GL/glx_mangle.h
183 %{_includedir}/GL/osmesa.h
184 %{_includedir}/GL/xmesa.h
185 %{_includedir}/GL/xmesa_x.h
186 %{_includedir}/GL/xmesa_xf86.h
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libGL.a
191 %{_libdir}/libGLU.a
192 %{_libdir}/libOSMesa.a
193
194 %files demos
195 %defattr(644,root,root,755)
196 %{_examplesdir}/Mesa
This page took 0.056192 seconds and 4 git commands to generate.