]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- release 2,
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.1
5 Release:        2
6 License:        GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://ftp.mesa3d.org/mesa/%{name}Lib-%{version}.tar.bz2
10 Source1:        ftp://ftp.mesa3d.org/mesa/%{name}Demos-%{version}.tar.bz2
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildRequires:  XFree86-devel
14 Provides:       OpenGL
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _prefix         /usr/X11R6
18 %define         _mandir         %{_prefix}/man
19
20 %description
21 Mesa is a 3-D graphics library with an API which is very similar to that of
22 OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax or
23 state machine, it is being used with authorization from Silicon Graphics,
24 Inc. However, the author makes no claim that Mesa is in any way a
25 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
26 Those who want a licensed implementation of OpenGL should contact a
27 licensed vendor. This software is distributed under the terms of the GNU
28 Library General Public License, see the LICENSE file for details.
29
30 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
31
32 %description -l pl
33 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
34
35 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
36
37 %package devel
38 Summary:        Development environment for Mesa
39 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
40 Group:          Development/Libraries
41 Group(pl):      Programowanie/Biblioteki
42 Requires:       %{name} = %{version}
43 Provides:       OpenGL-devel
44
45 %description devel
46 Header files and documentation needed for development.
47
48 %description -l pl devel
49 Pliki nag³ówkowe i dokumentacja do Mesy.
50
51 %package static
52 Summary:        Mesa static libraries
53 Summary(pl):    Biblioteki statyczne Mesy
54 Group:          Development/Libraries
55 Group(pl):      Programowanie/Biblioteki
56 Requires:       %{name}-devel = %{version}
57 Provides:       OpenGL-static
58
59 %description static
60 The static version of the Mesa libraries
61
62 %description -l pl static
63 Biblioteki statyczne Mesy.
64
65 %package demos
66 Summary:        Mesa Demos
67 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
68 Group:          Development/Libraries
69 Group(pl):      Programowanie/Biblioteki
70 Requires:       %{name} = %{version}
71
72 %description demos
73 Demonstration programs for the Mesa libraries.
74
75 %description -l pl demos
76 Programy demonstracyjne dla biblioteki Mesa.
77
78 %prep
79 %setup -q -n Mesa-%{version} -b 1
80 %patch -p1
81
82 %build
83 %ifarch alpha
84 make LIBS_ONLY=YES linux-alpha
85 make clean
86 make linux-alpha-elf
87 %endif
88
89 %ifarch ppc
90 make linux-ppc
91 %endif
92
93 %ifarch %{ix86}
94 make clean
95 make LIBS_ONLY=YES linux-386
96 make clean
97 make linux-386-elf
98 %endif
99
100 %ifarch sparc sparc64
101 make  linux-elf
102 %endif
103
104 (cd widgets-mesa; autoconf; \
105 LDFLAGS="-s"; export LDFLAGS
106 %configure \
107         --host=%{_host}
108 make)
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_includedir},%{_mandir}/man3} \
113         $RPM_BUILD_ROOT/usr/src/examples/Mesa
114
115 cp -dpr lib include $RPM_BUILD_ROOT%{_prefix}
116 cp -dpr util $RPM_BUILD_ROOT%{_libdir}/Mesa
117 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
118 install Make-config $RPM_BUILD_ROOT%{_libdir}/Mesa
119
120 (cd widgets-mesa; \
121 make install \
122         prefix=$RPM_BUILD_ROOT/usr/X11R6 \
123         mandir=$RPM_BUILD_ROOT%{_mandir}/man3)
124
125 install */lib*.a $RPM_BUILD_ROOT%{_libdir}
126
127 strip $RPM_BUILD_ROOT%{_libdir}/{lib*so.*.*,Mesa/*/*} || :
128
129 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
130         docs/{IAFA-PACKAGE,README*,RELNOTES,VERSIONS,CONFIG,CONFORM,COPYRIGHT,DEVINFO,*.spec}
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %clean
136 rm -fr $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc docs/CONFIG.gz
141
142 %ifnarch ppc
143 %attr(755,root,root) %{_libdir}/libGL*.so.*.*
144 %else
145 %{_libdir}/libGL*.a
146 %endif
147
148 %files devel
149 %defattr(644,root,root,755)
150 %doc docs/{IAFA-PACKAGE,README,RELNOTES,VERSIONS,CONFORM,COPYRIGHT,DEVINFO,*.spec}.gz
151 %doc docs/README.{3DFX,GGI,MGL,QUAKE,X11,THREADS}.gz
152
153 %ifnarch ppc
154 %attr(755,root,root) %{_libdir}/libGL*.so
155 %endif
156
157 %dir %{_libdir}/Mesa
158 %{_libdir}/Mesa/Make-config
159 %{_libdir}/Mesa/util
160
161 %dir /usr/X11R6/include/GL
162 %{_includedir}/GL/*.h
163 %{_mandir}/man3/*
164
165 %ifnarch ppc
166 %files static
167 %defattr(644,root,root,755)
168 %endif
169 %{_libdir}/libGL*.a
170
171 %files demos
172 %defattr(644,root,root,755)
173 %dir /usr/src/examples/Mesa/book
174 %dir /usr/src/examples/Mesa/demos
175 %dir /usr/src/examples/Mesa/samples
176 %dir /usr/src/examples/Mesa/xdemos
177
178 %attr(-,root,root)/usr/src/examples/Mesa/book/*
179 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
180 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
181 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
This page took 0.050139 seconds and 4 git commands to generate.