]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to final 7.7
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.7
28 Release:        1%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  e3fa64a1508bc23dd9de9dd2cea7cfb1
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  6fd616b27b9826d0faa23e08e05d9435
35 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
36 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
37 Patch0:         %{name}-realclean.patch
38 URL:            http://www.mesa3d.org/
39 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  expat-devel
43 %{?with_demos:BuildRequires:    glew-devel}
44 BuildRequires:  libdrm-devel >= 2.4.12-3
45 BuildRequires:  libselinux-devel
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool >= 2:1.4d
48 %{?with_motif:BuildRequires:    motif-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  python
51 BuildRequires:  rpmbuild(macros) >= 1.470
52 BuildRequires:  sed >= 4.0
53 BuildRequires:  xorg-lib-libXdamage-devel
54 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
55 BuildRequires:  xorg-lib-libXt-devel
56 BuildRequires:  xorg-lib-libXxf86vm-devel
57 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
58 BuildRequires:  xorg-proto-glproto-devel
59 BuildRequires:  xorg-proto-printproto-devel
60 BuildRequires:  xorg-util-makedepend
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %if %{without gallium}
64 %undefine       with_gallium_intel
65 %endif
66
67 %description
68 Mesa is a 3-D graphics library with an API which is very similar to
69 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
70 syntax or state machine, it is being used with authorization from
71 Silicon Graphics, Inc. However, the author does not possess an OpenGL
72 license from SGI, and makes no claim that Mesa is in any way a
73 compatible replacement for OpenGL or associated with SGI.
74
75 %description -l pl.UTF-8
76 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
77 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
78 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
79 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
80 OpenGL ani powiązana z SGI.
81
82 %package libGL
83 Summary:        Free Mesa3D implementation of libGL OpenGL library
84 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
85 License:        MIT
86 Group:          X11/Libraries
87 Requires:       libdrm >= 2.4.5
88 Provides:       OpenGL = 2.1
89 # reports version 1.3, but supports glXGetProcAddress() from 1.4
90 Provides:       OpenGL-GLX = 1.4
91 Obsoletes:      Mesa
92 Obsoletes:      Mesa-dri
93 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
94 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
95
96 %description libGL
97 Mesa is a 3-D graphics library with an API which is very similar to
98 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
99 syntax or state machine, it is being used with authorization from
100 Silicon Graphics, Inc. However, the author does not possess an OpenGL
101 license from SGI, and makes no claim that Mesa is in any way a
102 compatible replacement for OpenGL or associated with SGI.
103
104 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
105 specifications. It uses DRI for rendering.
106
107 %description libGL -l pl.UTF-8
108 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
109 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
110 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
111 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
112 OpenGL ani powiązana z SGI.
113
114 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
115 GLX 1.4. Używa DRI do renderowania.
116
117 %package libGL-devel
118 Summary:        Header files for Mesa3D libGL library
119 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
120 License:        MIT
121 Group:          X11/Development/Libraries
122 # loose dependency on libGL to use with other libGL binaries
123 Requires:       OpenGL >= 1.5
124 Requires:       xorg-lib-libX11-devel
125 Provides:       OpenGL-GLX-devel = 1.4
126 Provides:       OpenGL-devel = 2.1
127 Obsoletes:      Mesa-devel
128 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
129 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
130 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
131 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
132
133 %description libGL-devel
134 Header files for Mesa3D libGL library.
135
136 %description libGL-devel -l pl.UTF-8
137 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
138
139 %package libGL-static
140 Summary:        Static Mesa3D libGL library
141 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
142 License:        MIT
143 Group:          X11/Development/Libraries
144 Requires:       %{name}-libGL-devel = %{version}-%{release}
145 Provides:       OpenGL-static = 2.1
146 Obsoletes:      Mesa-static
147 Obsoletes:      X11-OpenGL-static < 1:7.0.0
148 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
149
150 %description libGL-static
151 Static Mesa3D libGL library. It uses software renderer.
152
153 %description libGL-static -l pl.UTF-8
154 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
155 renderingu.
156
157 %package libGLU
158 Summary:        SGI implementation of libGLU OpenGL library
159 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
160 License:        SGI Free Software License B v2.0 (MIT-like)
161 Group:          Libraries
162 # loose dependency on libGL.so.1 to use with other libGL binaries
163 Requires:       OpenGL >= 1.2
164 Provides:       OpenGL-GLU = 1.3
165 Obsoletes:      Mesa-devel
166 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
167 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
168
169 %description libGLU
170 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
171 1.3 specifications.
172
173 %description libGLU -l pl.UTF-8
174 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
175 specyfikację OpenGL GLU 1.3.
176
177 %package libGLU-devel
178 Summary:        Header files for SGI libGLU library
179 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
180 License:        SGI Free Software License B v2.0 (MIT-like)
181 Group:          Development/Libraries
182 Requires:       %{name}-libGLU = %{version}-%{release}
183 Requires:       OpenGL-devel >= 1.2
184 Requires:       libstdc++-devel
185 Provides:       OpenGL-GLU-devel = 1.3
186
187 %description libGLU-devel
188 Header files for SGI libGLU library.
189
190 %description libGLU-devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki SGI libGLU.
192
193 %package libGLU-static
194 Summary:        Static SGI libGLU library
195 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
196 License:        SGI Free Software License B v2.0 (MIT-like)
197 Group:          Development/Libraries
198 Requires:       %{name}-libGLU-devel = %{version}-%{release}
199 Provides:       OpenGL-GLU-static = 1.3
200
201 %description libGLU-static
202 Static SGI libGLU library.
203
204 %description libGLU-static -l pl.UTF-8
205 Statyczna biblioteka SGI libGLU.
206
207 %package libGLw
208 Summary:        SGI OpenGL Xt widgets library
209 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
210 License:        SGI MIT-like
211 Group:          Libraries
212 # loose dependency on libGL.so.1 to use with other libGL binaries
213 Requires:       OpenGL >= 1.1
214 Provides:       OpenGL-GLw
215
216 %description libGLw
217 SGI OpenGL Xt widgets library.
218
219 %description libGLU -l pl.UTF-8
220 Biblioteka SGI widgetów Xt dla OpenGL-a.
221
222 %package libGLw-devel
223 Summary:        Header files for SGI libGLw library
224 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
225 License:        SGI MIT-like
226 Group:          Development/Libraries
227 Requires:       %{name}-libGLw = %{version}-%{release}
228 Requires:       OpenGL-devel >= 1.2
229 Provides:       OpenGL-GLw-devel
230
231 %description libGLw-devel
232 Header files for SGI libGLw library.
233
234 %description libGLw-devel -l pl.UTF-8
235 Pliki nagłówkowe biblioteki SGI libGLw.
236
237 %package libGLw-static
238 Summary:        Static SGI libGLw library
239 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
240 License:        SGI MIT-like
241 Group:          Development/Libraries
242 Requires:       %{name}-libGLw-devel = %{version}-%{release}
243 Provides:       OpenGL-GLw-static
244
245 %description libGLw-static
246 Static SGI libGLw library.
247
248 %description libGLw-static -l pl.UTF-8
249 Statyczna biblioteka SGI libGLw.
250
251 %package libOSMesa
252 Summary:        OSMesa (off-screen renderer) library
253 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
254 License:        MIT
255 Group:          Libraries
256 # doesn't require base
257
258 %description libOSMesa
259 OSMesa (off-screen renderer) library.
260
261 %description libOSMesa -l pl.UTF-8
262 Biblioteka OSMesa (renderująca bitmapy w pamięci).
263
264 %package libOSMesa-devel
265 Summary:        Header file for OSMesa (off-screen renderer) library
266 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
267 License:        MIT
268 Group:          Development/Libraries
269 Requires:       %{name}-libOSMesa = %{version}-%{release}
270 # for <GL/gl.h> only
271 Requires:       OpenGL-devel
272
273 %description libOSMesa-devel
274 Header file for OSMesa (off-screen renderer) library.
275
276 %description libOSMesa-devel -l pl.UTF-8
277 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
278
279 %package libOSMesa-static
280 Summary:        Static OSMesa (off-screen renderer) library
281 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
282 License:        MIT
283 Group:          Development/Libraries
284 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
285 # this static build of OSMesa needs static non-dri Mesa implementation
286 Requires:       %{name}-libGL-static = %{version}-%{release}
287
288 %description libOSMesa-static
289 Static OSMesa (off-screen renderer) library.
290
291 %description libOSMesa-static -l pl.UTF-8
292 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
293
294 %package utils
295 Summary:        OpenGL utilities from Mesa3D
296 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
297 License:        MIT
298 Group:          X11/Applications/Graphics
299 # loose deps on libGL/libGLU
300
301 %description utils
302 OpenGL utilities from Mesa3D: glxgears and glxinfo.
303
304 %description utils -l pl.UTF-8
305 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
306
307 %package demos
308 Summary:        Mesa Demos source code
309 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
310 License:        various (MIT, SGI, GPL - see copyright notes in sources)
311 Group:          Development/Libraries
312 Requires:       OpenGL-devel
313
314 %description demos
315 Demonstration programs for the Mesa libraries in source code form.
316
317 %description demos -l pl.UTF-8
318 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
319
320 %package dri-driver-ati-mach64
321 Summary:        X.org DRI driver for ATI Mach64 card family
322 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
323 License:        MIT
324 Group:          X11/Libraries
325 Requires:       xorg-driver-video-mach64
326 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
327 Requires:       xorg-xserver-server >= %{xserver_ver}
328
329 %description dri-driver-ati-mach64
330 X.org DRI driver for ATI Mach64 card family.
331
332 %description dri-driver-ati-mach64 -l pl.UTF-8
333 Sterownik X.org DRI dla rodziny kart ATI Mach64.
334
335 %package dri-driver-ati-radeon-R100
336 Summary:        X.org DRI driver for ATI R100 card family
337 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
338 License:        MIT
339 Group:          X11/Libraries
340 Requires:       xorg-driver-video-ati
341 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
342 Requires:       xorg-xserver-server >= %{xserver_ver}
343 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
344
345 %description dri-driver-ati-radeon-R100
346 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
347
348 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
349 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
350
351 %package dri-driver-ati-radeon-R200
352 Summary:        X.org DRI driver for ATI R200 card family
353 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
354 License:        MIT
355 Group:          X11/Libraries
356 Requires:       xorg-driver-video-ati
357 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
358 Requires:       xorg-xserver-server >= %{xserver_ver}
359 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
360
361 %description dri-driver-ati-radeon-R200
362 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
363
364 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
365 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
366
367 %package dri-driver-ati-radeon-R300
368 Summary:        X.org DRI driver for ATI R300 card family
369 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
370 License:        MIT
371 Group:          X11/Libraries
372 Requires:       xorg-driver-video-ati
373 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
374 Requires:       xorg-xserver-server >= %{xserver_ver}
375 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
376
377 %description dri-driver-ati-radeon-R300
378 X.org DRI driver for ATI R300 card family.
379
380 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
381 Sterownik X.org DRI dla rodziny kart ATI R300.
382
383 %package dri-driver-ati-radeon-R600
384 Summary:        X.org DRI driver for ATI R600 card family
385 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
386 License:        MIT
387 Group:          X11/Libraries
388 Requires:       radeon-ucode
389 Requires:       xorg-driver-video-ati
390 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
391 Requires:       xorg-xserver-server >= %{xserver_ver}
392
393 %description dri-driver-ati-radeon-R600
394 X.org DRI driver for ATI R600 card family.
395
396 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
397 Sterownik X.org DRI dla rodziny kart ATI R600.
398
399 %package dri-driver-ati-rage128
400 Summary:        X.org DRI driver for ATI Rage128 card family
401 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
402 License:        MIT
403 Group:          X11/Libraries
404 Requires:       xorg-driver-video-r128
405 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
406 Requires:       xorg-xserver-server >= %{xserver_ver}
407 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
408
409 %description dri-driver-ati-rage128
410 X.org DRI driver for ATI Rage128 card family.
411
412 %description dri-driver-ati-rage128 -l pl.UTF-8
413 Sterownik X.org DRI dla rodziny kart ATI Rage128.
414
415 %package dri-driver-ffb
416 Summary:        X.org DRI driver for Sun FFB card family
417 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
418 License:        MIT
419 Group:          X11/Libraries
420 Requires:       xorg-driver-video-sunffb
421 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
422 Requires:       xorg-xserver-server >= %{xserver_ver}
423
424 %description dri-driver-ffb
425 X.org DRI driver for SUN Creator3D and Elite3D card family.
426
427 %description dri-driver-ffb -l pl.UTF-8
428 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
429
430 %package dri-driver-glint
431 Summary:        X.org DRI driver for GLINT/Permedia card family
432 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
433 License:        MIT
434 Group:          X11/Libraries
435 Requires:       xorg-driver-video-glint
436 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
437 Requires:       xorg-xserver-server >= %{xserver_ver}
438 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
439
440 %description dri-driver-glint
441 X.org DRI driver for GLINT/Permedia card family.
442
443 %description dri-driver-glint -l pl.UTF-8
444 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
445
446 %package dri-driver-intel-i810
447 Summary:        X.org DRI driver for Intel i810 card family
448 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
449 License:        MIT
450 Group:          X11/Libraries
451 Requires:       xorg-driver-video-intel
452 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
453 Requires:       xorg-xserver-server >= %{xserver_ver}
454 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
455
456 %description dri-driver-intel-i810
457 X.org DRI driver for Intel i810 card family.
458
459 %description dri-driver-intel-i810 -l pl.UTF-8
460 Sterownik X.org DRI dla rodziny kart Intel i810.
461
462 %package dri-driver-intel-i915
463 Summary:        X.org DRI driver for Intel i915 card family
464 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
465 License:        MIT
466 Group:          X11/Libraries
467 Requires:       xorg-driver-video-intel
468 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
469 Requires:       xorg-xserver-server >= %{xserver_ver}
470 Obsoletes:      Mesa-dri-driver-intel-i830
471 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
472
473 %description dri-driver-intel-i915
474 X.org DRI driver for Intel i915 card family.
475
476 %description dri-driver-intel-i915 -l pl.UTF-8
477 Sterownik X.org DRI dla rodziny kart Intel i915.
478
479 %package dri-driver-intel-i965
480 Summary:        X.org DRI driver for Intel i965 card family
481 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
482 License:        MIT
483 Group:          X11/Libraries
484 Requires:       xorg-driver-video-intel
485 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
486 Requires:       xorg-xserver-server >= %{xserver_ver}
487 Obsoletes:      Mesa-dri-driver-intel-i830
488 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
489
490 %description dri-driver-intel-i965
491 X.org DRI driver for Intel i965 card family.
492
493 %description dri-driver-intel-i965 -l pl.UTF-8
494 Sterownik X.org DRI dla rodziny kart Intel i965.
495
496 %package dri-driver-matrox
497 Summary:        X.org DRI driver for Matrox G card family
498 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
499 License:        MIT
500 Group:          X11/Libraries
501 Requires:       xorg-driver-video-mga
502 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
503 Requires:       xorg-xserver-server >= %{xserver_ver}
504 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
505
506 %description dri-driver-matrox
507 X.org DRI drivers for Matrox G card family.
508
509 %description dri-driver-matrox -l pl.UTF-8
510 Sterowniki X.org DRI dla rodziny kart Matrox G.
511
512 %package dri-driver-nouveau
513 Summary:        X.org DRI driver for NVIDIA card family
514 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
515 License:        MIT
516 Group:          X11/Libraries
517 Requires:       xorg-driver-video-nouveau
518 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
519 Requires:       xorg-xserver-server >= %{xserver_ver}
520
521 %description dri-driver-nouveau
522 X.org DRI drivers for NVIDIA card family.
523
524 %description dri-driver-nouveau -l pl.UTF-8
525 Sterowniki X.org DRI dla rodziny kart NVIDIA.
526
527 %package dri-driver-savage
528 Summary:        X.org DRI driver for S3 Savage card family
529 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
530 License:        MIT
531 Group:          X11/Libraries
532 Requires:       xorg-driver-video-savage
533 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
534 Requires:       xorg-xserver-server >= %{xserver_ver}
535
536 %description dri-driver-savage
537 X.org DRI driver for S3 Savage card family.
538
539 %description dri-driver-savage -l pl.UTF-8
540 Sterownik X.org DRI dla rodziny kart S3 Savage.
541
542 %package dri-driver-sis
543 Summary:        X.org DRI driver for SiS card family
544 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       xorg-driver-video-sis
548 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
549 Requires:       xorg-xserver-server >= %{xserver_ver}
550 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
551
552 %description dri-driver-sis
553 X.org DRI driver for SiS card family.
554
555 %description dri-driver-sis -l pl.UTF-8
556 Sterownik X.org DRI dla rodziny kart SiS.
557
558 %package dri-driver-swrast
559 Summary:        X.org DRI software rasterizer driver
560 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
561 License:        MIT
562 Group:          X11/Libraries
563 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
564 Requires:       xorg-xserver-server >= %{xserver_ver}
565
566 %description dri-driver-swrast
567 X.org DRI software rasterizer driver.
568
569 %description dri-driver-swrast -l pl.UTF-8
570 Sterownik X.org DRI obsługujący rysowanie programowe.
571
572 %package dri-driver-tdfx
573 Summary:        X.org DRI driver for 3DFX Voodoo card family
574 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
575 License:        MIT
576 Group:          X11/Libraries
577 Requires:       Glide3-DRI
578 Requires:       xorg-driver-video-tdfx
579 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
580 Requires:       xorg-xserver-server >= %{xserver_ver}
581 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
582
583 %description dri-driver-tdfx
584 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
585 and Velocity 100/200).
586
587 %description dri-driver-tdfx -l pl.UTF-8
588 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
589 Banshee i Velocity 100/200).
590
591 %package dri-driver-via-unichrome
592 Summary:        X.org DRI driver for VIA Unichrome card family
593 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
594 License:        MIT
595 Group:          X11/Libraries
596 Requires:       xorg-driver-video-openchrome
597 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
598 Requires:       xorg-xserver-server >= %{xserver_ver}
599
600 %description dri-driver-via-unichrome
601 X.org DRI driver for VIA Unichrome card family.
602
603 %description dri-driver-via-unichrome -l pl.UTF-8
604 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
605
606 %package dri-driver-vmwgfx
607 Summary:        X.org DRI driver for VMware
608 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
609 License:        MIT
610 Group:          X11/Libraries
611 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
612 Requires:       xorg-xserver-server >= %{xserver_ver}
613
614 %description dri-driver-vmwgfx
615 X.org DRI driver for VMWare.
616
617 %description dri-driver-vmwgfx -l pl.UTF-8
618 Sterownik X.org DRI dla VMware.
619
620 %prep
621 %setup -q -b1 -a2
622 %patch0 -p0
623
624 # fix demos
625 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
626
627 %build
628 %{__aclocal}
629 %{__autoconf}
630
631 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
632 %if %{without gallium_intel}
633 i915 \
634 %endif
635 %ifarch sparc sparcv9 sparc64
636 ffb \
637 %endif
638 %ifarch %{ix86} %{x8664}
639 sis \
640 %endif
641 swrast tdfx unichrome"
642
643 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
644
645 common_flags="\
646         --enable-shared \
647         --enable-selinux \
648         --enable-pic \
649         --enable-glx-tls \
650         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
651         --with%{!?with_demos:out}-demos"
652
653 %if %{with osmesa}
654 # osmesa variants
655 %configure $common_flags \
656         --with-driver=osmesa \
657         --disable-asm \
658         --with-osmesa-bits=8
659 %{__make} \
660         SRC_DIRS=mesa
661 mv %{_lib} osmesa8
662 %{__make} clean
663
664 %configure $common_flags \
665         --with-driver=osmesa \
666         --disable-asm \
667         --with-osmesa-bits=16
668 %{__make} \
669         SRC_DIRS=mesa
670 mv %{_lib} osmesa16
671 %{__make} clean
672
673 %configure $common_flags \
674         --with-driver=osmesa \
675         --disable-asm \
676         --with-osmesa-bits=32
677 %{__make} \
678         SRC_DIRS=mesa
679 mv %{_lib} osmesa32
680 %{__make} clean
681 %endif
682
683 %configure $common_flags \
684         --enable-glu \
685         --enable-glw \
686         --disable-glut \
687 %if %{with gallium}
688         --enable-gallium \
689         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
690         --enable-gallium-svga \
691         --enable-gallium-nouveau \
692         --with-state-trackers=dri \
693 %else
694         --disable-gallium \
695 %endif
696         --with-driver=dri \
697         --with-dri-drivers=${dri_drivers} \
698         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
699
700 %{__make}
701 %{__make} -C progs/xdemos glxgears glxinfo
702 %if %{with demos}
703 %{__make} -C progs/demos
704 %endif
705
706 cd gl-manpages-*
707 %configure
708 %{__make}
709
710 %install
711 rm -rf $RPM_BUILD_ROOT
712
713 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
714
715 # libs without drivers
716 %{__make} install \
717         DESTDIR=$RPM_BUILD_ROOT
718
719 cd gl-manpages-*
720 %{__make} install \
721         DESTDIR=$RPM_BUILD_ROOT
722 cd ..
723
724 %if %{with osmesa}
725 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
726 %endif
727
728 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
729 # work on copy to keep -bi --short-circuit working
730 rm -rf progs-clean
731 install -d progs-clean
732 for l in demos glsl osdemos redbook samples xdemos ; do
733         cp -a progs/$l progs-clean/$l
734         %{__make} -C progs-clean/$l clean
735         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
736 done
737 rm -rf progs-clean
738 for l in util images ; do
739         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
740 done
741 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
742
743 # strip out undesirable headers
744 olddir=$(pwd)
745 cd $RPM_BUILD_ROOT%{_includedir}/GL
746 rm [a-fh-np-wyz]*.h gg*.h glf*.h
747 cd $RPM_BUILD_ROOT%{_libdir}
748 cd $olddir
749
750 %if %{with multigl}
751 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
752
753 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
754 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
755
756 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
757 %endif
758
759 %clean
760 rm -rf $RPM_BUILD_ROOT
761
762 %post   libGL -p /sbin/ldconfig
763 %postun libGL -p /sbin/ldconfig
764
765 %post   libGLU -p /sbin/ldconfig
766 %postun libGLU -p /sbin/ldconfig
767
768 %post   libGLw -p /sbin/ldconfig
769 %postun libGLw -p /sbin/ldconfig
770
771 %files libGL
772 %defattr(644,root,root,755)
773 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
774 %if %{with multigl}
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
776 %dir %{_libdir}/Mesa
777 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
778 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
779 %else
780 %attr(755,root,root) %{_libdir}/libGL.so.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
782 # symlink for binary apps which fail to conform Linux OpenGL ABI
783 # (and dlopen libGL.so instead of libGL.so.1)
784 %attr(755,root,root) %{_libdir}/libGL.so
785 %endif
786
787 %files libGL-devel
788 %defattr(644,root,root,755)
789 %doc docs/*.spec
790 %if %{with multigl}
791 %attr(755,root,root) %{_libdir}/libGL.so
792 %endif
793 %dir %{_includedir}/GL
794 %{_includedir}/GL/gl.h
795 %{_includedir}/GL/glext.h
796 %{_includedir}/GL/gl_mangle.h
797 %{_includedir}/GL/glx.h
798 %{_includedir}/GL/glxext.h
799 %{_includedir}/GL/glx_mangle.h
800 %dir %{_includedir}/GL/internal
801 %{_includedir}/GL/internal/dri_interface.h
802 %{_pkgconfigdir}/dri.pc
803 %{_pkgconfigdir}/gl.pc
804 %{_mandir}/man3/gl[^uX]*.3gl*
805 %{_mandir}/man3/glX*.3gl*
806
807 %if %{with static}
808 %files libGL-static
809 %defattr(644,root,root,755)
810 %{_libdir}/libGL.a
811 %endif
812
813 %files libGLU
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
817
818 %files libGLU-devel
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libGLU.so
821 %{_includedir}/GL/glu.h
822 %{_includedir}/GL/glu_mangle.h
823 %{_pkgconfigdir}/glu.pc
824 %{_mandir}/man3/glu*.3gl*
825
826 %if %{with static}
827 %files libGLU-static
828 %defattr(644,root,root,755)
829 %{_libdir}/libGLU.a
830 %endif
831
832 %files libGLw
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
835 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
836
837 %files libGLw-devel
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libGLw.so
840 %{_includedir}/GL/GLwDrawA.h
841 %{_includedir}/GL/GLwDrawAP.h
842 %{_includedir}/GL/GLwMDrawA.h
843 %{_includedir}/GL/GLwMDrawAP.h
844 %{_pkgconfigdir}/glw.pc
845
846 %if %{with static}
847 %files libGLw-static
848 %defattr(644,root,root,755)
849 %{_libdir}/libGLw.a
850 %endif
851
852 %if %{with osmesa}
853 %files libOSMesa
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
856 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
857
858 %files libOSMesa-devel
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_libdir}/libOSMesa*.so
861 %{_includedir}/GL/osmesa.h
862
863 %if %{with static}
864 %files libOSMesa-static
865 %defattr(644,root,root,755)
866 %{_libdir}/libOSMesa*.a
867 %endif
868 %endif
869
870 %files utils
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_bindir}/glxgears
873 %attr(755,root,root) %{_bindir}/glxinfo
874
875 %files dri-driver-ati-mach64
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
878
879 %files dri-driver-ati-radeon-R100
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
882
883 %files dri-driver-ati-radeon-R200
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
886
887 %files dri-driver-ati-radeon-R300
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
890
891 %files dri-driver-ati-radeon-R600
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
894
895 %files dri-driver-ati-rage128
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
898
899 # sunffb (sparc only)
900 %ifarch sparc sparcv9 sparc64
901 %files dri-driver-ffb
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
904 %endif
905
906 # glint (requires update)
907 %if 0
908 %files dri-driver-glint
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
911 %endif
912
913 %files dri-driver-intel-i810
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
916
917 %files dri-driver-intel-i915
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
920
921 %files dri-driver-intel-i965
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
924
925 %files dri-driver-matrox
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
928
929 %if %{with gallium}
930 %files dri-driver-nouveau
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
933 %endif
934
935 %files dri-driver-savage
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
938
939 %ifarch %{ix86} %{x8664}
940 %files dri-driver-sis
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
943 %endif
944
945 %files dri-driver-swrast
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
948
949 %files dri-driver-tdfx
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
952
953 %files dri-driver-via-unichrome
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
956
957 %files dri-driver-vmwgfx
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
960
961 %if %{with demos}
962 %files demos
963 %defattr(644,root,root,755)
964 %{_examplesdir}/%{name}-%{version}
965 %endif
This page took 0.110356 seconds and 4 git commands to generate.