]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- fixed %doc
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.1
5 Release:        1
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildRequires:  XFree86-devel
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %define         _prefix         /usr/X11R6
17 %define         _mandir         %{_prefix}/man
18
19 %description
20 Mesa is a 3-D graphics library with an API which is very similar to that
21 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
22 or state machine, it is being used with authorization from Silicon Graphics,
23 Inc.  However, the author makes no claim that Mesa is in any way a
24 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
25 Those who want a licensed implementation of OpenGL should contact a licensed
26 vendor.  This software is distributed under the terms of the GNU Library
27 General Public License, see the LICENSE file for details.
28
29 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
30
31 %description -l pl
32 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
33 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
34
35 %package devel
36 Summary:        Development environment for Mesa
37 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
38 Group:          Development/Libraries
39 Group(pl):      Programowanie/Biblioteki
40 Requires:       %{name} = %{version}
41
42 %description devel
43 Header files and documentation needed for development.
44
45 %description -l pl devel
46 Pliki nag³ówkowe i dokumentacja do Mesy.
47
48 %package static
49 Summary:        Mesa static libraries
50 Summary(pl):    Biblioteki statyczne Mesy
51 Group:          Development/Libraries
52 Group(pl):      Programowanie/Biblioteki
53 Requires:       %{name}-devel = %{version}
54
55 %description static
56 The static version of the Mesa libraries
57
58 %description -l pl static
59 Biblioteki statyczne Mesy.
60
61 %package glut
62 Summary:        GLUT library for Mesa
63 Summary(pl):    Biblioteka GLUT dla Mesy
64 Group:          X11/Libraries
65 Group(pl):      X11/Biblioteki
66 Requires:       %{name} = %{version}
67 Obsoletes:      glut
68
69 %description glut
70 The GLUT library.
71
72 %description -l pl glut
73 Biblioteka GLUT
74
75 %package glut-devel
76 Summary:        GLUT Development environment for Mesa
77 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
78 Group:          Development/Libraries
79 Group(pl):      Programowanie/Biblioteki
80 Requires:       %{name} = %{version}
81 Obsoletes:      glut-devel
82
83 %description glut-devel
84 Header files needed for development aplications using GLUT library.
85
86 %description -l pl glut-devel
87 Pliki nag³ówkowe do biblioteki GLUT.
88
89 %package glut-static
90 Summary:        GLUT static libraries
91 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
92 Group:          Development/Libraries
93 Group(pl):      Programowanie/Biblioteki
94 Requires:       %{name}-glut-devel = %{version}
95 Obsoletes:      glut-devel
96
97 %description glut-static
98 The static version of the GLUT library.
99
100 %description -l pl glut-static
101 Biblioteki statyczne GLUT.
102
103 %package demos
104 Summary:        Mesa Demos
105 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
106 Group:          Development/Libraries
107 Group(pl):      Programowanie/Biblioteki
108 Requires:       %{name} = %{version}
109
110 %description demos
111 Demonstration programs for the Mesa libraries.
112
113 %description -l pl demos
114 Programy demonstracyjne dla biblioteki Mesa.
115
116 %prep
117 %setup -q -n Mesa-%{version} -b 1
118 %patch -p1
119
120 %build
121 %ifarch alpha
122 make LIBS_ONLY=YES linux-alpha
123 make clean
124 make linux-alpha-elf
125 %endif
126
127 %ifarch ppc
128 make linux-ppc
129 %endif
130
131 %ifarch %{ix86}
132 make clean
133 make LIBS_ONLY=YES linux-386
134 make clean
135 make linux-386-elf
136 %endif
137
138 %ifarch sparc sparc64
139 make  linux-elf
140 %endif
141
142 (cd widgets-mesa; autoconf; \
143 LDFLAGS="-s"; export LDFLAGS
144 %configure \
145         --host=%{_host}
146 make)
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_includedir},%{_mandir}/man3} \
151         $RPM_BUILD_ROOT/usr/src/examples/Mesa
152
153 cp -dpr lib include $RPM_BUILD_ROOT%{_prefix}
154 cp -dpr util $RPM_BUILD_ROOT%{_libdir}/Mesa
155 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
156 install Make-config $RPM_BUILD_ROOT%{_libdir}/Mesa
157
158 (cd widgets-mesa; \
159 make install \
160         prefix=$RPM_BUILD_ROOT/usr/X11R6 \
161         mandir=$RPM_BUILD_ROOT%{_mandir}/man3)
162
163 install */lib*.a $RPM_BUILD_ROOT%{_libdir}
164
165 strip $RPM_BUILD_ROOT%{_libdir}/{lib*so.*.*,Mesa/*/*} || :
166
167 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
168         docs/{IAFA-PACKAGE,README*,RELNOTES,VERSIONS,CONFIG,CONFORM,COPYRIGHT,DEVINFO,*.spec}
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %post   -p /sbin/ldconfig glut
174 %postun -p /sbin/ldconfig glut
175
176 %clean
177 rm -fr $RPM_BUILD_ROOT
178
179 %files
180 %defattr(644,root,root,755)
181 %doc docs/CONFIG.gz
182
183 %ifnarch ppc
184 %attr(755,root,root) %{_libdir}/libMesa*.so.*.*
185 %else
186 %{_libdir}/libMesa*.a
187 %endif
188
189 %files glut
190 %defattr(644,root,root,755)
191 %ifnarch ppc
192 %attr(755,root,root) %{_libdir}/libglut.so.*
193 %else
194 %{_libdir}/libglut.a
195 %endif
196
197 %files glut-devel
198 %defattr(644,root,root,755)
199 %{_includedir}/GL/glut.h
200 %ifnarch ppc
201 %attr(755,root,root) %{_libdir}/libglut.so
202 %endif
203
204 %ifnarch ppc
205 %files glut-static
206 %defattr(644,root,root,755)
207 %{_libdir}/libglut.a
208 %endif
209
210 %files devel
211 %defattr(644,root,root,755)
212 %doc docs/{IAFA-PACKAGE,README,RELNOTES,VERSIONS,CONFORM,COPYRIGHT,DEVINFO,*.spec}.gz
213 %doc README.{3DFX,GGI,MGL,QUAKE,X11,THREADS}.gz
214
215 %ifnarch ppc
216 %attr(755,root,root) %{_libdir}/libMesa*.so
217 %endif
218
219 %dir %{_libdir}/Mesa
220 %{_libdir}/Mesa/Make-config
221 %{_libdir}/Mesa/util
222
223 %dir /usr/X11R6/include/GL
224 %{_includedir}/GL/*.h
225 %{_mandir}/man3/*
226
227 %ifnarch ppc
228 %files static
229 %defattr(644,root,root,755)
230 %endif
231 %{_libdir}/libMesa*.a
232
233 %files demos
234 %defattr(644,root,root,755)
235 %dir /usr/src/examples/Mesa/book
236 %dir /usr/src/examples/Mesa/demos
237 %dir /usr/src/examples/Mesa/samples
238 %dir /usr/src/examples/Mesa/xdemos
239
240 %attr(-,root,root)/usr/src/examples/Mesa/book/*
241 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
242 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
243 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
This page took 0.049572 seconds and 4 git commands to generate.