]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- added using CVS keywords in %changelog (for automating them).
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.0
5 Release:        8
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildPrereq:    XFree86-devel
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %define _prefix /usr/X11R6
17
18 %description
19 Mesa is a 3-D graphics library with an API which is very similar to that
20 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
21 or state machine, it is being used with authorization from Silicon Graphics,
22 Inc.  However, the author makes no claim that Mesa is in any way a
23 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
24 Those who want a licensed implementation of OpenGL should contact a licensed
25 vendor.  This software is distributed under the terms of the GNU Library
26 General Public License, see the LICENSE file for details.
27
28 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
29
30 %description -l pl
31 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
32 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
33
34 %package devel
35 Summary:        Development environment for Mesa
36 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
37 Group:          Development/Libraries
38 Group(pl):      Programowanie/Biblioteki
39 Requires:       %{name} = %{version}
40
41 %description devel
42 Header files and documentation needed for development.
43
44 %description -l pl devel
45 Pliki nag³ówkowe i dokumentacja do Mesy.
46
47 %package static
48 Summary:        Mesa static libraries
49 Summary(pl):    Biblioteki statyczne Mesy
50 Group:          Development/Libraries
51 Group(pl):      Programowanie/Biblioteki
52 Requires:       %{name}-devel = %{version}
53
54 %description static
55 The static version of the Mesa libraries
56
57 %description -l pl static
58 Biblioteki statyczne Mesy.
59
60 %package glut
61 Summary:        GLUT library for Mesa
62 Summary(pl):    Biblioteka GLUT dla Mesy
63 Group:          X11/Libraries
64 Group(pl):      X11/Biblioteki
65 Requires:       %{name} = %{version}
66 Obsoletes:      glut
67
68 %description glut
69 The GLUT library.
70
71 %description -l pl glut
72 Biblioteka GLUT
73
74 %package glut-devel
75 Summary:        GLUT Development environment for Mesa
76 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
77 Group:          Development/Libraries
78 Group(pl):      Programowanie/Biblioteki
79 Requires:       %{name} = %{version}
80 Obsoletes:      glut-devel
81
82 %description glut-devel
83 Header files needed for development aplications using GLUT library.
84
85 %description -l pl glut-devel
86 Pliki nag³ówkowe do biblioteki GLUT.
87
88 %package glut-static
89 Summary:        GLUT static libraries
90 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
91 Group:          Development/Libraries
92 Group(pl):      Programowanie/Biblioteki
93 Requires:       %{name}-glut-devel = %{version}
94 Obsoletes:      glut-devel
95
96 %description glut-static
97 The static version of the GLUT library.
98
99 %description -l pl glut-static
100 Biblioteki statyczne GLUT.
101
102 %package demos
103 Summary:        Mesa Demos
104 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
105 Group:          Development/Libraries
106 Group(pl):      Programowanie/Biblioteki
107 Requires:       %{name} = %{version}
108
109 %description demos
110 Demonstration programs for the Mesa libraries.
111
112 %description -l pl demos
113 Programy demonstracyjne dla biblioteki Mesa.
114
115 %prep
116 %setup -q -n Mesa-%{version} -b 1
117 %patch -p1
118
119 %build
120 %ifarch alpha
121 make LIBS_ONLY=YES linux-alpha
122 make clean
123 make linux-alpha-elf
124 %endif
125
126 %ifarch ppc
127 make linux-ppc
128 %endif
129
130 %ifarch %{ix86}
131 make clean
132 make LIBS_ONLY=YES linux-386
133 make clean
134 make linux-386-elf
135 %endif
136
137 %ifarch sparc sparc64
138 make  linux-elf
139 %endif
140
141 (cd widgets-mesa; autoconf; \
142 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
143 ./configure \
144         --prefix=%{_prefix} \
145         --target=%{_target_platform} \
146         --host=%{_host}
147 make)
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_includedir},%{_mandir}/man3} \
152         $RPM_BUILD_ROOT/usr/src/examples/Mesa
153
154 cp -dpr lib include $RPM_BUILD_ROOT%{_prefix}
155 cp -dpr util $RPM_BUILD_ROOT%{_libdir}/Mesa
156 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
157 install Make-config $RPM_BUILD_ROOT%{_libdir}/Mesa
158
159 (cd widgets-mesa; \
160 make install \
161         prefix=$RPM_BUILD_ROOT/usr/X11R6 \
162         mandir=$RPM_BUILD_ROOT%{_mandir}/man3)
163
164 install */lib*.a $RPM_BUILD_ROOT%{_libdir}
165
166 strip $RPM_BUILD_ROOT%{_libdir}/{lib*so.*.*,Mesa/*/*} ||
167
168 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
169         FUTURE IAFA-PACKAGE LICENSE README* RELNOTES VERSIONS
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %post   -p /sbin/ldconfig glut
175 %postun -p /sbin/ldconfig glut
176
177 %clean
178 rm -fr $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182
183 %ifnarch ppc
184 %attr(755,root,root) %{_libdir}/libMesa*.so.*.*
185 %else
186 %{_libdir}/libMesa*.a
187 %endif
188
189 %files glut
190 %defattr(644,root,root,755)
191 %ifnarch ppc
192 %attr(755,root,root) %{_libdir}/libglut.so.*
193 %else
194 %{_libdir}/libglut.a
195 %endif
196
197 %files glut-devel
198 %defattr(644,root,root,755)
199 %{_includedir}/GL/glut.h
200 %ifnarch ppc
201 %attr(755,root,root) %{_libdir}/libglut.so
202 %endif
203
204 %ifnarch ppc
205 %files glut-static
206 %defattr(644,root,root,755)
207 %{_libdir}/libglut.a
208 %endif
209
210 %files devel
211 %defattr(644,root,root,755)
212 %doc {FUTURE,IAFA-PACKAGE,LICENSE,RELNOTES,VERSIONS,README}.gz
213 %doc README.{3DFX,GGI,MGL,QUAKE,VIRGE,X11}.gz
214
215 %ifnarch ppc
216 %attr(755,root,root) %{_libdir}/libMesa*.so
217 %endif
218
219 %dir %{_libdir}/Mesa
220 %{_libdir}/Mesa/Make-config
221 %{_libdir}/Mesa/util
222
223 %dir /usr/X11R6/include/GL
224 %{_includedir}/GL/*.h
225 %{_mandir}/man3/*
226
227 %ifnarch ppc
228 %files static
229 %defattr(644,root,root,755)
230 %endif
231 %{_libdir}/libMesa*.a
232
233 %files demos
234 %defattr(644,root,root,755)
235 %dir /usr/src/examples/Mesa/book
236 %dir /usr/src/examples/Mesa/demos
237 %dir /usr/src/examples/Mesa/samples
238 %dir /usr/src/examples/Mesa/xdemos
239
240 %attr(-,root,root)/usr/src/examples/Mesa/book/*
241 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
242 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
243 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
This page took 0.052531 seconds and 4 git commands to generate.