]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- typos
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         snap            -rc3
25 Summary:        Free OpenGL implementation
26 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
27 Name:           Mesa
28 Version:        7.7
29 Release:        0.1%{?with_multigl:.mgl}
30 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
31 Group:          X11/Libraries
32 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}%{snap}.tar.bz2
33 # Source0-md5:  775c278a211deacd722ed599e706a20e
34 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}%{snap}.tar.bz2
35 # Source1-md5:  2404747b148e05ca74ffb243b6e26606
36 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
37 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
38 Patch0:         %{name}-realclean.patch
39 URL:            http://www.mesa3d.org/
40 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  expat-devel
44 %{?with_demos:BuildRequires:    glew-devel}
45 BuildRequires:  libdrm-devel >= 2.4.12-3
46 BuildRequires:  libselinux-devel
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libtool >= 2:1.4d
49 %{?with_motif:BuildRequires:    motif-devel}
50 BuildRequires:  pkgconfig
51 BuildRequires:  python
52 BuildRequires:  rpmbuild(macros) >= 1.470
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  xorg-lib-libXdamage-devel
55 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
56 BuildRequires:  xorg-lib-libXt-devel
57 BuildRequires:  xorg-lib-libXxf86vm-devel
58 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
59 BuildRequires:  xorg-proto-glproto-devel
60 BuildRequires:  xorg-proto-printproto-devel
61 BuildRequires:  xorg-util-makedepend
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %if %{without gallium}
65 %undefine       with_gallium_intel
66 %endif
67
68 %description
69 Mesa is a 3-D graphics library with an API which is very similar to
70 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
71 syntax or state machine, it is being used with authorization from
72 Silicon Graphics, Inc. However, the author does not possess an OpenGL
73 license from SGI, and makes no claim that Mesa is in any way a
74 compatible replacement for OpenGL or associated with SGI.
75
76 %description -l pl.UTF-8
77 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
78 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
79 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
80 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
81 OpenGL ani powiązana z SGI.
82
83 %package libGL
84 Summary:        Free Mesa3D implementation of libGL OpenGL library
85 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
86 License:        MIT
87 Group:          X11/Libraries
88 Requires:       libdrm >= 2.4.5
89 Provides:       OpenGL = 2.1
90 # reports version 1.3, but supports glXGetProcAddress() from 1.4
91 Provides:       OpenGL-GLX = 1.4
92 Obsoletes:      Mesa
93 Obsoletes:      Mesa-dri
94 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
95 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
96
97 %description libGL
98 Mesa is a 3-D graphics library with an API which is very similar to
99 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
100 syntax or state machine, it is being used with authorization from
101 Silicon Graphics, Inc. However, the author does not possess an OpenGL
102 license from SGI, and makes no claim that Mesa is in any way a
103 compatible replacement for OpenGL or associated with SGI.
104
105 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
106 specifications. It uses DRI for rendering.
107
108 %description libGL -l pl.UTF-8
109 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
110 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
111 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
112 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
113 OpenGL ani powiązana z SGI.
114
115 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
116 GLX 1.4. Używa DRI do renderowania.
117
118 %package libGL-devel
119 Summary:        Header files for Mesa3D libGL library
120 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
121 License:        MIT
122 Group:          X11/Development/Libraries
123 # loose dependency on libGL to use with other libGL binaries
124 Requires:       OpenGL >= 1.5
125 Requires:       xorg-lib-libX11-devel
126 Provides:       OpenGL-GLX-devel = 1.4
127 Provides:       OpenGL-devel = 2.1
128 Obsoletes:      Mesa-devel
129 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
130 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
131 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
132 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
133
134 %description libGL-devel
135 Header files for Mesa3D libGL library.
136
137 %description libGL-devel -l pl.UTF-8
138 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
139
140 %package libGL-static
141 Summary:        Static Mesa3D libGL library
142 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
143 License:        MIT
144 Group:          X11/Development/Libraries
145 Requires:       %{name}-libGL-devel = %{version}-%{release}
146 Provides:       OpenGL-static = 2.1
147 Obsoletes:      Mesa-static
148 Obsoletes:      X11-OpenGL-static < 1:7.0.0
149 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
150
151 %description libGL-static
152 Static Mesa3D libGL library. It uses software renderer.
153
154 %description libGL-static -l pl.UTF-8
155 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
156 renderingu.
157
158 %package libGLU
159 Summary:        SGI implementation of libGLU OpenGL library
160 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
161 License:        SGI Free Software License B v2.0 (MIT-like)
162 Group:          Libraries
163 # loose dependency on libGL.so.1 to use with other libGL binaries
164 Requires:       OpenGL >= 1.2
165 Provides:       OpenGL-GLU = 1.3
166 Obsoletes:      Mesa-devel
167 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
168 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
169
170 %description libGLU
171 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
172 1.3 specifications.
173
174 %description libGLU -l pl.UTF-8
175 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
176 specyfikację OpenGL GLU 1.3.
177
178 %package libGLU-devel
179 Summary:        Header files for SGI libGLU library
180 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
181 License:        SGI Free Software License B v2.0 (MIT-like)
182 Group:          Development/Libraries
183 Requires:       %{name}-libGLU = %{version}-%{release}
184 Requires:       OpenGL-devel >= 1.2
185 Requires:       libstdc++-devel
186 Provides:       OpenGL-GLU-devel = 1.3
187
188 %description libGLU-devel
189 Header files for SGI libGLU library.
190
191 %description libGLU-devel -l pl.UTF-8
192 Pliki nagłówkowe biblioteki SGI libGLU.
193
194 %package libGLU-static
195 Summary:        Static SGI libGLU library
196 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
197 License:        SGI Free Software License B v2.0 (MIT-like)
198 Group:          Development/Libraries
199 Requires:       %{name}-libGLU-devel = %{version}-%{release}
200 Provides:       OpenGL-GLU-static = 1.3
201
202 %description libGLU-static
203 Static SGI libGLU library.
204
205 %description libGLU-static -l pl.UTF-8
206 Statyczna biblioteka SGI libGLU.
207
208 %package libGLw
209 Summary:        SGI OpenGL Xt widgets library
210 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
211 License:        SGI MIT-like
212 Group:          Libraries
213 # loose dependency on libGL.so.1 to use with other libGL binaries
214 Requires:       OpenGL >= 1.1
215 Provides:       OpenGL-GLw
216
217 %description libGLw
218 SGI OpenGL Xt widgets library.
219
220 %description libGLU -l pl.UTF-8
221 Biblioteka SGI widgetów Xt dla OpenGL-a.
222
223 %package libGLw-devel
224 Summary:        Header files for SGI libGLw library
225 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
226 License:        SGI MIT-like
227 Group:          Development/Libraries
228 Requires:       %{name}-libGLw = %{version}-%{release}
229 Requires:       OpenGL-devel >= 1.2
230 Provides:       OpenGL-GLw-devel
231
232 %description libGLw-devel
233 Header files for SGI libGLw library.
234
235 %description libGLw-devel -l pl.UTF-8
236 Pliki nagłówkowe biblioteki SGI libGLw.
237
238 %package libGLw-static
239 Summary:        Static SGI libGLw library
240 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
241 License:        SGI MIT-like
242 Group:          Development/Libraries
243 Requires:       %{name}-libGLw-devel = %{version}-%{release}
244 Provides:       OpenGL-GLw-static
245
246 %description libGLw-static
247 Static SGI libGLw library.
248
249 %description libGLw-static -l pl.UTF-8
250 Statyczna biblioteka SGI libGLw.
251
252 %package libOSMesa
253 Summary:        OSMesa (off-screen renderer) library
254 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
255 License:        MIT
256 Group:          Libraries
257 # doesn't require base
258
259 %description libOSMesa
260 OSMesa (off-screen renderer) library.
261
262 %description libOSMesa -l pl.UTF-8
263 Biblioteka OSMesa (renderująca bitmapy w pamięci).
264
265 %package libOSMesa-devel
266 Summary:        Header file for OSMesa (off-screen renderer) library
267 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
268 License:        MIT
269 Group:          Development/Libraries
270 Requires:       %{name}-libOSMesa = %{version}-%{release}
271 # for <GL/gl.h> only
272 Requires:       OpenGL-devel
273
274 %description libOSMesa-devel
275 Header file for OSMesa (off-screen renderer) library.
276
277 %description libOSMesa-devel -l pl.UTF-8
278 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
279
280 %package libOSMesa-static
281 Summary:        Static OSMesa (off-screen renderer) library
282 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
283 License:        MIT
284 Group:          Development/Libraries
285 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
286 # this static build of OSMesa needs static non-dri Mesa implementation
287 Requires:       %{name}-libGL-static = %{version}-%{release}
288
289 %description libOSMesa-static
290 Static OSMesa (off-screen renderer) library.
291
292 %description libOSMesa-static -l pl.UTF-8
293 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
294
295 %package utils
296 Summary:        OpenGL utilities from Mesa3D
297 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
298 License:        MIT
299 Group:          X11/Applications/Graphics
300 # loose deps on libGL/libGLU
301
302 %description utils
303 OpenGL utilities from Mesa3D: glxgears and glxinfo.
304
305 %description utils -l pl.UTF-8
306 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
307
308 %package demos
309 Summary:        Mesa Demos source code
310 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
311 License:        various (MIT, SGI, GPL - see copyright notes in sources)
312 Group:          Development/Libraries
313 Requires:       OpenGL-devel
314
315 %description demos
316 Demonstration programs for the Mesa libraries in source code form.
317
318 %description demos -l pl.UTF-8
319 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
320
321 %package dri-driver-ati-mach64
322 Summary:        X.org DRI driver for ATI Mach64 card family
323 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
324 License:        MIT
325 Group:          X11/Libraries
326 Requires:       xorg-driver-video-mach64
327 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
328 Requires:       xorg-xserver-server >= %{xserver_ver}
329
330 %description dri-driver-ati-mach64
331 X.org DRI driver for ATI Mach64 card family.
332
333 %description dri-driver-ati-mach64 -l pl.UTF-8
334 Sterownik X.org DRI dla rodziny kart ATI Mach64.
335
336 %package dri-driver-ati-radeon-R100
337 Summary:        X.org DRI driver for ATI R100 card family
338 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
339 License:        MIT
340 Group:          X11/Libraries
341 Requires:       xorg-driver-video-ati
342 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
343 Requires:       xorg-xserver-server >= %{xserver_ver}
344 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
345
346 %description dri-driver-ati-radeon-R100
347 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
348
349 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
350 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
351
352 %package dri-driver-ati-radeon-R200
353 Summary:        X.org DRI driver for ATI R200 card family
354 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
355 License:        MIT
356 Group:          X11/Libraries
357 Requires:       xorg-driver-video-ati
358 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
359 Requires:       xorg-xserver-server >= %{xserver_ver}
360 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
361
362 %description dri-driver-ati-radeon-R200
363 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
364
365 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
366 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
367
368 %package dri-driver-ati-radeon-R300
369 Summary:        X.org DRI driver for ATI R300 card family
370 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
371 License:        MIT
372 Group:          X11/Libraries
373 Requires:       xorg-driver-video-ati
374 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
375 Requires:       xorg-xserver-server >= %{xserver_ver}
376 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
377
378 %description dri-driver-ati-radeon-R300
379 X.org DRI driver for ATI R300 card family.
380
381 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
382 Sterownik X.org DRI dla rodziny kart ATI R300.
383
384 %package dri-driver-ati-radeon-R600
385 Summary:        X.org DRI driver for ATI R600 card family
386 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
387 License:        MIT
388 Group:          X11/Libraries
389 Requires:       radeon-ucode
390 Requires:       xorg-driver-video-ati
391 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
392 Requires:       xorg-xserver-server >= %{xserver_ver}
393
394 %description dri-driver-ati-radeon-R600
395 X.org DRI driver for ATI R600 card family.
396
397 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
398 Sterownik X.org DRI dla rodziny kart ATI R600.
399
400 %package dri-driver-ati-rage128
401 Summary:        X.org DRI driver for ATI Rage128 card family
402 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
403 License:        MIT
404 Group:          X11/Libraries
405 Requires:       xorg-driver-video-r128
406 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
407 Requires:       xorg-xserver-server >= %{xserver_ver}
408 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
409
410 %description dri-driver-ati-rage128
411 X.org DRI driver for ATI Rage128 card family.
412
413 %description dri-driver-ati-rage128 -l pl.UTF-8
414 Sterownik X.org DRI dla rodziny kart ATI Rage128.
415
416 %package dri-driver-ffb
417 Summary:        X.org DRI driver for Sun FFB card family
418 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
419 License:        MIT
420 Group:          X11/Libraries
421 Requires:       xorg-driver-video-sunffb
422 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
423 Requires:       xorg-xserver-server >= %{xserver_ver}
424
425 %description dri-driver-ffb
426 X.org DRI driver for SUN Creator3D and Elite3D card family.
427
428 %description dri-driver-ffb -l pl.UTF-8
429 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
430
431 %package dri-driver-glint
432 Summary:        X.org DRI driver for GLINT/Permedia card family
433 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
434 License:        MIT
435 Group:          X11/Libraries
436 Requires:       xorg-driver-video-glint
437 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
438 Requires:       xorg-xserver-server >= %{xserver_ver}
439 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
440
441 %description dri-driver-glint
442 X.org DRI driver for GLINT/Permedia card family.
443
444 %description dri-driver-glint -l pl.UTF-8
445 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
446
447 %package dri-driver-intel-i810
448 Summary:        X.org DRI driver for Intel i810 card family
449 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
450 License:        MIT
451 Group:          X11/Libraries
452 Requires:       xorg-driver-video-intel
453 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
454 Requires:       xorg-xserver-server >= %{xserver_ver}
455 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
456
457 %description dri-driver-intel-i810
458 X.org DRI driver for Intel i810 card family.
459
460 %description dri-driver-intel-i810 -l pl.UTF-8
461 Sterownik X.org DRI dla rodziny kart Intel i810.
462
463 %package dri-driver-intel-i915
464 Summary:        X.org DRI driver for Intel i915 card family
465 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
466 License:        MIT
467 Group:          X11/Libraries
468 Requires:       xorg-driver-video-intel
469 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
470 Requires:       xorg-xserver-server >= %{xserver_ver}
471 Obsoletes:      Mesa-dri-driver-intel-i830
472 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
473
474 %description dri-driver-intel-i915
475 X.org DRI driver for Intel i915 card family.
476
477 %description dri-driver-intel-i915 -l pl.UTF-8
478 Sterownik X.org DRI dla rodziny kart Intel i915.
479
480 %package dri-driver-intel-i965
481 Summary:        X.org DRI driver for Intel i965 card family
482 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
483 License:        MIT
484 Group:          X11/Libraries
485 Requires:       xorg-driver-video-intel
486 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
487 Requires:       xorg-xserver-server >= %{xserver_ver}
488 Obsoletes:      Mesa-dri-driver-intel-i830
489 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
490
491 %description dri-driver-intel-i965
492 X.org DRI driver for Intel i965 card family.
493
494 %description dri-driver-intel-i965 -l pl.UTF-8
495 Sterownik X.org DRI dla rodziny kart Intel i965.
496
497 %package dri-driver-matrox
498 Summary:        X.org DRI driver for Matrox G card family
499 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
500 License:        MIT
501 Group:          X11/Libraries
502 Requires:       xorg-driver-video-mga
503 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
504 Requires:       xorg-xserver-server >= %{xserver_ver}
505 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
506
507 %description dri-driver-matrox
508 X.org DRI drivers for Matrox G card family.
509
510 %description dri-driver-matrox -l pl.UTF-8
511 Sterowniki X.org DRI dla rodziny kart Matrox G.
512
513 %package dri-driver-nouveau
514 Summary:        X.org DRI driver for NVIDIA card family
515 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
516 License:        MIT
517 Group:          X11/Libraries
518 Requires:       xorg-driver-video-nouveau
519 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
520 Requires:       xorg-xserver-server >= %{xserver_ver}
521
522 %description dri-driver-nouveau
523 X.org DRI drivers for NVIDIA card family.
524
525 %description dri-driver-nouveau -l pl.UTF-8
526 Sterowniki X.org DRI dla rodziny kart NVIDIA.
527
528 %package dri-driver-savage
529 Summary:        X.org DRI driver for S3 Savage card family
530 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
531 License:        MIT
532 Group:          X11/Libraries
533 Requires:       xorg-driver-video-savage
534 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
535 Requires:       xorg-xserver-server >= %{xserver_ver}
536
537 %description dri-driver-savage
538 X.org DRI driver for S3 Savage card family.
539
540 %description dri-driver-savage -l pl.UTF-8
541 Sterownik X.org DRI dla rodziny kart S3 Savage.
542
543 %package dri-driver-sis
544 Summary:        X.org DRI driver for SiS card family
545 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
546 License:        MIT
547 Group:          X11/Libraries
548 Requires:       xorg-driver-video-sis
549 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
550 Requires:       xorg-xserver-server >= %{xserver_ver}
551 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
552
553 %description dri-driver-sis
554 X.org DRI driver for SiS card family.
555
556 %description dri-driver-sis -l pl.UTF-8
557 Sterownik X.org DRI dla rodziny kart SiS.
558
559 %package dri-driver-swrast
560 Summary:        X.org DRI software rasterizer driver
561 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
562 License:        MIT
563 Group:          X11/Libraries
564 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
565 Requires:       xorg-xserver-server >= %{xserver_ver}
566
567 %description dri-driver-swrast
568 X.org DRI software rasterizer driver.
569
570 %description dri-driver-swrast -l pl.UTF-8
571 Sterownik X.org DRI obsługujący rysowanie programowe.
572
573 %package dri-driver-tdfx
574 Summary:        X.org DRI driver for 3DFX Voodoo card family
575 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
576 License:        MIT
577 Group:          X11/Libraries
578 Requires:       Glide3-DRI
579 Requires:       xorg-driver-video-tdfx
580 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
581 Requires:       xorg-xserver-server >= %{xserver_ver}
582 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
583
584 %description dri-driver-tdfx
585 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
586 and Velocity 100/200).
587
588 %description dri-driver-tdfx -l pl.UTF-8
589 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
590 Banshee i Velocity 100/200).
591
592 %package dri-driver-via-unichrome
593 Summary:        X.org DRI driver for VIA Unichrome card family
594 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
595 License:        MIT
596 Group:          X11/Libraries
597 Requires:       xorg-driver-video-openchrome
598 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
599 Requires:       xorg-xserver-server >= %{xserver_ver}
600
601 %description dri-driver-via-unichrome
602 X.org DRI driver for VIA Unichrome card family.
603
604 %description dri-driver-via-unichrome -l pl.UTF-8
605 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
606
607 %package dri-driver-vmwgfx
608 Summary:        X.org DRI driver for VMware
609 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
610 License:        MIT
611 Group:          X11/Libraries
612 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
613 Requires:       xorg-xserver-server >= %{xserver_ver}
614
615 %description dri-driver-vmwgfx
616 X.org DRI driver for VMWare.
617
618 %description dri-driver-vmwgfx -l pl.UTF-8
619 Sterownik X.org DRI dla VMware.
620
621 %prep
622 %setup -q -b1 -a2
623 %patch0 -p0
624
625 # fix demos
626 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
627
628 %build
629 %{__aclocal}
630 %{__autoconf}
631
632 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
633 %if %{without gallium_intel}
634 i915 \
635 %endif
636 %ifarch sparc sparcv9 sparc64
637 ffb \
638 %endif
639 %ifarch %{ix86} %{x8664}
640 sis \
641 %endif
642 swrast tdfx unichrome"
643
644 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
645
646 common_flags="\
647         --enable-shared \
648         --enable-selinux \
649         --enable-pic \
650         --enable-glx-tls \
651         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
652         --with%{!?with_demos:out}-demos"
653
654 %if %{with osmesa}
655 # osmesa variants
656 %configure $common_flags \
657         --with-driver=osmesa \
658         --disable-asm \
659         --with-osmesa-bits=8
660 %{__make} \
661         SRC_DIRS=mesa
662 mv %{_lib} osmesa8
663 %{__make} clean
664
665 %configure $common_flags \
666         --with-driver=osmesa \
667         --disable-asm \
668         --with-osmesa-bits=16
669 %{__make} \
670         SRC_DIRS=mesa
671 mv %{_lib} osmesa16
672 %{__make} clean
673
674 %configure $common_flags \
675         --with-driver=osmesa \
676         --disable-asm \
677         --with-osmesa-bits=32
678 %{__make} \
679         SRC_DIRS=mesa
680 mv %{_lib} osmesa32
681 %{__make} clean
682 %endif
683
684 %configure $common_flags \
685         --enable-glu \
686         --enable-glw \
687         --disable-glut \
688 %if %{with gallium}
689         --enable-gallium \
690         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
691         --enable-gallium-nouveau \
692         --with-state-trackers=dri \
693 %else
694         --disable-gallium \
695 %endif
696         --with-driver=dri \
697         --with-dri-drivers=${dri_drivers} \
698         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
699
700 %{__make}
701 %{__make} -C progs/xdemos glxgears glxinfo
702 %if %{with demos}
703 %{__make} -C progs/demos
704 %endif
705
706 cd gl-manpages-*
707 %configure
708 %{__make}
709
710 %install
711 rm -rf $RPM_BUILD_ROOT
712
713 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
714
715 # libs without drivers
716 %{__make} install \
717         DESTDIR=$RPM_BUILD_ROOT
718
719 cd gl-manpages-*
720 %{__make} install \
721         DESTDIR=$RPM_BUILD_ROOT
722 cd ..
723
724 %if %{with osmesa}
725 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
726 %endif
727
728 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
729 # work on copy to keep -bi --short-circuit working
730 rm -rf progs-clean
731 install -d progs-clean
732 for l in demos glsl osdemos redbook samples xdemos ; do
733         cp -a progs/$l progs-clean/$l
734         %{__make} -C progs-clean/$l clean
735         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
736 done
737 rm -rf progs-clean
738 for l in util images ; do
739         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
740 done
741 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
742
743 # strip out undesirable headers
744 olddir=$(pwd)
745 cd $RPM_BUILD_ROOT%{_includedir}/GL
746 rm [a-fh-np-wyz]*.h gg*.h glf*.h
747 cd $RPM_BUILD_ROOT%{_libdir}
748 cd $olddir
749
750 %if %{with multigl}
751 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
752
753 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
754 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
755
756 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
757 %endif
758
759 %clean
760 rm -rf $RPM_BUILD_ROOT
761
762 %post   libGL -p /sbin/ldconfig
763 %postun libGL -p /sbin/ldconfig
764
765 %post   libGLU -p /sbin/ldconfig
766 %postun libGLU -p /sbin/ldconfig
767
768 %post   libGLw -p /sbin/ldconfig
769 %postun libGLw -p /sbin/ldconfig
770
771 %files libGL
772 %defattr(644,root,root,755)
773 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
774 %if %{with multigl}
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
776 %dir %{_libdir}/Mesa
777 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
778 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
779 %else
780 %attr(755,root,root) %{_libdir}/libGL.so.*.*
781 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
782 # symlink for binary apps which fail to conform Linux OpenGL ABI
783 # (and dlopen libGL.so instead of libGL.so.1)
784 %attr(755,root,root) %{_libdir}/libGL.so
785 %endif
786
787 %files libGL-devel
788 %defattr(644,root,root,755)
789 %doc docs/*.spec
790 %if %{with multigl}
791 %attr(755,root,root) %{_libdir}/libGL.so
792 %endif
793 %dir %{_includedir}/GL
794 %{_includedir}/GL/gl.h
795 %{_includedir}/GL/glext.h
796 %{_includedir}/GL/gl_mangle.h
797 %{_includedir}/GL/glx.h
798 %{_includedir}/GL/glxext.h
799 %{_includedir}/GL/glx_mangle.h
800 %dir %{_includedir}/GL/internal
801 %{_includedir}/GL/internal/dri_interface.h
802 %{_pkgconfigdir}/dri.pc
803 %{_pkgconfigdir}/gl.pc
804 %{_mandir}/man3/gl[^uX]*.3gl*
805 %{_mandir}/man3/glX*.3gl*
806
807 %if %{with static}
808 %files libGL-static
809 %defattr(644,root,root,755)
810 %{_libdir}/libGL.a
811 %endif
812
813 %files libGLU
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
817
818 %files libGLU-devel
819 %defattr(644,root,root,755)
820 %attr(755,root,root) %{_libdir}/libGLU.so
821 %{_includedir}/GL/glu.h
822 %{_includedir}/GL/glu_mangle.h
823 %{_pkgconfigdir}/glu.pc
824 %{_mandir}/man3/glu*.3gl*
825
826 %if %{with static}
827 %files libGLU-static
828 %defattr(644,root,root,755)
829 %{_libdir}/libGLU.a
830 %endif
831
832 %files libGLw
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
835 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
836
837 %files libGLw-devel
838 %defattr(644,root,root,755)
839 %attr(755,root,root) %{_libdir}/libGLw.so
840 %{_includedir}/GL/GLwDrawA.h
841 %{_includedir}/GL/GLwDrawAP.h
842 %{_includedir}/GL/GLwMDrawA.h
843 %{_includedir}/GL/GLwMDrawAP.h
844 %{_pkgconfigdir}/glw.pc
845
846 %if %{with static}
847 %files libGLw-static
848 %defattr(644,root,root,755)
849 %{_libdir}/libGLw.a
850 %endif
851
852 %if %{with osmesa}
853 %files libOSMesa
854 %defattr(644,root,root,755)
855 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
856 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
857
858 %files libOSMesa-devel
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_libdir}/libOSMesa*.so
861 %{_includedir}/GL/osmesa.h
862
863 %if %{with static}
864 %files libOSMesa-static
865 %defattr(644,root,root,755)
866 %{_libdir}/libOSMesa*.a
867 %endif
868 %endif
869
870 %files utils
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_bindir}/glxgears
873 %attr(755,root,root) %{_bindir}/glxinfo
874
875 %files dri-driver-ati-mach64
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
878
879 %files dri-driver-ati-radeon-R100
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
882
883 %files dri-driver-ati-radeon-R200
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
886
887 %files dri-driver-ati-radeon-R300
888 %defattr(644,root,root,755)
889 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
890
891 %files dri-driver-ati-radeon-R600
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
894
895 %files dri-driver-ati-rage128
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
898
899 # sunffb (sparc only)
900 %ifarch sparc sparcv9 sparc64
901 %files dri-driver-ffb
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
904 %endif
905
906 # glint (requires update)
907 %if 0
908 %files dri-driver-glint
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
911 %endif
912
913 %files dri-driver-intel-i810
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
916
917 %files dri-driver-intel-i915
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
920
921 %files dri-driver-intel-i965
922 %defattr(644,root,root,755)
923 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
924
925 %files dri-driver-matrox
926 %defattr(644,root,root,755)
927 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
928
929 %if %{with gallium}
930 %files dri-driver-nouveau
931 %defattr(644,root,root,755)
932 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
933 %endif
934
935 %files dri-driver-savage
936 %defattr(644,root,root,755)
937 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
938
939 %ifarch %{ix86} %{x8664}
940 %files dri-driver-sis
941 %defattr(644,root,root,755)
942 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
943 %endif
944
945 %files dri-driver-swrast
946 %defattr(644,root,root,755)
947 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
948
949 %files dri-driver-tdfx
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
952
953 %files dri-driver-via-unichrome
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
956
957 %files dri-driver-vmwgfx
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
960
961 %if %{with demos}
962 %files demos
963 %defattr(644,root,root,755)
964 %{_examplesdir}/%{name}-%{version}
965 %endif
This page took 0.102322 seconds and 4 git commands to generate.