]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- changed all BuildRoot definitons
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.1
5 Release:        1
6 License:        GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://ftp.mesa3d.org/mesa/%{name}Lib-%{version}.tar.bz2
10 Source1:        ftp://ftp.mesa3d.org/mesa/%{name}Demos-%{version}.tar.bz2
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildRequires:  XFree86-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _prefix         /usr/X11R6
17 %define         _mandir         %{_prefix}/man
18
19 %description
20 Mesa is a 3-D graphics library with an API which is very similar to that of
21 OpenGL*. To the extent that Mesa utilizes the OpenGL command syntax or
22 state machine, it is being used with authorization from Silicon Graphics,
23 Inc. However, the author makes no claim that Mesa is in any way a
24 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
25 Those who want a licensed implementation of OpenGL should contact a
26 licensed vendor. This software is distributed under the terms of the GNU
27 Library General Public License, see the LICENSE file for details.
28
29 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
30
31 %description -l pl
32 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
33
34 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
35
36 %package devel
37 Summary:        Development environment for Mesa
38 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
39 Group:          Development/Libraries
40 Group(pl):      Programowanie/Biblioteki
41 Requires:       %{name} = %{version}
42
43 %description devel
44 Header files and documentation needed for development.
45
46 %description -l pl devel
47 Pliki nag³ówkowe i dokumentacja do Mesy.
48
49 %package static
50 Summary:        Mesa static libraries
51 Summary(pl):    Biblioteki statyczne Mesy
52 Group:          Development/Libraries
53 Group(pl):      Programowanie/Biblioteki
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 The static version of the Mesa libraries
58
59 %description -l pl static
60 Biblioteki statyczne Mesy.
61
62 %package glut
63 Summary:        GLUT library for Mesa
64 Summary(pl):    Biblioteka GLUT dla Mesy
65 Group:          X11/Libraries
66 Group(pl):      X11/Biblioteki
67 Requires:       %{name} = %{version}
68 Obsoletes:      glut
69
70 %description glut
71 The GLUT library.
72
73 %description -l pl glut
74 Biblioteka GLUT
75
76 %package glut-devel
77 Summary:        GLUT Development environment for Mesa
78 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
79 Group:          Development/Libraries
80 Group(pl):      Programowanie/Biblioteki
81 Requires:       %{name} = %{version}
82 Obsoletes:      glut-devel
83
84 %description glut-devel
85 Header files needed for development aplications using GLUT library.
86
87 %description -l pl glut-devel
88 Pliki nag³ówkowe do biblioteki GLUT.
89
90 %package glut-static
91 Summary:        GLUT static libraries
92 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
93 Group:          Development/Libraries
94 Group(pl):      Programowanie/Biblioteki
95 Requires:       %{name}-glut-devel = %{version}
96 Obsoletes:      glut-devel
97
98 %description glut-static
99 The static version of the GLUT library.
100
101 %description -l pl glut-static
102 Biblioteki statyczne GLUT.
103
104 %package demos
105 Summary:        Mesa Demos
106 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
107 Group:          Development/Libraries
108 Group(pl):      Programowanie/Biblioteki
109 Requires:       %{name} = %{version}
110
111 %description demos
112 Demonstration programs for the Mesa libraries.
113
114 %description -l pl demos
115 Programy demonstracyjne dla biblioteki Mesa.
116
117 %prep
118 %setup -q -n Mesa-%{version} -b 1
119 %patch -p1
120
121 %build
122 %ifarch alpha
123 make LIBS_ONLY=YES linux-alpha
124 make clean
125 make linux-alpha-elf
126 %endif
127
128 %ifarch ppc
129 make linux-ppc
130 %endif
131
132 %ifarch %{ix86}
133 make clean
134 make LIBS_ONLY=YES linux-386
135 make clean
136 make linux-386-elf
137 %endif
138
139 %ifarch sparc sparc64
140 make  linux-elf
141 %endif
142
143 (cd widgets-mesa; autoconf; \
144 LDFLAGS="-s"; export LDFLAGS
145 %configure \
146         --host=%{_host}
147 make)
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_includedir},%{_mandir}/man3} \
152         $RPM_BUILD_ROOT/usr/src/examples/Mesa
153
154 cp -dpr lib include $RPM_BUILD_ROOT%{_prefix}
155 cp -dpr util $RPM_BUILD_ROOT%{_libdir}/Mesa
156 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
157 install Make-config $RPM_BUILD_ROOT%{_libdir}/Mesa
158
159 (cd widgets-mesa; \
160 make install \
161         prefix=$RPM_BUILD_ROOT/usr/X11R6 \
162         mandir=$RPM_BUILD_ROOT%{_mandir}/man3)
163
164 install */lib*.a $RPM_BUILD_ROOT%{_libdir}
165
166 strip $RPM_BUILD_ROOT%{_libdir}/{lib*so.*.*,Mesa/*/*} || :
167
168 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
169         docs/{IAFA-PACKAGE,README*,RELNOTES,VERSIONS,CONFIG,CONFORM,COPYRIGHT,DEVINFO,*.spec}
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %post   -p /sbin/ldconfig glut
175 %postun -p /sbin/ldconfig glut
176
177 %clean
178 rm -fr $RPM_BUILD_ROOT
179
180 %files
181 %defattr(644,root,root,755)
182 %doc docs/CONFIG.gz
183
184 %ifnarch ppc
185 %attr(755,root,root) %{_libdir}/libGL*.so.*.*
186 %else
187 %{_libdir}/libGL*.a
188 %endif
189
190 %files glut
191 %defattr(644,root,root,755)
192 %ifnarch ppc
193 %attr(755,root,root) %{_libdir}/libglut.so.*
194 %else
195 %{_libdir}/libglut.a
196 %endif
197
198 %files glut-devel
199 %defattr(644,root,root,755)
200 %{_includedir}/GL/glut.h
201 %ifnarch ppc
202 %attr(755,root,root) %{_libdir}/libglut.so
203 %endif
204
205 %ifnarch ppc
206 %files glut-static
207 %defattr(644,root,root,755)
208 %{_libdir}/libglut.a
209 %endif
210
211 %files devel
212 %defattr(644,root,root,755)
213 %doc docs/{IAFA-PACKAGE,README,RELNOTES,VERSIONS,CONFORM,COPYRIGHT,DEVINFO,*.spec}.gz
214 %doc docs/README.{3DFX,GGI,MGL,QUAKE,X11,THREADS}.gz
215
216 %ifnarch ppc
217 %attr(755,root,root) %{_libdir}/libGL*.so
218 %endif
219
220 %dir %{_libdir}/Mesa
221 %{_libdir}/Mesa/Make-config
222 %{_libdir}/Mesa/util
223
224 %dir /usr/X11R6/include/GL
225 %{_includedir}/GL/*.h
226 %{_mandir}/man3/*
227
228 %ifnarch ppc
229 %files static
230 %defattr(644,root,root,755)
231 %endif
232 %{_libdir}/libGL*.a
233
234 %files demos
235 %defattr(644,root,root,755)
236 %dir /usr/src/examples/Mesa/book
237 %dir /usr/src/examples/Mesa/demos
238 %dir /usr/src/examples/Mesa/samples
239 %dir /usr/src/examples/Mesa/xdemos
240
241 %attr(-,root,root)/usr/src/examples/Mesa/book/*
242 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
243 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
244 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
This page took 0.062812 seconds and 4 git commands to generate.