]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR: python (used inf src/gallium/auxiliary/util)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.6
28 Release:        5%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  8c75f90cd0303cfac9e4b6d54f6759ca
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  0ede7adf217951acd90dbe4551210c07
35 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
36 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-sparc64.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  expat-devel
45 %{?with_demos:BuildRequires:    glew-devel}
46 BuildRequires:  libdrm-devel >= 2.4.12-3
47 BuildRequires:  libselinux-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtool >= 2:1.4d
50 %{?with_motif:BuildRequires:    motif-devel}
51 BuildRequires:  pkgconfig
52 BuildRequires:  python
53 BuildRequires:  rpmbuild(macros) >= 1.470
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
57 BuildRequires:  xorg-lib-libXt-devel
58 BuildRequires:  xorg-lib-libXxf86vm-devel
59 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
60 BuildRequires:  xorg-proto-glproto-devel
61 BuildRequires:  xorg-proto-printproto-devel
62 BuildRequires:  xorg-util-makedepend
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %if %{without gallium}
66 %undefine       with_gallium_intel
67 %endif
68
69 %description
70 Mesa is a 3-D graphics library with an API which is very similar to
71 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
72 syntax or state machine, it is being used with authorization from
73 Silicon Graphics, Inc. However, the author does not possess an OpenGL
74 license from SGI, and makes no claim that Mesa is in any way a
75 compatible replacement for OpenGL or associated with SGI.
76
77 %description -l pl.UTF-8
78 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
79 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
80 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
81 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
82 OpenGL ani powiązana z SGI.
83
84 %package libGL
85 Summary:        Free Mesa3D implementation of libGL OpenGL library
86 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
87 License:        MIT
88 Group:          X11/Libraries
89 Requires:       libdrm >= 2.4.5
90 Provides:       OpenGL = 2.1
91 # reports version 1.3, but supports glXGetProcAddress() from 1.4
92 Provides:       OpenGL-GLX = 1.4
93 Obsoletes:      Mesa
94 Obsoletes:      Mesa-dri
95 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
96 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
97
98 %description libGL
99 Mesa is a 3-D graphics library with an API which is very similar to
100 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
101 syntax or state machine, it is being used with authorization from
102 Silicon Graphics, Inc. However, the author does not possess an OpenGL
103 license from SGI, and makes no claim that Mesa is in any way a
104 compatible replacement for OpenGL or associated with SGI.
105
106 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
107 specifications. It uses DRI for rendering.
108
109 %description libGL -l pl.UTF-8
110 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
111 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
112 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
113 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
114 OpenGL ani powiązana z SGI.
115
116 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
117 GLX 1.4. Używa DRI do renderowania.
118
119 %package libGL-devel
120 Summary:        Header files for Mesa3D libGL library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
122 License:        MIT
123 Group:          X11/Development/Libraries
124 # loose dependency on libGL to use with other libGL binaries
125 Requires:       OpenGL >= 1.5
126 Requires:       xorg-lib-libX11-devel
127 Provides:       OpenGL-GLX-devel = 1.4
128 Provides:       OpenGL-devel = 2.1
129 Obsoletes:      Mesa-devel
130 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
131 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
132 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
133 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
134
135 %description libGL-devel
136 Header files for Mesa3D libGL library.
137
138 %description libGL-devel -l pl.UTF-8
139 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
140
141 %package libGL-static
142 Summary:        Static Mesa3D libGL library
143 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
144 License:        MIT
145 Group:          X11/Development/Libraries
146 Requires:       %{name}-libGL-devel = %{version}-%{release}
147 Provides:       OpenGL-static = 2.1
148 Obsoletes:      Mesa-static
149 Obsoletes:      X11-OpenGL-static < 1:7.0.0
150 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
151
152 %description libGL-static
153 Static Mesa3D libGL library. It uses software renderer.
154
155 %description libGL-static -l pl.UTF-8
156 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
157 renderingu.
158
159 %package libGLU
160 Summary:        SGI implementation of libGLU OpenGL library
161 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
162 License:        SGI Free Software License B v2.0 (MIT-like)
163 Group:          Libraries
164 # loose dependency on libGL.so.1 to use with other libGL binaries
165 Requires:       OpenGL >= 1.2
166 Provides:       OpenGL-GLU = 1.3
167 Obsoletes:      Mesa-devel
168 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
169 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
170
171 %description libGLU
172 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
173 1.3 specifications.
174
175 %description libGLU -l pl.UTF-8
176 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
177 specyfikację OpenGL GLU 1.3.
178
179 %package libGLU-devel
180 Summary:        Header files for SGI libGLU library
181 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
182 License:        SGI Free Software License B v2.0 (MIT-like)
183 Group:          Development/Libraries
184 Requires:       %{name}-libGLU = %{version}-%{release}
185 Requires:       OpenGL-devel >= 1.2
186 Requires:       libstdc++-devel
187 Provides:       OpenGL-GLU-devel = 1.3
188
189 %description libGLU-devel
190 Header files for SGI libGLU library.
191
192 %description libGLU-devel -l pl.UTF-8
193 Pliki nagłówkowe biblioteki SGI libGLU.
194
195 %package libGLU-static
196 Summary:        Static SGI libGLU library
197 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
198 License:        SGI Free Software License B v2.0 (MIT-like)
199 Group:          Development/Libraries
200 Requires:       %{name}-libGLU-devel = %{version}-%{release}
201 Provides:       OpenGL-GLU-static = 1.3
202
203 %description libGLU-static
204 Static SGI libGLU library.
205
206 %description libGLU-static -l pl.UTF-8
207 Statyczna biblioteka SGI libGLU.
208
209 %package libGLw
210 Summary:        SGI OpenGL Xt widgets library
211 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
212 License:        SGI MIT-like
213 Group:          Libraries
214 # loose dependency on libGL.so.1 to use with other libGL binaries
215 Requires:       OpenGL >= 1.1
216 Provides:       OpenGL-GLw
217
218 %description libGLw
219 SGI OpenGL Xt widgets library.
220
221 %description libGLU -l pl.UTF-8
222 Biblioteka SGI widgetów Xt dla OpenGL-a.
223
224 %package libGLw-devel
225 Summary:        Header files for SGI libGLw library
226 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
227 License:        SGI MIT-like
228 Group:          Development/Libraries
229 Requires:       %{name}-libGLw = %{version}-%{release}
230 Requires:       OpenGL-devel >= 1.2
231 Provides:       OpenGL-GLw-devel
232
233 %description libGLw-devel
234 Header files for SGI libGLw library.
235
236 %description libGLw-devel -l pl.UTF-8
237 Pliki nagłówkowe biblioteki SGI libGLw.
238
239 %package libGLw-static
240 Summary:        Static SGI libGLw library
241 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
242 License:        SGI MIT-like
243 Group:          Development/Libraries
244 Requires:       %{name}-libGLw-devel = %{version}-%{release}
245 Provides:       OpenGL-GLw-static
246
247 %description libGLw-static
248 Static SGI libGLw library.
249
250 %description libGLw-static -l pl.UTF-8
251 Statyczna biblioteka SGI libGLw.
252
253 %package libOSMesa
254 Summary:        OSMesa (off-screen renderer) library
255 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
256 License:        MIT
257 Group:          Libraries
258 # doesn't require base
259
260 %description libOSMesa
261 OSMesa (off-screen renderer) library.
262
263 %description libOSMesa -l pl.UTF-8
264 Biblioteka OSMesa (renderująca bitmapy w pamięci).
265
266 %package libOSMesa-devel
267 Summary:        Header file for OSMesa (off-screen renderer) library
268 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
269 License:        MIT
270 Group:          Development/Libraries
271 Requires:       %{name}-libOSMesa = %{version}-%{release}
272 # for <GL/gl.h> only
273 Requires:       OpenGL-devel
274
275 %description libOSMesa-devel
276 Header file for OSMesa (off-screen renderer) library.
277
278 %description libOSMesa-devel -l pl.UTF-8
279 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
280
281 %package libOSMesa-static
282 Summary:        Static OSMesa (off-screen renderer) library
283 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
284 License:        MIT
285 Group:          Development/Libraries
286 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
287 # this static build of OSMesa needs static non-dri Mesa implementation
288 Requires:       %{name}-libGL-static = %{version}-%{release}
289
290 %description libOSMesa-static
291 Static OSMesa (off-screen renderer) library.
292
293 %description libOSMesa-static -l pl.UTF-8
294 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
295
296 %package utils
297 Summary:        OpenGL utilities from Mesa3D
298 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
299 License:        MIT
300 Group:          X11/Applications/Graphics
301 # loose deps on libGL/libGLU
302
303 %description utils
304 OpenGL utilities from Mesa3D: glxgears and glxinfo.
305
306 %description utils -l pl.UTF-8
307 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
308
309 %package demos
310 Summary:        Mesa Demos source code
311 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
312 License:        various (MIT, SGI, GPL - see copyright notes in sources)
313 Group:          Development/Libraries
314 Requires:       OpenGL-devel
315
316 %description demos
317 Demonstration programs for the Mesa libraries in source code form.
318
319 %description demos -l pl.UTF-8
320 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
321
322 %package dri-driver-ati-mach64
323 Summary:        X.org DRI driver for ATI Mach64 card family
324 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
325 License:        MIT
326 Group:          X11/Libraries
327 Requires:       xorg-driver-video-mach64
328 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
329 Requires:       xorg-xserver-server >= %{xserver_ver}
330
331 %description dri-driver-ati-mach64
332 X.org DRI driver for ATI Mach64 card family.
333
334 %description dri-driver-ati-mach64 -l pl.UTF-8
335 Sterownik X.org DRI dla rodziny kart ATI Mach64.
336
337 %package dri-driver-ati-radeon-R100
338 Summary:        X.org DRI driver for ATI R100 card family
339 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
340 License:        MIT
341 Group:          X11/Libraries
342 Requires:       xorg-driver-video-ati
343 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
344 Requires:       xorg-xserver-server >= %{xserver_ver}
345 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
346
347 %description dri-driver-ati-radeon-R100
348 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
349
350 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
351 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
352
353 %package dri-driver-ati-radeon-R200
354 Summary:        X.org DRI driver for ATI R200 card family
355 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
356 License:        MIT
357 Group:          X11/Libraries
358 Requires:       xorg-driver-video-ati
359 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
360 Requires:       xorg-xserver-server >= %{xserver_ver}
361 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
362
363 %description dri-driver-ati-radeon-R200
364 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
365
366 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
367 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
368
369 %package dri-driver-ati-radeon-R300
370 Summary:        X.org DRI driver for ATI R300 card family
371 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
372 License:        MIT
373 Group:          X11/Libraries
374 Requires:       xorg-driver-video-ati
375 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
376 Requires:       xorg-xserver-server >= %{xserver_ver}
377 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
378
379 %description dri-driver-ati-radeon-R300
380 X.org DRI driver for ATI R300 card family.
381
382 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
383 Sterownik X.org DRI dla rodziny kart ATI R300.
384
385 %package dri-driver-ati-rage128
386 Summary:        X.org DRI driver for ATI Rage128 card family
387 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
388 License:        MIT
389 Group:          X11/Libraries
390 Requires:       xorg-driver-video-r128
391 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
392 Requires:       xorg-xserver-server >= %{xserver_ver}
393 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
394
395 %description dri-driver-ati-rage128
396 X.org DRI driver for ATI Rage128 card family.
397
398 %description dri-driver-ati-rage128 -l pl.UTF-8
399 Sterownik X.org DRI dla rodziny kart ATI Rage128.
400
401 %package dri-driver-ffb
402 Summary:        X.org DRI driver for Sun FFB card family
403 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
404 License:        MIT
405 Group:          X11/Libraries
406 Requires:       xorg-driver-video-sunffb
407 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
408 Requires:       xorg-xserver-server >= %{xserver_ver}
409
410 %description dri-driver-ffb
411 X.org DRI driver for SUN Creator3D and Elite3D card family.
412
413 %description dri-driver-ffb -l pl.UTF-8
414 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
415
416 %package dri-driver-glint
417 Summary:        X.org DRI driver for GLINT/Permedia card family
418 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
419 License:        MIT
420 Group:          X11/Libraries
421 Requires:       xorg-driver-video-glint
422 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
423 Requires:       xorg-xserver-server >= %{xserver_ver}
424 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
425
426 %description dri-driver-glint
427 X.org DRI driver for GLINT/Permedia card family.
428
429 %description dri-driver-glint -l pl.UTF-8
430 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
431
432 %package dri-driver-intel-i810
433 Summary:        X.org DRI driver for Intel i810 card family
434 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
435 License:        MIT
436 Group:          X11/Libraries
437 Requires:       xorg-driver-video-intel
438 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
439 Requires:       xorg-xserver-server >= %{xserver_ver}
440 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
441
442 %description dri-driver-intel-i810
443 X.org DRI driver for Intel i810 card family.
444
445 %description dri-driver-intel-i810 -l pl.UTF-8
446 Sterownik X.org DRI dla rodziny kart Intel i810.
447
448 %package dri-driver-intel-i915
449 Summary:        X.org DRI driver for Intel i915 card family
450 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
451 License:        MIT
452 Group:          X11/Libraries
453 Requires:       xorg-driver-video-intel
454 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
455 Requires:       xorg-xserver-server >= %{xserver_ver}
456 Obsoletes:      Mesa-dri-driver-intel-i830
457 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
458
459 %description dri-driver-intel-i915
460 X.org DRI driver for Intel i915 card family.
461
462 %description dri-driver-intel-i915 -l pl.UTF-8
463 Sterownik X.org DRI dla rodziny kart Intel i915.
464
465 %package dri-driver-intel-i965
466 Summary:        X.org DRI driver for Intel i965 card family
467 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
468 License:        MIT
469 Group:          X11/Libraries
470 Requires:       xorg-driver-video-intel
471 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
472 Requires:       xorg-xserver-server >= %{xserver_ver}
473 Obsoletes:      Mesa-dri-driver-intel-i830
474 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
475
476 %description dri-driver-intel-i965
477 X.org DRI driver for Intel i965 card family.
478
479 %description dri-driver-intel-i965 -l pl.UTF-8
480 Sterownik X.org DRI dla rodziny kart Intel i965.
481
482 %package dri-driver-matrox
483 Summary:        X.org DRI driver for Matrox G card family
484 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
485 License:        MIT
486 Group:          X11/Libraries
487 Requires:       xorg-driver-video-mga
488 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
489 Requires:       xorg-xserver-server >= %{xserver_ver}
490 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
491
492 %description dri-driver-matrox
493 X.org DRI drivers for Matrox G card family.
494
495 %description dri-driver-matrox -l pl.UTF-8
496 Sterowniki X.org DRI dla rodziny kart Matrox G.
497
498 %package dri-driver-nouveau
499 Summary:        X.org DRI driver for NVIDIA card family
500 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
501 License:        MIT
502 Group:          X11/Libraries
503 Requires:       xorg-driver-video-nouveau
504 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
505 Requires:       xorg-xserver-server >= %{xserver_ver}
506
507 %description dri-driver-nouveau
508 X.org DRI drivers for NVIDIA card family.
509
510 %description dri-driver-nouveau -l pl.UTF-8
511 Sterowniki X.org DRI dla rodziny kart NVIDIA.
512
513 %package dri-driver-s3virge
514 Summary:        X.org DRI driver for S3 Virge card family
515 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
516 License:        MIT
517 Group:          X11/Libraries
518 Requires:       xorg-driver-video-s3virge
519 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
520 Requires:       xorg-xserver-server >= %{xserver_ver}
521
522 %description dri-driver-s3virge
523 X.org DRI driver for S3 Virge card family.
524
525 %description dri-driver-s3virge -l pl.UTF-8
526 Sterownik X.org DRI dla rodziny kart S3 Virge.
527
528 %package dri-driver-savage
529 Summary:        X.org DRI driver for S3 Savage card family
530 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
531 License:        MIT
532 Group:          X11/Libraries
533 Requires:       xorg-driver-video-savage
534 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
535 Requires:       xorg-xserver-server >= %{xserver_ver}
536
537 %description dri-driver-savage
538 X.org DRI driver for S3 Savage card family.
539
540 %description dri-driver-savage -l pl.UTF-8
541 Sterownik X.org DRI dla rodziny kart S3 Savage.
542
543 %package dri-driver-sis
544 Summary:        X.org DRI driver for SiS card family
545 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
546 License:        MIT
547 Group:          X11/Libraries
548 Requires:       xorg-driver-video-sis
549 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
550 Requires:       xorg-xserver-server >= %{xserver_ver}
551 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
552
553 %description dri-driver-sis
554 X.org DRI driver for SiS card family.
555
556 %description dri-driver-sis -l pl.UTF-8
557 Sterownik X.org DRI dla rodziny kart SiS.
558
559 %package dri-driver-swrast
560 Summary:        X.org DRI software rasterizer driver
561 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
562 License:        MIT
563 Group:          X11/Libraries
564 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
565 Requires:       xorg-xserver-server >= %{xserver_ver}
566
567 %description dri-driver-swrast
568 X.org DRI software rasterizer driver.
569
570 %description dri-driver-swrast -l pl.UTF-8
571 Sterownik X.org DRI obsługujący rysowanie programowe.
572
573 %package dri-driver-tdfx
574 Summary:        X.org DRI driver for 3DFX Voodoo card family
575 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
576 License:        MIT
577 Group:          X11/Libraries
578 Requires:       Glide3-DRI
579 Requires:       xorg-driver-video-tdfx
580 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
581 Requires:       xorg-xserver-server >= %{xserver_ver}
582 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
583
584 %description dri-driver-tdfx
585 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
586 and Velocity 100/200).
587
588 %description dri-driver-tdfx -l pl.UTF-8
589 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
590 Banshee i Velocity 100/200).
591
592 %package dri-driver-trident
593 Summary:        X.org DRI driver for Trident card family
594 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
595 License:        MIT
596 Group:          X11/Libraries
597 Requires:       xorg-driver-video-trident
598 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
599 Requires:       xorg-xserver-server >= %{xserver_ver}
600
601 %description dri-driver-trident
602 X.org DRI drivers for Trident card family.
603
604 %description dri-driver-trident -l pl.UTF-8
605 Sterowniki X.org DRI dla rodziny kart Trident.
606
607 %package dri-driver-via-unichrome
608 Summary:        X.org DRI driver for VIA Unichrome card family
609 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
610 License:        MIT
611 Group:          X11/Libraries
612 Requires:       xorg-driver-video-openchrome
613 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
614 Requires:       xorg-xserver-server >= %{xserver_ver}
615
616 %description dri-driver-via-unichrome
617 X.org DRI driver for VIA Unichrome card family.
618
619 %description dri-driver-via-unichrome -l pl.UTF-8
620 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
621
622 %prep
623 %setup -q -b1 -a2
624 %patch0 -p0
625 %patch1 -p1
626 %patch2 -p1
627
628 # fix demos
629 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
630
631 %build
632 %{__aclocal}
633 %{__autoconf}
634
635 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
636 %if %{without gallium_intel}
637 i915 \
638 %endif
639 %ifarch sparc sparcv9 sparc64
640 ffb \
641 %endif
642 %ifarch %{ix86} %{x8664}
643 sis \
644 %endif
645 swrast tdfx unichrome"
646
647 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
648
649 common_flags="\
650         --enable-shared \
651         --enable-selinux \
652         --enable-pic \
653         --enable-glx-tls \
654         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
655         --with%{!?with_demos:out}-demos"
656
657 %if %{with osmesa}
658 # osmesa variants
659 %configure $common_flags \
660         --with-driver=osmesa \
661         --disable-asm \
662         --with-osmesa-bits=8
663 %{__make} \
664         SRC_DIRS=mesa
665 mv %{_lib} osmesa8
666 %{__make} clean
667
668 %configure $common_flags \
669         --with-driver=osmesa \
670         --disable-asm \
671         --with-osmesa-bits=16
672 %{__make} \
673         SRC_DIRS=mesa
674 mv %{_lib} osmesa16
675 %{__make} clean
676
677 %configure $common_flags \
678         --with-driver=osmesa \
679         --disable-asm \
680         --with-osmesa-bits=32
681 %{__make} \
682         SRC_DIRS=mesa
683 mv %{_lib} osmesa32
684 %{__make} clean
685 %endif
686
687 %configure $common_flags \
688         --enable-glu \
689         --enable-glw \
690         --disable-glut \
691 %if %{with gallium}
692         --enable-gallium \
693         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
694         --enable-gallium-nouveau \
695         --with-state-trackers=dri \
696 %else
697         --disable-gallium \
698 %endif
699         --with-driver=dri \
700         --with-dri-drivers=${dri_drivers} \
701         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
702
703 %{__make}
704 %{__make} -C progs/xdemos glxgears glxinfo
705 %if %{with demos}
706 %{__make} -C progs/demos
707 %endif
708
709 cd gl-manpages-*
710 %configure
711 %{__make}
712
713 %install
714 rm -rf $RPM_BUILD_ROOT
715
716 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
717
718 # libs without drivers
719 %{__make} install \
720         DESTDIR=$RPM_BUILD_ROOT
721
722 cd gl-manpages-*
723 %{__make} install \
724         DESTDIR=$RPM_BUILD_ROOT
725 cd ..
726
727 %if %{with osmesa}
728 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
729 %endif
730
731 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
732 # work on copy to keep -bi --short-circuit working
733 rm -rf progs-clean
734 install -d progs-clean
735 for l in demos glsl osdemos redbook samples xdemos ; do
736         cp -a progs/$l progs-clean/$l
737         %{__make} -C progs-clean/$l clean
738         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
739 done
740 rm -rf progs-clean
741 for l in util images ; do
742         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
743 done
744 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
745
746 # strip out undesirable headers
747 olddir=$(pwd)
748 cd $RPM_BUILD_ROOT%{_includedir}/GL
749 rm [a-fh-np-wyz]*.h gg*.h glf*.h
750 cd $RPM_BUILD_ROOT%{_libdir}
751 cd $olddir
752
753 %if %{with multigl}
754 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
755
756 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
757 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
758
759 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
760 %endif
761
762 %clean
763 rm -rf $RPM_BUILD_ROOT
764
765 %post   libGL -p /sbin/ldconfig
766 %postun libGL -p /sbin/ldconfig
767
768 %post   libGLU -p /sbin/ldconfig
769 %postun libGLU -p /sbin/ldconfig
770
771 %post   libGLw -p /sbin/ldconfig
772 %postun libGLw -p /sbin/ldconfig
773
774 %files libGL
775 %defattr(644,root,root,755)
776 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
777 %if %{with multigl}
778 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
779 %dir %{_libdir}/Mesa
780 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
781 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
782 %else
783 %attr(755,root,root) %{_libdir}/libGL.so.*.*
784 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
785 # symlink for binary apps which fail to conform Linux OpenGL ABI
786 # (and dlopen libGL.so instead of libGL.so.1)
787 %attr(755,root,root) %{_libdir}/libGL.so
788 %endif
789
790 %files libGL-devel
791 %defattr(644,root,root,755)
792 %doc docs/*.spec
793 %if %{with multigl}
794 %attr(755,root,root) %{_libdir}/libGL.so
795 %endif
796 %dir %{_includedir}/GL
797 %{_includedir}/GL/gl.h
798 %{_includedir}/GL/glext.h
799 %{_includedir}/GL/gl_mangle.h
800 %{_includedir}/GL/glx.h
801 %{_includedir}/GL/glxext.h
802 %{_includedir}/GL/glx_mangle.h
803 %dir %{_includedir}/GL/internal
804 %{_includedir}/GL/internal/dri_interface.h
805 %{_pkgconfigdir}/dri.pc
806 %{_pkgconfigdir}/gl.pc
807 %{_mandir}/man3/gl[^uX]*.3gl*
808 %{_mandir}/man3/glX*.3gl*
809
810 %if %{with static}
811 %files libGL-static
812 %defattr(644,root,root,755)
813 %{_libdir}/libGL.a
814 %endif
815
816 %files libGLU
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
819 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
820
821 %files libGLU-devel
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libGLU.so
824 %{_includedir}/GL/glu.h
825 %{_includedir}/GL/glu_mangle.h
826 %{_pkgconfigdir}/glu.pc
827 %{_mandir}/man3/glu*.3gl*
828
829 %if %{with static}
830 %files libGLU-static
831 %defattr(644,root,root,755)
832 %{_libdir}/libGLU.a
833 %endif
834
835 %files libGLw
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
838 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
839
840 %files libGLw-devel
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/libGLw.so
843 %{_includedir}/GL/GLwDrawA.h
844 %{_includedir}/GL/GLwDrawAP.h
845 %{_includedir}/GL/GLwMDrawA.h
846 %{_includedir}/GL/GLwMDrawAP.h
847 %{_pkgconfigdir}/glw.pc
848
849 %if %{with static}
850 %files libGLw-static
851 %defattr(644,root,root,755)
852 %{_libdir}/libGLw.a
853 %endif
854
855 %if %{with osmesa}
856 %files libOSMesa
857 %defattr(644,root,root,755)
858 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
859 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
860
861 %files libOSMesa-devel
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/libOSMesa*.so
864 %{_includedir}/GL/osmesa.h
865
866 %if %{with static}
867 %files libOSMesa-static
868 %defattr(644,root,root,755)
869 %{_libdir}/libOSMesa*.a
870 %endif
871 %endif
872
873 %files utils
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_bindir}/glxgears
876 %attr(755,root,root) %{_bindir}/glxinfo
877
878 %files dri-driver-ati-mach64
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
881
882 %files dri-driver-ati-radeon-R100
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
885
886 %files dri-driver-ati-radeon-R200
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
889
890 %files dri-driver-ati-radeon-R300
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
893
894 %files dri-driver-ati-rage128
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
897
898 # sunffb (sparc only)
899 %ifarch sparc sparcv9 sparc64
900 %files dri-driver-ffb
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
903 %endif
904
905 # glint (requires update)
906 %if 0
907 %files dri-driver-glint
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
910 %endif
911
912 %files dri-driver-intel-i810
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
915
916 %files dri-driver-intel-i915
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
919
920 %files dri-driver-intel-i965
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
923
924 %files dri-driver-matrox
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
927
928 %if %{with gallium}
929 %files dri-driver-nouveau
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
932 %endif
933
934 %files dri-driver-s3virge
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
937
938 %files dri-driver-savage
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
941
942 %ifarch %{ix86} %{x8664}
943 %files dri-driver-sis
944 %defattr(644,root,root,755)
945 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
946 %endif
947
948 %files dri-driver-swrast
949 %defattr(644,root,root,755)
950 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
951
952 %files dri-driver-tdfx
953 %defattr(644,root,root,755)
954 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
955
956 %files dri-driver-trident
957 %defattr(644,root,root,755)
958 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
959
960 %files dri-driver-via-unichrome
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
963
964 %if %{with demos}
965 %files demos
966 %defattr(644,root,root,755)
967 %{_examplesdir}/%{name}-%{version}
968 %endif
This page took 0.143159 seconds and 4 git commands to generate.