]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR recent libdrm due to some nouveau defines
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.7
28 Release:        1%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  e3fa64a1508bc23dd9de9dd2cea7cfb1
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  6fd616b27b9826d0faa23e08e05d9435
35 Patch0:         %{name}-realclean.patch
36 Patch1:         %{name}-tgsi_dump.patch
37 URL:            http://www.mesa3d.org/
38 %{?with_demos:BuildRequires:    OpenGL-glut-devel >= 3.8}
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  expat-devel
42 %{?with_demos:BuildRequires:    glew-devel}
43 BuildRequires:  libdrm-devel >= 2.4.18
44 BuildRequires:  libselinux-devel
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool >= 2:1.4d
47 %{?with_motif:BuildRequires:    motif-devel}
48 BuildRequires:  pkgconfig
49 BuildRequires:  python
50 BuildRequires:  rpmbuild(macros) >= 1.470
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  xorg-lib-libXdamage-devel
53 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
54 BuildRequires:  xorg-lib-libXt-devel
55 BuildRequires:  xorg-lib-libXxf86vm-devel
56 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
57 BuildRequires:  xorg-proto-glproto-devel
58 BuildRequires:  xorg-proto-printproto-devel
59 BuildRequires:  xorg-util-makedepend
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %if %{without gallium}
63 %undefine       with_gallium_intel
64 %endif
65
66 %description
67 Mesa is a 3-D graphics library with an API which is very similar to
68 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
69 syntax or state machine, it is being used with authorization from
70 Silicon Graphics, Inc. However, the author does not possess an OpenGL
71 license from SGI, and makes no claim that Mesa is in any way a
72 compatible replacement for OpenGL or associated with SGI.
73
74 %description -l pl.UTF-8
75 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
76 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
77 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
78 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
79 OpenGL ani powiązana z SGI.
80
81 %package libGL
82 Summary:        Free Mesa3D implementation of libGL OpenGL library
83 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
84 License:        MIT
85 Group:          X11/Libraries
86 Requires:       libdrm >= 2.4.5
87 Provides:       OpenGL = 2.1
88 # reports version 1.3, but supports glXGetProcAddress() from 1.4
89 Provides:       OpenGL-GLX = 1.4
90 Obsoletes:      Mesa
91 Obsoletes:      Mesa-dri
92 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
93 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
94
95 %description libGL
96 Mesa is a 3-D graphics library with an API which is very similar to
97 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
98 syntax or state machine, it is being used with authorization from
99 Silicon Graphics, Inc. However, the author does not possess an OpenGL
100 license from SGI, and makes no claim that Mesa is in any way a
101 compatible replacement for OpenGL or associated with SGI.
102
103 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
104 specifications. It uses DRI for rendering.
105
106 %description libGL -l pl.UTF-8
107 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
108 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
109 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
110 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
111 OpenGL ani powiązana z SGI.
112
113 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
114 GLX 1.4. Używa DRI do renderowania.
115
116 %package libGL-devel
117 Summary:        Header files for Mesa3D libGL library
118 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
119 License:        MIT
120 Group:          X11/Development/Libraries
121 # loose dependency on libGL to use with other libGL binaries
122 Requires:       OpenGL >= 1.5
123 Requires:       xorg-lib-libX11-devel
124 Suggests:       OpenGL-doc-man
125 Provides:       OpenGL-GLX-devel = 1.4
126 Provides:       OpenGL-devel = 2.1
127 Obsoletes:      Mesa-devel
128 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
129 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
130 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
131 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
132
133 %description libGL-devel
134 Header files for Mesa3D libGL library.
135
136 %description libGL-devel -l pl.UTF-8
137 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
138
139 %package libGL-static
140 Summary:        Static Mesa3D libGL library
141 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
142 License:        MIT
143 Group:          X11/Development/Libraries
144 Requires:       %{name}-libGL-devel = %{version}-%{release}
145 Provides:       OpenGL-static = 2.1
146 Obsoletes:      Mesa-static
147 Obsoletes:      X11-OpenGL-static < 1:7.0.0
148 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
149
150 %description libGL-static
151 Static Mesa3D libGL library. It uses software renderer.
152
153 %description libGL-static -l pl.UTF-8
154 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
155 renderingu.
156
157 %package libGLU
158 Summary:        SGI implementation of libGLU OpenGL library
159 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
160 License:        SGI Free Software License B v2.0 (MIT-like)
161 Group:          Libraries
162 # loose dependency on libGL.so.1 to use with other libGL binaries
163 Requires:       OpenGL >= 1.2
164 Provides:       OpenGL-GLU = 1.3
165 Obsoletes:      Mesa-devel
166 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
167 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
168
169 %description libGLU
170 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
171 1.3 specifications.
172
173 %description libGLU -l pl.UTF-8
174 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
175 specyfikację OpenGL GLU 1.3.
176
177 %package libGLU-devel
178 Summary:        Header files for SGI libGLU library
179 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
180 License:        SGI Free Software License B v2.0 (MIT-like)
181 Group:          Development/Libraries
182 Requires:       %{name}-libGLU = %{version}-%{release}
183 Requires:       OpenGL-devel >= 1.2
184 Requires:       libstdc++-devel
185 Provides:       OpenGL-GLU-devel = 1.3
186
187 %description libGLU-devel
188 Header files for SGI libGLU library.
189
190 %description libGLU-devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki SGI libGLU.
192
193 %package libGLU-static
194 Summary:        Static SGI libGLU library
195 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
196 License:        SGI Free Software License B v2.0 (MIT-like)
197 Group:          Development/Libraries
198 Requires:       %{name}-libGLU-devel = %{version}-%{release}
199 Provides:       OpenGL-GLU-static = 1.3
200
201 %description libGLU-static
202 Static SGI libGLU library.
203
204 %description libGLU-static -l pl.UTF-8
205 Statyczna biblioteka SGI libGLU.
206
207 %package libGLw
208 Summary:        SGI OpenGL Xt widgets library
209 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
210 License:        SGI MIT-like
211 Group:          Libraries
212 # loose dependency on libGL.so.1 to use with other libGL binaries
213 Requires:       OpenGL >= 1.1
214 Provides:       OpenGL-GLw
215
216 %description libGLw
217 SGI OpenGL Xt widgets library.
218
219 %description libGLU -l pl.UTF-8
220 Biblioteka SGI widgetów Xt dla OpenGL-a.
221
222 %package libGLw-devel
223 Summary:        Header files for SGI libGLw library
224 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
225 License:        SGI MIT-like
226 Group:          Development/Libraries
227 Requires:       %{name}-libGLw = %{version}-%{release}
228 Requires:       OpenGL-devel >= 1.2
229 Provides:       OpenGL-GLw-devel
230
231 %description libGLw-devel
232 Header files for SGI libGLw library.
233
234 %description libGLw-devel -l pl.UTF-8
235 Pliki nagłówkowe biblioteki SGI libGLw.
236
237 %package libGLw-static
238 Summary:        Static SGI libGLw library
239 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
240 License:        SGI MIT-like
241 Group:          Development/Libraries
242 Requires:       %{name}-libGLw-devel = %{version}-%{release}
243 Provides:       OpenGL-GLw-static
244
245 %description libGLw-static
246 Static SGI libGLw library.
247
248 %description libGLw-static -l pl.UTF-8
249 Statyczna biblioteka SGI libGLw.
250
251 %package libOSMesa
252 Summary:        OSMesa (off-screen renderer) library
253 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
254 License:        MIT
255 Group:          Libraries
256 # doesn't require base
257
258 %description libOSMesa
259 OSMesa (off-screen renderer) library.
260
261 %description libOSMesa -l pl.UTF-8
262 Biblioteka OSMesa (renderująca bitmapy w pamięci).
263
264 %package libOSMesa-devel
265 Summary:        Header file for OSMesa (off-screen renderer) library
266 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
267 License:        MIT
268 Group:          Development/Libraries
269 Requires:       %{name}-libOSMesa = %{version}-%{release}
270 # for <GL/gl.h> only
271 Requires:       OpenGL-devel
272
273 %description libOSMesa-devel
274 Header file for OSMesa (off-screen renderer) library.
275
276 %description libOSMesa-devel -l pl.UTF-8
277 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
278
279 %package libOSMesa-static
280 Summary:        Static OSMesa (off-screen renderer) library
281 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
282 License:        MIT
283 Group:          Development/Libraries
284 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
285 # this static build of OSMesa needs static non-dri Mesa implementation
286 Requires:       %{name}-libGL-static = %{version}-%{release}
287
288 %description libOSMesa-static
289 Static OSMesa (off-screen renderer) library.
290
291 %description libOSMesa-static -l pl.UTF-8
292 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
293
294 %package utils
295 Summary:        OpenGL utilities from Mesa3D
296 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
297 License:        MIT
298 Group:          X11/Applications/Graphics
299 # loose deps on libGL/libGLU
300
301 %description utils
302 OpenGL utilities from Mesa3D: glxgears and glxinfo.
303
304 %description utils -l pl.UTF-8
305 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
306
307 %package demos
308 Summary:        Mesa Demos source code
309 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
310 License:        various (MIT, SGI, GPL - see copyright notes in sources)
311 Group:          Development/Libraries
312 Requires:       OpenGL-devel
313
314 %description demos
315 Demonstration programs for the Mesa libraries in source code form.
316
317 %description demos -l pl.UTF-8
318 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
319
320 %package dri-driver-ati-mach64
321 Summary:        X.org DRI driver for ATI Mach64 card family
322 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
323 License:        MIT
324 Group:          X11/Libraries
325 Requires:       xorg-driver-video-mach64
326 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
327 Requires:       xorg-xserver-server >= %{xserver_ver}
328
329 %description dri-driver-ati-mach64
330 X.org DRI driver for ATI Mach64 card family.
331
332 %description dri-driver-ati-mach64 -l pl.UTF-8
333 Sterownik X.org DRI dla rodziny kart ATI Mach64.
334
335 %package dri-driver-ati-radeon-R100
336 Summary:        X.org DRI driver for ATI R100 card family
337 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
338 License:        MIT
339 Group:          X11/Libraries
340 Requires:       xorg-driver-video-ati
341 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
342 Requires:       xorg-xserver-server >= %{xserver_ver}
343 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
344
345 %description dri-driver-ati-radeon-R100
346 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
347
348 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
349 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
350
351 %package dri-driver-ati-radeon-R200
352 Summary:        X.org DRI driver for ATI R200 card family
353 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
354 License:        MIT
355 Group:          X11/Libraries
356 Requires:       xorg-driver-video-ati
357 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
358 Requires:       xorg-xserver-server >= %{xserver_ver}
359 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
360
361 %description dri-driver-ati-radeon-R200
362 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
363
364 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
365 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
366
367 %package dri-driver-ati-radeon-R300
368 Summary:        X.org DRI driver for ATI R300 card family
369 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
370 License:        MIT
371 Group:          X11/Libraries
372 Requires:       xorg-driver-video-ati
373 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
374 Requires:       xorg-xserver-server >= %{xserver_ver}
375 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
376
377 %description dri-driver-ati-radeon-R300
378 X.org DRI driver for ATI R300 card family.
379
380 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
381 Sterownik X.org DRI dla rodziny kart ATI R300.
382
383 %package dri-driver-ati-radeon-R600
384 Summary:        X.org DRI driver for ATI R600 card family
385 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
386 License:        MIT
387 Group:          X11/Libraries
388 Requires:       radeon-ucode
389 Requires:       xorg-driver-video-ati
390 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
391 Requires:       xorg-xserver-server >= %{xserver_ver}
392
393 %description dri-driver-ati-radeon-R600
394 X.org DRI driver for ATI R600 card family.
395
396 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
397 Sterownik X.org DRI dla rodziny kart ATI R600.
398
399 %package dri-driver-ati-rage128
400 Summary:        X.org DRI driver for ATI Rage128 card family
401 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
402 License:        MIT
403 Group:          X11/Libraries
404 Requires:       xorg-driver-video-r128
405 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
406 Requires:       xorg-xserver-server >= %{xserver_ver}
407 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
408
409 %description dri-driver-ati-rage128
410 X.org DRI driver for ATI Rage128 card family.
411
412 %description dri-driver-ati-rage128 -l pl.UTF-8
413 Sterownik X.org DRI dla rodziny kart ATI Rage128.
414
415 %package dri-driver-ffb
416 Summary:        X.org DRI driver for Sun FFB card family
417 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
418 License:        MIT
419 Group:          X11/Libraries
420 Requires:       xorg-driver-video-sunffb
421 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
422 Requires:       xorg-xserver-server >= %{xserver_ver}
423
424 %description dri-driver-ffb
425 X.org DRI driver for SUN Creator3D and Elite3D card family.
426
427 %description dri-driver-ffb -l pl.UTF-8
428 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
429
430 %package dri-driver-glint
431 Summary:        X.org DRI driver for GLINT/Permedia card family
432 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
433 License:        MIT
434 Group:          X11/Libraries
435 Requires:       xorg-driver-video-glint
436 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
437 Requires:       xorg-xserver-server >= %{xserver_ver}
438 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
439
440 %description dri-driver-glint
441 X.org DRI driver for GLINT/Permedia card family.
442
443 %description dri-driver-glint -l pl.UTF-8
444 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
445
446 %package dri-driver-intel-i810
447 Summary:        X.org DRI driver for Intel i810 card family
448 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
449 License:        MIT
450 Group:          X11/Libraries
451 Requires:       xorg-driver-video-intel
452 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
453 Requires:       xorg-xserver-server >= %{xserver_ver}
454 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
455
456 %description dri-driver-intel-i810
457 X.org DRI driver for Intel i810 card family.
458
459 %description dri-driver-intel-i810 -l pl.UTF-8
460 Sterownik X.org DRI dla rodziny kart Intel i810.
461
462 %package dri-driver-intel-i915
463 Summary:        X.org DRI driver for Intel i915 card family
464 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
465 License:        MIT
466 Group:          X11/Libraries
467 Requires:       xorg-driver-video-intel
468 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
469 Requires:       xorg-xserver-server >= %{xserver_ver}
470 Obsoletes:      Mesa-dri-driver-intel-i830
471 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
472
473 %description dri-driver-intel-i915
474 X.org DRI driver for Intel i915 card family.
475
476 %description dri-driver-intel-i915 -l pl.UTF-8
477 Sterownik X.org DRI dla rodziny kart Intel i915.
478
479 %package dri-driver-intel-i965
480 Summary:        X.org DRI driver for Intel i965 card family
481 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
482 License:        MIT
483 Group:          X11/Libraries
484 Requires:       xorg-driver-video-intel
485 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
486 Requires:       xorg-xserver-server >= %{xserver_ver}
487 Obsoletes:      Mesa-dri-driver-intel-i830
488 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
489
490 %description dri-driver-intel-i965
491 X.org DRI driver for Intel i965 card family.
492
493 %description dri-driver-intel-i965 -l pl.UTF-8
494 Sterownik X.org DRI dla rodziny kart Intel i965.
495
496 %package dri-driver-matrox
497 Summary:        X.org DRI driver for Matrox G card family
498 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
499 License:        MIT
500 Group:          X11/Libraries
501 Requires:       xorg-driver-video-mga
502 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
503 Requires:       xorg-xserver-server >= %{xserver_ver}
504 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
505
506 %description dri-driver-matrox
507 X.org DRI drivers for Matrox G card family.
508
509 %description dri-driver-matrox -l pl.UTF-8
510 Sterowniki X.org DRI dla rodziny kart Matrox G.
511
512 %package dri-driver-nouveau
513 Summary:        X.org DRI driver for NVIDIA card family
514 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
515 License:        MIT
516 Group:          X11/Libraries
517 Requires:       xorg-driver-video-nouveau
518 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
519 Requires:       xorg-xserver-server >= %{xserver_ver}
520
521 %description dri-driver-nouveau
522 X.org DRI drivers for NVIDIA card family.
523
524 %description dri-driver-nouveau -l pl.UTF-8
525 Sterowniki X.org DRI dla rodziny kart NVIDIA.
526
527 %package dri-driver-savage
528 Summary:        X.org DRI driver for S3 Savage card family
529 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
530 License:        MIT
531 Group:          X11/Libraries
532 Requires:       xorg-driver-video-savage
533 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
534 Requires:       xorg-xserver-server >= %{xserver_ver}
535
536 %description dri-driver-savage
537 X.org DRI driver for S3 Savage card family.
538
539 %description dri-driver-savage -l pl.UTF-8
540 Sterownik X.org DRI dla rodziny kart S3 Savage.
541
542 %package dri-driver-sis
543 Summary:        X.org DRI driver for SiS card family
544 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       xorg-driver-video-sis
548 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
549 Requires:       xorg-xserver-server >= %{xserver_ver}
550 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
551
552 %description dri-driver-sis
553 X.org DRI driver for SiS card family.
554
555 %description dri-driver-sis -l pl.UTF-8
556 Sterownik X.org DRI dla rodziny kart SiS.
557
558 %package dri-driver-swrast
559 Summary:        X.org DRI software rasterizer driver
560 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
561 License:        MIT
562 Group:          X11/Libraries
563 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
564 Requires:       xorg-xserver-server >= %{xserver_ver}
565
566 %description dri-driver-swrast
567 X.org DRI software rasterizer driver.
568
569 %description dri-driver-swrast -l pl.UTF-8
570 Sterownik X.org DRI obsługujący rysowanie programowe.
571
572 %package dri-driver-tdfx
573 Summary:        X.org DRI driver for 3DFX Voodoo card family
574 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
575 License:        MIT
576 Group:          X11/Libraries
577 Requires:       Glide3-DRI
578 Requires:       xorg-driver-video-tdfx
579 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
580 Requires:       xorg-xserver-server >= %{xserver_ver}
581 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
582
583 %description dri-driver-tdfx
584 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
585 and Velocity 100/200).
586
587 %description dri-driver-tdfx -l pl.UTF-8
588 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
589 Banshee i Velocity 100/200).
590
591 %package dri-driver-via-unichrome
592 Summary:        X.org DRI driver for VIA Unichrome card family
593 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
594 License:        MIT
595 Group:          X11/Libraries
596 Requires:       xorg-driver-video-openchrome
597 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
598 Requires:       xorg-xserver-server >= %{xserver_ver}
599
600 %description dri-driver-via-unichrome
601 X.org DRI driver for VIA Unichrome card family.
602
603 %description dri-driver-via-unichrome -l pl.UTF-8
604 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
605
606 %package dri-driver-vmwgfx
607 Summary:        X.org DRI driver for VMware
608 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
609 License:        MIT
610 Group:          X11/Libraries
611 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
612 Requires:       xorg-xserver-server >= %{xserver_ver}
613
614 %description dri-driver-vmwgfx
615 X.org DRI driver for VMWare.
616
617 %description dri-driver-vmwgfx -l pl.UTF-8
618 Sterownik X.org DRI dla VMware.
619
620 %prep
621 %setup -q -b1
622 %patch0 -p0
623 %patch1 -p1
624
625 # fix demos
626 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
627
628 %build
629 %{__aclocal}
630 %{__autoconf}
631
632 dri_drivers="i810 i965 mach64 mga r128 r200 r300 r600 radeon savage \
633 %if %{without gallium_intel}
634 i915 \
635 %endif
636 %ifarch sparc sparcv9 sparc64
637 ffb \
638 %endif
639 %ifarch %{ix86} %{x8664}
640 sis \
641 %endif
642 swrast tdfx unichrome"
643
644 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
645
646 common_flags="\
647         --enable-shared \
648         --enable-selinux \
649         --enable-pic \
650         --enable-glx-tls \
651         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
652         --with%{!?with_demos:out}-demos"
653
654 %if %{with osmesa}
655 # osmesa variants
656 %configure $common_flags \
657         --with-driver=osmesa \
658         --disable-asm \
659         --with-osmesa-bits=8
660 %{__make} \
661         SRC_DIRS=mesa
662 mv %{_lib} osmesa8
663 %{__make} clean
664
665 %configure $common_flags \
666         --with-driver=osmesa \
667         --disable-asm \
668         --with-osmesa-bits=16
669 %{__make} \
670         SRC_DIRS=mesa
671 mv %{_lib} osmesa16
672 %{__make} clean
673
674 %configure $common_flags \
675         --with-driver=osmesa \
676         --disable-asm \
677         --with-osmesa-bits=32
678 %{__make} \
679         SRC_DIRS=mesa
680 mv %{_lib} osmesa32
681 %{__make} clean
682 %endif
683
684 %configure $common_flags \
685         --enable-glu \
686         --enable-glw \
687         --disable-glut \
688 %if %{with gallium}
689         --enable-gallium \
690         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
691         --enable-gallium-svga \
692         --enable-gallium-nouveau \
693         --with-state-trackers=dri \
694 %else
695         --disable-gallium \
696 %endif
697         --with-driver=dri \
698         --with-dri-drivers=${dri_drivers} \
699         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
700
701 %{__make}
702 %{__make} -C progs/xdemos glxgears glxinfo
703 %if %{with demos}
704 %{__make} -C progs/demos
705 %endif
706
707 %install
708 rm -rf $RPM_BUILD_ROOT
709
710 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
711
712 # libs without drivers
713 %{__make} install \
714         DESTDIR=$RPM_BUILD_ROOT
715
716 %if %{with osmesa}
717 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
718 %endif
719
720 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
721 # work on copy to keep -bi --short-circuit working
722 rm -rf progs-clean
723 install -d progs-clean
724 for l in demos glsl osdemos redbook samples xdemos ; do
725         cp -a progs/$l progs-clean/$l
726         %{__make} -C progs-clean/$l clean
727         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
728 done
729 rm -rf progs-clean
730 for l in util images ; do
731         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
732 done
733 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
734
735 # strip out undesirable headers
736 olddir=$(pwd)
737 cd $RPM_BUILD_ROOT%{_includedir}/GL
738 rm [a-fh-np-wyz]*.h gg*.h glf*.h
739 cd $RPM_BUILD_ROOT%{_libdir}
740 cd $olddir
741
742 %if %{with multigl}
743 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
744
745 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
746 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
747
748 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
749 %endif
750
751 %clean
752 rm -rf $RPM_BUILD_ROOT
753
754 %post   libGL -p /sbin/ldconfig
755 %postun libGL -p /sbin/ldconfig
756
757 %post   libGLU -p /sbin/ldconfig
758 %postun libGLU -p /sbin/ldconfig
759
760 %post   libGLw -p /sbin/ldconfig
761 %postun libGLw -p /sbin/ldconfig
762
763 %files libGL
764 %defattr(644,root,root,755)
765 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
766 %if %{with multigl}
767 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
768 %dir %{_libdir}/Mesa
769 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
770 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
771 %else
772 %attr(755,root,root) %{_libdir}/libGL.so.*.*
773 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
774 # symlink for binary apps which fail to conform Linux OpenGL ABI
775 # (and dlopen libGL.so instead of libGL.so.1)
776 %attr(755,root,root) %{_libdir}/libGL.so
777 %endif
778
779 %files libGL-devel
780 %defattr(644,root,root,755)
781 %doc docs/*.spec
782 %if %{with multigl}
783 %attr(755,root,root) %{_libdir}/libGL.so
784 %endif
785 %dir %{_includedir}/GL
786 %{_includedir}/GL/gl.h
787 %{_includedir}/GL/glext.h
788 %{_includedir}/GL/gl_mangle.h
789 %{_includedir}/GL/glx.h
790 %{_includedir}/GL/glxext.h
791 %{_includedir}/GL/glx_mangle.h
792 %dir %{_includedir}/GL/internal
793 %{_includedir}/GL/internal/dri_interface.h
794 %{_pkgconfigdir}/dri.pc
795 %{_pkgconfigdir}/gl.pc
796
797 %if %{with static}
798 %files libGL-static
799 %defattr(644,root,root,755)
800 %{_libdir}/libGL.a
801 %endif
802
803 %files libGLU
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
806 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
807
808 %files libGLU-devel
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libGLU.so
811 %{_includedir}/GL/glu.h
812 %{_includedir}/GL/glu_mangle.h
813 %{_pkgconfigdir}/glu.pc
814
815 %if %{with static}
816 %files libGLU-static
817 %defattr(644,root,root,755)
818 %{_libdir}/libGLU.a
819 %endif
820
821 %files libGLw
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
824 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
825
826 %files libGLw-devel
827 %defattr(644,root,root,755)
828 %attr(755,root,root) %{_libdir}/libGLw.so
829 %{_includedir}/GL/GLwDrawA.h
830 %{_includedir}/GL/GLwDrawAP.h
831 %{_includedir}/GL/GLwMDrawA.h
832 %{_includedir}/GL/GLwMDrawAP.h
833 %{_pkgconfigdir}/glw.pc
834
835 %if %{with static}
836 %files libGLw-static
837 %defattr(644,root,root,755)
838 %{_libdir}/libGLw.a
839 %endif
840
841 %if %{with osmesa}
842 %files libOSMesa
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
845 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
846
847 %files libOSMesa-devel
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libOSMesa*.so
850 %{_includedir}/GL/osmesa.h
851
852 %if %{with static}
853 %files libOSMesa-static
854 %defattr(644,root,root,755)
855 %{_libdir}/libOSMesa*.a
856 %endif
857 %endif
858
859 %files utils
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_bindir}/glxgears
862 %attr(755,root,root) %{_bindir}/glxinfo
863
864 %files dri-driver-ati-mach64
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
867
868 %files dri-driver-ati-radeon-R100
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
871
872 %files dri-driver-ati-radeon-R200
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
875
876 %files dri-driver-ati-radeon-R300
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
879
880 %files dri-driver-ati-radeon-R600
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
883
884 %files dri-driver-ati-rage128
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
887
888 # sunffb (sparc only)
889 %ifarch sparc sparcv9 sparc64
890 %files dri-driver-ffb
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
893 %endif
894
895 # glint (requires update)
896 %if 0
897 %files dri-driver-glint
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
900 %endif
901
902 %files dri-driver-intel-i810
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
905
906 %files dri-driver-intel-i915
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
909
910 %files dri-driver-intel-i965
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
913
914 %files dri-driver-matrox
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
917
918 %if %{with gallium}
919 %files dri-driver-nouveau
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
922 %endif
923
924 %files dri-driver-savage
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
927
928 %ifarch %{ix86} %{x8664}
929 %files dri-driver-sis
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
932 %endif
933
934 %files dri-driver-swrast
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
937
938 %files dri-driver-tdfx
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
941
942 %files dri-driver-via-unichrome
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
945
946 %files dri-driver-vmwgfx
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
949
950 %if %{with demos}
951 %files demos
952 %defattr(644,root,root,755)
953 %{_examplesdir}/%{name}-%{version}
954 %endif
This page took 0.279272 seconds and 4 git commands to generate.