]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- fixed typo :)
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.0
5 Release:        7
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildPrereq:    XFree86-devel
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %description
17 Mesa is a 3-D graphics library with an API which is very similar to that
18 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
19 or state machine, it is being used with authorization from Silicon Graphics,
20 Inc.  However, the author makes no claim that Mesa is in any way a
21 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
22 Those who want a licensed implementation of OpenGL should contact a licensed
23 vendor.  This software is distributed under the terms of the GNU Library
24 General Public License, see the LICENSE file for details.
25
26 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
27
28 %description -l pl
29 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
30 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
31
32 %package devel
33 Summary:        Development environment for Mesa
34 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
35 Group:          Development/Libraries
36 Group(pl):      Programowanie/Biblioteki
37 Requires:       %{name} = %{version}
38
39 %description devel
40 Header files and documentation needed for development.
41
42 %description -l pl devel
43 Pliki nag³ówkowe i dokumentacja do Mesy.
44
45 %package static
46 Summary:        Mesa static libraries
47 Summary(pl):    Biblioteki statyczne Mesy
48 Group:          Development/Libraries
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 The static version of the Mesa libraries
54
55 %description -l pl static
56 Biblioteki statyczne Mesy.
57
58 %package glut
59 Summary:        GLUT library for Mesa
60 Summary(pl):    Biblioteka GLUT dla Mesy
61 Group:          X11/Libraries
62 Group(pl):      X11/Biblioteki
63 Requires:       %{name} = %{version}
64 Obsoletes:      glut
65
66 %description glut
67 The GLUT library.
68
69 %description -l pl glut
70 Biblioteka GLUT
71
72 %package glut-devel
73 Summary:        GLUT Development environment for Mesa
74 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
75 Group:          Development/Libraries
76 Group(pl):      Programowanie/Biblioteki
77 Requires:       %{name} = %{version}
78 Obsoletes:      glut-devel
79
80 %description glut-devel
81 Header files needed for development aplications using GLUT library.
82
83 %description -l pl glut-devel
84 Pliki nag³ówkowe do biblioteki GLUT.
85
86 %package glut-static
87 Summary:        GLUT static libraries
88 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
89 Group:          Development/Libraries
90 Group(pl):      Programowanie/Biblioteki
91 Requires:       %{name}-glut-devel = %{version}
92 Obsoletes:      glut-devel
93
94 %description glut-static
95 The static version of the GLUT library.
96
97 %description -l pl glut-static
98 Biblioteki statyczne GLUT.
99
100 %package demos
101 Summary:        Mesa Demos
102 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
103 Group:          Development/Libraries
104 Group(pl):      Programowanie/Biblioteki
105 Requires:       %{name} = %{version}
106
107 %description demos
108 Demonstration programs for the Mesa libraries.
109
110 %description -l pl demos
111 Programy demonstracyjne dla biblioteki Mesa.
112
113 %prep
114 %setup -q -n Mesa-%{version} -b 1
115 %patch -p1
116
117 %build
118 %ifarch alpha
119 make LIBS_ONLY=YES linux-alpha
120 make clean
121 make linux-alpha-elf
122 %endif
123
124 %ifarch ppc
125 make linux-ppc
126 %endif
127
128 %ifarch %{ix86}
129 make clean
130 make LIBS_ONLY=YES linux-386
131 make clean
132 make linux-386-elf
133 %endif
134
135 %ifarch sparc sparc64
136 make  linux-elf
137 %endif
138
139 (cd widgets-mesa; autoconf; \
140 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
141 ./configure \
142         --prefix=/usr/X11R6/ \
143         --target=%{_target_platform} \
144         --host=%{_host}
145 make)
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT/usr/X11R6/{lib/Mesa,include,share/man/man3}
150 install -d $RPM_BUILD_ROOT/usr/src/examples/Mesa
151
152 cp -dpr lib include $RPM_BUILD_ROOT/usr/X11R6
153 cp -dpr util $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
154 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
155 install Make-config $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
156
157 (cd widgets-mesa; \
158 make install \
159         prefix=$RPM_BUILD_ROOT/usr/X11R6 \
160         mandir=$RPM_BUILD_ROOT/usr/X11R6/share/man/man3)
161
162 install */lib*.a $RPM_BUILD_ROOT/usr/X11R6/lib
163
164 strip $RPM_BUILD_ROOT/usr/X11R6/lib/{lib*so.*.*,Mesa/*/*} ||
165
166 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/share/man/man3/* \
167         FUTURE IAFA-PACKAGE LICENSE README* RELNOTES VERSIONS
168
169 %post   -p /sbin/ldconfig
170 %postun -p /sbin/ldconfig
171
172 %post   -p /sbin/ldconfig glut
173 %postun -p /sbin/ldconfig glut
174
175 %clean
176 rm -fr $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180
181 %ifnarch ppc
182 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so.*.*
183 %else
184 /usr/X11R6/lib/libMesa*.a
185 %endif
186
187 %files glut
188 %defattr(644,root,root,755)
189 %ifnarch ppc
190 %attr(755,root,root) /usr/X11R6/lib/libglut.so.*
191 %else
192 /usr/X11R6/lib/libglut.a
193 %endif
194
195 %files glut-devel
196 %defattr(644,root,root,755)
197 /usr/X11R6/include/GL/glut.h
198 %ifnarch ppc
199 %attr(755,root,root) /usr/X11R6/lib/libglut.so
200 %endif
201
202 %ifnarch ppc
203 %files glut-static
204 %defattr(644,root,root,755)
205 /usr/X11R6/lib/libglut.a
206 %endif
207
208 %files devel
209 %defattr(644,root,root,755)
210 %doc {FUTURE,IAFA-PACKAGE,LICENSE,RELNOTES,VERSIONS,README}.gz
211 %doc README.{3DFX,GGI,MGL,QUAKE,VIRGE,X11}.gz
212
213 %ifnarch ppc
214 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so
215 %endif
216
217 %dir /usr/X11R6/lib/Mesa
218 /usr/X11R6/lib/Mesa/Make-config
219 /usr/X11R6/lib/Mesa/util
220
221 %dir /usr/X11R6/include/GL
222 /usr/X11R6/include/GL/*.h
223 /usr/X11R6/share/man/man3/*
224
225 %ifnarch ppc
226 %files static
227 %defattr(644,root,root,755)
228 %endif
229 /usr/X11R6/lib/libMesa*.a
230
231 %files demos
232 %defattr(644,root,root,755)
233 %dir /usr/src/examples/Mesa/book
234 %dir /usr/src/examples/Mesa/demos
235 %dir /usr/src/examples/Mesa/samples
236 %dir /usr/src/examples/Mesa/xdemos
237
238 %attr(-,root,root)/usr/src/examples/Mesa/book/*
239 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
240 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
241 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
242
243 %changelog
244 * Mon May 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
245   [3.0-7]
246 - now package is FHS 2.0 compliant.
247
248 * Mon Mar  8 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
249   [3.0-4]
250 - updated URL to http://www.mesa3d.org/,
251 - %doc moved to devel,
252 - added static subpackages,
253 - removed some README files,
254 - removed man group from man pages.
255
256 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
257   [3.0-3d]
258 - added gzipping documentation
259 - simplification in %files
260 - fixed pl translations
261
262 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
263   [3.0-2d]
264 - added LDFLAGS="-s" to ./configure enviroment,
265 - fixed permission on lib*so* files (must be 755),
266 - removed RPM_OPT_FLAGS="$RPM_OPT_FLAGS" make parameters
267   (this is redundant).
268
269 * Sat Jan 23 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
270 - gzipped man page.
271
272 * Thu Jan 12 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
273 - fixing library location.
274
275 * Thu Oct  1 1998 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
276   [3.0-1]
277 - fixing access permision.
278
279 * Wed May  5 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
280 - removed declarate %%{version}, %%{name}, %%{release} macros because
281   all are predefined,
282 - removed check $RPM_BUILD_ROOT in %clean and %install,
283 - added "Requires: Mesa = %%{version}" for all subpackages (for
284   keeping corectly dependences),
285 - in Mesa-glut* packages changed "Conflict:" to "Obsoletes:",
286 - added striping shared libs and demos,
287 - added modification in %build wihch allow build Mesa on sparc[64]
288   architecture,
289 - all utils and demos instaled in /usr/lib/Mesa,
290 - added %defattr macros in %files (on rebuild require rpm >= 2.4.99),
291 - added -q %setup parameter.
292
293 * Thu Feb 12 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
294 - updated to final version 2.6
295
296 * Thu Feb 05 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
297 - Fixed thinko in misc patch
298 - build against glibc
299
300 * Sat Jan 31 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
301 - updated to version 2.6beta5
302 - added widget-mesa to the things to be build.
303
304 * Mon Jan 26 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
305 - updated to version 2.6beta4
306
307 * Sun Dec 14 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
308 - updated to version 2.6beta1
309
310 * Sat Dec 13 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
311 - Moved GLUT into a separate subpackage and added an Obsoletes tag to this
312   subpackage
313 - Moved lib*.so to the devel package, they are only needed for development,
314   not for a runtime environment.
315
316 * Sat Nov 29 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
317 - added patches from ftp://iris.ssec.wisc.edu/pub/Mesa/patches_to_2.5
318 - BuildRoot'ed
319 - Prefix'ed
320 - added static versions of the libraries. (PPC version seems not to have
321   support for shared versions of the library)
322 - moved static versions of the library and the includes to the new subpackage
323   'devel'
324 - targets other than linux-x86 still untested.
325 - added Conflitcs tag
326 - added %postun
327 - added patch for RPM_OPT_FLAGS support
328
329 * Fri Nov 21 1997 Karsten Weiss <karsten@addx.au.s.shuttle.de>
330 - Upgraded to Mesa 2.5
331 - Multiarch destinations (untested).
332 - Included GLUT.
333 - Removed some of the READMEs for other platforms from the binary RPM.
This page took 0.07001 seconds and 4 git commands to generate.