]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- compiled on rpm 3
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.0
5 Release:        6
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildRoot:      /tmp/%{name}-%{version}-root
14
15 %description
16 Mesa is a 3-D graphics library with an API which is very similar to that
17 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
18 or state machine, it is being used with authorization from Silicon Graphics,
19 Inc.  However, the author makes no claim that Mesa is in any way a
20 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
21 Those who want a licensed implementation of OpenGL should contact a licensed
22 vendor.  This software is distributed under the terms of the GNU Library
23 General Public License, see the LICENSE file for details.
24
25 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
26
27 %description -l pl
28 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
29 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
30
31 %package devel
32 Summary:        Development environment for Mesa
33 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
34 Group:          Development/Libraries
35 Group(pl):      Programowanie/Biblioteki
36 Requires:       %{name} = %{version}
37
38 %description devel
39 Header files and documentation needed for development.
40
41 %description -l pl devel
42 Pliki nag³ówkowe i dokumentacja do Mesy.
43
44 %package static
45 Summary:        Mesa static libraries
46 Summary(pl):    Biblioteki statyczne Mesy
47 Group:          Development/Libraries
48 Group(pl):      Programowanie/Biblioteki
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 The static version of the Mesa libraries
53
54 %description -l pl static
55 Biblioteki statyczne Mesy.
56
57 %package glut
58 Summary:        GLUT library for Mesa
59 Summary(pl):    Biblioteka GLUT dla Mesy
60 Group:          X11/Libraries
61 Group(pl):      X11/Biblioteki
62 Requires:       %{name} = %{version}
63 Obsoletes:      glut
64
65 %description glut
66 The GLUT library.
67
68 %description -l pl glut
69 Biblioteka GLUT
70
71 %package glut-devel
72 Summary:        GLUT Development environment for Mesa
73 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
74 Group:          Development/Libraries
75 Group(pl):      Programowanie/Biblioteki
76 Requires:       %{name} = %{version}
77 Obsoletes:      glut-devel
78
79 %description glut-devel
80 Header files needed for development aplications using GLUT library.
81
82 %description -l pl glut-devel
83 Pliki nag³ówkowe do biblioteki GLUT.
84
85 %package glut-static
86 Summary:        GLUT static libraries
87 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
88 Group:          Development/Libraries
89 Group(pl):      Programowanie/Biblioteki
90 Requires:       %{name}-glut-devel = %{version}
91 Obsoletes:      glut-devel
92
93 %description glut-static
94 The static version of the GLUT library.
95
96 %description -l pl glut-static
97 Biblioteki statyczne GLUT.
98
99 %package demos
100 Summary:        Mesa Demos
101 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
102 Group:          Development/Libraries
103 Group(pl):      Programowanie/Biblioteki
104 Requires:       %{name} = %{version}
105
106 %description demos
107 Demonstration programs for the Mesa libraries.
108
109 %description -l pl demos
110 Programy demonstracyjne dla biblioteki Mesa.
111
112 %prep
113 %setup -q -n Mesa-%{version} -b 1
114 %patch -p1
115
116 %build
117 %ifarch alpha
118 make LIBS_ONLY=YES linux-alpha
119 make clean
120 make linux-alpha-elf
121 %endif
122
123 %ifarch ppc
124 make linux-ppc
125 %endif
126
127 %ifarch i386
128 make clean
129 make LIBS_ONLY=YES linux-386
130 make clean
131 make linux-386-elf
132 %endif
133
134 %ifarch sparc sparc64
135 make  linux-elf
136 %endif
137
138 (cd widgets-mesa; CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
139 ./configure \
140         --prefix=/usr/X11R6/
141 make)
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145 install -d $RPM_BUILD_ROOT/usr/X11R6/{lib/Mesa,include,man/man3}
146 install -d $RPM_BUILD_ROOT/usr/src/examples/Mesa
147
148 cp -dpr lib include $RPM_BUILD_ROOT/usr/X11R6
149 cp -dpr util $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
150 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
151 install Make-config $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
152
153 (cd widgets-mesa; make prefix=$RPM_BUILD_ROOT/usr/X11R6 install )
154
155 install */lib*.a $RPM_BUILD_ROOT/usr/X11R6/lib
156
157 strip $RPM_BUILD_ROOT/usr/X11R6/lib/{lib*so.*.*,Mesa/*/*} ||
158
159 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man3/* \
160         FUTURE IAFA-PACKAGE LICENSE README* RELNOTES VERSIONS
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %post   -p /sbin/ldconfig glut
166 %postun -p /sbin/ldconfig glut
167
168 %clean
169 rm -fr $RPM_BUILD_ROOT
170
171 %files
172 %defattr(644,root,root,755)
173
174 %ifnarch ppc
175 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so.*.*
176 %else
177 /usr/X11R6/lib/libMesa*.a
178 %endif
179
180 %files glut
181 %defattr(644,root,root,755)
182 %ifnarch ppc
183 %attr(755,root,root) /usr/X11R6/lib/libglut.so.*
184 %else
185 /usr/X11R6/lib/libglut.a
186 %endif
187
188 %files glut-devel
189 %defattr(644,root,root,755)
190 /usr/X11R6/include/GL/glut.h
191 %ifnarch ppc
192 %attr(755,root,root) /usr/X11R6/lib/libglut.so
193 %endif
194
195 %ifnarch ppc
196 %files glut-static
197 %defattr(644,root,root,755)
198 /usr/X11R6/lib/libglut.a
199 %endif
200
201 %files devel
202 %defattr(644,root,root,755)
203 %doc {FUTURE,IAFA-PACKAGE,LICENSE,RELNOTES,VERSIONS,README}.gz
204 %doc README.{3DFX,GGI,MGL,QUAKE,VIRGE,X11}.gz
205
206 %ifnarch ppc
207 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so
208 %endif
209
210 %dir /usr/X11R6/lib/Mesa
211 /usr/X11R6/lib/Mesa/Make-config
212 /usr/X11R6/lib/Mesa/util
213
214 %dir /usr/X11R6/include/GL
215 /usr/X11R6/include/GL/*.h
216 /usr/X11R6/man/man3/*
217
218 %ifnarch ppc
219 %files static
220 %defattr(644,root,root,755)
221 %endif
222 /usr/X11R6/lib/libMesa*.a
223
224 %files demos
225 %defattr(644,root,root,755)
226 %dir /usr/src/examples/Mesa/book
227 %dir /usr/src/examples/Mesa/demos
228 %dir /usr/src/examples/Mesa/samples
229 %dir /usr/src/examples/Mesa/xdemos
230
231 %attr(-,root,root)/usr/src/examples/Mesa/book/*
232 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
233 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
234 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
235
236 %changelog
237 * Mon Mar  8 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
238   [3.0-4]
239 - updated URL to http://www.mesa3d.org/,
240 - %doc moved to devel,
241 - added static subpackages,
242 - removed some README files,
243 - removed man group from man pages.
244
245 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
246   [3.0-3d]
247 - added gzipping documentation
248 - simplification in %files
249 - fixed pl translations
250
251 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
252   [3.0-2d]
253 - added LDFLAGS="-s" to ./configure enviroment,
254 - fixed permission on lib*so* files (must be 755),
255 - removed RPM_OPT_FLAGS="$RPM_OPT_FLAGS" make parameters
256   (this is redundant).
257
258 * Sat Jan 23 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
259 - gzipped man page.
260
261 * Thu Jan 12 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
262 - fixing library location.
263
264 * Thu Oct  1 1998 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
265   [3.0-1]
266 - fixing access permision.
267
268 * Wed May  5 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
269 - removed declarate %%{version}, %%{name}, %%{release} macros because
270   all are predefined,
271 - removed check $RPM_BUILD_ROOT in %clean and %install,
272 - added "Requires: Mesa = %%{version}" for all subpackages (for
273   keeping corectly dependences),
274 - in Mesa-glut* packages changed "Conflict:" to "Obsoletes:",
275 - added striping shared libs and demos,
276 - added modification in %build wihch allow build Mesa on sparc[64]
277   architecture,
278 - all utils and demos instaled in /usr/lib/Mesa,
279 - added %defattr macros in %files (on rebuild require rpm >= 2.4.99),
280 - added -q %setup parameter.
281
282 * Thu Feb 12 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
283 - updated to final version 2.6
284
285 * Thu Feb 05 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
286 - Fixed thinko in misc patch
287 - build against glibc
288
289 * Sat Jan 31 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
290 - updated to version 2.6beta5
291 - added widget-mesa to the things to be build.
292
293 * Mon Jan 26 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
294 - updated to version 2.6beta4
295
296 * Sun Dec 14 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
297 - updated to version 2.6beta1
298
299 * Sat Dec 13 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
300 - Moved GLUT into a separate subpackage and added an Obsoletes tag to this
301   subpackage
302 - Moved lib*.so to the devel package, they are only needed for development,
303   not for a runtime environment.
304
305 * Sat Nov 29 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
306 - added patches from ftp://iris.ssec.wisc.edu/pub/Mesa/patches_to_2.5
307 - BuildRoot'ed
308 - Prefix'ed
309 - added static versions of the libraries. (PPC version seems not to have
310   support for shared versions of the library)
311 - moved static versions of the library and the includes to the new subpackage
312   'devel'
313 - targets other than linux-x86 still untested.
314 - added Conflitcs tag
315 - added %postun
316 - added patch for RPM_OPT_FLAGS support
317
318 * Fri Nov 21 1997 Karsten Weiss <karsten@addx.au.s.shuttle.de>
319 - Upgraded to Mesa 2.5
320 - Multiarch destinations (untested).
321 - Included GLUT.
322 - Removed some of the READMEs for other platforms from the binary RPM.
This page took 0.090455 seconds and 4 git commands to generate.