]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
added %{_target} macro
[packages/Mesa.git] / Mesa.spec
1 Summary:        Free OpenGL implementation. Runtime environment
2 Summary(pl):    Bezp³atna implementacja standardu OpenGL
3 Name:           Mesa
4 Version:        3.0
5 Release:        6
6 Copyright:      GPL
7 Group:          X11/Libraries
8 Group(pl):      X11/Biblioteki
9 Source0:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Lib-%{version}.tar.gz
10 Source1:        ftp://iris.ssec.wisc.edu/pub/Mesa/%{name}Demos-%{version}.tar.gz
11 Patch:          Mesa-misc.diff
12 URL:            http://www.mesa3d.org/
13 BuildPrereq:    XFree86-devel
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %description
17 Mesa is a 3-D graphics library with an API which is very similar to that
18 of OpenGL*.  To the extent that Mesa utilizes the OpenGL command syntax
19 or state machine, it is being used with authorization from Silicon Graphics,
20 Inc.  However, the author makes no claim that Mesa is in any way a
21 compatible replacement for OpenGL or associated with Silicon Graphics, Inc.
22 Those who want a licensed implementation of OpenGL should contact a licensed
23 vendor.  This software is distributed under the terms of the GNU Library
24 General Public License, see the LICENSE file for details.
25
26 * OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
27
28 %description -l pl
29 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standartu OpenGL(*).
30 * OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics, Inc.
31
32 %package devel
33 Summary:        Development environment for Mesa
34 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
35 Group:          Development/Libraries
36 Group(pl):      Programowanie/Biblioteki
37 Requires:       %{name} = %{version}
38
39 %description devel
40 Header files and documentation needed for development.
41
42 %description -l pl devel
43 Pliki nag³ówkowe i dokumentacja do Mesy.
44
45 %package static
46 Summary:        Mesa static libraries
47 Summary(pl):    Biblioteki statyczne Mesy
48 Group:          Development/Libraries
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 The static version of the Mesa libraries
54
55 %description -l pl static
56 Biblioteki statyczne Mesy.
57
58 %package glut
59 Summary:        GLUT library for Mesa
60 Summary(pl):    Biblioteka GLUT dla Mesy
61 Group:          X11/Libraries
62 Group(pl):      X11/Biblioteki
63 Requires:       %{name} = %{version}
64 Obsoletes:      glut
65
66 %description glut
67 The GLUT library.
68
69 %description -l pl glut
70 Biblioteka GLUT
71
72 %package glut-devel
73 Summary:        GLUT Development environment for Mesa
74 Summary(pl):    ¦rodowisko programistyczne 'GLUT' dla biblioteki MESA.
75 Group:          Development/Libraries
76 Group(pl):      Programowanie/Biblioteki
77 Requires:       %{name} = %{version}
78 Obsoletes:      glut-devel
79
80 %description glut-devel
81 Header files needed for development aplications using GLUT library.
82
83 %description -l pl glut-devel
84 Pliki nag³ówkowe do biblioteki GLUT.
85
86 %package glut-static
87 Summary:        GLUT static libraries
88 Summary(pl):    Biblioteki statyczne do biblioteki GLUT
89 Group:          Development/Libraries
90 Group(pl):      Programowanie/Biblioteki
91 Requires:       %{name}-glut-devel = %{version}
92 Obsoletes:      glut-devel
93
94 %description glut-static
95 The static version of the GLUT library.
96
97 %description -l pl glut-static
98 Biblioteki statyczne GLUT.
99
100 %package demos
101 Summary:        Mesa Demos
102 Summary(pl):    Demonstracje mo¿liwo¶ci biblioteki MESA.
103 Group:          Development/Libraries
104 Group(pl):      Programowanie/Biblioteki
105 Requires:       %{name} = %{version}
106
107 %description demos
108 Demonstration programs for the Mesa libraries.
109
110 %description -l pl demos
111 Programy demonstracyjne dla biblioteki Mesa.
112
113 %prep
114 %setup -q -n Mesa-%{version} -b 1
115 %patch -p1
116
117 %build
118 %ifarch alpha
119 make LIBS_ONLY=YES linux-alpha
120 make clean
121 make linux-alpha-elf
122 %endif
123
124 %ifarch ppc
125 make linux-ppc
126 %endif
127
128 %ifarch i386
129 make clean
130 make LIBS_ONLY=YES linux-386
131 make clean
132 make linux-386-elf
133 %endif
134
135 %ifarch sparc sparc64
136 make  linux-elf
137 %endif
138
139 (cd widgets-mesa; CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
140 ./configure %{_target} \
141         --prefix=/usr/X11R6/
142 make)
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146 install -d $RPM_BUILD_ROOT/usr/X11R6/{lib/Mesa,include,man/man3}
147 install -d $RPM_BUILD_ROOT/usr/src/examples/Mesa
148
149 cp -dpr lib include $RPM_BUILD_ROOT/usr/X11R6
150 cp -dpr util $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
151 cp -dpr book demos xdemos samples $RPM_BUILD_ROOT/usr/src/examples/Mesa
152 install Make-config $RPM_BUILD_ROOT/usr/X11R6/lib/Mesa
153
154 (cd widgets-mesa; make prefix=$RPM_BUILD_ROOT/usr/X11R6 install )
155
156 install */lib*.a $RPM_BUILD_ROOT/usr/X11R6/lib
157
158 strip $RPM_BUILD_ROOT/usr/X11R6/lib/{lib*so.*.*,Mesa/*/*} ||
159
160 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man3/* \
161         FUTURE IAFA-PACKAGE LICENSE README* RELNOTES VERSIONS
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %post   -p /sbin/ldconfig glut
167 %postun -p /sbin/ldconfig glut
168
169 %clean
170 rm -fr $RPM_BUILD_ROOT
171
172 %files
173 %defattr(644,root,root,755)
174
175 %ifnarch ppc
176 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so.*.*
177 %else
178 /usr/X11R6/lib/libMesa*.a
179 %endif
180
181 %files glut
182 %defattr(644,root,root,755)
183 %ifnarch ppc
184 %attr(755,root,root) /usr/X11R6/lib/libglut.so.*
185 %else
186 /usr/X11R6/lib/libglut.a
187 %endif
188
189 %files glut-devel
190 %defattr(644,root,root,755)
191 /usr/X11R6/include/GL/glut.h
192 %ifnarch ppc
193 %attr(755,root,root) /usr/X11R6/lib/libglut.so
194 %endif
195
196 %ifnarch ppc
197 %files glut-static
198 %defattr(644,root,root,755)
199 /usr/X11R6/lib/libglut.a
200 %endif
201
202 %files devel
203 %defattr(644,root,root,755)
204 %doc {FUTURE,IAFA-PACKAGE,LICENSE,RELNOTES,VERSIONS,README}.gz
205 %doc README.{3DFX,GGI,MGL,QUAKE,VIRGE,X11}.gz
206
207 %ifnarch ppc
208 %attr(755,root,root) /usr/X11R6/lib/libMesa*.so
209 %endif
210
211 %dir /usr/X11R6/lib/Mesa
212 /usr/X11R6/lib/Mesa/Make-config
213 /usr/X11R6/lib/Mesa/util
214
215 %dir /usr/X11R6/include/GL
216 /usr/X11R6/include/GL/*.h
217 /usr/X11R6/man/man3/*
218
219 %ifnarch ppc
220 %files static
221 %defattr(644,root,root,755)
222 %endif
223 /usr/X11R6/lib/libMesa*.a
224
225 %files demos
226 %defattr(644,root,root,755)
227 %dir /usr/src/examples/Mesa/book
228 %dir /usr/src/examples/Mesa/demos
229 %dir /usr/src/examples/Mesa/samples
230 %dir /usr/src/examples/Mesa/xdemos
231
232 %attr(-,root,root)/usr/src/examples/Mesa/book/*
233 %attr(-,root,root)/usr/src/examples/Mesa/demos/*
234 %attr(-,root,root)/usr/src/examples/Mesa/samples/*
235 %attr(-,root,root)/usr/src/examples/Mesa/xdemos/*
236
237 %changelog
238 * Mon Mar  8 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
239   [3.0-4]
240 - updated URL to http://www.mesa3d.org/,
241 - %doc moved to devel,
242 - added static subpackages,
243 - removed some README files,
244 - removed man group from man pages.
245
246 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
247   [3.0-3d]
248 - added gzipping documentation
249 - simplification in %files
250 - fixed pl translations
251
252 * Sat Jan 30 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
253   [3.0-2d]
254 - added LDFLAGS="-s" to ./configure enviroment,
255 - fixed permission on lib*so* files (must be 755),
256 - removed RPM_OPT_FLAGS="$RPM_OPT_FLAGS" make parameters
257   (this is redundant).
258
259 * Sat Jan 23 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
260 - gzipped man page.
261
262 * Thu Jan 12 1999 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
263 - fixing library location.
264
265 * Thu Oct  1 1998 Wojciech "Sas" Cieciwa <cieciwa@alpha.zarz.agh.edu.pl>
266   [3.0-1]
267 - fixing access permision.
268
269 * Wed May  5 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
270 - removed declarate %%{version}, %%{name}, %%{release} macros because
271   all are predefined,
272 - removed check $RPM_BUILD_ROOT in %clean and %install,
273 - added "Requires: Mesa = %%{version}" for all subpackages (for
274   keeping corectly dependences),
275 - in Mesa-glut* packages changed "Conflict:" to "Obsoletes:",
276 - added striping shared libs and demos,
277 - added modification in %build wihch allow build Mesa on sparc[64]
278   architecture,
279 - all utils and demos instaled in /usr/lib/Mesa,
280 - added %defattr macros in %files (on rebuild require rpm >= 2.4.99),
281 - added -q %setup parameter.
282
283 * Thu Feb 12 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
284 - updated to final version 2.6
285
286 * Thu Feb 05 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
287 - Fixed thinko in misc patch
288 - build against glibc
289
290 * Sat Jan 31 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
291 - updated to version 2.6beta5
292 - added widget-mesa to the things to be build.
293
294 * Mon Jan 26 1998 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
295 - updated to version 2.6beta4
296
297 * Sun Dec 14 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
298 - updated to version 2.6beta1
299
300 * Sat Dec 13 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
301 - Moved GLUT into a separate subpackage and added an Obsoletes tag to this
302   subpackage
303 - Moved lib*.so to the devel package, they are only needed for development,
304   not for a runtime environment.
305
306 * Sat Nov 29 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
307 - added patches from ftp://iris.ssec.wisc.edu/pub/Mesa/patches_to_2.5
308 - BuildRoot'ed
309 - Prefix'ed
310 - added static versions of the libraries. (PPC version seems not to have
311   support for shared versions of the library)
312 - moved static versions of the library and the includes to the new subpackage
313   'devel'
314 - targets other than linux-x86 still untested.
315 - added Conflitcs tag
316 - added %postun
317 - added patch for RPM_OPT_FLAGS support
318
319 * Fri Nov 21 1997 Karsten Weiss <karsten@addx.au.s.shuttle.de>
320 - Upgraded to Mesa 2.5
321 - Multiarch destinations (untested).
322 - Included GLUT.
323 - Removed some of the READMEs for other platforms from the binary RPM.
This page took 0.061427 seconds and 4 git commands to generate.