]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 20060730
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_with     glide   # with GLIDE (broken now)
8 %bcond_without  motif   # build static libGLw without Motif interface
9 #
10 Summary:        Free OpenGL implementation
11 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
12 Name:           Mesa
13 Version:        6.5
14 %define snap    20060730
15 Release:        1.%{snap}.1
16 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
17 Group:          X11/Libraries
18 Source0:        %{name}-%{snap}.tar.gz
19 # Source0-md5:  848144f960c309a79bf29ddcaf2cd2d7
20 #Source0:       http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
21 #Source1:       http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
22 Patch0:         %{name}-modules_dir.patch
23 URL:            http://www.mesa3d.org/
24 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
25 BuildRequires:  expat-devel
26 BuildRequires:  libdrm-devel >= 2.0.2
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.4d
29 %{?with_motif:BuildRequires:    motif-devel}
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  xorg-lib-libXt-devel
32 BuildRequires:  xorg-lib-libXxf86vm-devel
33 BuildRequires:  xorg-proto-glproto-devel
34 BuildRequires:  xorg-util-makedepend
35 Obsoletes:      Mesa-dri
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # avoid XFree86-OpenGL* dependency
39 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
41
42 %define         _sysconfdir     /etc/X11
43
44 %description
45 Mesa is a 3-D graphics library with an API which is very similar to
46 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
47 syntax or state machine, it is being used with authorization from
48 Silicon Graphics, Inc. However, the author does not possess an OpenGL
49 license from SGI, and makes no claim that Mesa is in any way a
50 compatible replacement for OpenGL or associated with SGI.
51
52 %description -l pl
53 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
54 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
55 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
56 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
57 OpenGL ani powi±zana z SGI.
58
59 %package libGL
60 Summary:        Free Mesa3D implementation of libGL OpenGL library
61 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
62 License:        MIT
63 Group:          X11/Libraries
64 %{?with_glide:Requires: Glide3-DRI}
65 Provides:       OpenGL = 1.5
66 # reports version 1.3, but supports glXGetProcAddress() from 1.4
67 Provides:       OpenGL-GLX = 1.4
68 Obsoletes:      Mesa
69 Obsoletes:      X11-OpenGL-libGL
70 Obsoletes:      XFree86-OpenGL-libGL
71
72 %description libGL
73 Mesa is a 3-D graphics library with an API which is very similar to
74 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
75 syntax or state machine, it is being used with authorization from
76 Silicon Graphics, Inc. However, the author does not possess an OpenGL
77 license from SGI, and makes no claim that Mesa is in any way a
78 compatible replacement for OpenGL or associated with SGI.
79
80 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
81 specifications. It uses DRI for rendering.
82
83 %description libGL -l pl
84 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
85 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
86 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
87 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
88 OpenGL ani powi±zana z SGI.
89
90 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
91 GLX 1.4. U¿ywa DRI do renderowania.
92
93 %package libGL-devel
94 Summary:        Header files for Mesa3D libGL library
95 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
96 License:        MIT
97 Group:          X11/Development/Libraries
98 # loose dependency on libGL to use with other libGL binaries
99 Requires:       OpenGL >= 1.5
100 Requires:       xorg-lib-libX11-devel
101 Provides:       OpenGL-devel = 1.5
102 Provides:       OpenGL-GLX-devel = 1.4
103 Obsoletes:      Mesa-devel
104 Obsoletes:      X11-OpenGL-devel
105 Obsoletes:      X11-OpenGL-devel-base
106 Obsoletes:      XFree86-OpenGL-devel
107 Obsoletes:      XFree86-OpenGL-devel-base
108
109 %description libGL-devel
110 Header files for Mesa3D libGL library.
111
112 %description libGL-devel -l pl
113 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
114
115 %package libGL-static
116 Summary:        Static Mesa3D libGL library
117 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
118 License:        MIT
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-libGL-devel = %{version}-%{release}
121 Provides:       OpenGL-static = 1.5
122 Obsoletes:      Mesa-static
123 Obsoletes:      X11-OpenGL-static
124 Obsoletes:      XFree86-OpenGL-static
125
126 %description libGL-static
127 Static Mesa3D libGL library. It uses software renderer.
128
129 %description libGL-static -l pl
130 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
131 renderingu.
132
133 %package libGLU
134 Summary:        SGI implementation of libGLU OpenGL library
135 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
136 License:        SGI Free Software License B v1.1
137 Group:          Libraries
138 # loose dependency on libGL.so.1 to use with other libGL binaries
139 Requires:       OpenGL >= 1.2
140 Provides:       OpenGL-GLU = 1.3
141 Obsoletes:      Mesa-devel
142 Obsoletes:      X11-OpenGL-libs
143 Obsoletes:      XFree86-OpenGL-libs
144
145 %description libGLU
146 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
147 1.3 specifications.
148
149 %description libGLU -l pl
150 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
151 specyfikacjê OpenGL GLU 1.3.
152
153 %package libGLU-devel
154 Summary:        Header files for SGI libGLU library
155 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
156 License:        SGI Free Software License B v1.1
157 Group:          Development/Libraries
158 Requires:       %{name}-libGLU = %{version}-%{release}
159 Requires:       OpenGL-devel >= 1.2
160 Requires:       libstdc++-devel
161 Provides:       OpenGL-GLU-devel = 1.3
162
163 %description libGLU-devel
164 Header files for SGI libGLU library.
165
166 %description libGLU-devel -l pl
167 Pliki nag³ówkowe biblioteki SGI libGLU.
168
169 %package libGLU-static
170 Summary:        Static SGI libGLU library
171 Summary(pl):    Statyczna biblioteka SGI libGLU
172 License:        SGI Free Software License B v1.1
173 Group:          Development/Libraries
174 Requires:       %{name}-libGLU-devel = %{version}-%{release}
175 Provides:       OpenGL-GLU-static = 1.3
176
177 %description libGLU-static
178 Static SGI libGLU library.
179
180 %description libGLU-static -l pl
181 Statyczna biblioteka SGI libGLU.
182
183 %package libGLw
184 Summary:        SGI OpenGL Xt widgets library
185 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
186 License:        SGI MIT-like
187 Group:          Libraries
188 # loose dependency on libGL.so.1 to use with other libGL binaries
189 Requires:       OpenGL >= 1.1
190 Provides:       OpenGL-GLw
191
192 %description libGLw
193 SGI OpenGL Xt widgets library.
194
195 %description libGLU -l pl
196 Biblioteka SGI widgetów Xt dla OpenGL-a.
197
198 %package libGLw-devel
199 Summary:        Header files for SGI libGLw library
200 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
201 License:        SGI Free Software License B v1.1
202 Group:          Development/Libraries
203 Requires:       %{name}-libGLw = %{version}-%{release}
204 Requires:       OpenGL-devel >= 1.2
205 Provides:       OpenGL-GLw-devel
206
207 %description libGLw-devel
208 Header files for SGI libGLw library.
209
210 %description libGLw-devel -l pl
211 Pliki nag³ówkowe biblioteki SGI libGLw.
212
213 %package libGLw-static
214 Summary:        Static SGI libGLw library
215 Summary(pl):    Statyczna biblioteka SGI libGLw
216 License:        SGI Free Software License B v1.1
217 Group:          Development/Libraries
218 Requires:       %{name}-libGLw-devel = %{version}-%{release}
219 Provides:       OpenGL-GLw-static
220
221 %description libGLw-static
222 Static SGI libGLw library.
223
224 %description libGLw-static -l pl
225 Statyczna biblioteka SGI libGLw.
226
227 %package utils
228 Summary:        OpenGL utilities from Mesa3D
229 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
230 Group:          X11/Applications/Graphics
231 # loose deps on libGL/libGLU
232
233 %description utils
234 OpenGL utilities from Mesa3D: glxgears and glxinfo.
235
236 %description utils -l pl
237 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
238
239 %package demos
240 Summary:        Mesa Demos
241 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
242 Group:          Development/Libraries
243 Requires:       OpenGL-devel
244
245 %description demos
246 Demonstration programs for the Mesa libraries.
247
248 %description demos -l pl
249 Programy demonstracyjne dla bibliotek Mesa.
250
251 %package dri-driver-ati-mach64
252 Summary:        X.org DRI drivers
253 Summary(pl):    Sterowniki DRI dla X.org
254 Group:          X11/Libraries
255 Requires:       xorg-xserver-server
256
257 %description dri-driver-ati-mach64
258 X.org DRI drivers for ATI mach64 card family.
259
260 %description dri-driver-ati-mach64 -l pl
261 Sterowniki X.org DRI dla rodziny kart ATI mach64.
262
263 %package dri-driver-ati-radeon-R100
264 Summary:        X.org DRI drivers
265 Summary(pl):    Sterowniki DRI dla X.org
266 Group:          X11/Libraries
267 Requires:       xorg-xserver-server
268
269 %description dri-driver-ati-radeon-R100
270 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
271
272 %description dri-driver-ati-radeon-R100 -l pl
273 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
274
275 %package dri-driver-ati-radeon-R200
276 Summary:        X.org DRI drivers
277 Summary(pl):    Sterowniki DRI dla X.org
278 Group:          X11/Libraries
279 Requires:       xorg-xserver-server
280
281 %description dri-driver-ati-radeon-R200
282 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
283
284 %description dri-driver-ati-radeon-R200 -l pl
285 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
286
287 %package dri-driver-ati-radeon-R300
288 Summary:        X.org DRI drivers
289 Summary(pl):    Sterowniki DRI dla X.org
290 Group:          X11/Libraries
291 Requires:       xorg-xserver-server
292
293 %description dri-driver-ati-radeon-R300
294 X.org DRI drivers for ATI R300 card family.
295
296 %description dri-driver-ati-radeon-R300 -l pl
297 Sterowniki X.org DRI dla rodziny kart ATI R300.
298
299 %package dri-driver-ati-rage128
300 Summary:        X.org DRI drivers
301 Summary(pl):    Sterowniki DRI dla X.org
302 Group:          X11/Libraries
303 Requires:       xorg-xserver-server
304
305 %description dri-driver-ati-rage128
306 X.org DRI drivers for ATI rage128 card family.
307
308 %description dri-driver-ati-rage128 -l pl
309 Sterowniki X.org DRI dla rodziny kart ATI rage128.
310
311 %package dri-driver-ffb
312 Summary:        X.org DRI drivers
313 Summary(pl):    Sterowniki DRI dla X.org
314 Group:          X11/Libraries
315 Requires:       xorg-xserver-server
316
317 %description dri-driver-ffb
318 X.org DRI drivers for SUN Creator3D and Elite3D card family.
319
320 %description dri-driver-ffb -l pl
321 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
322
323 %package dri-driver-glint
324 Summary:        X.org DRI drivers
325 Summary(pl):    Sterowniki DRI dla X.org
326 Group:          X11/Libraries
327 Requires:       xorg-xserver-server
328
329 %description dri-driver-glint
330 X.org DRI drivers for GLINT/Permedia card family.
331
332 %description dri-driver-glint -l pl
333 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
334
335 %package dri-driver-intel-i810
336 Summary:        X.org DRI drivers
337 Summary(pl):    Sterowniki DRI dla X.org
338 Group:          X11/Libraries
339 Requires:       xorg-xserver-server
340
341 %description dri-driver-intel-i810
342 X.org DRI drivers for Intel i810 card family.
343
344 %description dri-driver-intel-i810 -l pl
345 Sterowniki X.org DRI dla rodziny kart i810.
346
347 %package dri-driver-intel-i830
348 Summary:        X.org DRI drivers
349 Summary(pl):    Sterowniki DRI dla X.org
350 Group:          X11/Libraries
351 Requires:       xorg-xserver-server
352
353 %description dri-driver-intel-i830
354 X.org DRI drivers for Intel i830 card family.
355
356 %description dri-driver-intel-i830 -l pl
357 Sterowniki X.org DRI dla rodziny kart i830.
358
359 %package dri-driver-intel-i915
360 Summary:        X.org DRI drivers
361 Summary(pl):    Sterowniki DRI dla X.org
362 Group:          X11/Libraries
363 Requires:       xorg-xserver-server
364 Obsoletes:      Mesa-dri-driver-intel-i830
365
366 %description dri-driver-intel-i915
367 X.org DRI drivers for Intel i915 card family.
368
369 %description dri-driver-intel-i915 -l pl
370 Sterowniki X.org DRI dla rodziny kart i915.
371
372 %package dri-driver-matrox
373 Summary:        X.org DRI drivers
374 Summary(pl):    Sterowniki DRI dla X.org
375 Group:          X11/Libraries
376 Requires:       xorg-xserver-server
377
378 %description dri-driver-matrox
379 X.org DRI drivers for Matrox G card family.
380
381 %description dri-driver-matrox -l pl
382 Sterowniki X.org DRI dla rodziny kart Matrox G.
383
384 %package dri-driver-s3virge
385 Summary:        X.org DRI drivers
386 Summary(pl):    Sterowniki DRI dla X.org
387 Group:          X11/Libraries
388 Requires:       xorg-xserver-server
389
390 %description dri-driver-s3virge
391 X.org DRI drivers for S3 Virge card family.
392
393 %description dri-driver-s3virge -l pl
394 Sterowniki X.org DRI dla rodziny kart S3 Virge.
395
396 %package dri-driver-savage
397 Summary:        X.org DRI drivers
398 Summary(pl):    Sterowniki DRI dla X.org
399 Group:          X11/Libraries
400 Requires:       xorg-xserver-server
401
402 %description dri-driver-savage
403 X.org DRI drivers for S3 Savage card family.
404
405 %description dri-driver-savage -l pl
406 Sterowniki X.org DRI dla rodziny kart S3 Savage.
407
408 %package dri-driver-sis
409 Summary:        X.org DRI drivers
410 Summary(pl):    Sterowniki DRI dla X.org
411 Group:          X11/Libraries
412 Requires:       xorg-xserver-server
413
414 %description dri-driver-sis
415 X.org DRI drivers for SiS card family.
416
417 %description dri-driver-sis -l pl
418 Sterowniki X.org DRI dla rodziny kart SiS.
419
420 %package dri-driver-tdfx
421 Summary:        X.org DRI drivers
422 Summary(pl):    Sterowniki DRI dla X.org
423 Group:          X11/Libraries
424 Requires:       xorg-xserver-server
425
426 %description dri-driver-tdfx
427 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
428 and Velocity 100/200).
429
430 %description dri-driver-tdfx -l pl
431 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
432 Banshee and Velocity 100/200).
433
434 %package dri-driver-trident
435 Summary:        X.org DRI drivers
436 Summary(pl):    Sterowniki DRI dla X.org
437 Group:          X11/Libraries
438 Requires:       xorg-xserver-server
439
440 %description dri-driver-trident
441 X.org DRI drivers for Trident card family.
442
443 %description dri-driver-trident -l pl
444 Sterowniki X.org DRI dla rodziny kart Trident.
445
446 %package dri-driver-via-unichrome
447 Summary:        X.org DRI drivers
448 Summary(pl):    Sterowniki DRI dla X.org
449 Group:          X11/Libraries
450 Requires:       xorg-xserver-server
451
452 %description dri-driver-via-unichrome
453 X.org DRI drivers for VIA Unichrome card family.
454
455 %description dri-driver-via-unichrome -l pl
456 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
457
458 %prep
459 %setup -q -n Mesa-%{snap}
460 #setup -q -n Mesa-%{version} -b 1
461 %patch0 -p1
462
463 # fix dri path
464 sed -i -e 's#/usr/lib/xorg/modules/dri#%{_libdir}/xorg/modules/dri#g' src/glx/x11/dri_glx.c
465
466 # fix demos
467 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
468
469 %ifnarch sparc sparcv9 sparc64
470 # for sunffb driver - useful on sparc only
471 sed -i -e 's/ ffb$//' configs/linux-dri
472 %endif
473
474 %ifnarch %{ix86} %{x8664}
475 # sis needs write-memory barrier
476 sed -i -e 's/ sis / /' configs/linux-dri
477 %endif
478
479 %build
480 %ifarch %{ix86}
481 targ=-x86
482 %else
483 targ=""
484 %endif
485
486 %{__make} linux${targ}-static \
487         CC="%{__cc}" \
488         CXX="%{__cxx}" \
489         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
490         XLIB_DIR=%{_libdir} \
491         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
492         SRC_DIRS="mesa glu glw" \
493         PROGRAM_DIRS=
494 mv -f lib lib-static
495 %{__make} clean
496
497 %{__make} linux-dri${targ} \
498         CC="%{__cc}" \
499         CXX="%{__cxx}" \
500         MKDEP=makedepend \
501         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
502         XLIB_DIR=%{_libdir} \
503         SRC_DIRS="glx/x11 mesa glu glw" \
504         PROGRAM_DIRS=
505
506 %{__make} -C progs/xdemos \
507         CC="%{__cc}" \
508         CXX="%{__cxx}" \
509         OPT_FLAGS="%{rpmcflags}" \
510         XLIB_DIR=%{_libdir} \
511         PROGS="glxgears" \
512         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
513
514 %{__make} -C progs/xdemos \
515         CC="%{__cc}" \
516         CXX="%{__cxx}" \
517         OPT_FLAGS="%{rpmcflags}" \
518         XLIB_DIR=%{_libdir} \
519         PROGS="glxinfo" \
520         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL -L../../lib-dri -lGLU"
521
522 mv -f lib lib-dri
523 %{__make} clean \
524         MKDEP=makedepend
525
526 %{__make} linux${targ} \
527         CC="%{__cc}" \
528         CXX="%{__cxx}" \
529         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
530         XLIB_DIR=%{_libdir} \
531         SRC_DIRS="mesa" \
532         PROGRAM_DIRS=
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
537 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
538
539 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
540 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
541 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
542 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
543 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
544
545 # keep for -bi --short-circuit
546 cp -a progs progs.org
547 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
548 for l in demos redbook samples xdemos ; do
549         %{__make} -C progs/$l clean
550 done
551 for l in demos redbook samples util xdemos images ; do
552         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
553 done
554 rm -rf progs && mv -f progs.org progs
555 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
556
557 %clean
558 rm -rf $RPM_BUILD_ROOT
559
560 %post   libGL -p /sbin/ldconfig
561 %postun libGL -p /sbin/ldconfig
562
563 %post   libGLU -p /sbin/ldconfig
564 %postun libGLU -p /sbin/ldconfig
565
566 %post   libGLw -p /sbin/ldconfig
567 %postun libGLw -p /sbin/ldconfig
568
569 %files libGL
570 %defattr(644,root,root,755)
571 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*,VERSIONS}
572 %attr(755,root,root) %{_libdir}/libGL.so.*.*
573 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
574 # symlink for binary apps which fail to conform Linux OpenGL ABI
575 # (and dlopen libGL.so instead of libGL.so.1)
576 %attr(755,root,root) %{_libdir}/libGL.so
577
578 %files libGL-devel
579 %defattr(644,root,root,755)
580 %doc docs/*.spec
581 %attr(755,root,root) %{_libdir}/libOSMesa.so
582 %dir %{_includedir}/GL
583 %{_includedir}/GL/gl.h
584 %{_includedir}/GL/glext.h
585 %{_includedir}/GL/glfbdev.h
586 %{_includedir}/GL/gl_mangle.h
587 %{_includedir}/GL/glx.h
588 %{_includedir}/GL/glxext.h
589 %{_includedir}/GL/glx_mangle.h
590 %{_includedir}/GL/osmesa.h
591 %{_includedir}/GL/xmesa.h
592 %{_includedir}/GL/xmesa_x.h
593 %{_includedir}/GL/xmesa_xf86.h
594
595 %files libGL-static
596 %defattr(644,root,root,755)
597 %{_libdir}/libGL.a
598 %{_libdir}/libOSMesa.a
599
600 %files libGLU
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
603
604 %files libGLU-devel
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/libGLU.so
607 %{_includedir}/GL/glu.h
608 %{_includedir}/GL/glu_mangle.h
609
610 %files libGLU-static
611 %defattr(644,root,root,755)
612 %{_libdir}/libGLU.a
613
614 %files libGLw
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
617
618 %files libGLw-devel
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/libGLw.so
621 %{_includedir}/GL/GLwDrawA.h
622 %{_includedir}/GL/GLwDrawAP.h
623 %{_includedir}/GL/GLwMDrawA.h
624 %{_includedir}/GL/GLwMDrawAP.h
625
626 %files libGLw-static
627 %defattr(644,root,root,755)
628 %{_libdir}/libGLw.a
629
630 %files utils
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/glxgears
633 %attr(755,root,root) %{_bindir}/glxinfo
634
635 %files dri-driver-ati-mach64
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
638
639 %files dri-driver-ati-radeon-R100
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
642
643 %files dri-driver-ati-radeon-R200
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
646
647 %files dri-driver-ati-radeon-R300
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
650
651 %files dri-driver-ati-rage128
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
654
655 # sunffb (sparc only)
656 %ifarch sparc sparcv9 sparc64
657 %files dri-driver-ffb
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
660 %endif
661
662 # glint (requires update)
663 %if 0
664 %files dri-driver-glint
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
667 %endif
668
669 %files dri-driver-intel-i810
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
672
673 %if 0
674 %files dri-driver-intel-i830
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
677 %endif
678
679 %files dri-driver-intel-i915
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
682
683 %files dri-driver-matrox
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
686
687 %files dri-driver-s3virge
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
690
691 %files dri-driver-savage
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
694
695 %ifarch %{ix86} %{x8664}
696 %files dri-driver-sis
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
699 %endif
700
701 %files dri-driver-tdfx
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
704
705 %files dri-driver-trident
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
708
709 %files dri-driver-via-unichrome
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
712
713 %files demos
714 %defattr(644,root,root,755)
715 %{_examplesdir}/%{name}-%{version}
This page took 0.103847 seconds and 4 git commands to generate.