]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- new doc
[packages/Mesa.git] / Mesa.spec
1 #
2 # _with_glide: with GLIDE
3 #
4 Summary:        Free OpenGL implementation
5 Summary(pl):    Bezp³atna implementacja standardu OpenGL
6 Name:           Mesa
7 Version:        4.0.3
8 Release:        1
9 License:        MIT (core), LGPL (MesaGLU), SGI (GLU,libGLw) and others - see COPYRIGHT file
10 Group:          X11/Libraries
11 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/mesa3d/%{name}Lib-%{version}.tar.bz2
12 Source1:        ftp://ftp.sourceforge.net/pub/sourceforge/mesa3d/%{name}Demos-%{version}.tar.bz2
13 Patch0:         %{name}-am.patch
14 Patch1:         %{name}-ac.patch
15 Patch2:         %{name}-paths.patch
16 Patch3:         %{name}-libGLw.patch
17 URL:            http://www.mesa3d.org/
18 BuildRequires:  XFree86-devel
19 BuildRequires:  autoconf
20 BuildRequires:  motif-devel
21 BuildRequires:  perl
22 %ifarch %{ix86} alpha
23 %{?_with_glide:BuildRequires:   Glide3-DRI-devel}
24 %{?_with_glide:Requires:        Glide3-DRI}
25 %endif
26 Provides:       OpenGL
27 Obsoletes:      XFree86-OpenGL-core XFree86-OpenGL-libs
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # avoid XFree86-OpenGL* dependency
31 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
32 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
33
34 %define         _prefix         /usr/X11R6
35 %define         _mandir         %{_prefix}/man
36
37 %description
38 Mesa is a 3-D graphics library with an API which is very similar to
39 that of OpenGL*. To the extent that Mesa utilizes the OpenGL command
40 syntax or state machine, it is being used with authorization from
41 Silicon Graphics, Inc. However, the author makes no claim that Mesa is
42 in any way a compatible replacement for OpenGL or associated with
43 Silicon Graphics, Inc. Those who want a licensed implementation of
44 OpenGL should contact a licensed vendor. This software is distributed
45 under the terms of the GNU Library General Public License, see the
46 LICENSE file for details.
47
48 - OpenGL(R) is a registered trademark of Silicon Graphics, Inc.
49
50 %description -l pl
51 Mesa jest bibliotek± 3D bêd±c± darmowym odpowiednikiem standardu
52 OpenGL(*).
53
54 - OpenGL jest zastrze¿onym znakiem towarowym firmy Silicon Graphics,
55   Inc.
56
57 %package devel
58 Summary:        Development environment for Mesa
59 Summary(pl):    ¦rodowisko programistyczne biblioteki Mesa
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}
62 Requires:       XFree86-devel
63 Provides:       OpenGL-devel
64 Obsoletes:      XFree86-OpenGL-devel
65
66 %description devel
67 Header files and documentation needed for development.
68
69 %description devel -l pl
70 Pliki nag³ówkowe i dokumentacja do Mesy.
71
72 %package static
73 Summary:        Mesa static libraries
74 Summary(pl):    Biblioteki statyczne Mesy
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}
77 Provides:       OpenGL-static
78 Obsoletes:      XFree86-OpenGL-static
79
80 %description static
81 The static version of the Mesa libraries.
82
83 %description static -l pl
84 Biblioteki statyczne Mesy.
85
86 %package demos
87 Summary:        Mesa Demos
88 Summary(pl):    Demonstracje mo¿liwo¶ci bibliotek Mesa
89 Group:          Development/Libraries
90 Requires:       OpenGL-devel
91
92 %description demos
93 Demonstration programs for the Mesa libraries.
94
95 %description demos -l pl
96 Programy demonstracyjne dla bibliotek Mesa.
97
98 %prep
99 %setup -q -n Mesa-%{version} -b 1
100 %patch0 -p1
101 %patch1 -p1
102 #%patch2 -p1
103 %patch3 -p1
104
105 # fix demos
106 perl -pi -e "s,\.\./images/,%{_examplesdir}/Mesa/images/,g" demos/*
107
108 %build
109 %configure \
110         --enable-static \
111         --enable-shared \
112         --with-ggi="no" \
113         --with-svga="no" \
114         --disable-ggi-fbdev \
115         --disable-ggi-genkgi \
116         --enable-optimize \
117         %{!?_with_glide:--without-glide} \
118 %ifarch %{ix86} \
119         --enable-x86 \
120   %ifarch i586 i686 k6 athlon \
121         --enable-mmx \
122         --enable-3dnow \
123     %ifarch i686 athlon \
124         --enable-katmai \
125     %else \
126         --disable-katmai \
127     %endif \
128   %else \
129         --disable-mmx \
130         --disable-3dnow \
131   %endif \
132 %else \
133 %ifarch sparc \
134         --enable-sparc \
135 %endif \
136         --disable-x86 \
137         --disable-mmx \
138         --disable-3dnow
139 %endif
140
141 %{__make}
142         
143 (cd widgets-mesa
144 %{__autoconf}
145 %configure \
146         --with-motif
147 %{__make} || :
148 )
149
150 (cd widgets-sgi
151 touch depend
152 %{__make} dep
153 %{__make} linux OPTFLAGS="%{rpmcflags}"
154 )
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158 %{__make} install DESTDIR=$RPM_BUILD_ROOT
159
160 install -d $RPM_BUILD_ROOT%{_mandir}/man3
161
162 (cd widgets-mesa
163 %{__make} install \
164         prefix=$RPM_BUILD_ROOT%{_prefix} \
165         mandir=$RPM_BUILD_ROOT%{_mandir}/man3
166 # Mesa widgets are not binary compatible with SGI ones
167 cd $RPM_BUILD_ROOT%{_includedir}/GL
168 mkdir Mesa-widgets
169 mv -f GLw*.h Mesa*.h Mesa-widgets
170 )
171
172 install widgets-sgi/libGLw* $RPM_BUILD_ROOT%{_libdir}
173 install widgets-sgi/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
174
175 install -d $RPM_BUILD_ROOT/usr/src/examples/Mesa
176 for l in book demos samples xdemos images ; do
177         cp -Rf $l $RPM_BUILD_ROOT%{_examplesdir}/Mesa/$l
178 done
179
180 rm -f docs/*~
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc docs/CONFIG
190 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mesa.conf
191 %attr(755,root,root) %{_libdir}/libGL*.so.*.*
192 %attr(755,root,root) %{_libdir}/libGL.so
193 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
194
195 %files devel
196 %defattr(644,root,root,755)
197 %doc docs/{IAFA-PACKAGE,README,RELNOTES-*,VERSIONS,CONFORM,COPYRIGHT,DEVINFO,*.spec}
198 %doc docs/README.{3DFX,GGI,MITS,QUAKE,X11,THREADS}
199 %attr(755,root,root) %{_libdir}/libGLU.so
200 %attr(755,root,root) %{_libdir}/libOSMesa.so
201 %{_libdir}/libGLw.a
202 %{_libdir}/libMesaGLw*.a
203 %dir %{_includedir}/GL
204 %{_includedir}/GL/Mesa-widgets
205 %{_includedir}/GL/GLwDrawA.h
206 %{_includedir}/GL/GLwDrawAP.h
207 %{_includedir}/GL/GLwMDrawA.h
208 %{_includedir}/GL/GLwMDrawAP.h
209 %{_includedir}/GL/gl.h
210 %{_includedir}/GL/glext.h
211 %{_includedir}/GL/gl_mangle.h
212 %{_includedir}/GL/glu.h
213 %{_includedir}/GL/glu_mangle.h
214 %{_includedir}/GL/glx.h
215 %{_includedir}/GL/glxext.h
216 %{_includedir}/GL/glx_mangle.h
217 %{_includedir}/GL/osmesa.h
218 %{_includedir}/GL/xmesa.h
219 %{_includedir}/GL/xmesa_x.h
220 %{_includedir}/GL/xmesa_xf86.h
221 %{_mandir}/man3/*
222
223 %files static
224 %defattr(644,root,root,755)
225 %{_libdir}/libGL.a
226 %{_libdir}/libGLU.a
227 %{_libdir}/libOSMesa.a
228
229 %files demos
230 %defattr(644,root,root,755)
231 %dir %{_examplesdir}/Mesa
232 %dir %{_examplesdir}/Mesa/book
233 %dir %{_examplesdir}/Mesa/demos
234 %dir %{_examplesdir}/Mesa/samples
235 %dir %{_examplesdir}/Mesa/xdemos
236
237 %doc %{_examplesdir}/Mesa/book/*
238 %doc %{_examplesdir}/Mesa/demos/*
239 %doc %{_examplesdir}/Mesa/samples/*
240 %doc %{_examplesdir}/Mesa/xdemos/*
This page took 0.055372 seconds and 4 git commands to generate.