]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- de-adapterized
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 #
5 # Conditional build:
6 %bcond_with     glide   # with GLIDE (broken now)
7 %bcond_without  motif   # build static libGLw without Motif interface
8 #
9 Summary:        Free OpenGL implementation
10 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
11 Name:           Mesa
12 Version:        6.4.1
13 Release:        2.1
14 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
17 # Source0-md5:  ea148c828ec6f645526451db1b8556f1
18 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
19 # Source1-md5:  99df1fdcb98d391666b476ca6f1dda8a
20 Patch0:         %{name}-modules_dir.patch
21 URL:            http://www.mesa3d.org/
22 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
23 BuildRequires:  expat-devel
24 BuildRequires:  libdrm-devel >= 1.0.4-1.20051022
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.4d
27 %{?with_motif:BuildRequires:    motif-devel}
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  xorg-lib-libXt-devel
30 BuildRequires:  xorg-lib-libXxf86vm-devel
31 BuildRequires:  xorg-proto-glproto-devel
32 BuildRequires:  xorg-util-makedepend
33 Obsoletes:      Mesa-dri
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # avoid XFree86-OpenGL* dependency
37 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
39
40 %define         _sysconfdir     /etc/X11
41
42 %description
43 Mesa is a 3-D graphics library with an API which is very similar to
44 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
45 syntax or state machine, it is being used with authorization from
46 Silicon Graphics, Inc. However, the author does not possess an OpenGL
47 license from SGI, and makes no claim that Mesa is in any way a
48 compatible replacement for OpenGL or associated with SGI.
49
50 %description -l pl
51 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
52 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
53 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
54 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
55 OpenGL ani powi±zana z SGI.
56
57 %package libGL
58 Summary:        Free Mesa3D implementation of libGL OpenGL library
59 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
60 License:        MIT
61 Group:          X11/Libraries
62 %{?with_glide:Requires: Glide3-DRI}
63 Provides:       OpenGL = 1.5
64 # reports version 1.3, but supports glXGetProcAddress() from 1.4
65 Provides:       OpenGL-GLX = 1.4
66 Obsoletes:      Mesa
67 Obsoletes:      XFree86-OpenGL-libGL
68
69 %description libGL
70 Mesa is a 3-D graphics library with an API which is very similar to
71 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
72 syntax or state machine, it is being used with authorization from
73 Silicon Graphics, Inc. However, the author does not possess an OpenGL
74 license from SGI, and makes no claim that Mesa is in any way a
75 compatible replacement for OpenGL or associated with SGI.
76
77 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
78 specifications. It uses DRI for rendering.
79
80 %description libGL -l pl
81 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
82 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
83 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
84 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
85 OpenGL ani powi±zana z SGI.
86
87 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
88 GLX 1.4. U¿ywa DRI do renderowania.
89
90 %package libGL-devel
91 Summary:        Header files for Mesa3D libGL library
92 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
93 License:        MIT
94 Group:          X11/Development/Libraries
95 # loose dependency on libGL to use with other libGL binaries
96 Requires:       OpenGL >= 1.5
97 Requires:       xorg-lib-libX11-devel
98 Provides:       OpenGL-devel = 1.5
99 Provides:       OpenGL-GLX-devel = 1.4
100 Obsoletes:      Mesa-devel
101 Obsoletes:      XFree86-OpenGL-devel
102 Obsoletes:      XFree86-OpenGL-devel-base
103
104 %description libGL-devel
105 Header files for Mesa3D libGL library.
106
107 %description libGL-devel -l pl
108 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
109
110 %package libGL-static
111 Summary:        Static Mesa3D libGL library
112 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
113 License:        MIT
114 Group:          X11/Development/Libraries
115 Requires:       %{name}-libGL-devel = %{version}-%{release}
116 Provides:       OpenGL-static = 1.5
117 Obsoletes:      Mesa-static
118
119 %description libGL-static
120 Static Mesa3D libGL library. It uses software renderer.
121
122 %description libGL-static -l pl
123 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
124 renderingu.
125
126 %package libGLU
127 Summary:        SGI implementation of libGLU OpenGL library
128 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
129 License:        SGI Free Software License B v1.1
130 Group:          Libraries
131 # loose dependency on libGL.so.1 to use with other libGL binaries
132 Requires:       OpenGL >= 1.2
133 Provides:       OpenGL-GLU = 1.3
134 Obsoletes:      Mesa-devel
135 Obsoletes:      XFree86-OpenGL-libs
136
137 %description libGLU
138 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
139 1.3 specifications.
140
141 %description libGLU -l pl
142 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
143 specyfikacjê OpenGL GLU 1.3.
144
145 %package libGLU-devel
146 Summary:        Header files for SGI libGLU library
147 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
148 License:        SGI Free Software License B v1.1
149 Group:          Development/Libraries
150 Requires:       %{name}-libGLU = %{version}-%{release}
151 Requires:       OpenGL-devel >= 1.2
152 Requires:       libstdc++-devel
153 Provides:       OpenGL-GLU-devel = 1.3
154
155 %description libGLU-devel
156 Header files for SGI libGLU library.
157
158 %description libGLU-devel -l pl
159 Pliki nag³ówkowe biblioteki SGI libGLU.
160
161 %package libGLU-static
162 Summary:        Static SGI libGLU library
163 Summary(pl):    Statyczna biblioteka SGI libGLU
164 License:        SGI Free Software License B v1.1
165 Group:          Development/Libraries
166 Requires:       %{name}-libGLU-devel = %{version}-%{release}
167 Provides:       OpenGL-GLU-static = 1.3
168
169 %description libGLU-static
170 Static SGI libGLU library.
171
172 %description libGLU-static -l pl
173 Statyczna biblioteka SGI libGLU.
174
175 %package libGLw
176 Summary:        SGI OpenGL Xt widgets library
177 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
178 License:        SGI MIT-like
179 Group:          Libraries
180 # loose dependency on libGL.so.1 to use with other libGL binaries
181 Requires:       OpenGL >= 1.1
182 Provides:       OpenGL-GLw
183
184 %description libGLw
185 SGI OpenGL Xt widgets library.
186
187 %description libGLU -l pl
188 Biblioteka SGI widgetów Xt dla OpenGL-a.
189
190 %package libGLw-devel
191 Summary:        Header files for SGI libGLw library
192 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
193 License:        SGI Free Software License B v1.1
194 Group:          Development/Libraries
195 Requires:       %{name}-libGLw = %{version}-%{release}
196 Requires:       OpenGL-devel >= 1.2
197 Provides:       OpenGL-GLw-devel
198
199 %description libGLw-devel
200 Header files for SGI libGLw library.
201
202 %description libGLw-devel -l pl
203 Pliki nag³ówkowe biblioteki SGI libGLw.
204
205 %package libGLw-static
206 Summary:        Static SGI libGLw library
207 Summary(pl):    Statyczna biblioteka SGI libGLw
208 License:        SGI Free Software License B v1.1
209 Group:          Development/Libraries
210 Requires:       %{name}-libGLw-devel = %{version}-%{release}
211 Provides:       OpenGL-GLw-static
212
213 %description libGLw-static
214 Static SGI libGLw library.
215
216 %description libGLw-static -l pl
217 Statyczna biblioteka SGI libGLw.
218
219 %package utils
220 Summary:        OpenGL utilities from Mesa3D
221 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
222 Group:          X11/Applications/Graphics
223 # loose deps on libGL/libGLU
224
225 %description utils
226 OpenGL utilities from Mesa3D: glxgears and glxinfo.
227
228 %description utils -l pl
229 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
230
231 %package demos
232 Summary:        Mesa Demos
233 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
234 Group:          Development/Libraries
235 Requires:       OpenGL-devel
236
237 %description demos
238 Demonstration programs for the Mesa libraries.
239
240 %description demos -l pl
241 Programy demonstracyjne dla bibliotek Mesa.
242
243 %package dri-driver-ati-mach64
244 Summary:        X.org DRI drivers
245 Summary(pl):    Sterowniki DRI dla X.org
246 Group:          Development/Libraries
247 Requires:       xorg-xserver-server
248
249 %description dri-driver-ati-mach64
250 X.org DRI drivers for ATI mach64 card family.
251
252 %description dri-driver-ati-mach64 -l pl
253 Sterowniki X.org DRI dla rodziny kart ATI mach64.
254
255 %package dri-driver-ati-radeon-R100
256 Summary:        X.org DRI drivers
257 Summary(pl):    Sterowniki DRI dla X.org
258 Group:          Development/Libraries
259 Requires:       xorg-xserver-server
260
261 %description dri-driver-ati-radeon-R100
262 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
263
264 %description dri-driver-ati-radeon-R100 -l pl
265 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
266
267 %package dri-driver-ati-radeon-R200
268 Summary:        X.org DRI drivers
269 Summary(pl):    Sterowniki DRI dla X.org
270 Group:          Development/Libraries
271 Requires:       xorg-xserver-server
272
273 %description dri-driver-ati-radeon-R200
274 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
275
276 %description dri-driver-ati-radeon-R200 -l pl
277 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
278
279 %package dri-driver-ati-radeon-R300
280 Summary:        X.org DRI drivers
281 Summary(pl):    Sterowniki DRI dla X.org
282 Group:          Development/Libraries
283 Requires:       xorg-xserver-server
284
285 %description dri-driver-ati-radeon-R300
286 X.org DRI drivers for ATI R300 card family.
287
288 %description dri-driver-ati-radeon-R300 -l pl
289 Sterowniki X.org DRI dla rodziny kart ATI R300.
290
291 %package dri-driver-ati-rage128
292 Summary:        X.org DRI drivers
293 Summary(pl):    Sterowniki DRI dla X.org
294 Group:          Development/Libraries
295 Requires:       xorg-xserver-server
296
297 %description dri-driver-ati-rage128
298 X.org DRI drivers for ATI rage128 card family.
299
300 %description dri-driver-ati-rage128 -l pl
301 Sterowniki X.org DRI dla rodziny kart ATI rage128.
302
303 %package dri-driver-ffb
304 Summary:        X.org DRI drivers
305 Summary(pl):    Sterowniki DRI dla X.org
306 Group:          Development/Libraries
307 Requires:       xorg-xserver-server
308
309 %description dri-driver-ffb
310 X.org DRI drivers for SUN Creator3D and Elite3D card family.
311
312 %description dri-driver-ffb -l pl
313 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
314
315 %package dri-driver-glint
316 Summary:        X.org DRI drivers
317 Summary(pl):    Sterowniki DRI dla X.org
318 Group:          Development/Libraries
319 Requires:       xorg-xserver-server
320
321 %description dri-driver-glint
322 X.org DRI drivers for GLINT/Permedia card family.
323
324 %description dri-driver-glint -l pl
325 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
326
327 %package dri-driver-intel-i810
328 Summary:        X.org DRI drivers
329 Summary(pl):    Sterowniki DRI dla X.org
330 Group:          Development/Libraries
331 Requires:       xorg-xserver-server
332
333 %description dri-driver-intel-i810
334 X.org DRI drivers for Intel i810 card family.
335
336 %description dri-driver-intel-i810 -l pl
337 Sterowniki X.org DRI dla rodziny kart i810.
338
339 %package dri-driver-intel-i830
340 Summary:        X.org DRI drivers
341 Summary(pl):    Sterowniki DRI dla X.org
342 Group:          Development/Libraries
343 Requires:       xorg-xserver-server
344
345 %description dri-driver-intel-i830
346 X.org DRI drivers for Intel i830 card family.
347
348 %description dri-driver-intel-i830 -l pl
349 Sterowniki X.org DRI dla rodziny kart i830.
350
351 %package dri-driver-intel-i915
352 Summary:        X.org DRI drivers
353 Summary(pl):    Sterowniki DRI dla X.org
354 Group:          Development/Libraries
355 Requires:       xorg-xserver-server
356
357 %description dri-driver-intel-i915
358 X.org DRI drivers for Intel i915 card family.
359
360 %description dri-driver-intel-i915 -l pl
361 Sterowniki X.org DRI dla rodziny kart i915.
362
363 %package dri-driver-matrox
364 Summary:        X.org DRI drivers
365 Summary(pl):    Sterowniki DRI dla X.org
366 Group:          Development/Libraries
367 Requires:       xorg-xserver-server
368
369 %description dri-driver-matrox
370 X.org DRI drivers for Matrox G card family.
371
372 %description dri-driver-matrox -l pl
373 Sterowniki X.org DRI dla rodziny kart Matrox G.
374
375 %package dri-driver-s3virge
376 Summary:        X.org DRI drivers
377 Summary(pl):    Sterowniki DRI dla X.org
378 Group:          Development/Libraries
379 Requires:       xorg-xserver-server
380
381 %description dri-driver-s3virge
382 X.org DRI drivers for S3 Virge card family.
383
384 %description dri-driver-s3virge -l pl
385 Sterowniki X.org DRI dla rodziny kart S3 Virge.
386
387 %package dri-driver-savage
388 Summary:        X.org DRI drivers
389 Summary(pl):    Sterowniki DRI dla X.org
390 Group:          Development/Libraries
391 Requires:       xorg-xserver-server
392
393 %description dri-driver-savage
394 X.org DRI drivers for S3 Savage card family.
395
396 %description dri-driver-savage -l pl
397 Sterowniki X.org DRI dla rodziny kart S3 Savage.
398
399 %package dri-driver-sis
400 Summary:        X.org DRI drivers
401 Summary(pl):    Sterowniki DRI dla X.org
402 Group:          Development/Libraries
403 Requires:       xorg-xserver-server
404
405 %description dri-driver-sis
406 X.org DRI drivers for SiS card family.
407
408 %description dri-driver-sis -l pl
409 Sterowniki X.org DRI dla rodziny kart SiS.
410
411 %package dri-driver-tdfx
412 Summary:        X.org DRI drivers
413 Summary(pl):    Sterowniki DRI dla X.org
414 Group:          Development/Libraries
415 Requires:       xorg-xserver-server
416
417 %description dri-driver-tdfx
418 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
419 and Velocity 100/200).
420
421 %description dri-driver-tdfx -l pl
422 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
423 Banshee and Velocity 100/200).
424
425 %package dri-driver-trident
426 Summary:        X.org DRI drivers
427 Summary(pl):    Sterowniki DRI dla X.org
428 Group:          Development/Libraries
429 Requires:       xorg-xserver-server
430
431 %description dri-driver-trident
432 X.org DRI drivers for Trident card family.
433
434 %description dri-driver-trident -l pl
435 Sterowniki X.org DRI dla rodziny kart Trident.
436
437 %package dri-driver-via-unichrome
438 Summary:        X.org DRI drivers
439 Summary(pl):    Sterowniki DRI dla X.org
440 Group:          Development/Libraries
441 Requires:       xorg-xserver-server
442
443 %description dri-driver-via-unichrome
444 X.org DRI drivers for VIA Unichrome card family.
445
446 %description dri-driver-via-unichrome -l pl
447 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
448
449 %prep
450 %setup -q -n Mesa-%{version} -b 1
451 %patch0 -p1
452
453 # fix demos
454 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
455
456 %ifnarch sparc sparcv9 sparc64
457 # for sunffb driver - useful on sparc only
458 sed -i -e 's/ ffb$//' configs/linux-dri
459 %endif
460
461 %build
462 %ifarch %{ix86}
463 targ=-x86
464 %else
465 targ=""
466 %endif
467
468 %{__make} linux${targ}-static \
469         CC="%{__cc}" \
470         CXX="%{__cxx}" \
471         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
472         XLIB_DIR=%{_libdir} \
473         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
474         SRC_DIRS="mesa glu glw" \
475         PROGRAM_DIRS=
476 mv -f lib lib-static
477 %{__make} clean
478
479 %{__make} linux-dri${targ} \
480         CC="%{__cc}" \
481         CXX="%{__cxx}" \
482         MKDEP=makedepend \
483         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
484         XLIB_DIR=%{_libdir} \
485         SRC_DIRS="glx/x11 mesa glu glw" \
486         PROGRAM_DIRS=
487
488 %{__make} -C progs/xdemos \
489         CC="%{__cc}" \
490         CXX="%{__cxx}" \
491         OPT_FLAGS="%{rpmcflags}" \
492         XLIB_DIR=%{_libdir} \
493         PROGS="glxgears" \
494         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL"
495
496 %{__make} -C progs/xdemos \
497         CC="%{__cc}" \
498         CXX="%{__cxx}" \
499         OPT_FLAGS="%{rpmcflags}" \
500         XLIB_DIR=%{_libdir} \
501         PROGS="glxinfo" \
502         APP_LIB_DEPS="-L\$(LIB_DIR) -lGL -L../../lib-dri -lGLU"
503
504 mv -f lib lib-dri
505 %{__make} clean \
506         MKDEP=makedepend
507
508 %{__make} linux${targ} \
509         CC="%{__cc}" \
510         CXX="%{__cxx}" \
511         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
512         XLIB_DIR=%{_libdir} \
513         SRC_DIRS="mesa" \
514         PROGRAM_DIRS=
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
519 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
520
521 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
522 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
523 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
524 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
525 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
526
527 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
528 for l in demos redbook samples xdemos ; do
529         %{__make} -C progs/$l clean
530 done
531 for l in demos redbook samples util xdemos images ; do
532         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
533 done
534 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
535
536 %clean
537 rm -rf $RPM_BUILD_ROOT
538
539 %post   libGL -p /sbin/ldconfig
540 %postun libGL -p /sbin/ldconfig
541
542 %post   libGLU -p /sbin/ldconfig
543 %postun libGLU -p /sbin/ldconfig
544
545 %post   libGLw -p /sbin/ldconfig
546 %postun libGLw -p /sbin/ldconfig
547
548 %files libGL
549 %defattr(644,root,root,755)
550 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS,X11},RELNOTES*,VERSIONS}
551 %attr(755,root,root) %{_libdir}/libGL.so.*.*
552 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
553 # symlink for binary apps which fail to conform Linux OpenGL ABI
554 # (and dlopen libGL.so instead of libGL.so.1)
555 %attr(755,root,root) %{_libdir}/libGL.so
556
557 %files libGL-devel
558 %defattr(644,root,root,755)
559 %doc docs/*.spec
560 %attr(755,root,root) %{_libdir}/libOSMesa.so
561 %dir %{_includedir}/GL
562 %{_includedir}/GL/gl.h
563 %{_includedir}/GL/glext.h
564 %{_includedir}/GL/gl_mangle.h
565 %{_includedir}/GL/glx.h
566 %{_includedir}/GL/glxext.h
567 %{_includedir}/GL/glx_mangle.h
568 %{_includedir}/GL/osmesa.h
569 %{_includedir}/GL/xmesa.h
570 %{_includedir}/GL/xmesa_x.h
571 %{_includedir}/GL/xmesa_xf86.h
572
573 %files libGL-static
574 %defattr(644,root,root,755)
575 %{_libdir}/libGL.a
576 %{_libdir}/libOSMesa.a
577
578 %files libGLU
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
581
582 %files libGLU-devel
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/libGLU.so
585 %{_includedir}/GL/glu.h
586 %{_includedir}/GL/glu_mangle.h
587
588 %files libGLU-static
589 %defattr(644,root,root,755)
590 %{_libdir}/libGLU.a
591
592 %files libGLw
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
595
596 %files libGLw-devel
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/libGLw.so
599 %{_includedir}/GL/GLwDrawA.h
600 %{_includedir}/GL/GLwDrawAP.h
601 %{_includedir}/GL/GLwMDrawA.h
602 %{_includedir}/GL/GLwMDrawAP.h
603
604 %files libGLw-static
605 %defattr(644,root,root,755)
606 %{_libdir}/libGLw.a
607
608 %files utils
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_bindir}/glxgears
611 %attr(755,root,root) %{_bindir}/glxinfo
612
613 %files dri-driver-ati-mach64
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
616
617 %files dri-driver-ati-radeon-R100
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
620
621 %files dri-driver-ati-radeon-R200
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
624
625 %files dri-driver-ati-radeon-R300
626 %defattr(644,root,root,755)
627 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
628
629 %files dri-driver-ati-rage128
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
632
633 # sunffb (sparc only)
634 %ifarch sparc sparcv9 sparc64
635 %files dri-driver-ffb
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
638 %endif
639
640 # glint (requires update)
641 %if 0
642 %files dri-driver-glint
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
645 %endif
646
647 %files dri-driver-intel-i810
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
650
651 %files dri-driver-intel-i830
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
654
655 %files dri-driver-intel-i915
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
658
659 %files dri-driver-matrox
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
662
663 %files dri-driver-s3virge
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
666
667 %files dri-driver-savage
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
670
671 %files dri-driver-sis
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
674
675 %files dri-driver-tdfx
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
678
679 %files dri-driver-trident
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
682
683 %files dri-driver-via-unichrome
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
686
687 %files demos
688 %defattr(644,root,root,755)
689 %{_examplesdir}/%{name}-%{version}
This page took 0.088537 seconds and 4 git commands to generate.