]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 7.5.1
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  demos   # don't build demos
8 %bcond_without  motif   # build static libGLw without Motif interface
9 %bcond_without  gallium
10 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
11 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
12 %bcond_with     static
13 #
14 # minimal supported xserver version
15 %define         xserver_ver     1.5.0
16 # glapi version (glapi tables in dri drivers and libglx must be in sync);
17 # set to current Mesa version on ABI break, when xserver tables get regenerated
18 # (until they start to be somehow versioned themselves)
19 %define         glapi_ver       7.1.0
20 #
21 Summary:        Free OpenGL implementation
22 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
23 Name:           Mesa
24 Version:        7.5.1
25 Release:        1%{?with_multigl:.mgl}
26 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
27 Group:          X11/Libraries
28 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
29 # Source0-md5:  877d6a4b24efc2b1d02aa553f262cba8
30 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
31 # Source1-md5:  785402e3b9f0e335538fcc6bf19f6987
32 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
33 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
34 Patch0:         %{name}-realclean.patch
35 Patch1:         %{name}-noveau-abi-0.0.15.patch
36 Patch2:         %{name}-sparc64.patch
37 URL:            http://www.mesa3d.org/
38 BuildRequires:  expat-devel
39 %{?with_demos:BuildRequires:    glew-devel}
40 BuildRequires:  libdrm-devel >= 2.4.12-3
41 BuildRequires:  libselinux-devel
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool >= 2:1.4d
44 %{?with_motif:BuildRequires:    motif-devel}
45 BuildRequires:  rpmbuild(macros) >= 1.470
46 BuildRequires:  sed >= 4.0
47 BuildRequires:  xorg-lib-libXdamage-devel
48 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
49 BuildRequires:  xorg-lib-libXt-devel
50 BuildRequires:  xorg-lib-libXxf86vm-devel
51 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
52 BuildRequires:  xorg-proto-glproto-devel
53 BuildRequires:  xorg-proto-printproto-devel
54 BuildRequires:  xorg-util-makedepend
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %if %{without gallium}
58 %undefine       with_gallium_intel
59 %endif
60
61 %description
62 Mesa is a 3-D graphics library with an API which is very similar to
63 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
64 syntax or state machine, it is being used with authorization from
65 Silicon Graphics, Inc. However, the author does not possess an OpenGL
66 license from SGI, and makes no claim that Mesa is in any way a
67 compatible replacement for OpenGL or associated with SGI.
68
69 %description -l pl.UTF-8
70 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
71 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
72 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
73 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
74 OpenGL ani powiązana z SGI.
75
76 %package libGL
77 Summary:        Free Mesa3D implementation of libGL OpenGL library
78 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
79 License:        MIT
80 Group:          X11/Libraries
81 Requires:       libdrm >= 2.4.5
82 Provides:       OpenGL = 2.1
83 # reports version 1.3, but supports glXGetProcAddress() from 1.4
84 Provides:       OpenGL-GLX = 1.4
85 Obsoletes:      Mesa
86 Obsoletes:      Mesa-dri
87 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
88 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
89
90 %description libGL
91 Mesa is a 3-D graphics library with an API which is very similar to
92 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
93 syntax or state machine, it is being used with authorization from
94 Silicon Graphics, Inc. However, the author does not possess an OpenGL
95 license from SGI, and makes no claim that Mesa is in any way a
96 compatible replacement for OpenGL or associated with SGI.
97
98 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
99 specifications. It uses DRI for rendering.
100
101 %description libGL -l pl.UTF-8
102 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
103 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
104 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
105 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
106 OpenGL ani powiązana z SGI.
107
108 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
109 GLX 1.4. Używa DRI do renderowania.
110
111 %package libGL-devel
112 Summary:        Header files for Mesa3D libGL library
113 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
114 License:        MIT
115 Group:          X11/Development/Libraries
116 # loose dependency on libGL to use with other libGL binaries
117 Requires:       OpenGL >= 1.5
118 Requires:       xorg-lib-libX11-devel
119 Provides:       OpenGL-GLX-devel = 1.4
120 Provides:       OpenGL-devel = 2.1
121 Obsoletes:      Mesa-devel
122 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
123 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
124 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
125 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
126
127 %description libGL-devel
128 Header files for Mesa3D libGL library.
129
130 %description libGL-devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
132
133 %package libGL-static
134 Summary:        Static Mesa3D libGL library
135 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
136 License:        MIT
137 Group:          X11/Development/Libraries
138 Requires:       %{name}-libGL-devel = %{version}-%{release}
139 Provides:       OpenGL-static = 2.1
140 Obsoletes:      Mesa-static
141 Obsoletes:      X11-OpenGL-static < 1:7.0.0
142 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
143
144 %description libGL-static
145 Static Mesa3D libGL library. It uses software renderer.
146
147 %description libGL-static -l pl.UTF-8
148 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
149 renderingu.
150
151 %package libGLU
152 Summary:        SGI implementation of libGLU OpenGL library
153 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
154 License:        SGI Free Software License B v2.0 (MIT-like)
155 Group:          Libraries
156 # loose dependency on libGL.so.1 to use with other libGL binaries
157 Requires:       OpenGL >= 1.2
158 Provides:       OpenGL-GLU = 1.3
159 Obsoletes:      Mesa-devel
160 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
161 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
162
163 %description libGLU
164 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
165 1.3 specifications.
166
167 %description libGLU -l pl.UTF-8
168 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
169 specyfikację OpenGL GLU 1.3.
170
171 %package libGLU-devel
172 Summary:        Header files for SGI libGLU library
173 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
174 License:        SGI Free Software License B v2.0 (MIT-like)
175 Group:          Development/Libraries
176 Requires:       %{name}-libGLU = %{version}-%{release}
177 Requires:       OpenGL-devel >= 1.2
178 Requires:       libstdc++-devel
179 Provides:       OpenGL-GLU-devel = 1.3
180
181 %description libGLU-devel
182 Header files for SGI libGLU library.
183
184 %description libGLU-devel -l pl.UTF-8
185 Pliki nagłówkowe biblioteki SGI libGLU.
186
187 %package libGLU-static
188 Summary:        Static SGI libGLU library
189 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
190 License:        SGI Free Software License B v2.0 (MIT-like)
191 Group:          Development/Libraries
192 Requires:       %{name}-libGLU-devel = %{version}-%{release}
193 Provides:       OpenGL-GLU-static = 1.3
194
195 %description libGLU-static
196 Static SGI libGLU library.
197
198 %description libGLU-static -l pl.UTF-8
199 Statyczna biblioteka SGI libGLU.
200
201 %package libGLw
202 Summary:        SGI OpenGL Xt widgets library
203 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
204 License:        SGI MIT-like
205 Group:          Libraries
206 # loose dependency on libGL.so.1 to use with other libGL binaries
207 Requires:       OpenGL >= 1.1
208 Provides:       OpenGL-GLw
209
210 %description libGLw
211 SGI OpenGL Xt widgets library.
212
213 %description libGLU -l pl.UTF-8
214 Biblioteka SGI widgetów Xt dla OpenGL-a.
215
216 %package libGLw-devel
217 Summary:        Header files for SGI libGLw library
218 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
219 License:        SGI MIT-like
220 Group:          Development/Libraries
221 Requires:       %{name}-libGLw = %{version}-%{release}
222 Requires:       OpenGL-devel >= 1.2
223 Provides:       OpenGL-GLw-devel
224
225 %description libGLw-devel
226 Header files for SGI libGLw library.
227
228 %description libGLw-devel -l pl.UTF-8
229 Pliki nagłówkowe biblioteki SGI libGLw.
230
231 %package libGLw-static
232 Summary:        Static SGI libGLw library
233 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
234 License:        SGI MIT-like
235 Group:          Development/Libraries
236 Requires:       %{name}-libGLw-devel = %{version}-%{release}
237 Provides:       OpenGL-GLw-static
238
239 %description libGLw-static
240 Static SGI libGLw library.
241
242 %description libGLw-static -l pl.UTF-8
243 Statyczna biblioteka SGI libGLw.
244
245 %package libOSMesa
246 Summary:        OSMesa (off-screen renderer) library
247 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
248 License:        MIT
249 Group:          Libraries
250 # doesn't require base
251
252 %description libOSMesa
253 OSMesa (off-screen renderer) library.
254
255 %description libOSMesa -l pl.UTF-8
256 Biblioteka OSMesa (renderująca bitmapy w pamięci).
257
258 %package libOSMesa-devel
259 Summary:        Header file for OSMesa (off-screen renderer) library
260 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
261 License:        MIT
262 Group:          Development/Libraries
263 Requires:       %{name}-libOSMesa = %{version}-%{release}
264 # for <GL/gl.h> only
265 Requires:       OpenGL-devel
266
267 %description libOSMesa-devel
268 Header file for OSMesa (off-screen renderer) library.
269
270 %description libOSMesa-devel -l pl.UTF-8
271 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
272
273 %package libOSMesa-static
274 Summary:        Static OSMesa (off-screen renderer) library
275 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
276 License:        MIT
277 Group:          Development/Libraries
278 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
279 # this static build of OSMesa needs static non-dri Mesa implementation
280 Requires:       %{name}-libGL-static = %{version}-%{release}
281
282 %description libOSMesa-static
283 Static OSMesa (off-screen renderer) library.
284
285 %description libOSMesa-static -l pl.UTF-8
286 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
287
288 %package utils
289 Summary:        OpenGL utilities from Mesa3D
290 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
291 License:        MIT
292 Group:          X11/Applications/Graphics
293 # loose deps on libGL/libGLU
294
295 %description utils
296 OpenGL utilities from Mesa3D: glxgears and glxinfo.
297
298 %description utils -l pl.UTF-8
299 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
300
301 %package demos
302 Summary:        Mesa Demos source code
303 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
304 License:        various (MIT, SGI, GPL - see copyright notes in sources)
305 Group:          Development/Libraries
306 Requires:       OpenGL-devel
307
308 %description demos
309 Demonstration programs for the Mesa libraries in source code form.
310
311 %description demos -l pl.UTF-8
312 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
313
314 %package dri-driver-ati-mach64
315 Summary:        X.org DRI driver for ATI Mach64 card family
316 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
317 License:        MIT
318 Group:          X11/Libraries
319 Requires:       xorg-driver-video-mach64
320 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
321 Requires:       xorg-xserver-server >= %{xserver_ver}
322
323 %description dri-driver-ati-mach64
324 X.org DRI driver for ATI Mach64 card family.
325
326 %description dri-driver-ati-mach64 -l pl.UTF-8
327 Sterownik X.org DRI dla rodziny kart ATI Mach64.
328
329 %package dri-driver-ati-radeon-R100
330 Summary:        X.org DRI driver for ATI R100 card family
331 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
332 License:        MIT
333 Group:          X11/Libraries
334 Requires:       xorg-driver-video-ati
335 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
336 Requires:       xorg-xserver-server >= %{xserver_ver}
337 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
338
339 %description dri-driver-ati-radeon-R100
340 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
341
342 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
343 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
344
345 %package dri-driver-ati-radeon-R200
346 Summary:        X.org DRI driver for ATI R200 card family
347 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
348 License:        MIT
349 Group:          X11/Libraries
350 Requires:       xorg-driver-video-ati
351 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
352 Requires:       xorg-xserver-server >= %{xserver_ver}
353 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
354
355 %description dri-driver-ati-radeon-R200
356 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
357
358 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
359 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
360
361 %package dri-driver-ati-radeon-R300
362 Summary:        X.org DRI driver for ATI R300 card family
363 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
364 License:        MIT
365 Group:          X11/Libraries
366 Requires:       xorg-driver-video-ati
367 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
368 Requires:       xorg-xserver-server >= %{xserver_ver}
369 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
370
371 %description dri-driver-ati-radeon-R300
372 X.org DRI driver for ATI R300 card family.
373
374 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
375 Sterownik X.org DRI dla rodziny kart ATI R300.
376
377 %package dri-driver-ati-rage128
378 Summary:        X.org DRI driver for ATI Rage128 card family
379 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
380 License:        MIT
381 Group:          X11/Libraries
382 Requires:       xorg-driver-video-r128
383 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
384 Requires:       xorg-xserver-server >= %{xserver_ver}
385 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
386
387 %description dri-driver-ati-rage128
388 X.org DRI driver for ATI Rage128 card family.
389
390 %description dri-driver-ati-rage128 -l pl.UTF-8
391 Sterownik X.org DRI dla rodziny kart ATI Rage128.
392
393 %package dri-driver-ffb
394 Summary:        X.org DRI driver for Sun FFB card family
395 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
396 License:        MIT
397 Group:          X11/Libraries
398 Requires:       xorg-driver-video-sunffb
399 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
400 Requires:       xorg-xserver-server >= %{xserver_ver}
401
402 %description dri-driver-ffb
403 X.org DRI driver for SUN Creator3D and Elite3D card family.
404
405 %description dri-driver-ffb -l pl.UTF-8
406 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
407
408 %package dri-driver-glint
409 Summary:        X.org DRI driver for GLINT/Permedia card family
410 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
411 License:        MIT
412 Group:          X11/Libraries
413 Requires:       xorg-driver-video-glint
414 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
415 Requires:       xorg-xserver-server >= %{xserver_ver}
416 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
417
418 %description dri-driver-glint
419 X.org DRI driver for GLINT/Permedia card family.
420
421 %description dri-driver-glint -l pl.UTF-8
422 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
423
424 %package dri-driver-intel-i810
425 Summary:        X.org DRI driver for Intel i810 card family
426 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
427 License:        MIT
428 Group:          X11/Libraries
429 Requires:       xorg-driver-video-intel
430 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
431 Requires:       xorg-xserver-server >= %{xserver_ver}
432 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
433
434 %description dri-driver-intel-i810
435 X.org DRI driver for Intel i810 card family.
436
437 %description dri-driver-intel-i810 -l pl.UTF-8
438 Sterownik X.org DRI dla rodziny kart Intel i810.
439
440 %package dri-driver-intel-i915
441 Summary:        X.org DRI driver for Intel i915 card family
442 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
443 License:        MIT
444 Group:          X11/Libraries
445 Requires:       xorg-driver-video-intel
446 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
447 Requires:       xorg-xserver-server >= %{xserver_ver}
448 Obsoletes:      Mesa-dri-driver-intel-i830
449 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
450
451 %description dri-driver-intel-i915
452 X.org DRI driver for Intel i915 card family.
453
454 %description dri-driver-intel-i915 -l pl.UTF-8
455 Sterownik X.org DRI dla rodziny kart Intel i915.
456
457 %package dri-driver-intel-i965
458 Summary:        X.org DRI driver for Intel i965 card family
459 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
460 License:        MIT
461 Group:          X11/Libraries
462 Requires:       xorg-driver-video-intel
463 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
464 Requires:       xorg-xserver-server >= %{xserver_ver}
465 Obsoletes:      Mesa-dri-driver-intel-i830
466 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
467
468 %description dri-driver-intel-i965
469 X.org DRI driver for Intel i965 card family.
470
471 %description dri-driver-intel-i965 -l pl.UTF-8
472 Sterownik X.org DRI dla rodziny kart Intel i965.
473
474 %package dri-driver-matrox
475 Summary:        X.org DRI driver for Matrox G card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       xorg-driver-video-mga
480 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
481 Requires:       xorg-xserver-server >= %{xserver_ver}
482 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
483
484 %description dri-driver-matrox
485 X.org DRI drivers for Matrox G card family.
486
487 %description dri-driver-matrox -l pl.UTF-8
488 Sterowniki X.org DRI dla rodziny kart Matrox G.
489
490 %package dri-driver-nouveau
491 Summary:        X.org DRI driver for NVIDIA card family
492 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
493 License:        MIT
494 Group:          X11/Libraries
495 Requires:       xorg-driver-video-nouveau
496 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
497 Requires:       xorg-xserver-server >= %{xserver_ver}
498
499 %description dri-driver-nouveau
500 X.org DRI drivers for NVIDIA card family.
501
502 %description dri-driver-nouveau -l pl.UTF-8
503 Sterowniki X.org DRI dla rodziny kart NVIDIA.
504
505 %package dri-driver-s3virge
506 Summary:        X.org DRI driver for S3 Virge card family
507 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
508 License:        MIT
509 Group:          X11/Libraries
510 Requires:       xorg-driver-video-s3virge
511 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
512 Requires:       xorg-xserver-server >= %{xserver_ver}
513
514 %description dri-driver-s3virge
515 X.org DRI driver for S3 Virge card family.
516
517 %description dri-driver-s3virge -l pl.UTF-8
518 Sterownik X.org DRI dla rodziny kart S3 Virge.
519
520 %package dri-driver-savage
521 Summary:        X.org DRI driver for S3 Savage card family
522 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
523 License:        MIT
524 Group:          X11/Libraries
525 Requires:       xorg-driver-video-savage
526 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
527 Requires:       xorg-xserver-server >= %{xserver_ver}
528
529 %description dri-driver-savage
530 X.org DRI driver for S3 Savage card family.
531
532 %description dri-driver-savage -l pl.UTF-8
533 Sterownik X.org DRI dla rodziny kart S3 Savage.
534
535 %package dri-driver-sis
536 Summary:        X.org DRI driver for SiS card family
537 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
538 License:        MIT
539 Group:          X11/Libraries
540 Requires:       xorg-driver-video-sis
541 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
542 Requires:       xorg-xserver-server >= %{xserver_ver}
543 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
544
545 %description dri-driver-sis
546 X.org DRI driver for SiS card family.
547
548 %description dri-driver-sis -l pl.UTF-8
549 Sterownik X.org DRI dla rodziny kart SiS.
550
551 %package dri-driver-swrast
552 Summary:        X.org DRI software rasterizer driver
553 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
554 License:        MIT
555 Group:          X11/Libraries
556 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
557 Requires:       xorg-xserver-server >= %{xserver_ver}
558
559 %description dri-driver-swrast
560 X.org DRI software rasterizer driver.
561
562 %description dri-driver-swrast -l pl.UTF-8
563 Sterownik X.org DRI obsługujący rysowanie programowe.
564
565 %package dri-driver-tdfx
566 Summary:        X.org DRI driver for 3DFX Voodoo card family
567 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
568 License:        MIT
569 Group:          X11/Libraries
570 Requires:       Glide3-DRI
571 Requires:       xorg-driver-video-tdfx
572 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
573 Requires:       xorg-xserver-server >= %{xserver_ver}
574 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
575
576 %description dri-driver-tdfx
577 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
578 and Velocity 100/200).
579
580 %description dri-driver-tdfx -l pl.UTF-8
581 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
582 Banshee i Velocity 100/200).
583
584 %package dri-driver-trident
585 Summary:        X.org DRI driver for Trident card family
586 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
587 License:        MIT
588 Group:          X11/Libraries
589 Requires:       xorg-driver-video-trident
590 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
591 Requires:       xorg-xserver-server >= %{xserver_ver}
592
593 %description dri-driver-trident
594 X.org DRI drivers for Trident card family.
595
596 %description dri-driver-trident -l pl.UTF-8
597 Sterowniki X.org DRI dla rodziny kart Trident.
598
599 %package dri-driver-via-unichrome
600 Summary:        X.org DRI driver for VIA Unichrome card family
601 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
602 License:        MIT
603 Group:          X11/Libraries
604 Requires:       xorg-driver-video-openchrome
605 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
606 Requires:       xorg-xserver-server >= %{xserver_ver}
607
608 %description dri-driver-via-unichrome
609 X.org DRI driver for VIA Unichrome card family.
610
611 %description dri-driver-via-unichrome -l pl.UTF-8
612 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
613
614 %prep
615 %setup -q -b1 -a2
616 %patch0 -p0
617 %patch1 -p1
618 %patch2 -p1
619
620 # fix demos
621 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
622
623 %build
624 [ ! -f configure ] && ./autogen.sh
625
626 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
627 %if %{without gallium_intel}
628 i915 \
629 %endif
630 %ifarch sparc sparcv9 sparc64
631 ffb \
632 %endif
633 %ifarch %{ix86} %{x8664}
634 sis \
635 %endif
636 swrast tdfx unichrome"
637
638 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
639
640 common_flags="\
641         --enable-shared \
642         --enable-selinux \
643         --enable-pic \
644         --enable-glx-tls \
645         --disable-egl \
646         --with%{!?with_demos:out}-demos"
647
648 # osmesa variants
649 %configure $common_flags \
650         --with-driver=osmesa \
651         --disable-asm \
652         --with-osmesa-bits=8
653 %{__make} \
654         SRC_DIRS=mesa
655 mv %{_lib} osmesa8
656 %{__make} clean
657
658 %configure $common_flags \
659         --with-driver=osmesa \
660         --disable-asm \
661         --with-osmesa-bits=16
662 %{__make} \
663         SRC_DIRS=mesa
664 mv %{_lib} osmesa16
665 %{__make} clean
666
667 %configure $common_flags \
668         --with-driver=osmesa \
669         --disable-asm \
670         --with-osmesa-bits=32
671 %{__make} \
672         SRC_DIRS=mesa
673 mv %{_lib} osmesa32
674 %{__make} clean
675
676 %configure $common_flags \
677         --enable-glu \
678         --enable-glw \
679         --disable-glut \
680 %if %{with gallium}
681         --enable-gallium \
682         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
683         --enable-gallium-nouveau \
684         --with-state-trackers=dri \
685 %else
686         --disable-gallium \
687 %endif
688         --with-driver=dri \
689         --with-dri-drivers=${dri_drivers} \
690         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
691
692 %{__make}
693 %{__make} -C progs/xdemos glxgears glxinfo
694 %if %{with demos}
695 %{__make} -C progs/demos
696 %endif
697
698 cd gl-manpages-*
699 %configure
700 %{__make}
701
702 %install
703 rm -rf $RPM_BUILD_ROOT
704
705 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
706
707 # libs without drivers
708 %{__make} install \
709         DESTDIR=$RPM_BUILD_ROOT
710
711 cd gl-manpages-*
712 %{__make} install \
713         DESTDIR=$RPM_BUILD_ROOT
714 cd ..
715
716 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
717
718 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
719 # work on copy to keep -bi --short-circuit working
720 rm -rf progs-clean
721 install -d progs-clean
722 for l in demos glsl osdemos redbook samples xdemos ; do
723         cp -a progs/$l progs-clean/$l
724         %{__make} -C progs-clean/$l clean
725         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
726 done
727 rm -rf progs-clean
728 for l in util images ; do
729         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
730 done
731 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
732
733 # strip out undesirable headers
734 olddir=$(pwd)
735 cd $RPM_BUILD_ROOT%{_includedir}/GL
736 rm [a-fh-np-wyz]*.h gg*.h glf*.h
737 cd $RPM_BUILD_ROOT%{_libdir}
738 cd $olddir
739
740 %if %{with multigl}
741 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
742
743 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
744 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
745
746 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
747 %endif
748
749 %clean
750 rm -rf $RPM_BUILD_ROOT
751
752 %post   libGL -p /sbin/ldconfig
753 %postun libGL -p /sbin/ldconfig
754
755 %post   libGLU -p /sbin/ldconfig
756 %postun libGLU -p /sbin/ldconfig
757
758 %post   libGLw -p /sbin/ldconfig
759 %postun libGLw -p /sbin/ldconfig
760
761 %files libGL
762 %defattr(644,root,root,755)
763 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
764 %if %{with multigl}
765 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
766 %dir %{_libdir}/Mesa
767 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
768 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
769 %else
770 %attr(755,root,root) %{_libdir}/libGL.so.*.*
771 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
772 # symlink for binary apps which fail to conform Linux OpenGL ABI
773 # (and dlopen libGL.so instead of libGL.so.1)
774 %attr(755,root,root) %{_libdir}/libGL.so
775 %endif
776
777 %files libGL-devel
778 %defattr(644,root,root,755)
779 %doc docs/*.spec
780 %if %{with multigl}
781 %attr(755,root,root) %{_libdir}/libGL.so
782 %endif
783 %dir %{_includedir}/GL
784 %{_includedir}/GL/gl.h
785 %{_includedir}/GL/glext.h
786 %{_includedir}/GL/gl_mangle.h
787 %{_includedir}/GL/glx.h
788 %{_includedir}/GL/glxext.h
789 %{_includedir}/GL/glx_mangle.h
790 %dir %{_includedir}/GL/internal
791 %{_includedir}/GL/internal/dri_interface.h
792 %{_pkgconfigdir}/dri.pc
793 %{_pkgconfigdir}/gl.pc
794 %{_mandir}/man3/gl[^uX]*.3gl*
795 %{_mandir}/man3/glX*.3gl*
796
797 %if %{with static}
798 %files libGL-static
799 %defattr(644,root,root,755)
800 %{_libdir}/libGL.a
801 %endif
802
803 %files libGLU
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
806 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
807
808 %files libGLU-devel
809 %defattr(644,root,root,755)
810 %attr(755,root,root) %{_libdir}/libGLU.so
811 %{_includedir}/GL/glu.h
812 %{_includedir}/GL/glu_mangle.h
813 %{_pkgconfigdir}/glu.pc
814 %{_mandir}/man3/glu*.3gl*
815
816 %if %{with static}
817 %files libGLU-static
818 %defattr(644,root,root,755)
819 %{_libdir}/libGLU.a
820 %endif
821
822 %files libGLw
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
826
827 %files libGLw-devel
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_libdir}/libGLw.so
830 %{_includedir}/GL/GLwDrawA.h
831 %{_includedir}/GL/GLwDrawAP.h
832 %{_includedir}/GL/GLwMDrawA.h
833 %{_includedir}/GL/GLwMDrawAP.h
834 %{_pkgconfigdir}/glw.pc
835
836 %if %{with static}
837 %files libGLw-static
838 %defattr(644,root,root,755)
839 %{_libdir}/libGLw.a
840 %endif
841
842 %files libOSMesa
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
845 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
846
847 %files libOSMesa-devel
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libOSMesa*.so
850 %{_includedir}/GL/osmesa.h
851
852 %if %{with static}
853 %files libOSMesa-static
854 %defattr(644,root,root,755)
855 %{_libdir}/libOSMesa*.a
856 %endif
857
858 %files utils
859 %defattr(644,root,root,755)
860 %attr(755,root,root) %{_bindir}/glxgears
861 %attr(755,root,root) %{_bindir}/glxinfo
862
863 %files dri-driver-ati-mach64
864 %defattr(644,root,root,755)
865 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
866
867 %files dri-driver-ati-radeon-R100
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
870
871 %files dri-driver-ati-radeon-R200
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
874
875 %files dri-driver-ati-radeon-R300
876 %defattr(644,root,root,755)
877 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
878
879 %files dri-driver-ati-rage128
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
882
883 # sunffb (sparc only)
884 %ifarch sparc sparcv9 sparc64
885 %files dri-driver-ffb
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
888 %endif
889
890 # glint (requires update)
891 %if 0
892 %files dri-driver-glint
893 %defattr(644,root,root,755)
894 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
895 %endif
896
897 %files dri-driver-intel-i810
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
900
901 %files dri-driver-intel-i915
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
904
905 %files dri-driver-intel-i965
906 %defattr(644,root,root,755)
907 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
908
909 %files dri-driver-matrox
910 %defattr(644,root,root,755)
911 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
912
913 %if %{with gallium}
914 %files dri-driver-nouveau
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri2.so
918 %endif
919
920 %files dri-driver-s3virge
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
923
924 %files dri-driver-savage
925 %defattr(644,root,root,755)
926 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
927
928 %ifarch %{ix86} %{x8664}
929 %files dri-driver-sis
930 %defattr(644,root,root,755)
931 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
932 %endif
933
934 %files dri-driver-swrast
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
937
938 %files dri-driver-tdfx
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
941
942 %files dri-driver-trident
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
945
946 %files dri-driver-via-unichrome
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
949
950 %if %{with demos}
951 %files demos
952 %defattr(644,root,root,755)
953 %{_examplesdir}/%{name}-%{version}
954 %endif
This page took 0.09808 seconds and 4 git commands to generate.