]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- BR glew-devel for demos
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - what's libEGL?
6 #
7 # Conditional build:
8 %bcond_without  motif   # build static libGLw without Motif interface
9 %bcond_without  gallium
10 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
11 %bcond_with     static
12 #
13 # minimal supported xserver version
14 %define         xserver_ver     1.5.0
15 # glapi version (glapi tables in dri drivers and libglx must be in sync);
16 # set to current Mesa version on ABI break, when xserver tables get regenerated
17 # (until they start to be somehow versioned themselves)
18 %define         glapi_ver       7.1.0
19 #
20 Summary:        Free OpenGL implementation
21 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
22 Name:           Mesa
23 Version:        7.5
24 Release:        1%{?with_multigl:.mgl}
25 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
26 Group:          X11/Libraries
27 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
28 # Source0-md5:  459f332551f6ebb86f384d21dd15e1f0
29 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
30 # Source1-md5:  398ee8801814a00e47f6c2314e3dfddc
31 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
32 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
33 Patch0:         %{name}-realclean.patch
34 URL:            http://www.mesa3d.org/
35 BuildRequires:  expat-devel
36 BuildRequires:  glew-devel
37 BuildRequires:  libdrm-devel >= 2.4.5
38 BuildRequires:  libselinux-devel
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool >= 2:1.4d
41 %{?with_motif:BuildRequires:    motif-devel}
42 BuildRequires:  rpmbuild(macros) >= 1.470
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  xorg-lib-libXdamage-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 BuildRequires:  xorg-lib-libXxf86vm-devel
47 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
48 BuildRequires:  xorg-proto-glproto-devel
49 BuildRequires:  xorg-proto-printproto-devel
50 BuildRequires:  xorg-util-makedepend
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Mesa is a 3-D graphics library with an API which is very similar to
55 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
56 syntax or state machine, it is being used with authorization from
57 Silicon Graphics, Inc. However, the author does not possess an OpenGL
58 license from SGI, and makes no claim that Mesa is in any way a
59 compatible replacement for OpenGL or associated with SGI.
60
61 %description -l pl.UTF-8
62 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
63 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
64 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
65 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
66 OpenGL ani powiązana z SGI.
67
68 %package libGL
69 Summary:        Free Mesa3D implementation of libGL OpenGL library
70 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
71 License:        MIT
72 Group:          X11/Libraries
73 Requires:       libdrm >= 2.4.5
74 Provides:       OpenGL = 2.1
75 # reports version 1.3, but supports glXGetProcAddress() from 1.4
76 Provides:       OpenGL-GLX = 1.4
77 Obsoletes:      Mesa
78 Obsoletes:      Mesa-dri
79 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
80 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
81
82 %description libGL
83 Mesa is a 3-D graphics library with an API which is very similar to
84 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
85 syntax or state machine, it is being used with authorization from
86 Silicon Graphics, Inc. However, the author does not possess an OpenGL
87 license from SGI, and makes no claim that Mesa is in any way a
88 compatible replacement for OpenGL or associated with SGI.
89
90 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
91 specifications. It uses DRI for rendering.
92
93 %description libGL -l pl.UTF-8
94 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
95 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
96 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
97 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
98 OpenGL ani powiązana z SGI.
99
100 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
101 GLX 1.4. Używa DRI do renderowania.
102
103 %package libGL-devel
104 Summary:        Header files for Mesa3D libGL library
105 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
106 License:        MIT
107 Group:          X11/Development/Libraries
108 # loose dependency on libGL to use with other libGL binaries
109 Requires:       OpenGL >= 1.5
110 Requires:       xorg-lib-libX11-devel
111 Provides:       OpenGL-devel = 2.1
112 Provides:       OpenGL-GLX-devel = 1.4
113 Obsoletes:      Mesa-devel
114 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
115 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
116 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
117 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
118
119 %description libGL-devel
120 Header files for Mesa3D libGL library.
121
122 %description libGL-devel -l pl.UTF-8
123 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
124
125 %package libGL-static
126 Summary:        Static Mesa3D libGL library
127 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
128 License:        MIT
129 Group:          X11/Development/Libraries
130 Requires:       %{name}-libGL-devel = %{version}-%{release}
131 Provides:       OpenGL-static = 2.1
132 Obsoletes:      Mesa-static
133 Obsoletes:      X11-OpenGL-static < 1:7.0.0
134 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
135
136 %description libGL-static
137 Static Mesa3D libGL library. It uses software renderer.
138
139 %description libGL-static -l pl.UTF-8
140 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
141 renderingu.
142
143 %package libGLU
144 Summary:        SGI implementation of libGLU OpenGL library
145 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
146 License:        SGI Free Software License B v2.0 (MIT-like)
147 Group:          Libraries
148 # loose dependency on libGL.so.1 to use with other libGL binaries
149 Requires:       OpenGL >= 1.2
150 Provides:       OpenGL-GLU = 1.3
151 Obsoletes:      Mesa-devel
152 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
153 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
154
155 %description libGLU
156 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
157 1.3 specifications.
158
159 %description libGLU -l pl.UTF-8
160 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
161 specyfikację OpenGL GLU 1.3.
162
163 %package libGLU-devel
164 Summary:        Header files for SGI libGLU library
165 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
166 License:        SGI Free Software License B v2.0 (MIT-like)
167 Group:          Development/Libraries
168 Requires:       %{name}-libGLU = %{version}-%{release}
169 Requires:       OpenGL-devel >= 1.2
170 Requires:       libstdc++-devel
171 Provides:       OpenGL-GLU-devel = 1.3
172
173 %description libGLU-devel
174 Header files for SGI libGLU library.
175
176 %description libGLU-devel -l pl.UTF-8
177 Pliki nagłówkowe biblioteki SGI libGLU.
178
179 %package libGLU-static
180 Summary:        Static SGI libGLU library
181 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
182 License:        SGI Free Software License B v2.0 (MIT-like)
183 Group:          Development/Libraries
184 Requires:       %{name}-libGLU-devel = %{version}-%{release}
185 Provides:       OpenGL-GLU-static = 1.3
186
187 %description libGLU-static
188 Static SGI libGLU library.
189
190 %description libGLU-static -l pl.UTF-8
191 Statyczna biblioteka SGI libGLU.
192
193 %package libGLw
194 Summary:        SGI OpenGL Xt widgets library
195 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
196 License:        SGI MIT-like
197 Group:          Libraries
198 # loose dependency on libGL.so.1 to use with other libGL binaries
199 Requires:       OpenGL >= 1.1
200 Provides:       OpenGL-GLw
201
202 %description libGLw
203 SGI OpenGL Xt widgets library.
204
205 %description libGLU -l pl.UTF-8
206 Biblioteka SGI widgetów Xt dla OpenGL-a.
207
208 %package libGLw-devel
209 Summary:        Header files for SGI libGLw library
210 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
211 License:        SGI MIT-like
212 Group:          Development/Libraries
213 Requires:       %{name}-libGLw = %{version}-%{release}
214 Requires:       OpenGL-devel >= 1.2
215 Provides:       OpenGL-GLw-devel
216
217 %description libGLw-devel
218 Header files for SGI libGLw library.
219
220 %description libGLw-devel -l pl.UTF-8
221 Pliki nagłówkowe biblioteki SGI libGLw.
222
223 %package libGLw-static
224 Summary:        Static SGI libGLw library
225 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
226 License:        SGI MIT-like
227 Group:          Development/Libraries
228 Requires:       %{name}-libGLw-devel = %{version}-%{release}
229 Provides:       OpenGL-GLw-static
230
231 %description libGLw-static
232 Static SGI libGLw library.
233
234 %description libGLw-static -l pl.UTF-8
235 Statyczna biblioteka SGI libGLw.
236
237 %package libOSMesa
238 Summary:        OSMesa (off-screen renderer) library
239 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
240 License:        MIT
241 Group:          Libraries
242 # doesn't require base
243
244 %description libOSMesa
245 OSMesa (off-screen renderer) library.
246
247 %description libOSMesa -l pl.UTF-8
248 Biblioteka OSMesa (renderująca bitmapy w pamięci).
249
250 %package libOSMesa-devel
251 Summary:        Header file for OSMesa (off-screen renderer) library
252 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
253 License:        MIT
254 Group:          Development/Libraries
255 Requires:       %{name}-libOSMesa = %{version}-%{release}
256 # for <GL/gl.h> only
257 Requires:       OpenGL-devel
258
259 %description libOSMesa-devel
260 Header file for OSMesa (off-screen renderer) library.
261
262 %description libOSMesa-devel -l pl.UTF-8
263 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
264
265 %package libOSMesa-static
266 Summary:        Static OSMesa (off-screen renderer) library
267 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
268 License:        MIT
269 Group:          Development/Libraries
270 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
271 # this static build of OSMesa needs static non-dri Mesa implementation
272 Requires:       %{name}-libGL-static = %{version}-%{release}
273
274 %description libOSMesa-static
275 Static OSMesa (off-screen renderer) library.
276
277 %description libOSMesa-static -l pl.UTF-8
278 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
279
280 %package utils
281 Summary:        OpenGL utilities from Mesa3D
282 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
283 License:        MIT
284 Group:          X11/Applications/Graphics
285 # loose deps on libGL/libGLU
286
287 %description utils
288 OpenGL utilities from Mesa3D: glxgears and glxinfo.
289
290 %description utils -l pl.UTF-8
291 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
292
293 %package demos
294 Summary:        Mesa Demos source code
295 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
296 License:        various (MIT, SGI, GPL - see copyright notes in sources)
297 Group:          Development/Libraries
298 Requires:       OpenGL-devel
299
300 %description demos
301 Demonstration programs for the Mesa libraries in source code form.
302
303 %description demos -l pl.UTF-8
304 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
305
306 %package dri-driver-ati-mach64
307 Summary:        X.org DRI driver for ATI Mach64 card family
308 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
309 License:        MIT
310 Group:          X11/Libraries
311 Requires:       xorg-driver-video-mach64
312 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
313 Requires:       xorg-xserver-server >= %{xserver_ver}
314
315 %description dri-driver-ati-mach64
316 X.org DRI driver for ATI Mach64 card family.
317
318 %description dri-driver-ati-mach64 -l pl.UTF-8
319 Sterownik X.org DRI dla rodziny kart ATI Mach64.
320
321 %package dri-driver-ati-radeon-R100
322 Summary:        X.org DRI driver for ATI R100 card family
323 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
324 License:        MIT
325 Group:          X11/Libraries
326 Requires:       xorg-driver-video-ati
327 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
328 Requires:       xorg-xserver-server >= %{xserver_ver}
329 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
330
331 %description dri-driver-ati-radeon-R100
332 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
333
334 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
335 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
336
337 %package dri-driver-ati-radeon-R200
338 Summary:        X.org DRI driver for ATI R200 card family
339 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
340 License:        MIT
341 Group:          X11/Libraries
342 Requires:       xorg-driver-video-ati
343 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
344 Requires:       xorg-xserver-server >= %{xserver_ver}
345 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
346
347 %description dri-driver-ati-radeon-R200
348 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
349
350 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
351 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
352
353 %package dri-driver-ati-radeon-R300
354 Summary:        X.org DRI driver for ATI R300 card family
355 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
356 License:        MIT
357 Group:          X11/Libraries
358 Requires:       xorg-driver-video-ati
359 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
360 Requires:       xorg-xserver-server >= %{xserver_ver}
361 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
362
363 %description dri-driver-ati-radeon-R300
364 X.org DRI driver for ATI R300 card family.
365
366 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
367 Sterownik X.org DRI dla rodziny kart ATI R300.
368
369 %package dri-driver-ati-rage128
370 Summary:        X.org DRI driver for ATI Rage128 card family
371 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
372 License:        MIT
373 Group:          X11/Libraries
374 Requires:       xorg-driver-video-r128
375 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
376 Requires:       xorg-xserver-server >= %{xserver_ver}
377 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
378
379 %description dri-driver-ati-rage128
380 X.org DRI driver for ATI Rage128 card family.
381
382 %description dri-driver-ati-rage128 -l pl.UTF-8
383 Sterownik X.org DRI dla rodziny kart ATI Rage128.
384
385 %package dri-driver-ffb
386 Summary:        X.org DRI driver for Sun FFB card family
387 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
388 License:        MIT
389 Group:          X11/Libraries
390 Requires:       xorg-driver-video-sunffb
391 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
392 Requires:       xorg-xserver-server >= %{xserver_ver}
393
394 %description dri-driver-ffb
395 X.org DRI driver for SUN Creator3D and Elite3D card family.
396
397 %description dri-driver-ffb -l pl.UTF-8
398 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
399
400 %package dri-driver-glint
401 Summary:        X.org DRI driver for GLINT/Permedia card family
402 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
403 License:        MIT
404 Group:          X11/Libraries
405 Requires:       xorg-driver-video-glint
406 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
407 Requires:       xorg-xserver-server >= %{xserver_ver}
408 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
409
410 %description dri-driver-glint
411 X.org DRI driver for GLINT/Permedia card family.
412
413 %description dri-driver-glint -l pl.UTF-8
414 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
415
416 %package dri-driver-intel-i810
417 Summary:        X.org DRI driver for Intel i810 card family
418 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
419 License:        MIT
420 Group:          X11/Libraries
421 Requires:       xorg-driver-video-intel
422 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
423 Requires:       xorg-xserver-server >= %{xserver_ver}
424 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
425
426 %description dri-driver-intel-i810
427 X.org DRI driver for Intel i810 card family.
428
429 %description dri-driver-intel-i810 -l pl.UTF-8
430 Sterownik X.org DRI dla rodziny kart Intel i810.
431
432 %package dri-driver-intel-i915
433 Summary:        X.org DRI driver for Intel i915 card family
434 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
435 License:        MIT
436 Group:          X11/Libraries
437 Requires:       xorg-driver-video-intel
438 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
439 Requires:       xorg-xserver-server >= %{xserver_ver}
440 Obsoletes:      Mesa-dri-driver-intel-i830
441 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
442
443 %description dri-driver-intel-i915
444 X.org DRI driver for Intel i915 card family.
445
446 %description dri-driver-intel-i915 -l pl.UTF-8
447 Sterownik X.org DRI dla rodziny kart Intel i915.
448
449 %package dri-driver-intel-i965
450 Summary:        X.org DRI driver for Intel i965 card family
451 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
452 License:        MIT
453 Group:          X11/Libraries
454 Requires:       xorg-driver-video-intel
455 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
456 Requires:       xorg-xserver-server >= %{xserver_ver}
457 Obsoletes:      Mesa-dri-driver-intel-i830
458 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
459
460 %description dri-driver-intel-i965
461 X.org DRI driver for Intel i965 card family.
462
463 %description dri-driver-intel-i965 -l pl.UTF-8
464 Sterownik X.org DRI dla rodziny kart Intel i965.
465
466 %package dri-driver-matrox
467 Summary:        X.org DRI driver for Matrox G card family
468 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
469 License:        MIT
470 Group:          X11/Libraries
471 Requires:       xorg-driver-video-mga
472 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
473 Requires:       xorg-xserver-server >= %{xserver_ver}
474 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
475
476 %description dri-driver-matrox
477 X.org DRI drivers for Matrox G card family.
478
479 %description dri-driver-matrox -l pl.UTF-8
480 Sterowniki X.org DRI dla rodziny kart Matrox G.
481
482 %package dri-driver-s3virge
483 Summary:        X.org DRI driver for S3 Virge card family
484 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
485 License:        MIT
486 Group:          X11/Libraries
487 Requires:       xorg-driver-video-s3virge
488 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
489 Requires:       xorg-xserver-server >= %{xserver_ver}
490
491 %description dri-driver-s3virge
492 X.org DRI driver for S3 Virge card family.
493
494 %description dri-driver-s3virge -l pl.UTF-8
495 Sterownik X.org DRI dla rodziny kart S3 Virge.
496
497 %package dri-driver-savage
498 Summary:        X.org DRI driver for S3 Savage card family
499 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
500 License:        MIT
501 Group:          X11/Libraries
502 Requires:       xorg-driver-video-savage
503 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
504 Requires:       xorg-xserver-server >= %{xserver_ver}
505
506 %description dri-driver-savage
507 X.org DRI driver for S3 Savage card family.
508
509 %description dri-driver-savage -l pl.UTF-8
510 Sterownik X.org DRI dla rodziny kart S3 Savage.
511
512 %package dri-driver-sis
513 Summary:        X.org DRI driver for SiS card family
514 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
515 License:        MIT
516 Group:          X11/Libraries
517 Requires:       xorg-driver-video-sis
518 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
519 Requires:       xorg-xserver-server >= %{xserver_ver}
520 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
521
522 %description dri-driver-sis
523 X.org DRI driver for SiS card family.
524
525 %description dri-driver-sis -l pl.UTF-8
526 Sterownik X.org DRI dla rodziny kart SiS.
527
528 %package dri-driver-swrast
529 Summary:        X.org DRI software rasterizer driver
530 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
531 License:        MIT
532 Group:          X11/Libraries
533 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
534 Requires:       xorg-xserver-server >= %{xserver_ver}
535
536 %description dri-driver-swrast
537 X.org DRI software rasterizer driver.
538
539 %description dri-driver-swrast -l pl.UTF-8
540 Sterownik X.org DRI obsługujący rysowanie programowe.
541
542 %package dri-driver-tdfx
543 Summary:        X.org DRI driver for 3DFX Voodoo card family
544 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       Glide3-DRI
548 Requires:       xorg-driver-video-tdfx
549 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
550 Requires:       xorg-xserver-server >= %{xserver_ver}
551 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
552
553 %description dri-driver-tdfx
554 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
555 and Velocity 100/200).
556
557 %description dri-driver-tdfx -l pl.UTF-8
558 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
559 Banshee i Velocity 100/200).
560
561 %package dri-driver-trident
562 Summary:        X.org DRI driver for Trident card family
563 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
564 License:        MIT
565 Group:          X11/Libraries
566 Requires:       xorg-driver-video-trident
567 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
568 Requires:       xorg-xserver-server >= %{xserver_ver}
569
570 %description dri-driver-trident
571 X.org DRI drivers for Trident card family.
572
573 %description dri-driver-trident -l pl.UTF-8
574 Sterowniki X.org DRI dla rodziny kart Trident.
575
576 %package dri-driver-via-unichrome
577 Summary:        X.org DRI driver for VIA Unichrome card family
578 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
579 License:        MIT
580 Group:          X11/Libraries
581 Requires:       xorg-driver-video-openchrome
582 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
583 Requires:       xorg-xserver-server >= %{xserver_ver}
584
585 %description dri-driver-via-unichrome
586 X.org DRI driver for VIA Unichrome card family.
587
588 %description dri-driver-via-unichrome -l pl.UTF-8
589 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
590
591 %prep
592 %setup -q -b1 -a2
593 %patch0 -p0
594
595 # fix demos
596 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
597
598 %build
599 [ ! -f configure ] && ./autogen.sh
600
601 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
602 %if %{without gallium}
603 i915 \
604 %endif
605 %ifarch sparc sparcv9 sparc64
606 ffb \
607 %endif
608 %ifarch %{ix86} %{x8664}
609 sis \
610 %endif
611 swrast tdfx unichrome"
612
613 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
614
615 common_flags="\
616         --enable-shared \
617         --enable-selinux \
618         --enable-pic"
619
620 # osmesa variants
621 %configure $common_flags \
622         --with-driver=osmesa \
623         --disable-asm \
624         --with-osmesa-bits=8
625 %{__make} \
626         SRC_DIRS=mesa
627 mv %{_lib} osmesa8
628 %{__make} clean
629
630 %configure $common_flags \
631         --with-driver=osmesa \
632         --disable-asm \
633         --with-osmesa-bits=16
634 %{__make} \
635         SRC_DIRS=mesa
636 mv %{_lib} osmesa16
637 %{__make} clean
638
639 %configure $common_flags \
640         --with-driver=osmesa \
641         --disable-asm \
642         --with-osmesa-bits=32
643 %{__make} \
644         SRC_DIRS=mesa
645 mv %{_lib} osmesa32
646 %{__make} clean
647
648 %configure $common_flags \
649         --enable-glu \
650         --enable-glw \
651         --disable-glut \
652         --%{?with_gallium:en}%{!?with_gallium:dis}able-gallium \
653         --with-driver=dri \
654         --with-dri-drivers=${dri_drivers} \
655         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
656
657 %{__make}
658 %{__make} -C progs/xdemos glxgears glxinfo
659 %{__make} -C progs/demos
660
661 cd gl-manpages-*
662 %configure
663 %{__make}
664
665 %install
666 rm -rf $RPM_BUILD_ROOT
667
668 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
669
670 # libs without drivers
671 %{__make} install \
672         DESTDIR=$RPM_BUILD_ROOT
673
674 cd gl-manpages-*
675 %{__make} install \
676         DESTDIR=$RPM_BUILD_ROOT
677 cd ..
678
679 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
680
681 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
682 # work on copy to keep -bi --short-circuit working
683 rm -rf progs-clean
684 install -d progs-clean
685 for l in demos glsl osdemos redbook samples xdemos ; do
686         cp -a progs/$l progs-clean/$l
687         %{__make} -C progs-clean/$l clean
688         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
689 done
690 rm -rf progs-clean
691 for l in util images ; do
692         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
693 done
694 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
695
696 # strip out undesirable headers
697 olddir=$(pwd)
698 cd $RPM_BUILD_ROOT%{_includedir}/GL 
699 rm [a-fh-np-wyz]*.h gg*.h glf*.h
700 cd $RPM_BUILD_ROOT%{_libdir}
701 %if %{without gallium}
702 rm libEGL*
703 %endif
704 cd $olddir
705
706 %if %{with multigl}
707 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
708
709 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
710 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
711
712 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
713 %endif
714
715 %clean
716 rm -rf $RPM_BUILD_ROOT
717
718 %post   libGL -p /sbin/ldconfig
719 %postun libGL -p /sbin/ldconfig
720
721 %post   libGLU -p /sbin/ldconfig
722 %postun libGLU -p /sbin/ldconfig
723
724 %post   libGLw -p /sbin/ldconfig
725 %postun libGLw -p /sbin/ldconfig
726
727 %files libGL
728 %defattr(644,root,root,755)
729 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
730 %if %{with multigl}
731 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
732 %dir %{_libdir}/Mesa
733 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
734 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
735 %else
736 %attr(755,root,root) %{_libdir}/libGL.so.*.*
737 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
738 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
739 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
740 # symlink for binary apps which fail to conform Linux OpenGL ABI
741 # (and dlopen libGL.so instead of libGL.so.1)
742 %attr(755,root,root) %{_libdir}/libGL.so
743 %attr(755,root,root) %{_libdir}/libEGL.so
744 %endif
745
746 %files libGL-devel
747 %defattr(644,root,root,755)
748 %doc docs/*.spec
749 %if %{with multigl}
750 %attr(755,root,root) %{_libdir}/libGL.so
751 %endif
752 %dir %{_includedir}/GL
753 %{_includedir}/GL/gl.h
754 %{_includedir}/GL/glext.h
755 %{_includedir}/GL/gl_mangle.h
756 %{_includedir}/GL/glx.h
757 %{_includedir}/GL/glxext.h
758 %{_includedir}/GL/glx_mangle.h
759 %dir %{_includedir}/GL/internal
760 %{_includedir}/GL/internal/dri_interface.h
761 %{_pkgconfigdir}/dri.pc
762 %{_pkgconfigdir}/gl.pc
763 %{_datadir}/man/man3/gl[^uX]*.3gl*
764 %{_datadir}/man/man3/glX*.3gl*
765
766 %if %{with static}
767 %files libGL-static
768 %defattr(644,root,root,755)
769 %{_libdir}/libGL.a
770 %endif
771
772 %files libGLU
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
775 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
776
777 %files libGLU-devel
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libGLU.so
780 %{_includedir}/GL/glu.h
781 %{_includedir}/GL/glu_mangle.h
782 %{_pkgconfigdir}/glu.pc
783 %{_datadir}/man/man3/glu*.3gl*
784
785 %if %{with static}
786 %files libGLU-static
787 %defattr(644,root,root,755)
788 %{_libdir}/libGLU.a
789 %endif
790
791 %files libGLw
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
794 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
795
796 %files libGLw-devel
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libGLw.so
799 %{_includedir}/GL/GLwDrawA.h
800 %{_includedir}/GL/GLwDrawAP.h
801 %{_includedir}/GL/GLwMDrawA.h
802 %{_includedir}/GL/GLwMDrawAP.h
803 %{_pkgconfigdir}/glw.pc
804
805 %if %{with static}
806 %files libGLw-static
807 %defattr(644,root,root,755)
808 %{_libdir}/libGLw.a
809 %endif
810
811 %files libOSMesa
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
815
816 %files libOSMesa-devel
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libOSMesa*.so
819 %{_includedir}/GL/osmesa.h
820
821 %if %{with static}
822 %files libOSMesa-static
823 %defattr(644,root,root,755)
824 %{_libdir}/libOSMesa*.a
825 %endif
826
827 %files utils
828 %defattr(644,root,root,755)
829 %attr(755,root,root) %{_bindir}/glxgears
830 %attr(755,root,root) %{_bindir}/glxinfo
831
832 %files dri-driver-ati-mach64
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
835
836 %files dri-driver-ati-radeon-R100
837 %defattr(644,root,root,755)
838 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
839
840 %files dri-driver-ati-radeon-R200
841 %defattr(644,root,root,755)
842 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
843
844 %files dri-driver-ati-radeon-R300
845 %defattr(644,root,root,755)
846 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
847
848 %files dri-driver-ati-rage128
849 %defattr(644,root,root,755)
850 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
851
852 # sunffb (sparc only)
853 %ifarch sparc sparcv9 sparc64
854 %files dri-driver-ffb
855 %defattr(644,root,root,755)
856 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
857 %endif
858
859 # glint (requires update)
860 %if 0
861 %files dri-driver-glint
862 %defattr(644,root,root,755)
863 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
864 %endif
865
866 %files dri-driver-intel-i810
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
869
870 %files dri-driver-intel-i915
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_libdir}/xorg/modules/dri/EGL_i915.so
873
874 %files dri-driver-intel-i965
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
877
878 %files dri-driver-matrox
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
881
882 %files dri-driver-s3virge
883 %defattr(644,root,root,755)
884 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
885
886 %files dri-driver-savage
887 %defattr(644,root,root,755)
888 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
889
890 %ifarch %{ix86} %{x8664}
891 %files dri-driver-sis
892 %defattr(644,root,root,755)
893 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
894 %endif
895
896 %files dri-driver-swrast
897 %defattr(644,root,root,755)
898 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
899
900 %files dri-driver-tdfx
901 %defattr(644,root,root,755)
902 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
903
904 %files dri-driver-trident
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
907
908 %files dri-driver-via-unichrome
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
911
912 %files demos
913 %defattr(644,root,root,755)
914 %{_examplesdir}/%{name}-%{version}
This page took 0.540841 seconds and 4 git commands to generate.