]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- spec from HEAD adapted for DEVEL purposes
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - consider:
4 #   --enable-shared-glapi (for libGL; required if the same app uses GL and GLES)
5 #   --enable-shared-dricore
6 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
7 # - resurrect static if it's useful
8 #
9 # Conditional build:
10 %bcond_without  egl     # build egl
11 %bcond_without  gallium # don't build gallium
12 %bcond_with     gallium_intel   # gallium i915 driver (but doesn't work with AIGLX)
13 %bcond_without  gallium_nouveau # gallium nouveau driver
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_without  gbm     # with Graphics Buffer Manager
16 %bcond_with     static_libs     # static libraries
17 #
18 # minimal supported xserver version
19 %define         xserver_ver     1.5.0
20 # glapi version (glapi tables in dri drivers and libglx must be in sync);
21 # set to current Mesa version on ABI break, when xserver tables get regenerated
22 # (until they start to be somehow versioned themselves)
23 %define         glapi_ver       7.1.0
24 #
25 %define         libdrm_ver      2.4.30
26 %define         dri2proto_ver   2.6
27 %define         glproto_ver     1.4.11
28 #
29 %define         snap            20120209
30 #
31 Summary:        Free OpenGL implementation
32 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
33 Name:           Mesa
34 Version:        8.0
35 Release:        1
36 License:        MIT (core), SGI (GLU) and others - see license.html file
37 Group:          X11/Libraries
38 #Source0:       ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
39 Source0:        %{name}Lib-%{snap}.tar.bz2
40 # Source0-md5:  8c2f1afb5fcae32ebfd5e3153ed7111b
41 Patch0:         %{name}-realclean.patch
42 URL:            http://www.mesa3d.org/
43 BuildRequires:  autoconf >= 2.59
44 BuildRequires:  automake
45 BuildRequires:  expat-devel
46 BuildRequires:  gcc >= 5:3.3
47 BuildRequires:  libdrm-devel >= %{libdrm_ver}
48 BuildRequires:  libselinux-devel
49 BuildRequires:  libstdc++-devel >= 5:3.3.0
50 BuildRequires:  libtalloc-devel >= 2:2.0.1
51 BuildRequires:  libtool >= 2:1.4d
52 BuildRequires:  libvdpau-devel
53 BuildRequires:  llvm-devel >= 2.9
54 BuildRequires:  pixman-devel
55 BuildRequires:  pkgconfig
56 BuildRequires:  pkgconfig(talloc) >= 2.0.1
57 BuildRequires:  python
58 BuildRequires:  python-libxml2
59 BuildRequires:  python-modules
60 BuildRequires:  rpmbuild(macros) >= 1.470
61 BuildRequires:  sed >= 4.0
62 BuildRequires:  xorg-lib-libXdamage-devel
63 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
64 BuildRequires:  xorg-lib-libXt-devel
65 BuildRequires:  xorg-lib-libXvMC-devel
66 BuildRequires:  xorg-lib-libXxf86vm-devel
67 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
68 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
69 BuildRequires:  xorg-util-makedepend
70 BuildRequires:  xorg-xserver-server-devel
71 %if %{with egl}
72 BuildRequires:  libxcb-devel
73 BuildRequires:  udev-devel >= 150
74 %endif
75 %if %{with gallium}
76 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
77 BuildRequires:  xorg-xserver-server-devel >= 1.6.0
78 %endif
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %if %{without gallium}
82 %undefine       with_gallium_intel
83 %endif
84
85 %if %{without egl}
86 %undefine       with_gbm
87 %endif
88
89 # _glapi_tls_Dispatch is defined in libglapi, but it's some kind of symbol ldd -r doesn't notice(?)
90 %define         skip_post_check_so      libGLESv1_CM.so.1.* libGLESv2.so.2.* libGL.so.1.* libXvMCnouveau.so.1.* libXvMCr300.so.1.*  libXvMCr600.so.1.* libXvMCsoftpipe.so.1.* libvdpau_nouveau.so.1.*
91
92 %description
93 Mesa is a 3-D graphics library with an API which is very similar to
94 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
95 syntax or state machine, it is being used with authorization from
96 Silicon Graphics, Inc. However, the author does not possess an OpenGL
97 license from SGI, and makes no claim that Mesa is in any way a
98 compatible replacement for OpenGL or associated with SGI.
99
100 %description -l pl.UTF-8
101 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
102 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
103 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
104 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
105 OpenGL ani powiązana z SGI.
106
107 %package libEGL
108 Summary:        Mesa implementation of EGL Native Platform Graphics Interface library
109 Summary(pl.UTF-8):      Implementacja Mesa biblioteki interfejsu EGL
110 License:        MIT
111 Group:          Libraries
112 # glx driver in libEGL dlopens libGL.so
113 Requires:       OpenGL >= 1.2
114 Requires:       libdrm >= %{libdrm_ver}
115 %if %{with gallium}
116 # for egl_gallium.so
117 Requires:       Mesa-libOpenVG = %{version}-%{release}
118 Requires:       udev-libs >= 150
119 %endif
120 Provides:       EGL = 1.4
121
122 %description libEGL
123 This package contains shared libEGL - Mesa implementation of EGL
124 Native Platform Graphics Interface as specified by Khronos Group:
125 <http://www.khronos.org/egl/>.
126
127 %description libEGL -l pl.UTF-8
128 Ten pakiet zawiera bibliotekę współdzieloną libEGL - implementację
129 Mesa standardu EGL Native Platform Graphics Interface (interfejsu
130 graficznego platformy natywnej) wg specyfikacji Khronos Group:
131 <http://www.khronos.org/egl/>.
132
133 %package libEGL-devel
134 Summary:        Header files for Mesa implementation of EGL library
135 Summary(pl.UTF-8):      Pliki nagłówkowe implementacji Mesa biblioteki EGL
136 License:        MIT
137 Group:          Development/Libraries
138 Requires:       %{name}-libEGL = %{version}-%{release}
139 Requires:       libdrm-devel >= %{libdrm_ver}
140 Requires:       xorg-lib-libX11-devel
141 Requires:       xorg-lib-libXdamage-devel
142 Requires:       xorg-lib-libXext-devel
143 Requires:       xorg-lib-libXfixes-devel
144 Requires:       xorg-lib-libXxf86vm-devel
145 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
146 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
147 Provides:       EGL-devel = 1.4
148
149 %description libEGL-devel
150 Header files for Mesa implementation of EGL library.
151
152 %description libEGL-devel -l pl.UTF-8
153 Pliki nagłówkowe implementacji Mesa biblioteki EGL.
154
155 %package libEGL-static
156 Summary:        Static Mesa EGL library
157 Summary(pl.UTF-8):      Statyczna biblioteka Mesa EGL
158 License:        MIT
159 Group:          Development/Libraries
160 Requires:       %{name}-libEGL-devel = %{version}-%{release}
161 Provides:       EGL-static = 1.4
162
163 %description libEGL-static
164 Static Mesa EGL library.
165
166 %description libEGL-static -l pl.UTF-8
167 Statyczna biblioteka Mesa EGL.
168
169 %package libGL
170 Summary:        Free Mesa3D implementation of libGL OpenGL library
171 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
172 License:        MIT
173 Group:          X11/Libraries
174 Requires:       libdrm >= %{libdrm_ver}
175 Provides:       OpenGL = 2.1
176 Provides:       OpenGL-GLX = 1.4
177 Obsoletes:      Mesa
178 Obsoletes:      Mesa-dri
179 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
180 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
181
182 %description libGL
183 Mesa is a 3-D graphics library with an API which is very similar to
184 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
185 syntax or state machine, it is being used with authorization from
186 Silicon Graphics, Inc. However, the author does not possess an OpenGL
187 license from SGI, and makes no claim that Mesa is in any way a
188 compatible replacement for OpenGL or associated with SGI.
189
190 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
191 specifications. It uses DRI for rendering.
192
193 %description libGL -l pl.UTF-8
194 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
195 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
196 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
197 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
198 OpenGL ani powiązana z SGI.
199
200 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
201 GLX 1.4. Używa DRI do renderowania.
202
203 %package libGL-devel
204 Summary:        Header files for Mesa3D libGL library
205 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
206 License:        MIT
207 Group:          X11/Development/Libraries
208 # loose dependency on libGL to use with other libGL binaries
209 Requires:       OpenGL >= 1.5
210 Requires:       libdrm-devel >= %{libdrm_ver}
211 Requires:       xorg-lib-libX11-devel
212 Requires:       xorg-lib-libXdamage-devel
213 Requires:       xorg-lib-libXext-devel
214 Requires:       xorg-lib-libXxf86vm-devel
215 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
216 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
217 Suggests:       OpenGL-doc-man
218 Provides:       OpenGL-GLX-devel = 1.4
219 Provides:       OpenGL-devel = 2.1
220 Obsoletes:      Mesa-devel
221 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
222 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
223 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
224 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
225
226 %description libGL-devel
227 Header files for Mesa3D libGL library.
228
229 %description libGL-devel -l pl.UTF-8
230 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
231
232 %package libGL-static
233 Summary:        Static Mesa3D libGL library
234 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
235 License:        MIT
236 Group:          X11/Development/Libraries
237 Requires:       %{name}-libGL-devel = %{version}-%{release}
238 Provides:       OpenGL-static = 2.1
239 Obsoletes:      Mesa-static
240 Obsoletes:      X11-OpenGL-static < 1:7.0.0
241 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
242
243 %description libGL-static
244 Static Mesa3D libGL library. It uses software renderer.
245
246 %description libGL-static -l pl.UTF-8
247 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
248 renderingu.
249
250 %package libGLES
251 Summary:        Mesa implementation of GLES (OpenGL ES) libraries
252 Summary(pl.UTF-8):      Implementacja Mesa bibliotek GLES (OpenGL ES)
253 Group:          Libraries
254 # only for libglapi.so.0
255 Requires:       %{name}-libEGL = %{version}-%{release}
256
257 %description libGLES
258 This package contains shared libraries of Mesa implementation of GLES
259 (OpenGL ES) - cross-platform API for full-function 2D and 3D graphics
260 on embedded systems. OpenGL ES specification can be found on Khronos
261 Group site: <http://www.khronos.org/opengles/>. Mesa implements OpenGL
262 ES 1.1 and 2.0.
263
264 %description libGLES -l pl.UTF-8
265 Ten pakiet zawiera biblioteki współdzielone implementacji Mesa
266 standardu GLES (OpenGL ES) - wieloplatformowego API do w pełni
267 funkcjonalnej grafiki 2D i 3D na systemach wbudowanych. Specyfikację
268 OpenGL ES można znaleźć na stronie Khronos Group:
269 <http://www.khronos.org/opengles/>. Mesa zawiera implementacją OpenGL
270 ES 1.1 i 2.0.
271
272 %package libGLES-devel
273 Summary:        Header files for Mesa GLES libraries
274 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Mesa GLES
275 Group:          Development/Libraries
276 # EGL for libglapi.so, <KHR/khrplatform.h> always required, <EGL/egl.h> for <GLES/egl.h>
277 Requires:       %{name}-libEGL-devel = %{version}-%{release}
278 Requires:       %{name}-libGLES = %{version}-%{release}
279
280 %description libGLES-devel
281 Header files for Mesa GLES libraries.
282
283 %description libGLES-devel -l pl.UTF-8
284 Pliki nagłówkowe bibliotek Mesa GLES.
285
286 %package libGLU
287 Summary:        SGI implementation of libGLU OpenGL library
288 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
289 License:        SGI Free Software License B v2.0 (MIT-like)
290 Group:          Libraries
291 # loose dependency on libGL.so.1 to use with other libGL binaries
292 Requires:       OpenGL >= 1.2
293 Provides:       OpenGL-GLU = 1.3
294 Obsoletes:      Mesa-devel
295 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
296 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
297
298 %description libGLU
299 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
300 1.3 specifications.
301
302 %description libGLU -l pl.UTF-8
303 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
304 specyfikację OpenGL GLU 1.3.
305
306 %package libGLU-devel
307 Summary:        Header files for SGI libGLU library
308 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
309 License:        SGI Free Software License B v2.0 (MIT-like)
310 Group:          Development/Libraries
311 Requires:       %{name}-libGLU = %{version}-%{release}
312 Requires:       OpenGL-devel >= 1.2
313 Requires:       libstdc++-devel
314 Provides:       OpenGL-GLU-devel = 1.3
315
316 %description libGLU-devel
317 Header files for SGI libGLU library.
318
319 %description libGLU-devel -l pl.UTF-8
320 Pliki nagłówkowe biblioteki SGI libGLU.
321
322 %package libGLU-static
323 Summary:        Static SGI libGLU library
324 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
325 License:        SGI Free Software License B v2.0 (MIT-like)
326 Group:          Development/Libraries
327 Requires:       %{name}-libGLU-devel = %{version}-%{release}
328 Provides:       OpenGL-GLU-static = 1.3
329
330 %description libGLU-static
331 Static SGI libGLU library.
332
333 %description libGLU-static -l pl.UTF-8
334 Statyczna biblioteka SGI libGLU.
335
336 %package libOSMesa
337 Summary:        OSMesa (off-screen renderer) library
338 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
339 License:        MIT
340 Group:          Libraries
341 # doesn't require base
342
343 %description libOSMesa
344 OSMesa (off-screen renderer) library.
345
346 %description libOSMesa -l pl.UTF-8
347 Biblioteka OSMesa (renderująca bitmapy w pamięci).
348
349 %package libOSMesa-devel
350 Summary:        Header file for OSMesa (off-screen renderer) library
351 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
352 License:        MIT
353 Group:          Development/Libraries
354 Requires:       %{name}-libOSMesa = %{version}-%{release}
355 # for <GL/gl.h> only
356 Requires:       OpenGL-devel
357 Requires:       libselinux-devel
358
359 %description libOSMesa-devel
360 Header file for OSMesa (off-screen renderer) library.
361
362 %description libOSMesa-devel -l pl.UTF-8
363 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
364
365 %package libOSMesa-static
366 Summary:        Static OSMesa (off-screen renderer) library
367 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
368 License:        MIT
369 Group:          Development/Libraries
370 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
371 # this static build of OSMesa needs static non-dri Mesa implementation
372 Requires:       %{name}-libGL-static = %{version}-%{release}
373
374 %description libOSMesa-static
375 Static OSMesa (off-screen renderer) library.
376
377 %description libOSMesa-static -l pl.UTF-8
378 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
379
380 %package libOpenVG
381 Summary:        Mesa implementation of OpenVG (Vector Graphics Accelleration) API
382 Summary(pl.UTF-8):      Implementacja Mesa API OpenVG (akceleracji grafiki wektorowej)
383 License:        MIT
384 Group:          Libraries
385 # doesn't require base
386
387 %description libOpenVG
388 This package contains Mesa implementation of OpenVG - cross-platform
389 API that provides a low-level hardware acceleration interface for
390 vector graphics libraries such as Flash and SVG. OpenVG specification
391 can be found on Khronos Group site: <http://www.khronos.org/openvg/>.
392 Mesa implements OpenVG 1.1.
393
394 %description libOpenVG -l pl.UTF-8
395 Ten pakiet zawiera implementację Mesa standardu OpenVG -
396 wieloplatfomowego API zapewniającego niskopoziomowy interfejs
397 akceleracji sprzętowej dla bibliotek grafiki wektorowej, takiej jak
398 Flash czy SVG. Specyfikację OpenVG można znaleźć na stronie Khronos
399 Group: <http://www.khronos.org/openvg/>. Mesa zawiera implementację
400 OpenVG w wersji 1.1.
401
402 %package libOpenVG-devel
403 Summary:        Header file for Mesa OpenVG library
404 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki Mesa OpenVG
405 License:        MIT
406 Group:          Development/Libraries
407 # EGL headers for <KHR/khrplatform.h>
408 Requires:       %{name}-libEGL-devel = %{version}-%{release}
409 Requires:       %{name}-libOpenVG = %{version}-%{release}
410
411 %description libOpenVG-devel
412 Header file for Mesa OpenVG library.
413
414 %description libOpenVG-devel -l pl.UTF-8
415 Plik nagłówkowy biblioteki Mesa OpenVG.
416
417 %package libXvMC
418 Summary:        XvMC implementations
419 Summary(pl.UTF-8):      Implementacje API XvMC
420 License:        MIT
421 Group:          Libraries
422 # doesn't require base
423
424 %description libXvMC
425 libXvMC implementations.
426
427 %description libXvMC -l pl.UTF-8
428 Implementacje API libXvMC.
429
430 %package dri-driver-ati-radeon-R100
431 Summary:        X.org DRI driver for ATI R100 card family
432 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
433 License:        MIT
434 Group:          X11/Libraries
435 Requires:       xorg-driver-video-ati
436 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
437 Requires:       xorg-xserver-server >= %{xserver_ver}
438 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
439
440 %description dri-driver-ati-radeon-R100
441 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
442
443 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
444 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
445
446 %package dri-driver-ati-radeon-R200
447 Summary:        X.org DRI driver for ATI R200 card family
448 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
449 License:        MIT
450 Group:          X11/Libraries
451 Requires:       xorg-driver-video-ati
452 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
453 Requires:       xorg-xserver-server >= %{xserver_ver}
454 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
455
456 %description dri-driver-ati-radeon-R200
457 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
458
459 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
460 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
461
462 %package dri-driver-ati-radeon-R300
463 Summary:        X.org DRI driver for ATI R300 card family
464 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
465 License:        MIT
466 Group:          X11/Libraries
467 Requires:       xorg-driver-video-ati
468 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
469 Requires:       xorg-xserver-server >= %{xserver_ver}
470 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
471
472 %description dri-driver-ati-radeon-R300
473 X.org DRI driver for ATI R300 card family.
474
475 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
476 Sterownik X.org DRI dla rodziny kart ATI R300.
477
478 %package dri-driver-ati-radeon-R600
479 Summary:        X.org DRI driver for ATI R600 card family
480 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
481 License:        MIT
482 Group:          X11/Libraries
483 Requires:       radeon-ucode
484 Requires:       xorg-driver-video-ati
485 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
486 Requires:       xorg-xserver-server >= %{xserver_ver}
487
488 %description dri-driver-ati-radeon-R600
489 X.org DRI driver for ATI R600 card family.
490
491 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
492 Sterownik X.org DRI dla rodziny kart ATI R600.
493
494 %package dri-driver-ffb
495 Summary:        X.org DRI driver for Sun FFB card family
496 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
497 License:        MIT
498 Group:          X11/Libraries
499 Requires:       xorg-driver-video-sunffb
500 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
501 Requires:       xorg-xserver-server >= %{xserver_ver}
502
503 %description dri-driver-ffb
504 X.org DRI driver for SUN Creator3D and Elite3D card family.
505
506 %description dri-driver-ffb -l pl.UTF-8
507 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
508
509 %package dri-driver-glint
510 Summary:        X.org DRI driver for GLINT/Permedia card family
511 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
512 License:        MIT
513 Group:          X11/Libraries
514 Requires:       xorg-driver-video-glint
515 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
516 Requires:       xorg-xserver-server >= %{xserver_ver}
517 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
518
519 %description dri-driver-glint
520 X.org DRI driver for GLINT/Permedia card family.
521
522 %description dri-driver-glint -l pl.UTF-8
523 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
524
525 %package dri-driver-intel-i915
526 Summary:        X.org DRI driver for Intel i915 card family
527 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
528 License:        MIT
529 Group:          X11/Libraries
530 Requires:       xorg-driver-video-intel
531 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
532 Requires:       xorg-xserver-server >= %{xserver_ver}
533 Obsoletes:      Mesa-dri-driver-intel-i830
534 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
535
536 %description dri-driver-intel-i915
537 X.org DRI driver for Intel i915 card family.
538
539 %description dri-driver-intel-i915 -l pl.UTF-8
540 Sterownik X.org DRI dla rodziny kart Intel i915.
541
542 %package dri-driver-intel-i965
543 Summary:        X.org DRI driver for Intel i965 card family
544 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
545 License:        MIT
546 Group:          X11/Libraries
547 Requires:       xorg-driver-video-intel
548 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
549 Requires:       xorg-xserver-server >= %{xserver_ver}
550 Obsoletes:      Mesa-dri-driver-intel-i830
551 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
552
553 %description dri-driver-intel-i965
554 X.org DRI driver for Intel i965 card family.
555
556 %description dri-driver-intel-i965 -l pl.UTF-8
557 Sterownik X.org DRI dla rodziny kart Intel i965.
558
559 %package dri-driver-nouveau
560 Summary:        X.org DRI driver for NVIDIA card family
561 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
562 License:        MIT
563 Group:          X11/Libraries
564 Requires:       xorg-driver-video-nouveau
565 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
566 Requires:       xorg-xserver-server >= %{xserver_ver}
567
568 %description dri-driver-nouveau
569 X.org DRI drivers for NVIDIA card family.
570
571 %description dri-driver-nouveau -l pl.UTF-8
572 Sterowniki X.org DRI dla rodziny kart NVIDIA.
573
574 %package dri-driver-swrast
575 Summary:        X.org DRI software rasterizer driver
576 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
577 License:        MIT
578 Group:          X11/Libraries
579 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
580 Requires:       xorg-xserver-server >= %{xserver_ver}
581
582 %description dri-driver-swrast
583 X.org DRI software rasterizer driver.
584
585 %description dri-driver-swrast -l pl.UTF-8
586 Sterownik X.org DRI obsługujący rysowanie programowe.
587
588 %package dri-driver-vmwgfx
589 Summary:        X.org DRI driver for VMware
590 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
591 License:        MIT
592 Group:          X11/Libraries
593 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
594 Requires:       xorg-xserver-server >= %{xserver_ver}
595
596 %description dri-driver-vmwgfx
597 X.org DRI driver for VMWare.
598
599 %description dri-driver-vmwgfx -l pl.UTF-8
600 Sterownik X.org DRI dla VMware.
601
602 %package -n libvdpau-driver-mesa
603 Summary:        Mesa driver for the vdpau API
604 Summary(pl.UTF-8):      Sterownik Mesa dla API vdpau
605 License:        MIT
606 Group:          X11/Libraries
607
608 %description -n libvdpau-driver-mesa
609 Mesa driver for the vdpau API.
610
611 %description -n libvdpau-driver-mesa -l pl.UTF-8
612 Sterownik Mesa dla API vdpau.
613
614 # llvm build broken
615 %define         filterout_ld    -Wl,--as-needed
616
617 %prep
618 %setup -q
619 %patch0 -p0
620
621 %build
622 if [ -x autogen.sh ]; then
623         ./autogen.sh
624 else
625         %{__aclocal}
626         %{__autoconf}
627 fi
628
629 dri_drivers="r200 radeon \
630 %if %{without gallium_intel}
631 i915 i965 \
632 %endif
633 %ifarch sparc sparcv9 sparc64
634 ffb \
635 %endif
636 swrast"
637
638 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
639
640 gallium_drivers="svga swrast \
641 %if %{with gallium_intel}
642 i915 \
643 i965 \
644 %endif
645 r300 \
646 r600 \
647 %if %{with gallium_nouveau}
648 nouveau \
649 %endif
650 "
651
652 gallium_drivers=$(echo $gallium_drivers | xargs | tr ' ' ',')
653
654 common_flags="\
655         --enable-shared \
656         --enable-glx-tls \
657         --enable-pic \
658         --enable-selinux \
659         %{?with_static_libs:--enable-static} \
660 "
661
662 osmesa_common_flags="\
663         --with-driver=osmesa \
664         --disable-asm \
665         --disable-egl \
666         --disable-glu"
667
668 %if %{with osmesa}
669 %configure $common_flags $osmesa_common_flags \
670         --with-osmesa-bits=8
671 %{__make}
672 %{__make} -C src/mesa osmesa.pc
673 mv %{_lib} osmesa8
674 cp -p src/mesa/osmesa.pc osmesa8
675 %{__make} clean
676 %endif
677
678 %configure $common_flags \
679         --enable-shared-glapi \
680         %{__enable gbm} \
681 %if %{with egl}
682         --enable-egl \
683         --enable-gles1 \
684         --enable-gles2 \
685 %endif
686 %if %{with gallium}
687         --enable-openvg \
688         --enable-gallium-llvm \
689         %{__enable egl gallium-egl} \
690         %{__enable gbm gallium-gbm} \
691         --enable-vdpau \
692         --enable-xvmc \
693         --with-gallium-drivers=${gallium_drivers} \
694 %else
695         --disable-gallium \
696 %endif
697         --with-driver=dri \
698         --with-dri-drivers=${dri_drivers} \
699         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
700
701 %{__make}
702
703 %install
704 rm -rf $RPM_BUILD_ROOT
705
706 # libs without drivers
707 %{__make} install \
708         DESTDIR=$RPM_BUILD_ROOT
709
710 %if %{with osmesa}
711 cp -p osmesa8/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
712 cp -p osmesa8/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
713 %endif
714
715 # strip out undesirable headers
716 %{__rm} $RPM_BUILD_ROOT%{_includedir}/GL/{vms_x_fix,wglext,wmesa}.h
717
718 # remove "OS ABI: Linux 2.4.20" tag, so private copies (nvidia or fglrx),
719 # set up via /etc/ld.so.conf.d/*.conf will be preferred over this
720 strip -R .note.ABI-tag $RPM_BUILD_ROOT%{_libdir}/libGL.so.*.*
721
722 %clean
723 rm -rf $RPM_BUILD_ROOT
724
725 %post   libEGL -p /sbin/ldconfig
726 %postun libEGL -p /sbin/ldconfig
727
728 %post   libGL -p /sbin/ldconfig
729 %postun libGL -p /sbin/ldconfig
730
731 %post   libGLES -p /sbin/ldconfig
732 %postun libGLES -p /sbin/ldconfig
733
734 %post   libGLU -p /sbin/ldconfig
735 %postun libGLU -p /sbin/ldconfig
736
737 %post   libOSMesa -p /sbin/ldconfig
738 %postun libOSMesa -p /sbin/ldconfig
739
740 %post   libOpenVG -p /sbin/ldconfig
741 %postun libOpenVG -p /sbin/ldconfig
742
743 %post   libXvMC -p /sbin/ldconfig
744 %postun libXvMC -p /sbin/ldconfig
745
746 %if %{with egl}
747 %files libEGL
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
750 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.1
751 %attr(755,root,root) %{_libdir}/libglapi.so.*.*
752 %attr(755,root,root) %ghost %{_libdir}/libglapi.so.0
753 %if %{with gbm}
754 %dir %{_libdir}/gbm
755 %attr(755,root,root) %{_libdir}/libgbm.so.*.*
756 %attr(755,root,root) %ghost %{_libdir}/libgbm.so.1
757 %endif
758 %if %{with gallium}
759 %dir %{_libdir}/egl
760 %attr(755,root,root) %{_libdir}/egl/egl_gallium.so
761 %attr(755,root,root) %{_libdir}/gbm/pipe_r300.so
762 %attr(755,root,root) %{_libdir}/gbm/pipe_r600.so
763 %if %{with gbm}
764 %attr(755,root,root) %{_libdir}/gbm/gbm_gallium_drm.so
765 %attr(755,root,root) %{_libdir}/gbm/pipe_vmwgfx.so
766 %if %{with gallium_nouveau}
767 %attr(755,root,root) %{_libdir}/gbm/pipe_nouveau.so
768 %endif
769 %if %{with gallium_intel}
770 %attr(755,root,root) %{_libdir}/egl/pipe_i915.so
771 %attr(755,root,root) %{_libdir}/egl/pipe_i965.so
772 %endif
773 %endif
774 %endif
775
776 %files libEGL-devel
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libEGL.so
779 %attr(755,root,root) %{_libdir}/libglapi.so
780 %dir %{_includedir}/EGL
781 %{_includedir}/EGL/egl.h
782 %{_includedir}/EGL/eglext.h
783 %{_includedir}/EGL/eglmesaext.h
784 %{_includedir}/EGL/eglplatform.h
785 %dir %{_includedir}/KHR
786 %{_includedir}/KHR/khrplatform.h
787 %{_pkgconfigdir}/egl.pc
788 %if %{with gbm}
789 %attr(755,root,root) %{_libdir}/libgbm.so
790 %{_includedir}/gbm.h
791 %{_pkgconfigdir}/gbm.pc
792 %endif
793
794 %if %{with static_libs}
795 %files libEGL-static
796 %defattr(644,root,root,755)
797 %{_libdir}/libEGL.a
798 %endif
799 %endif
800
801 %files libGL
802 %defattr(644,root,root,755)
803 %doc docs/{*.html,README.{MITS,QUAKE,THREADS},RELNOTES*}
804 %attr(755,root,root) %{_libdir}/libGL.so.*.*
805 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
806 # symlink for binary apps which fail to conform Linux OpenGL ABI
807 # (and dlopen libGL.so instead of libGL.so.1; the same does Mesa libEGL)
808 %attr(755,root,root) %{_libdir}/libGL.so
809
810 %files libGL-devel
811 %defattr(644,root,root,755)
812 %doc docs/*.spec
813 %dir %{_includedir}/GL
814 %{_includedir}/GL/gl.h
815 %{_includedir}/GL/glext.h
816 %{_includedir}/GL/gl_mangle.h
817 %{_includedir}/GL/glx.h
818 %{_includedir}/GL/glxext.h
819 %{_includedir}/GL/glx_mangle.h
820 %dir %{_includedir}/GL/internal
821 %{_includedir}/GL/internal/dri_interface.h
822 %{_pkgconfigdir}/dri.pc
823 %{_pkgconfigdir}/gl.pc
824
825 %if %{with static_libs}
826 %files libGL-static
827 %defattr(644,root,root,755)
828 %{_libdir}/libGL.a
829 %endif
830
831 %files libGLES
832 %defattr(644,root,root,755)
833 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so.*.*.*
834 %attr(755,root,root) %ghost %{_libdir}/libGLESv1_CM.so.1
835 %attr(755,root,root) %{_libdir}/libGLESv2.so.*.*
836 %attr(755,root,root) %ghost %{_libdir}/libGLESv2.so.2
837
838 %files libGLES-devel
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/libGLESv1_CM.so
841 %attr(755,root,root) %{_libdir}/libGLESv2.so
842 %{_includedir}/GLES
843 %{_includedir}/GLES2
844 %{_pkgconfigdir}/glesv1_cm.pc
845 %{_pkgconfigdir}/glesv2.pc
846
847 %files libGLU
848 %defattr(644,root,root,755)
849 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
850 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
851
852 %files libGLU-devel
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/libGLU.so
855 %{_includedir}/GL/glu.h
856 %{_includedir}/GL/glu_mangle.h
857 %{_pkgconfigdir}/glu.pc
858
859 %if %{with static_libs}
860 %files libGLU-static
861 %defattr(644,root,root,755)
862 %{_libdir}/libGLU.a
863 %endif
864
865 %if %{with osmesa}
866 %files libOSMesa
867 %defattr(644,root,root,755)
868 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
869 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.8
870
871 %files libOSMesa-devel
872 %defattr(644,root,root,755)
873 %attr(755,root,root) %{_libdir}/libOSMesa.so
874 %{_includedir}/GL/osmesa.h
875 %{_pkgconfigdir}/osmesa.pc
876
877 %if %{with static_libs}
878 %files libOSMesa-static
879 %defattr(644,root,root,755)
880 %{_libdir}/libOSMesa.a
881 %endif
882 %endif
883
884 %if %{with gallium}
885 %files libOpenVG
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/libOpenVG.so.*.*.*
888 %attr(755,root,root) %ghost %{_libdir}/libOpenVG.so.1
889
890 %files libOpenVG-devel
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/libOpenVG.so
893 %{_includedir}/VG
894 %{_pkgconfigdir}/vg.pc
895 %endif
896
897 %files libXvMC
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %ghost %{_libdir}/libXvMCnouveau.so.1
900 %attr(755,root,root) %{_libdir}/libXvMCnouveau.so.1.0
901 %attr(755,root,root) %ghost %{_libdir}/libXvMCr300.so.1
902 %attr(755,root,root) %{_libdir}/libXvMCr300.so.1.0
903 %attr(755,root,root) %ghost %{_libdir}/libXvMCr600.so.1
904 %attr(755,root,root) %{_libdir}/libXvMCr600.so.1.0
905 %attr(755,root,root) %ghost %{_libdir}/libXvMCsoftpipe.so.1
906 %attr(755,root,root) %{_libdir}/libXvMCsoftpipe.so.1.0
907
908 %files dri-driver-ati-radeon-R100
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
911
912 %files dri-driver-ati-radeon-R200
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
915
916 %files dri-driver-ati-radeon-R300
917 %defattr(644,root,root,755)
918 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
919
920 %files dri-driver-ati-radeon-R600
921 %defattr(644,root,root,755)
922 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
923
924 # sunffb (sparc only)
925 %ifarch sparc sparcv9 sparc64
926 %files dri-driver-ffb
927 %defattr(644,root,root,755)
928 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
929 %endif
930
931 # glint (requires update)
932 %if 0
933 %files dri-driver-glint
934 %defattr(644,root,root,755)
935 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
936 %endif
937
938 %files dri-driver-intel-i915
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
941
942 %files dri-driver-intel-i965
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
945 %if %{with gallium_intel}
946 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/i965g_drv.so
947 %endif
948
949 %if %{with gallium_nouveau}
950 %files dri-driver-nouveau
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
953 %endif
954
955 %files dri-driver-swrast
956 %defattr(644,root,root,755)
957 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
958
959 %if %{with gallium}
960 %files dri-driver-vmwgfx
961 %defattr(644,root,root,755)
962 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
963 %endif
964
965 %files -n libvdpau-driver-mesa
966 %defattr(644,root,root,755)
967 # there is no ldconfig here
968 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1.0
969 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so.1
970 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_softpipe.so
971 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1.0
972 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so.1
973 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r300.so
974 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1.0
975 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so.1
976 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_r600.so
977 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1.0
978 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so.1
979 %attr(755,root,root) %{_libdir}/vdpau/libvdpau_nouveau.so
This page took 0.227643 seconds and 4 git commands to generate.