]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- ups,fix %setup
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - package OpenGL man pages (from monolith or SGI) somewhere
5 #
6 # Conditional build:
7 %bcond_with     glide   # with GLIDE (broken now)
8 %bcond_without  motif   # build static libGLw without Motif interface
9 #
10 %define snap    20061103
11 #
12 Summary:        Free OpenGL implementation
13 Summary(pl):    Wolnodostêpna implementacja standardu OpenGL
14 Name:           Mesa
15 Version:        6.5.2
16 Release:        0.1
17 License:        MIT (core), SGI (GLU,libGLw) and others - see COPYRIGHT file
18 Group:          X11/Libraries
19 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
20 # Source0-md5:  e4d894181f1859651658b3704633e10d
21 # Source0:      %{name}-%{snap}.tar.gz
22 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
23 # Source1-md5:  e870efe98d3a50be01ab211b9b2e25d9
24 Patch0:         %{name}-realclean.patch
25 URL:            http://www.mesa3d.org/
26 %{?with_glide:BuildRequires:    Glide3-DRI-devel}
27 BuildRequires:  expat-devel
28 BuildRequires:  libdrm-devel >= 2.0.2
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:1.4d
31 %{?with_motif:BuildRequires:    motif-devel}
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  xorg-lib-libXt-devel
34 BuildRequires:  xorg-lib-libXxf86vm-devel
35 BuildRequires:  xorg-proto-glproto-devel
36 BuildRequires:  xorg-util-makedepend
37 Obsoletes:      Mesa-dri
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # avoid XFree86-OpenGL* dependency
41 # Glide3 can be provided by Glide_V3-DRI or Glide_V5-DRI
42 %define         _noautoreqdep   libGL.so.1 libGLU.so.1 libOSMesa.so.4   libglide3.so.3
43
44 %define         _sysconfdir     /etc/X11
45
46 %description
47 Mesa is a 3-D graphics library with an API which is very similar to
48 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
49 syntax or state machine, it is being used with authorization from
50 Silicon Graphics, Inc. However, the author does not possess an OpenGL
51 license from SGI, and makes no claim that Mesa is in any way a
52 compatible replacement for OpenGL or associated with SGI.
53
54 %description -l pl
55 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
56 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
57 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
58 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
59 OpenGL ani powi±zana z SGI.
60
61 %package libGL
62 Summary:        Free Mesa3D implementation of libGL OpenGL library
63 Summary(pl):    Wolnodostêpna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
64 License:        MIT
65 Group:          X11/Libraries
66 %{?with_glide:Requires: Glide3-DRI}
67 Provides:       OpenGL = 1.5
68 # reports version 1.3, but supports glXGetProcAddress() from 1.4
69 Provides:       OpenGL-GLX = 1.4
70 Obsoletes:      Mesa
71 Obsoletes:      X11-OpenGL-libGL
72 Obsoletes:      XFree86-OpenGL-libGL
73
74 %description libGL
75 Mesa is a 3-D graphics library with an API which is very similar to
76 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
77 syntax or state machine, it is being used with authorization from
78 Silicon Graphics, Inc. However, the author does not possess an OpenGL
79 license from SGI, and makes no claim that Mesa is in any way a
80 compatible replacement for OpenGL or associated with SGI.
81
82 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
83 specifications. It uses DRI for rendering.
84
85 %description libGL -l pl
86 Mesa jest bibliotek± grafiki 3D z API bardzo podobnym do OpenGL(R). Do
87 tego stopnia, ¿e Mesa u¿ywa sk³adni i automatu OpenGL jest u¿ywana z
88 autoryzacj± Silicon Graphics, Inc. Jednak autor nie posiada licencji
89 OpenGL od SGI i nie twierdzi, ¿e Mesa jest kompatybilnym zamiennikiem
90 OpenGL ani powi±zana z SGI.
91
92 Ten pakiet zawiera libGL implementuj±c± specyfikacje OpenGL 1.5 oraz
93 GLX 1.4. U¿ywa DRI do renderowania.
94
95 %package libGL-devel
96 Summary:        Header files for Mesa3D libGL library
97 Summary(pl):    Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D
98 License:        MIT
99 Group:          X11/Development/Libraries
100 # loose dependency on libGL to use with other libGL binaries
101 Requires:       OpenGL >= 1.5
102 Requires:       xorg-lib-libX11-devel
103 Provides:       OpenGL-devel = 1.5
104 Provides:       OpenGL-GLX-devel = 1.4
105 Obsoletes:      Mesa-devel
106 Obsoletes:      X11-OpenGL-devel
107 Obsoletes:      X11-OpenGL-devel-base
108 Obsoletes:      XFree86-OpenGL-devel
109 Obsoletes:      XFree86-OpenGL-devel-base
110
111 %description libGL-devel
112 Header files for Mesa3D libGL library.
113
114 %description libGL-devel -l pl
115 Pliki nag³ówkowe biblioteki libGL z projektu Mesa3D.
116
117 %package libGL-static
118 Summary:        Static Mesa3D libGL library
119 Summary(pl):    Statyczna biblioteka libGL z projektu Mesa3D
120 License:        MIT
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-libGL-devel = %{version}-%{release}
123 Provides:       OpenGL-static = 1.5
124 Obsoletes:      Mesa-static
125 Obsoletes:      X11-OpenGL-static
126 Obsoletes:      XFree86-OpenGL-static
127
128 %description libGL-static
129 Static Mesa3D libGL library. It uses software renderer.
130
131 %description libGL-static -l pl
132 Statyczna biblioteka libGL z projektu Mesa3D. U¿ywa programowego
133 renderingu.
134
135 %package libGLU
136 Summary:        SGI implementation of libGLU OpenGL library
137 Summary(pl):    Implementacja SGI biblioteki libGLU ze standardu OpenGL
138 License:        SGI Free Software License B v1.1
139 Group:          Libraries
140 # loose dependency on libGL.so.1 to use with other libGL binaries
141 Requires:       OpenGL >= 1.2
142 Provides:       OpenGL-GLU = 1.3
143 Obsoletes:      Mesa-devel
144 Obsoletes:      X11-OpenGL-libs
145 Obsoletes:      XFree86-OpenGL-libs
146
147 %description libGLU
148 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
149 1.3 specifications.
150
151 %description libGLU -l pl
152 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
153 specyfikacjê OpenGL GLU 1.3.
154
155 %package libGLU-devel
156 Summary:        Header files for SGI libGLU library
157 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLU
158 License:        SGI Free Software License B v1.1
159 Group:          Development/Libraries
160 Requires:       %{name}-libGLU = %{version}-%{release}
161 Requires:       OpenGL-devel >= 1.2
162 Requires:       libstdc++-devel
163 Provides:       OpenGL-GLU-devel = 1.3
164
165 %description libGLU-devel
166 Header files for SGI libGLU library.
167
168 %description libGLU-devel -l pl
169 Pliki nag³ówkowe biblioteki SGI libGLU.
170
171 %package libGLU-static
172 Summary:        Static SGI libGLU library
173 Summary(pl):    Statyczna biblioteka SGI libGLU
174 License:        SGI Free Software License B v1.1
175 Group:          Development/Libraries
176 Requires:       %{name}-libGLU-devel = %{version}-%{release}
177 Provides:       OpenGL-GLU-static = 1.3
178
179 %description libGLU-static
180 Static SGI libGLU library.
181
182 %description libGLU-static -l pl
183 Statyczna biblioteka SGI libGLU.
184
185 %package libGLw
186 Summary:        SGI OpenGL Xt widgets library
187 Summary(pl):    Biblioteka SGI widgetów Xt dla OpenGL-a
188 License:        SGI MIT-like
189 Group:          Libraries
190 # loose dependency on libGL.so.1 to use with other libGL binaries
191 Requires:       OpenGL >= 1.1
192 Provides:       OpenGL-GLw
193
194 %description libGLw
195 SGI OpenGL Xt widgets library.
196
197 %description libGLU -l pl
198 Biblioteka SGI widgetów Xt dla OpenGL-a.
199
200 %package libGLw-devel
201 Summary:        Header files for SGI libGLw library
202 Summary(pl):    Pliki nag³ówkowe biblioteki SGI libGLw
203 License:        SGI Free Software License B v1.1
204 Group:          Development/Libraries
205 Requires:       %{name}-libGLw = %{version}-%{release}
206 Requires:       OpenGL-devel >= 1.2
207 Provides:       OpenGL-GLw-devel
208
209 %description libGLw-devel
210 Header files for SGI libGLw library.
211
212 %description libGLw-devel -l pl
213 Pliki nag³ówkowe biblioteki SGI libGLw.
214
215 %package libGLw-static
216 Summary:        Static SGI libGLw library
217 Summary(pl):    Statyczna biblioteka SGI libGLw
218 License:        SGI Free Software License B v1.1
219 Group:          Development/Libraries
220 Requires:       %{name}-libGLw-devel = %{version}-%{release}
221 Provides:       OpenGL-GLw-static
222
223 %description libGLw-static
224 Static SGI libGLw library.
225
226 %description libGLw-static -l pl
227 Statyczna biblioteka SGI libGLw.
228
229 %package utils
230 Summary:        OpenGL utilities from Mesa3D
231 Summary(pl):    Programy narzêdziowe OpenGL z projektu Mesa3D
232 Group:          X11/Applications/Graphics
233 # loose deps on libGL/libGLU
234
235 %description utils
236 OpenGL utilities from Mesa3D: glxgears and glxinfo.
237
238 %description utils -l pl
239 Programy narzêdziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
240
241 %package demos
242 Summary:        Mesa Demos
243 Summary(pl):    Programy demonstruj±ce mo¿liwo¶ci bibliotek Mesa
244 Group:          Development/Libraries
245 Requires:       OpenGL-devel
246
247 %description demos
248 Demonstration programs for the Mesa libraries.
249
250 %description demos -l pl
251 Programy demonstracyjne dla bibliotek Mesa.
252
253 %package dri-driver-ati-mach64
254 Summary:        X.org DRI drivers
255 Summary(pl):    Sterowniki DRI dla X.org
256 Group:          X11/Libraries
257 Requires:       xorg-xserver-server
258
259 %description dri-driver-ati-mach64
260 X.org DRI drivers for ATI mach64 card family.
261
262 %description dri-driver-ati-mach64 -l pl
263 Sterowniki X.org DRI dla rodziny kart ATI mach64.
264
265 %package dri-driver-ati-radeon-R100
266 Summary:        X.org DRI drivers
267 Summary(pl):    Sterowniki DRI dla X.org
268 Group:          X11/Libraries
269 Requires:       xorg-xserver-server
270
271 %description dri-driver-ati-radeon-R100
272 X.org DRI drivers for ATI R100 card family (Radeon 7000-7500).
273
274 %description dri-driver-ati-radeon-R100 -l pl
275 Sterowniki X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
276
277 %package dri-driver-ati-radeon-R200
278 Summary:        X.org DRI drivers
279 Summary(pl):    Sterowniki DRI dla X.org
280 Group:          X11/Libraries
281 Requires:       xorg-xserver-server
282
283 %description dri-driver-ati-radeon-R200
284 X.org DRI drivers for ATI R200 card family (Radeon 8500-92xx)
285
286 %description dri-driver-ati-radeon-R200 -l pl
287 Sterowniki X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
288
289 %package dri-driver-ati-radeon-R300
290 Summary:        X.org DRI drivers
291 Summary(pl):    Sterowniki DRI dla X.org
292 Group:          X11/Libraries
293 Requires:       xorg-xserver-server
294
295 %description dri-driver-ati-radeon-R300
296 X.org DRI drivers for ATI R300 card family.
297
298 %description dri-driver-ati-radeon-R300 -l pl
299 Sterowniki X.org DRI dla rodziny kart ATI R300.
300
301 %package dri-driver-ati-rage128
302 Summary:        X.org DRI drivers
303 Summary(pl):    Sterowniki DRI dla X.org
304 Group:          X11/Libraries
305 Requires:       xorg-xserver-server
306
307 %description dri-driver-ati-rage128
308 X.org DRI drivers for ATI rage128 card family.
309
310 %description dri-driver-ati-rage128 -l pl
311 Sterowniki X.org DRI dla rodziny kart ATI rage128.
312
313 %package dri-driver-ffb
314 Summary:        X.org DRI drivers
315 Summary(pl):    Sterowniki DRI dla X.org
316 Group:          X11/Libraries
317 Requires:       xorg-xserver-server
318
319 %description dri-driver-ffb
320 X.org DRI drivers for SUN Creator3D and Elite3D card family.
321
322 %description dri-driver-ffb -l pl
323 Sterowniki X.org DRI dla rodziny kart SUN Creator3D and Elite3D.
324
325 %package dri-driver-glint
326 Summary:        X.org DRI drivers
327 Summary(pl):    Sterowniki DRI dla X.org
328 Group:          X11/Libraries
329 Requires:       xorg-xserver-server
330
331 %description dri-driver-glint
332 X.org DRI drivers for GLINT/Permedia card family.
333
334 %description dri-driver-glint -l pl
335 Sterowniki X.org DRI dla rodziny kart GLINT/Permedia.
336
337 %package dri-driver-intel-i810
338 Summary:        X.org DRI drivers
339 Summary(pl):    Sterowniki DRI dla X.org
340 Group:          X11/Libraries
341 Requires:       xorg-xserver-server
342
343 %description dri-driver-intel-i810
344 X.org DRI drivers for Intel i810 card family.
345
346 %description dri-driver-intel-i810 -l pl
347 Sterowniki X.org DRI dla rodziny kart i810.
348
349 %package dri-driver-intel-i830
350 Summary:        X.org DRI drivers
351 Summary(pl):    Sterowniki DRI dla X.org
352 Group:          X11/Libraries
353 Requires:       xorg-xserver-server
354
355 %description dri-driver-intel-i830
356 X.org DRI drivers for Intel i830 card family.
357
358 %description dri-driver-intel-i830 -l pl
359 Sterowniki X.org DRI dla rodziny kart i830.
360
361 %package dri-driver-intel-i915
362 Summary:        X.org DRI drivers
363 Summary(pl):    Sterowniki DRI dla X.org
364 Group:          X11/Libraries
365 Requires:       xorg-xserver-server
366 Obsoletes:      Mesa-dri-driver-intel-i830
367
368 %description dri-driver-intel-i915
369 X.org DRI drivers for Intel i915 card family.
370
371 %description dri-driver-intel-i915 -l pl
372 Sterowniki X.org DRI dla rodziny kart i915.
373
374 %package dri-driver-intel-i965
375 Summary:        X.org DRI drivers
376 Summary(pl):    Sterowniki DRI dla X.org
377 Group:          X11/Libraries
378 Requires:       xorg-xserver-server
379 Obsoletes:      Mesa-dri-driver-intel-i830
380 Obsoletes:      Mesa-dri-driver-intel-i915
381
382 %description dri-driver-intel-i965
383 X.org DRI drivers for Intel i965 card family.
384
385 %description dri-driver-intel-i965 -l pl
386 Sterowniki X.org DRI dla rodziny kart i965.
387
388 %package dri-driver-matrox
389 Summary:        X.org DRI drivers
390 Summary(pl):    Sterowniki DRI dla X.org
391 Group:          X11/Libraries
392 Requires:       xorg-xserver-server
393
394 %description dri-driver-matrox
395 X.org DRI drivers for Matrox G card family.
396
397 %description dri-driver-matrox -l pl
398 Sterowniki X.org DRI dla rodziny kart Matrox G.
399
400 %package dri-driver-s3virge
401 Summary:        X.org DRI drivers
402 Summary(pl):    Sterowniki DRI dla X.org
403 Group:          X11/Libraries
404 Requires:       xorg-xserver-server
405
406 %description dri-driver-s3virge
407 X.org DRI drivers for S3 Virge card family.
408
409 %description dri-driver-s3virge -l pl
410 Sterowniki X.org DRI dla rodziny kart S3 Virge.
411
412 %package dri-driver-savage
413 Summary:        X.org DRI drivers
414 Summary(pl):    Sterowniki DRI dla X.org
415 Group:          X11/Libraries
416 Requires:       xorg-xserver-server
417
418 %description dri-driver-savage
419 X.org DRI drivers for S3 Savage card family.
420
421 %description dri-driver-savage -l pl
422 Sterowniki X.org DRI dla rodziny kart S3 Savage.
423
424 %package dri-driver-sis
425 Summary:        X.org DRI drivers
426 Summary(pl):    Sterowniki DRI dla X.org
427 Group:          X11/Libraries
428 Requires:       xorg-xserver-server
429
430 %description dri-driver-sis
431 X.org DRI drivers for SiS card family.
432
433 %description dri-driver-sis -l pl
434 Sterowniki X.org DRI dla rodziny kart SiS.
435
436 %package dri-driver-tdfx
437 Summary:        X.org DRI drivers
438 Summary(pl):    Sterowniki DRI dla X.org
439 Group:          X11/Libraries
440 Requires:       xorg-xserver-server
441
442 %description dri-driver-tdfx
443 X.org DRI drivers for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
444 and Velocity 100/200).
445
446 %description dri-driver-tdfx -l pl
447 Sterowniki X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
448 Banshee and Velocity 100/200).
449
450 %package dri-driver-trident
451 Summary:        X.org DRI drivers
452 Summary(pl):    Sterowniki DRI dla X.org
453 Group:          X11/Libraries
454 Requires:       xorg-xserver-server
455
456 %description dri-driver-trident
457 X.org DRI drivers for Trident card family.
458
459 %description dri-driver-trident -l pl
460 Sterowniki X.org DRI dla rodziny kart Trident.
461
462 %package dri-driver-via-unichrome
463 Summary:        X.org DRI drivers
464 Summary(pl):    Sterowniki DRI dla X.org
465 Group:          X11/Libraries
466 Requires:       xorg-xserver-server
467
468 %description dri-driver-via-unichrome
469 X.org DRI drivers for VIA Unichrome card family.
470
471 %description dri-driver-via-unichrome -l pl
472 Sterowniki X.org DRI dla rodziny kart VIA Unichrome.
473
474 %prep
475 %setup -q -b1
476 #%setup -q -n %{name}
477 %patch0 -p0
478
479 # fix demos
480 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
481
482 %ifnarch sparc sparcv9 sparc64
483 # for sunffb driver - useful on sparc only
484 sed -i -e 's/ ffb$//' configs/linux-dri
485 %endif
486
487 %ifnarch %{ix86} %{x8664}
488 # sis needs write-memory barrier
489 sed -i -e 's/ sis / /' configs/linux-dri
490 %endif
491
492 %build
493 %ifarch %{ix86}
494 targ=-x86
495 %else
496 targ=""
497 %endif
498
499 %{__make} linux${targ}-static \
500         CC="%{__cc}" \
501         CXX="%{__cxx}" \
502         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
503         XLIB_DIR=%{_libdir} \
504         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
505         SRC_DIRS="mesa glu glw" \
506         PROGRAM_DIRS=
507 mv -f lib lib-static
508 %{__make} realclean
509
510 %{__make} linux-dri${targ} \
511         CC="%{__cc}" \
512         CXX="%{__cxx}" \
513         MKDEP=makedepend \
514         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
515         XLIB_DIR=%{_libdir} \
516         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
517         SRC_DIRS="glx/x11 mesa glu glw" \
518         PROGRAM_DIRS=
519
520 %{__make} -C progs/xdemos \
521         CC="%{__cc}" \
522         CXX="%{__cxx}" \
523         OPT_FLAGS="%{rpmcflags}" \
524         XLIB_DIR=%{_libdir} \
525         PROGS="glxgears" \
526         APP_LIB_DEPS="-L../../lib -lGL"
527
528 %{__make} -C progs/xdemos \
529         CC="%{__cc}" \
530         CXX="%{__cxx}" \
531         OPT_FLAGS="%{rpmcflags}" \
532         XLIB_DIR=%{_libdir} \
533         PROGS="glxinfo" \
534         APP_LIB_DEPS="-L../../lib -lGL -L../../lib-dri -lGLU"
535
536 mv -f lib lib-dri
537 %{__make} clean \
538         MKDEP=makedepend
539 %{__make} realclean
540
541 %{__make} linux${targ} \
542         CC="%{__cc}" \
543         CXX="%{__cxx}" \
544         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
545         XLIB_DIR=%{_libdir} \
546         SRC_DIRS="mesa" \
547         PROGRAM_DIRS=
548
549 %install
550 rm -rf $RPM_BUILD_ROOT
551 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL,%{_examplesdir}/%{name}-%{version}}
552 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
553
554 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
555 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
556 cp -df lib/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
557 cp -rf include/GL/{gl[!u]*,glu.h,glu_*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
558 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
559
560 # keep for -bi --short-circuit
561 cp -a progs progs.org
562 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
563 for l in demos redbook samples xdemos ; do
564         %{__make} -C progs/$l clean
565 done
566 for l in demos redbook samples util xdemos images ; do
567         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
568 done
569 rm -rf progs && mv -f progs.org progs
570 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
571
572 %clean
573 rm -rf $RPM_BUILD_ROOT
574
575 %post   libGL -p /sbin/ldconfig
576 %postun libGL -p /sbin/ldconfig
577
578 %post   libGLU -p /sbin/ldconfig
579 %postun libGLU -p /sbin/ldconfig
580
581 %post   libGLw -p /sbin/ldconfig
582 %postun libGLw -p /sbin/ldconfig
583
584 %files libGL
585 %defattr(644,root,root,755)
586 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
587 %attr(755,root,root) %{_libdir}/libGL.so.*.*
588 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
589 # symlink for binary apps which fail to conform Linux OpenGL ABI
590 # (and dlopen libGL.so instead of libGL.so.1)
591 %attr(755,root,root) %{_libdir}/libGL.so
592
593 %files libGL-devel
594 %defattr(644,root,root,755)
595 %doc docs/*.spec
596 %attr(755,root,root) %{_libdir}/libOSMesa.so
597 %dir %{_includedir}/GL
598 %{_includedir}/GL/gl.h
599 %{_includedir}/GL/glext.h
600 %{_includedir}/GL/glfbdev.h
601 %{_includedir}/GL/gl_mangle.h
602 %{_includedir}/GL/glx.h
603 %{_includedir}/GL/glxext.h
604 %{_includedir}/GL/glx_mangle.h
605 %{_includedir}/GL/osmesa.h
606 %{_includedir}/GL/xmesa.h
607 %{_includedir}/GL/xmesa_x.h
608 %{_includedir}/GL/xmesa_xf86.h
609
610 %files libGL-static
611 %defattr(644,root,root,755)
612 %{_libdir}/libGL.a
613 %{_libdir}/libOSMesa.a
614
615 %files libGLU
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
618
619 %files libGLU-devel
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/libGLU.so
622 %{_includedir}/GL/glu.h
623 %{_includedir}/GL/glu_mangle.h
624
625 %files libGLU-static
626 %defattr(644,root,root,755)
627 %{_libdir}/libGLU.a
628
629 %files libGLw
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
632
633 %files libGLw-devel
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/libGLw.so
636 %{_includedir}/GL/GLwDrawA.h
637 %{_includedir}/GL/GLwDrawAP.h
638 %{_includedir}/GL/GLwMDrawA.h
639 %{_includedir}/GL/GLwMDrawAP.h
640
641 %files libGLw-static
642 %defattr(644,root,root,755)
643 %{_libdir}/libGLw.a
644
645 %files utils
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_bindir}/glxgears
648 %attr(755,root,root) %{_bindir}/glxinfo
649
650 %files dri-driver-ati-mach64
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
653
654 %files dri-driver-ati-radeon-R100
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
657
658 %files dri-driver-ati-radeon-R200
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
661
662 %files dri-driver-ati-radeon-R300
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
665
666 %files dri-driver-ati-rage128
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
669
670 # sunffb (sparc only)
671 %ifarch sparc sparcv9 sparc64
672 %files dri-driver-ffb
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
675 %endif
676
677 # glint (requires update)
678 %if 0
679 %files dri-driver-glint
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
682 %endif
683
684 %files dri-driver-intel-i810
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
687
688 %if 0
689 %files dri-driver-intel-i830
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i830_dri.so
692 %endif
693
694 %files dri-driver-intel-i915
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
697 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915tex_dri.so
698
699 %files dri-driver-intel-i965
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
702
703 %files dri-driver-matrox
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
706
707 %files dri-driver-s3virge
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
710
711 %files dri-driver-savage
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
714
715 %ifarch %{ix86} %{x8664}
716 %files dri-driver-sis
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
719 %endif
720
721 %files dri-driver-tdfx
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
724
725 %files dri-driver-trident
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
728
729 %files dri-driver-via-unichrome
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
732
733 %files demos
734 %defattr(644,root,root,755)
735 %{_examplesdir}/%{name}-%{version}
This page took 0.098051 seconds and 3 git commands to generate.