]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- rel 2; use classic driver instead of gallium for radeon
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 #
6 # Conditional build:
7 %bcond_without  egl     # build egl
8 %bcond_without  gallium # don't build gallium
9 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
10 %bcond_with     gallium_radeon
11 %bcond_without  gallium_nouveau
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 %define         libdrm_ver      2.4.21
25 %define         dri2proto_ver   1.99.3
26 %define         glproto_ver     1.4.11
27 #
28 Summary:        Free OpenGL implementation
29 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
30 Name:           Mesa
31 Version:        7.9
32 Release:        2%{?with_multigl:.mgl}
33 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
34 Group:          X11/Libraries
35 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
36 # Source0-md5:  82c740c49d572baa6da2b1a1eee90bca
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-selinux.patch
39 URL:            http://www.mesa3d.org/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  expat-devel
43 BuildRequires:  libdrm-devel >= %{libdrm_ver}
44 BuildRequires:  libselinux-devel
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool >= 2:1.4d
47 %{?with_motif:BuildRequires:    motif-devel}
48 BuildRequires:  pixman-devel
49 BuildRequires:  pkgconfig
50 BuildRequires:  pkgconfig(talloc) >= 2.0.1
51 BuildRequires:  python
52 BuildRequires:  python-modules
53 BuildRequires:  rpmbuild(macros) >= 1.470
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
57 BuildRequires:  xorg-lib-libXt-devel
58 BuildRequires:  xorg-lib-libXxf86vm-devel
59 BuildRequires:  xorg-proto-dri2proto-devel >= %{dri2proto_ver}
60 BuildRequires:  xorg-proto-glproto-devel >= %{glproto_ver}
61 BuildRequires:  xorg-util-makedepend
62 BuildRequires:  xorg-xserver-server-devel
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %if %{without gallium}
66 %undefine       with_gallium_intel
67 %undefine       with_gallium_radeon
68 %endif
69
70 %description
71 Mesa is a 3-D graphics library with an API which is very similar to
72 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
73 syntax or state machine, it is being used with authorization from
74 Silicon Graphics, Inc. However, the author does not possess an OpenGL
75 license from SGI, and makes no claim that Mesa is in any way a
76 compatible replacement for OpenGL or associated with SGI.
77
78 %description -l pl.UTF-8
79 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
80 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
81 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
82 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
83 OpenGL ani powiązana z SGI.
84
85 %package libEGL
86 Summary:        SGI implementation of libEGL OpenGL library
87 Summary(pl.UTF-8):      Implementacja SGI biblioteki libEGL ze standardu OpenGL
88 License:        SGI Free Software License B v2.0 (MIT-like)
89 Group:          Libraries
90 Requires:       OpenGL >= 1.2
91 Provides:       OpenGL-EGL = 1.0
92
93 %description libEGL
94 SGI implementation of libEGL OpenGL library.
95
96 %description libEGL -l pl.UTF-8
97 Implementacja SGI biblioteki libEGL ze standardu OpenGL.
98
99 %package libEGL-devel
100 Summary:        Header files for SGI libEGL library
101 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libEGL
102 License:        SGI Free Software License B v2.0 (MIT-like)
103 Group:          Development/Libraries
104 Requires:       %{name}-libEGL = %{version}-%{release}
105 Requires:       OpenGL-devel >= 1.2
106 Requires:       libstdc++-devel
107 Provides:       OpenGL-EGL-devel = 1.0
108
109 %description libEGL-devel
110 Header files for SGI libEGL library.
111
112 %description libEGL-devel -l pl.UTF-8
113 Pliki nagłówkowe biblioteki SGI libEGL.
114
115 %package libEGL-static
116 Summary:        Static SGI libEGL library
117 Summary(pl.UTF-8):      Statyczna biblioteka SGI libEGL
118 License:        SGI Free Software License B v2.0 (MIT-like)
119 Group:          Development/Libraries
120 Requires:       %{name}-libEGL-devel = %{version}-%{release}
121 Provides:       OpenGL-EGL-static = 1.0
122
123 %description libEGL-static
124 Static SGI libEGL library.
125
126 %description libEGL-static -l pl.UTF-8
127 Statyczna biblioteka SGI libEGL.
128
129 %package libGL
130 Summary:        Free Mesa3D implementation of libGL OpenGL library
131 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
132 License:        MIT
133 Group:          X11/Libraries
134 Requires:       libdrm >= %{libdrm_ver}
135 Provides:       OpenGL = 2.1
136 # reports version 1.3, but supports glXGetProcAddress() from 1.4
137 Provides:       OpenGL-GLX = 1.4
138 Obsoletes:      Mesa
139 Obsoletes:      Mesa-dri
140 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
141 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
142
143 %description libGL
144 Mesa is a 3-D graphics library with an API which is very similar to
145 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
146 syntax or state machine, it is being used with authorization from
147 Silicon Graphics, Inc. However, the author does not possess an OpenGL
148 license from SGI, and makes no claim that Mesa is in any way a
149 compatible replacement for OpenGL or associated with SGI.
150
151 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
152 specifications. It uses DRI for rendering.
153
154 %description libGL -l pl.UTF-8
155 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
156 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
157 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
158 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
159 OpenGL ani powiązana z SGI.
160
161 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
162 GLX 1.4. Używa DRI do renderowania.
163
164 %package libGL-devel
165 Summary:        Header files for Mesa3D libGL library
166 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
167 License:        MIT
168 Group:          X11/Development/Libraries
169 # loose dependency on libGL to use with other libGL binaries
170 Requires:       OpenGL >= 1.5
171 Requires:       libdrm-devel >= %{libdrm_ver}
172 Requires:       xorg-lib-libX11-devel
173 Requires:       xorg-lib-libXdamage-devel
174 Requires:       xorg-lib-libXext-devel
175 Requires:       xorg-lib-libXxf86vm-devel
176 Requires:       xorg-proto-dri2proto-devel >= %{dri2proto_ver}
177 Requires:       xorg-proto-glproto-devel >= %{glproto_ver}
178 Suggests:       OpenGL-doc-man
179 Provides:       OpenGL-GLX-devel = 1.4
180 Provides:       OpenGL-devel = 2.1
181 Obsoletes:      Mesa-devel
182 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
183 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
184 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
185 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
186
187 %description libGL-devel
188 Header files for Mesa3D libGL library.
189
190 %description libGL-devel -l pl.UTF-8
191 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
192
193 %package libGL-static
194 Summary:        Static Mesa3D libGL library
195 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
196 License:        MIT
197 Group:          X11/Development/Libraries
198 Requires:       %{name}-libGL-devel = %{version}-%{release}
199 Provides:       OpenGL-static = 2.1
200 Obsoletes:      Mesa-static
201 Obsoletes:      X11-OpenGL-static < 1:7.0.0
202 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
203
204 %description libGL-static
205 Static Mesa3D libGL library. It uses software renderer.
206
207 %description libGL-static -l pl.UTF-8
208 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
209 renderingu.
210
211 %package libGLU
212 Summary:        SGI implementation of libGLU OpenGL library
213 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
214 License:        SGI Free Software License B v2.0 (MIT-like)
215 Group:          Libraries
216 # loose dependency on libGL.so.1 to use with other libGL binaries
217 Requires:       OpenGL >= 1.2
218 Provides:       OpenGL-GLU = 1.3
219 Obsoletes:      Mesa-devel
220 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
221 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
222
223 %description libGLU
224 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
225 1.3 specifications.
226
227 %description libGLU -l pl.UTF-8
228 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
229 specyfikację OpenGL GLU 1.3.
230
231 %package libGLU-devel
232 Summary:        Header files for SGI libGLU library
233 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
234 License:        SGI Free Software License B v2.0 (MIT-like)
235 Group:          Development/Libraries
236 Requires:       %{name}-libGLU = %{version}-%{release}
237 Requires:       OpenGL-devel >= 1.2
238 Requires:       libstdc++-devel
239 Provides:       OpenGL-GLU-devel = 1.3
240
241 %description libGLU-devel
242 Header files for SGI libGLU library.
243
244 %description libGLU-devel -l pl.UTF-8
245 Pliki nagłówkowe biblioteki SGI libGLU.
246
247 %package libGLU-static
248 Summary:        Static SGI libGLU library
249 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
250 License:        SGI Free Software License B v2.0 (MIT-like)
251 Group:          Development/Libraries
252 Requires:       %{name}-libGLU-devel = %{version}-%{release}
253 Provides:       OpenGL-GLU-static = 1.3
254
255 %description libGLU-static
256 Static SGI libGLU library.
257
258 %description libGLU-static -l pl.UTF-8
259 Statyczna biblioteka SGI libGLU.
260
261 %package libGLw
262 Summary:        SGI OpenGL Xt widgets library
263 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
264 License:        SGI MIT-like
265 Group:          Libraries
266 # loose dependency on libGL.so.1 to use with other libGL binaries
267 Requires:       OpenGL >= 1.1
268 Provides:       OpenGL-GLw
269
270 %description libGLw
271 SGI OpenGL Xt widgets library.
272
273 %description libGLU -l pl.UTF-8
274 Biblioteka SGI widgetów Xt dla OpenGL-a.
275
276 %package libGLw-devel
277 Summary:        Header files for SGI libGLw library
278 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
279 License:        SGI MIT-like
280 Group:          Development/Libraries
281 Requires:       %{name}-libGLw = %{version}-%{release}
282 Requires:       OpenGL-devel >= 1.2
283 Provides:       OpenGL-GLw-devel
284
285 %description libGLw-devel
286 Header files for SGI libGLw library.
287
288 %description libGLw-devel -l pl.UTF-8
289 Pliki nagłówkowe biblioteki SGI libGLw.
290
291 %package libGLw-static
292 Summary:        Static SGI libGLw library
293 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
294 License:        SGI MIT-like
295 Group:          Development/Libraries
296 Requires:       %{name}-libGLw-devel = %{version}-%{release}
297 Provides:       OpenGL-GLw-static
298
299 %description libGLw-static
300 Static SGI libGLw library.
301
302 %description libGLw-static -l pl.UTF-8
303 Statyczna biblioteka SGI libGLw.
304
305 %package libOSMesa
306 Summary:        OSMesa (off-screen renderer) library
307 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
308 License:        MIT
309 Group:          Libraries
310 # doesn't require base
311
312 %description libOSMesa
313 OSMesa (off-screen renderer) library.
314
315 %description libOSMesa -l pl.UTF-8
316 Biblioteka OSMesa (renderująca bitmapy w pamięci).
317
318 %package libOSMesa-devel
319 Summary:        Header file for OSMesa (off-screen renderer) library
320 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
321 License:        MIT
322 Group:          Development/Libraries
323 Requires:       %{name}-libOSMesa = %{version}-%{release}
324 # for <GL/gl.h> only
325 Requires:       OpenGL-devel
326
327 %description libOSMesa-devel
328 Header file for OSMesa (off-screen renderer) library.
329
330 %description libOSMesa-devel -l pl.UTF-8
331 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
332
333 %package libOSMesa-static
334 Summary:        Static OSMesa (off-screen renderer) library
335 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
336 License:        MIT
337 Group:          Development/Libraries
338 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
339 # this static build of OSMesa needs static non-dri Mesa implementation
340 Requires:       %{name}-libGL-static = %{version}-%{release}
341
342 %description libOSMesa-static
343 Static OSMesa (off-screen renderer) library.
344
345 %description libOSMesa-static -l pl.UTF-8
346 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
347
348 %package utils
349 Summary:        OpenGL utilities from Mesa3D
350 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
351 License:        MIT
352 Group:          X11/Applications/Graphics
353 # loose deps on libGL/libGLU
354
355 %description utils
356 OpenGL utilities from Mesa3D: glxgears and glxinfo.
357
358 %description utils -l pl.UTF-8
359 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
360
361 %package dri-driver-ati-mach64
362 Summary:        X.org DRI driver for ATI Mach64 card family
363 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
364 License:        MIT
365 Group:          X11/Libraries
366 Requires:       xorg-driver-video-mach64
367 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
368 Requires:       xorg-xserver-server >= %{xserver_ver}
369
370 %description dri-driver-ati-mach64
371 X.org DRI driver for ATI Mach64 card family.
372
373 %description dri-driver-ati-mach64 -l pl.UTF-8
374 Sterownik X.org DRI dla rodziny kart ATI Mach64.
375
376 %package dri-driver-ati-radeon-R100
377 Summary:        X.org DRI driver for ATI R100 card family
378 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
379 License:        MIT
380 Group:          X11/Libraries
381 Requires:       xorg-driver-video-ati
382 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
383 Requires:       xorg-xserver-server >= %{xserver_ver}
384 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
385
386 %description dri-driver-ati-radeon-R100
387 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
388
389 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
390 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
391
392 %package dri-driver-ati-radeon-R200
393 Summary:        X.org DRI driver for ATI R200 card family
394 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
395 License:        MIT
396 Group:          X11/Libraries
397 Requires:       xorg-driver-video-ati
398 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
399 Requires:       xorg-xserver-server >= %{xserver_ver}
400 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
401
402 %description dri-driver-ati-radeon-R200
403 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
404
405 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
406 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
407
408 %package dri-driver-ati-radeon-R300
409 Summary:        X.org DRI driver for ATI R300 card family
410 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
411 License:        MIT
412 Group:          X11/Libraries
413 Requires:       xorg-driver-video-ati
414 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
415 Requires:       xorg-xserver-server >= %{xserver_ver}
416 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
417
418 %description dri-driver-ati-radeon-R300
419 X.org DRI driver for ATI R300 card family.
420
421 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
422 Sterownik X.org DRI dla rodziny kart ATI R300.
423
424 %package dri-driver-ati-radeon-R600
425 Summary:        X.org DRI driver for ATI R600 card family
426 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R600
427 License:        MIT
428 Group:          X11/Libraries
429 Requires:       radeon-ucode
430 Requires:       xorg-driver-video-ati
431 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
432 Requires:       xorg-xserver-server >= %{xserver_ver}
433
434 %description dri-driver-ati-radeon-R600
435 X.org DRI driver for ATI R600 card family.
436
437 %description dri-driver-ati-radeon-R600 -l pl.UTF-8
438 Sterownik X.org DRI dla rodziny kart ATI R600.
439
440 %package dri-driver-ati-rage128
441 Summary:        X.org DRI driver for ATI Rage128 card family
442 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
443 License:        MIT
444 Group:          X11/Libraries
445 Requires:       xorg-driver-video-r128
446 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
447 Requires:       xorg-xserver-server >= %{xserver_ver}
448 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
449
450 %description dri-driver-ati-rage128
451 X.org DRI driver for ATI Rage128 card family.
452
453 %description dri-driver-ati-rage128 -l pl.UTF-8
454 Sterownik X.org DRI dla rodziny kart ATI Rage128.
455
456 %package dri-driver-ffb
457 Summary:        X.org DRI driver for Sun FFB card family
458 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
459 License:        MIT
460 Group:          X11/Libraries
461 Requires:       xorg-driver-video-sunffb
462 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
463 Requires:       xorg-xserver-server >= %{xserver_ver}
464
465 %description dri-driver-ffb
466 X.org DRI driver for SUN Creator3D and Elite3D card family.
467
468 %description dri-driver-ffb -l pl.UTF-8
469 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
470
471 %package dri-driver-glint
472 Summary:        X.org DRI driver for GLINT/Permedia card family
473 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
474 License:        MIT
475 Group:          X11/Libraries
476 Requires:       xorg-driver-video-glint
477 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
478 Requires:       xorg-xserver-server >= %{xserver_ver}
479 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
480
481 %description dri-driver-glint
482 X.org DRI driver for GLINT/Permedia card family.
483
484 %description dri-driver-glint -l pl.UTF-8
485 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
486
487 %package dri-driver-intel-i810
488 Summary:        X.org DRI driver for Intel i810 card family
489 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
490 License:        MIT
491 Group:          X11/Libraries
492 Requires:       xorg-driver-video-intel
493 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
494 Requires:       xorg-xserver-server >= %{xserver_ver}
495 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
496
497 %description dri-driver-intel-i810
498 X.org DRI driver for Intel i810 card family.
499
500 %description dri-driver-intel-i810 -l pl.UTF-8
501 Sterownik X.org DRI dla rodziny kart Intel i810.
502
503 %package dri-driver-intel-i915
504 Summary:        X.org DRI driver for Intel i915 card family
505 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
506 License:        MIT
507 Group:          X11/Libraries
508 Requires:       xorg-driver-video-intel
509 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
510 Requires:       xorg-xserver-server >= %{xserver_ver}
511 Obsoletes:      Mesa-dri-driver-intel-i830
512 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
513
514 %description dri-driver-intel-i915
515 X.org DRI driver for Intel i915 card family.
516
517 %description dri-driver-intel-i915 -l pl.UTF-8
518 Sterownik X.org DRI dla rodziny kart Intel i915.
519
520 %package dri-driver-intel-i965
521 Summary:        X.org DRI driver for Intel i965 card family
522 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
523 License:        MIT
524 Group:          X11/Libraries
525 Requires:       xorg-driver-video-intel
526 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
527 Requires:       xorg-xserver-server >= %{xserver_ver}
528 Obsoletes:      Mesa-dri-driver-intel-i830
529 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
530
531 %description dri-driver-intel-i965
532 X.org DRI driver for Intel i965 card family.
533
534 %description dri-driver-intel-i965 -l pl.UTF-8
535 Sterownik X.org DRI dla rodziny kart Intel i965.
536
537 %package dri-driver-matrox
538 Summary:        X.org DRI driver for Matrox G card family
539 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
540 License:        MIT
541 Group:          X11/Libraries
542 Requires:       xorg-driver-video-mga
543 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
544 Requires:       xorg-xserver-server >= %{xserver_ver}
545 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
546
547 %description dri-driver-matrox
548 X.org DRI drivers for Matrox G card family.
549
550 %description dri-driver-matrox -l pl.UTF-8
551 Sterowniki X.org DRI dla rodziny kart Matrox G.
552
553 %package dri-driver-nouveau
554 Summary:        X.org DRI driver for NVIDIA card family
555 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
556 License:        MIT
557 Group:          X11/Libraries
558 Requires:       xorg-driver-video-nouveau
559 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
560 Requires:       xorg-xserver-server >= %{xserver_ver}
561
562 %description dri-driver-nouveau
563 X.org DRI drivers for NVIDIA card family.
564
565 %description dri-driver-nouveau -l pl.UTF-8
566 Sterowniki X.org DRI dla rodziny kart NVIDIA.
567
568 %package dri-driver-savage
569 Summary:        X.org DRI driver for S3 Savage card family
570 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
571 License:        MIT
572 Group:          X11/Libraries
573 Requires:       xorg-driver-video-savage
574 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
575 Requires:       xorg-xserver-server >= %{xserver_ver}
576
577 %description dri-driver-savage
578 X.org DRI driver for S3 Savage card family.
579
580 %description dri-driver-savage -l pl.UTF-8
581 Sterownik X.org DRI dla rodziny kart S3 Savage.
582
583 %package dri-driver-sis
584 Summary:        X.org DRI driver for SiS card family
585 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
586 License:        MIT
587 Group:          X11/Libraries
588 Requires:       xorg-driver-video-sis
589 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
590 Requires:       xorg-xserver-server >= %{xserver_ver}
591 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
592
593 %description dri-driver-sis
594 X.org DRI driver for SiS card family.
595
596 %description dri-driver-sis -l pl.UTF-8
597 Sterownik X.org DRI dla rodziny kart SiS.
598
599 %package dri-driver-swrast
600 Summary:        X.org DRI software rasterizer driver
601 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
602 License:        MIT
603 Group:          X11/Libraries
604 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
605 Requires:       xorg-xserver-server >= %{xserver_ver}
606
607 %description dri-driver-swrast
608 X.org DRI software rasterizer driver.
609
610 %description dri-driver-swrast -l pl.UTF-8
611 Sterownik X.org DRI obsługujący rysowanie programowe.
612
613 %package dri-driver-tdfx
614 Summary:        X.org DRI driver for 3DFX Voodoo card family
615 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
616 License:        MIT
617 Group:          X11/Libraries
618 Requires:       Glide3-DRI
619 Requires:       xorg-driver-video-tdfx
620 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
621 Requires:       xorg-xserver-server >= %{xserver_ver}
622 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
623
624 %description dri-driver-tdfx
625 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
626 and Velocity 100/200).
627
628 %description dri-driver-tdfx -l pl.UTF-8
629 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
630 Banshee i Velocity 100/200).
631
632 %package dri-driver-via-unichrome
633 Summary:        X.org DRI driver for VIA Unichrome card family
634 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
635 License:        MIT
636 Group:          X11/Libraries
637 Requires:       xorg-driver-video-openchrome
638 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
639 Requires:       xorg-xserver-server >= %{xserver_ver}
640
641 %description dri-driver-via-unichrome
642 X.org DRI driver for VIA Unichrome card family.
643
644 %description dri-driver-via-unichrome -l pl.UTF-8
645 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
646
647 %package dri-driver-vmwgfx
648 Summary:        X.org DRI driver for VMware
649 Summary(pl.UTF-8):      Sterownik X.org DRI dla VMware
650 License:        MIT
651 Group:          X11/Libraries
652 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
653 Requires:       xorg-xserver-server >= %{xserver_ver}
654
655 %description dri-driver-vmwgfx
656 X.org DRI driver for VMWare.
657
658 %description dri-driver-vmwgfx -l pl.UTF-8
659 Sterownik X.org DRI dla VMware.
660
661 %prep
662 %setup -q
663 %patch0 -p0
664 %patch1 -p0
665
666 %build
667 #autoreconf --install
668 %{__aclocal}
669 %{__autoconf}
670
671 dri_drivers="i810 i965 mach64 mga r128 \
672 %if %{without gallium_radeon}
673 r200 r300 r600 radeon \
674 %endif
675 savage \
676 %if %{without gallium_intel}
677 i915 \
678 %endif
679 %ifarch sparc sparcv9 sparc64
680 ffb \
681 %endif
682 %ifarch %{ix86} %{x8664}
683 sis \
684 %endif
685 swrast tdfx unichrome"
686
687 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
688
689 common_flags="\
690         --enable-shared \
691         --enable-selinux \
692         --enable-pic \
693         --enable-glx-tls \
694         --disable-glut \
695         --disable-os-mesa \
696         --%{?with_egl:en}%{!?with_egl:dis}able-egl"
697
698 osmesa_common_flags="\
699         --with-driver=osmesa \
700         --disable-asm \
701         --disable-glu"
702
703 %if %{with osmesa}
704 # osmesa variants
705 %configure $common_flags $osmesa_common_flags \
706         --with-osmesa-bits=8
707 %{__make}
708 mv %{_lib} osmesa8
709 %{__make} clean
710
711 %configure $common_flags $osmesa_common_flags \
712         --with-osmesa-bits=16
713 %{__make}
714 mv %{_lib} osmesa16
715 %{__make} clean
716
717 %configure $common_flags $osmesa_common_flags \
718         --with-osmesa-bits=32
719 %{__make}
720 mv %{_lib} osmesa32
721 %{__make} clean
722 %endif
723
724 %configure $common_flags \
725 %if %{with gallium}
726         --enable-gallium \
727         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
728         --%{?with_gallium_radeon:en}%{!?with_gallium_radeon:dis}able-gallium-radeon \
729         --enable-gallium-svga \
730 %{?with_gallium_nouveau:--enable-gallium-nouveau} \
731         --with-state-trackers=dri,glx \
732 %else
733         --disable-gallium \
734 %endif
735         --with-driver=dri \
736         --with-dri-drivers=${dri_drivers} \
737         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
738
739 %{__make}
740
741 %install
742 rm -rf $RPM_BUILD_ROOT
743
744 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
745
746 # libs without drivers
747 %{__make} install \
748         DESTDIR=$RPM_BUILD_ROOT
749
750 %if %{with osmesa}
751 install osmesa*/*OSMesa* $RPM_BUILD_ROOT%{_libdir}
752 %endif
753
754 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
755
756 # strip out undesirable headers
757 olddir=$(pwd)
758 cd $RPM_BUILD_ROOT%{_includedir}/GL
759 rm [a-fh-np-wyz]*.h glf*.h
760 cd $RPM_BUILD_ROOT%{_libdir}
761 cd $olddir
762
763 %if %{with multigl}
764 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
765
766 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
767 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
768
769 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
770 %endif
771
772 %clean
773 rm -rf $RPM_BUILD_ROOT
774
775 %post   libEGL -p /sbin/ldconfig
776 %postun libEGL -p /sbin/ldconfig
777
778 %post   libGL -p /sbin/ldconfig
779 %postun libGL -p /sbin/ldconfig
780
781 %post   libGLU -p /sbin/ldconfig
782 %postun libGLU -p /sbin/ldconfig
783
784 %post   libGLw -p /sbin/ldconfig
785 %postun libGLw -p /sbin/ldconfig
786
787 %if %{with egl}
788 %files libEGL
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libEGL.so.*.*
791 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.?
792 %dir %{_libdir}/egl
793 %attr(755,root,root) %{_libdir}/egl/egl_dri2.so
794 %attr(755,root,root) %{_libdir}/egl/egl_glx.so
795
796 %files libEGL-devel
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{_libdir}/libEGL.so
799 %attr(755,root,root) %ghost %{_libdir}/libEGL.so.?
800 %dir %{_includedir}/EGL
801 %{_includedir}/EGL/egl.h
802 %{_includedir}/EGL/eglext.h
803 %{_includedir}/EGL/eglplatform.h
804 %dir %{_includedir}/KHR
805 %{_includedir}/KHR/khrplatform.h
806 %{_pkgconfigdir}/egl.pc
807
808 %if %{with static}
809 %files libEGL-static
810 %defattr(644,root,root,755)
811 %{_libdir}/libEGL.a
812 %endif
813 %endif
814
815 %files libGL
816 %defattr(644,root,root,755)
817 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
818 %if %{with multigl}
819 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
820 %dir %{_libdir}/Mesa
821 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
822 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
823 %else
824 %attr(755,root,root) %{_libdir}/libGL.so.*.*
825 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
826 # symlink for binary apps which fail to conform Linux OpenGL ABI
827 # (and dlopen libGL.so instead of libGL.so.1)
828 %attr(755,root,root) %{_libdir}/libGL.so
829 %endif
830
831 %files libGL-devel
832 %defattr(644,root,root,755)
833 %doc docs/*.spec
834 %if %{with multigl}
835 %attr(755,root,root) %{_libdir}/libGL.so
836 %endif
837 %dir %{_includedir}/GL
838 %{_includedir}/GL/gl.h
839 %{_includedir}/GL/glext.h
840 %{_includedir}/GL/gl_mangle.h
841 %{_includedir}/GL/glx.h
842 %{_includedir}/GL/glxext.h
843 %{_includedir}/GL/glx_mangle.h
844 %dir %{_includedir}/GL/internal
845 %{_includedir}/GL/internal/dri_interface.h
846 %{_pkgconfigdir}/dri.pc
847 %{_pkgconfigdir}/gl.pc
848
849 %if %{with static}
850 %files libGL-static
851 %defattr(644,root,root,755)
852 %{_libdir}/libGL.a
853 %endif
854
855 %files libGLU
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
858 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.?
859
860 %files libGLU-devel
861 %defattr(644,root,root,755)
862 %attr(755,root,root) %{_libdir}/libGLU.so
863 %{_includedir}/GL/glu.h
864 %{_includedir}/GL/glu_mangle.h
865 %{_pkgconfigdir}/glu.pc
866
867 %if %{with static}
868 %files libGLU-static
869 %defattr(644,root,root,755)
870 %{_libdir}/libGLU.a
871 %endif
872
873 %files libGLw
874 %defattr(644,root,root,755)
875 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
876 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.?
877
878 %files libGLw-devel
879 %defattr(644,root,root,755)
880 %attr(755,root,root) %{_libdir}/libGLw.so
881 %{_includedir}/GL/GLwDrawA.h
882 %{_includedir}/GL/GLwDrawAP.h
883 %{_includedir}/GL/GLwMDrawA.h
884 %{_includedir}/GL/GLwMDrawAP.h
885 %{_pkgconfigdir}/glw.pc
886
887 %if %{with static}
888 %files libGLw-static
889 %defattr(644,root,root,755)
890 %{_libdir}/libGLw.a
891 %endif
892
893 %if %{with osmesa}
894 %files libOSMesa
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
897 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
898
899 %files libOSMesa-devel
900 %defattr(644,root,root,755)
901 %attr(755,root,root) %{_libdir}/libOSMesa*.so
902 %{_includedir}/GL/osmesa.h
903
904 %if %{with static}
905 %files libOSMesa-static
906 %defattr(644,root,root,755)
907 %{_libdir}/libOSMesa*.a
908 %endif
909 %endif
910
911 %files dri-driver-ati-mach64
912 %defattr(644,root,root,755)
913 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
914
915 %files dri-driver-ati-radeon-R100
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
918
919 %files dri-driver-ati-radeon-R200
920 %defattr(644,root,root,755)
921 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
922
923 %files dri-driver-ati-radeon-R300
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
926
927 %files dri-driver-ati-radeon-R600
928 %defattr(644,root,root,755)
929 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r600_dri.so
930
931 %files dri-driver-ati-rage128
932 %defattr(644,root,root,755)
933 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
934
935 # sunffb (sparc only)
936 %ifarch sparc sparcv9 sparc64
937 %files dri-driver-ffb
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
940 %endif
941
942 # glint (requires update)
943 %if 0
944 %files dri-driver-glint
945 %defattr(644,root,root,755)
946 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
947 %endif
948
949 %files dri-driver-intel-i810
950 %defattr(644,root,root,755)
951 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
952
953 %files dri-driver-intel-i915
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
956
957 %files dri-driver-intel-i965
958 %defattr(644,root,root,755)
959 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
960
961 %files dri-driver-matrox
962 %defattr(644,root,root,755)
963 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
964
965 %if %{with gallium}
966 %if %{with gallium_nouveau}
967 %files dri-driver-nouveau
968 %defattr(644,root,root,755)
969 #%attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
970 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
971 %endif
972 %endif
973
974 %files dri-driver-savage
975 %defattr(644,root,root,755)
976 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
977
978 %ifarch %{ix86} %{x8664}
979 %files dri-driver-sis
980 %defattr(644,root,root,755)
981 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
982 %endif
983
984 %files dri-driver-swrast
985 %defattr(644,root,root,755)
986 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
987 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrastg_dri.so
988
989 %files dri-driver-tdfx
990 %defattr(644,root,root,755)
991 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
992
993 %files dri-driver-via-unichrome
994 %defattr(644,root,root,755)
995 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
996
997 %if %{with gallium}
998 %files dri-driver-vmwgfx
999 %defattr(644,root,root,755)
1000 %attr(755,root,root) %{_libdir}/xorg/modules/dri/vmwgfx_dri.so
1001 %endif
This page took 0.098132 seconds and 3 git commands to generate.