]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
d41c5e0ae0f916c5205b2001e673d356a4975929
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 # - resurrect static if it's useful
5 # - subpackage egl?
6 #
7 # Conditional build:
8 %bcond_without  demos   # don't build demos
9 %bcond_with     egl     # don't build egl
10 %bcond_without  gallium # don't build gallium
11 %bcond_with     gallium_intel # gallium i915 driver (but doesn't work with AIGLX)
12 %bcond_without  motif   # build static libGLw without Motif interface
13 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
14 %bcond_without  osmesa  # don't build osmesa
15 %bcond_with     static
16 #
17 # minimal supported xserver version
18 %define         xserver_ver     1.5.0
19 # glapi version (glapi tables in dri drivers and libglx must be in sync);
20 # set to current Mesa version on ABI break, when xserver tables get regenerated
21 # (until they start to be somehow versioned themselves)
22 %define         glapi_ver       7.1.0
23 #
24 Summary:        Free OpenGL implementation
25 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
26 Name:           Mesa
27 Version:        7.6
28 Release:        2%{?with_multigl:.mgl}
29 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
30 Group:          X11/Libraries
31 Source0:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Lib-%{version}.tar.bz2
32 # Source0-md5:  8c75f90cd0303cfac9e4b6d54f6759ca
33 Source1:        ftp://ftp.freedesktop.org/pub/mesa/%{version}/%{name}Demos-%{version}.tar.bz2
34 # Source1-md5:  0ede7adf217951acd90dbe4551210c07
35 Source2:        http://www.archlinux.org/~jgc/gl-manpages-1.0.1.tar.bz2
36 # Source2-md5:  6ae05158e678f4594343f32c2ca50515
37 Patch0:         %{name}-realclean.patch
38 Patch1:         %{name}-sparc64.patch
39 Patch2:         %{name}-git.patch
40 URL:            http://www.mesa3d.org/
41 BuildRequires:  expat-devel
42 %{?with_demos:BuildRequires:    glew-devel}
43 BuildRequires:  libdrm-devel >= 2.4.12-3
44 BuildRequires:  libselinux-devel
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libtool >= 2:1.4d
47 %{?with_motif:BuildRequires:    motif-devel}
48 BuildRequires:  rpmbuild(macros) >= 1.470
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  xorg-lib-libXdamage-devel
51 BuildRequires:  xorg-lib-libXext-devel >= 1.0.5
52 BuildRequires:  xorg-lib-libXt-devel
53 BuildRequires:  xorg-lib-libXxf86vm-devel
54 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
55 BuildRequires:  xorg-proto-glproto-devel
56 BuildRequires:  xorg-proto-printproto-devel
57 BuildRequires:  xorg-util-makedepend
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %if %{without gallium}
61 %undefine       with_gallium_intel
62 %endif
63
64 %description
65 Mesa is a 3-D graphics library with an API which is very similar to
66 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
67 syntax or state machine, it is being used with authorization from
68 Silicon Graphics, Inc. However, the author does not possess an OpenGL
69 license from SGI, and makes no claim that Mesa is in any way a
70 compatible replacement for OpenGL or associated with SGI.
71
72 %description -l pl.UTF-8
73 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
74 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
75 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
76 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
77 OpenGL ani powiązana z SGI.
78
79 %package libGL
80 Summary:        Free Mesa3D implementation of libGL OpenGL library
81 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
82 License:        MIT
83 Group:          X11/Libraries
84 Requires:       libdrm >= 2.4.5
85 Provides:       OpenGL = 2.1
86 # reports version 1.3, but supports glXGetProcAddress() from 1.4
87 Provides:       OpenGL-GLX = 1.4
88 Obsoletes:      Mesa
89 Obsoletes:      Mesa-dri
90 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
91 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
92
93 %description libGL
94 Mesa is a 3-D graphics library with an API which is very similar to
95 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
96 syntax or state machine, it is being used with authorization from
97 Silicon Graphics, Inc. However, the author does not possess an OpenGL
98 license from SGI, and makes no claim that Mesa is in any way a
99 compatible replacement for OpenGL or associated with SGI.
100
101 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
102 specifications. It uses DRI for rendering.
103
104 %description libGL -l pl.UTF-8
105 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
106 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
107 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
108 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
109 OpenGL ani powiązana z SGI.
110
111 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
112 GLX 1.4. Używa DRI do renderowania.
113
114 %package libGL-devel
115 Summary:        Header files for Mesa3D libGL library
116 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
117 License:        MIT
118 Group:          X11/Development/Libraries
119 # loose dependency on libGL to use with other libGL binaries
120 Requires:       OpenGL >= 1.5
121 Requires:       xorg-lib-libX11-devel
122 Provides:       OpenGL-GLX-devel = 1.4
123 Provides:       OpenGL-devel = 2.1
124 Obsoletes:      Mesa-devel
125 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
126 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
127 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
128 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
129
130 %description libGL-devel
131 Header files for Mesa3D libGL library.
132
133 %description libGL-devel -l pl.UTF-8
134 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
135
136 %package libGL-static
137 Summary:        Static Mesa3D libGL library
138 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
139 License:        MIT
140 Group:          X11/Development/Libraries
141 Requires:       %{name}-libGL-devel = %{version}-%{release}
142 Provides:       OpenGL-static = 2.1
143 Obsoletes:      Mesa-static
144 Obsoletes:      X11-OpenGL-static < 1:7.0.0
145 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
146
147 %description libGL-static
148 Static Mesa3D libGL library. It uses software renderer.
149
150 %description libGL-static -l pl.UTF-8
151 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
152 renderingu.
153
154 %package libGLU
155 Summary:        SGI implementation of libGLU OpenGL library
156 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
157 License:        SGI Free Software License B v2.0 (MIT-like)
158 Group:          Libraries
159 # loose dependency on libGL.so.1 to use with other libGL binaries
160 Requires:       OpenGL >= 1.2
161 Provides:       OpenGL-GLU = 1.3
162 Obsoletes:      Mesa-devel
163 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
164 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
165
166 %description libGLU
167 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
168 1.3 specifications.
169
170 %description libGLU -l pl.UTF-8
171 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
172 specyfikację OpenGL GLU 1.3.
173
174 %package libGLU-devel
175 Summary:        Header files for SGI libGLU library
176 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
177 License:        SGI Free Software License B v2.0 (MIT-like)
178 Group:          Development/Libraries
179 Requires:       %{name}-libGLU = %{version}-%{release}
180 Requires:       OpenGL-devel >= 1.2
181 Requires:       libstdc++-devel
182 Provides:       OpenGL-GLU-devel = 1.3
183
184 %description libGLU-devel
185 Header files for SGI libGLU library.
186
187 %description libGLU-devel -l pl.UTF-8
188 Pliki nagłówkowe biblioteki SGI libGLU.
189
190 %package libGLU-static
191 Summary:        Static SGI libGLU library
192 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
193 License:        SGI Free Software License B v2.0 (MIT-like)
194 Group:          Development/Libraries
195 Requires:       %{name}-libGLU-devel = %{version}-%{release}
196 Provides:       OpenGL-GLU-static = 1.3
197
198 %description libGLU-static
199 Static SGI libGLU library.
200
201 %description libGLU-static -l pl.UTF-8
202 Statyczna biblioteka SGI libGLU.
203
204 %package libGLw
205 Summary:        SGI OpenGL Xt widgets library
206 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
207 License:        SGI MIT-like
208 Group:          Libraries
209 # loose dependency on libGL.so.1 to use with other libGL binaries
210 Requires:       OpenGL >= 1.1
211 Provides:       OpenGL-GLw
212
213 %description libGLw
214 SGI OpenGL Xt widgets library.
215
216 %description libGLU -l pl.UTF-8
217 Biblioteka SGI widgetów Xt dla OpenGL-a.
218
219 %package libGLw-devel
220 Summary:        Header files for SGI libGLw library
221 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
222 License:        SGI MIT-like
223 Group:          Development/Libraries
224 Requires:       %{name}-libGLw = %{version}-%{release}
225 Requires:       OpenGL-devel >= 1.2
226 Provides:       OpenGL-GLw-devel
227
228 %description libGLw-devel
229 Header files for SGI libGLw library.
230
231 %description libGLw-devel -l pl.UTF-8
232 Pliki nagłówkowe biblioteki SGI libGLw.
233
234 %package libGLw-static
235 Summary:        Static SGI libGLw library
236 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
237 License:        SGI MIT-like
238 Group:          Development/Libraries
239 Requires:       %{name}-libGLw-devel = %{version}-%{release}
240 Provides:       OpenGL-GLw-static
241
242 %description libGLw-static
243 Static SGI libGLw library.
244
245 %description libGLw-static -l pl.UTF-8
246 Statyczna biblioteka SGI libGLw.
247
248 %package libOSMesa
249 Summary:        OSMesa (off-screen renderer) library
250 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
251 License:        MIT
252 Group:          Libraries
253 # doesn't require base
254
255 %description libOSMesa
256 OSMesa (off-screen renderer) library.
257
258 %description libOSMesa -l pl.UTF-8
259 Biblioteka OSMesa (renderująca bitmapy w pamięci).
260
261 %package libOSMesa-devel
262 Summary:        Header file for OSMesa (off-screen renderer) library
263 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
264 License:        MIT
265 Group:          Development/Libraries
266 Requires:       %{name}-libOSMesa = %{version}-%{release}
267 # for <GL/gl.h> only
268 Requires:       OpenGL-devel
269
270 %description libOSMesa-devel
271 Header file for OSMesa (off-screen renderer) library.
272
273 %description libOSMesa-devel -l pl.UTF-8
274 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
275
276 %package libOSMesa-static
277 Summary:        Static OSMesa (off-screen renderer) library
278 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
279 License:        MIT
280 Group:          Development/Libraries
281 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
282 # this static build of OSMesa needs static non-dri Mesa implementation
283 Requires:       %{name}-libGL-static = %{version}-%{release}
284
285 %description libOSMesa-static
286 Static OSMesa (off-screen renderer) library.
287
288 %description libOSMesa-static -l pl.UTF-8
289 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
290
291 %package utils
292 Summary:        OpenGL utilities from Mesa3D
293 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
294 License:        MIT
295 Group:          X11/Applications/Graphics
296 # loose deps on libGL/libGLU
297
298 %description utils
299 OpenGL utilities from Mesa3D: glxgears and glxinfo.
300
301 %description utils -l pl.UTF-8
302 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
303
304 %package demos
305 Summary:        Mesa Demos source code
306 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
307 License:        various (MIT, SGI, GPL - see copyright notes in sources)
308 Group:          Development/Libraries
309 Requires:       OpenGL-devel
310
311 %description demos
312 Demonstration programs for the Mesa libraries in source code form.
313
314 %description demos -l pl.UTF-8
315 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
316
317 %package dri-driver-ati-mach64
318 Summary:        X.org DRI driver for ATI Mach64 card family
319 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
320 License:        MIT
321 Group:          X11/Libraries
322 Requires:       xorg-driver-video-mach64
323 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
324 Requires:       xorg-xserver-server >= %{xserver_ver}
325
326 %description dri-driver-ati-mach64
327 X.org DRI driver for ATI Mach64 card family.
328
329 %description dri-driver-ati-mach64 -l pl.UTF-8
330 Sterownik X.org DRI dla rodziny kart ATI Mach64.
331
332 %package dri-driver-ati-radeon-R100
333 Summary:        X.org DRI driver for ATI R100 card family
334 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
335 License:        MIT
336 Group:          X11/Libraries
337 Requires:       xorg-driver-video-ati
338 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
339 Requires:       xorg-xserver-server >= %{xserver_ver}
340 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
341
342 %description dri-driver-ati-radeon-R100
343 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
344
345 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
346 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
347
348 %package dri-driver-ati-radeon-R200
349 Summary:        X.org DRI driver for ATI R200 card family
350 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
351 License:        MIT
352 Group:          X11/Libraries
353 Requires:       xorg-driver-video-ati
354 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
355 Requires:       xorg-xserver-server >= %{xserver_ver}
356 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
357
358 %description dri-driver-ati-radeon-R200
359 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
360
361 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
362 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
363
364 %package dri-driver-ati-radeon-R300
365 Summary:        X.org DRI driver for ATI R300 card family
366 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
367 License:        MIT
368 Group:          X11/Libraries
369 Requires:       xorg-driver-video-ati
370 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
371 Requires:       xorg-xserver-server >= %{xserver_ver}
372 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
373
374 %description dri-driver-ati-radeon-R300
375 X.org DRI driver for ATI R300 card family.
376
377 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
378 Sterownik X.org DRI dla rodziny kart ATI R300.
379
380 %package dri-driver-ati-rage128
381 Summary:        X.org DRI driver for ATI Rage128 card family
382 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
383 License:        MIT
384 Group:          X11/Libraries
385 Requires:       xorg-driver-video-r128
386 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
387 Requires:       xorg-xserver-server >= %{xserver_ver}
388 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
389
390 %description dri-driver-ati-rage128
391 X.org DRI driver for ATI Rage128 card family.
392
393 %description dri-driver-ati-rage128 -l pl.UTF-8
394 Sterownik X.org DRI dla rodziny kart ATI Rage128.
395
396 %package dri-driver-ffb
397 Summary:        X.org DRI driver for Sun FFB card family
398 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
399 License:        MIT
400 Group:          X11/Libraries
401 Requires:       xorg-driver-video-sunffb
402 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
403 Requires:       xorg-xserver-server >= %{xserver_ver}
404
405 %description dri-driver-ffb
406 X.org DRI driver for SUN Creator3D and Elite3D card family.
407
408 %description dri-driver-ffb -l pl.UTF-8
409 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
410
411 %package dri-driver-glint
412 Summary:        X.org DRI driver for GLINT/Permedia card family
413 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
414 License:        MIT
415 Group:          X11/Libraries
416 Requires:       xorg-driver-video-glint
417 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
418 Requires:       xorg-xserver-server >= %{xserver_ver}
419 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
420
421 %description dri-driver-glint
422 X.org DRI driver for GLINT/Permedia card family.
423
424 %description dri-driver-glint -l pl.UTF-8
425 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
426
427 %package dri-driver-intel-i810
428 Summary:        X.org DRI driver for Intel i810 card family
429 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
430 License:        MIT
431 Group:          X11/Libraries
432 Requires:       xorg-driver-video-intel
433 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
434 Requires:       xorg-xserver-server >= %{xserver_ver}
435 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
436
437 %description dri-driver-intel-i810
438 X.org DRI driver for Intel i810 card family.
439
440 %description dri-driver-intel-i810 -l pl.UTF-8
441 Sterownik X.org DRI dla rodziny kart Intel i810.
442
443 %package dri-driver-intel-i915
444 Summary:        X.org DRI driver for Intel i915 card family
445 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
446 License:        MIT
447 Group:          X11/Libraries
448 Requires:       xorg-driver-video-intel
449 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
450 Requires:       xorg-xserver-server >= %{xserver_ver}
451 Obsoletes:      Mesa-dri-driver-intel-i830
452 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
453
454 %description dri-driver-intel-i915
455 X.org DRI driver for Intel i915 card family.
456
457 %description dri-driver-intel-i915 -l pl.UTF-8
458 Sterownik X.org DRI dla rodziny kart Intel i915.
459
460 %package dri-driver-intel-i965
461 Summary:        X.org DRI driver for Intel i965 card family
462 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
463 License:        MIT
464 Group:          X11/Libraries
465 Requires:       xorg-driver-video-intel
466 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
467 Requires:       xorg-xserver-server >= %{xserver_ver}
468 Obsoletes:      Mesa-dri-driver-intel-i830
469 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
470
471 %description dri-driver-intel-i965
472 X.org DRI driver for Intel i965 card family.
473
474 %description dri-driver-intel-i965 -l pl.UTF-8
475 Sterownik X.org DRI dla rodziny kart Intel i965.
476
477 %package dri-driver-matrox
478 Summary:        X.org DRI driver for Matrox G card family
479 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
480 License:        MIT
481 Group:          X11/Libraries
482 Requires:       xorg-driver-video-mga
483 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
484 Requires:       xorg-xserver-server >= %{xserver_ver}
485 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
486
487 %description dri-driver-matrox
488 X.org DRI drivers for Matrox G card family.
489
490 %description dri-driver-matrox -l pl.UTF-8
491 Sterowniki X.org DRI dla rodziny kart Matrox G.
492
493 %package dri-driver-nouveau
494 Summary:        X.org DRI driver for NVIDIA card family
495 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart NVIDIA
496 License:        MIT
497 Group:          X11/Libraries
498 Requires:       xorg-driver-video-nouveau
499 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
500 Requires:       xorg-xserver-server >= %{xserver_ver}
501
502 %description dri-driver-nouveau
503 X.org DRI drivers for NVIDIA card family.
504
505 %description dri-driver-nouveau -l pl.UTF-8
506 Sterowniki X.org DRI dla rodziny kart NVIDIA.
507
508 %package dri-driver-s3virge
509 Summary:        X.org DRI driver for S3 Virge card family
510 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
511 License:        MIT
512 Group:          X11/Libraries
513 Requires:       xorg-driver-video-s3virge
514 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
515 Requires:       xorg-xserver-server >= %{xserver_ver}
516
517 %description dri-driver-s3virge
518 X.org DRI driver for S3 Virge card family.
519
520 %description dri-driver-s3virge -l pl.UTF-8
521 Sterownik X.org DRI dla rodziny kart S3 Virge.
522
523 %package dri-driver-savage
524 Summary:        X.org DRI driver for S3 Savage card family
525 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
526 License:        MIT
527 Group:          X11/Libraries
528 Requires:       xorg-driver-video-savage
529 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
530 Requires:       xorg-xserver-server >= %{xserver_ver}
531
532 %description dri-driver-savage
533 X.org DRI driver for S3 Savage card family.
534
535 %description dri-driver-savage -l pl.UTF-8
536 Sterownik X.org DRI dla rodziny kart S3 Savage.
537
538 %package dri-driver-sis
539 Summary:        X.org DRI driver for SiS card family
540 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
541 License:        MIT
542 Group:          X11/Libraries
543 Requires:       xorg-driver-video-sis
544 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
545 Requires:       xorg-xserver-server >= %{xserver_ver}
546 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
547
548 %description dri-driver-sis
549 X.org DRI driver for SiS card family.
550
551 %description dri-driver-sis -l pl.UTF-8
552 Sterownik X.org DRI dla rodziny kart SiS.
553
554 %package dri-driver-swrast
555 Summary:        X.org DRI software rasterizer driver
556 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
557 License:        MIT
558 Group:          X11/Libraries
559 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
560 Requires:       xorg-xserver-server >= %{xserver_ver}
561
562 %description dri-driver-swrast
563 X.org DRI software rasterizer driver.
564
565 %description dri-driver-swrast -l pl.UTF-8
566 Sterownik X.org DRI obsługujący rysowanie programowe.
567
568 %package dri-driver-tdfx
569 Summary:        X.org DRI driver for 3DFX Voodoo card family
570 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
571 License:        MIT
572 Group:          X11/Libraries
573 Requires:       Glide3-DRI
574 Requires:       xorg-driver-video-tdfx
575 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
576 Requires:       xorg-xserver-server >= %{xserver_ver}
577 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
578
579 %description dri-driver-tdfx
580 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
581 and Velocity 100/200).
582
583 %description dri-driver-tdfx -l pl.UTF-8
584 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
585 Banshee i Velocity 100/200).
586
587 %package dri-driver-trident
588 Summary:        X.org DRI driver for Trident card family
589 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
590 License:        MIT
591 Group:          X11/Libraries
592 Requires:       xorg-driver-video-trident
593 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
594 Requires:       xorg-xserver-server >= %{xserver_ver}
595
596 %description dri-driver-trident
597 X.org DRI drivers for Trident card family.
598
599 %description dri-driver-trident -l pl.UTF-8
600 Sterowniki X.org DRI dla rodziny kart Trident.
601
602 %package dri-driver-via-unichrome
603 Summary:        X.org DRI driver for VIA Unichrome card family
604 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
605 License:        MIT
606 Group:          X11/Libraries
607 Requires:       xorg-driver-video-openchrome
608 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
609 Requires:       xorg-xserver-server >= %{xserver_ver}
610
611 %description dri-driver-via-unichrome
612 X.org DRI driver for VIA Unichrome card family.
613
614 %description dri-driver-via-unichrome -l pl.UTF-8
615 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
616
617 %prep
618 %setup -q -b1 -a2
619 %patch0 -p0
620 %patch1 -p1
621 %patch2 -p1
622
623 # fix demos
624 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
625
626 %build
627 [ ! -f configure ] && ./autogen.sh
628
629 dri_drivers="i810 i965 mach64 mga r128 r200 r300 radeon savage s3v trident \
630 %if %{without gallium_intel}
631 i915 \
632 %endif
633 %ifarch sparc sparcv9 sparc64
634 ffb \
635 %endif
636 %ifarch %{ix86} %{x8664}
637 sis \
638 %endif
639 swrast tdfx unichrome"
640
641 dri_drivers=$(echo $dri_drivers | xargs | tr ' ' ',')
642
643 common_flags="\
644         --enable-shared \
645         --enable-selinux \
646         --enable-pic \
647         --enable-glx-tls \
648         --%{?with_egl:en}%{!?with_egl:dis}able-egl \
649         --with%{!?with_demos:out}-demos"
650
651 %if %{with osmesa}
652 # osmesa variants
653 %configure $common_flags \
654         --with-driver=osmesa \
655         --disable-asm \
656         --with-osmesa-bits=8
657 %{__make} \
658         SRC_DIRS=mesa
659 mv %{_lib} osmesa8
660 %{__make} clean
661
662 %configure $common_flags \
663         --with-driver=osmesa \
664         --disable-asm \
665         --with-osmesa-bits=16
666 %{__make} \
667         SRC_DIRS=mesa
668 mv %{_lib} osmesa16
669 %{__make} clean
670
671 %configure $common_flags \
672         --with-driver=osmesa \
673         --disable-asm \
674         --with-osmesa-bits=32
675 %{__make} \
676         SRC_DIRS=mesa
677 mv %{_lib} osmesa32
678 %{__make} clean
679 %endif
680
681 %configure $common_flags \
682         --enable-glu \
683         --enable-glw \
684         --disable-glut \
685 %if %{with gallium}
686         --enable-gallium \
687         --%{?with_gallium_intel:en}%{!?with_gallium_intel:dis}able-gallium-intel \
688         --enable-gallium-nouveau \
689         --with-state-trackers=dri \
690 %else
691         --disable-gallium \
692 %endif
693         --with-driver=dri \
694         --with-dri-drivers=${dri_drivers} \
695         --with-dri-driverdir=%{_libdir}/xorg/modules/dri
696
697 %{__make}
698 %{__make} -C progs/xdemos glxgears glxinfo
699 %if %{with demos}
700 %{__make} -C progs/demos
701 %endif
702
703 cd gl-manpages-*
704 %configure
705 %{__make}
706
707 %install
708 rm -rf $RPM_BUILD_ROOT
709
710 install -d $RPM_BUILD_ROOT{%{_bindir},%{_examplesdir}/%{name}-%{version}}
711
712 # libs without drivers
713 %{__make} install \
714         DESTDIR=$RPM_BUILD_ROOT
715
716 cd gl-manpages-*
717 %{__make} install \
718         DESTDIR=$RPM_BUILD_ROOT
719 cd ..
720
721 %if %{with osmesa}
722 install osmesa*/* $RPM_BUILD_ROOT%{_libdir}
723 %endif
724
725 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
726 # work on copy to keep -bi --short-circuit working
727 rm -rf progs-clean
728 install -d progs-clean
729 for l in demos glsl osdemos redbook samples xdemos ; do
730         cp -a progs/$l progs-clean/$l
731         %{__make} -C progs-clean/$l clean
732         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
733 done
734 rm -rf progs-clean
735 for l in util images ; do
736         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
737 done
738 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
739
740 # strip out undesirable headers
741 olddir=$(pwd)
742 cd $RPM_BUILD_ROOT%{_includedir}/GL
743 rm [a-fh-np-wyz]*.h gg*.h glf*.h
744 cd $RPM_BUILD_ROOT%{_libdir}
745 cd $olddir
746
747 %if %{with multigl}
748 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
749
750 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
751 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
752
753 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
754 %endif
755
756 %clean
757 rm -rf $RPM_BUILD_ROOT
758
759 %post   libGL -p /sbin/ldconfig
760 %postun libGL -p /sbin/ldconfig
761
762 %post   libGLU -p /sbin/ldconfig
763 %postun libGLU -p /sbin/ldconfig
764
765 %post   libGLw -p /sbin/ldconfig
766 %postun libGLw -p /sbin/ldconfig
767
768 %files libGL
769 %defattr(644,root,root,755)
770 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
771 %if %{with multigl}
772 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
773 %dir %{_libdir}/Mesa
774 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
775 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
776 %else
777 %attr(755,root,root) %{_libdir}/libGL.so.*.*
778 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
779 # symlink for binary apps which fail to conform Linux OpenGL ABI
780 # (and dlopen libGL.so instead of libGL.so.1)
781 %attr(755,root,root) %{_libdir}/libGL.so
782 %endif
783
784 %files libGL-devel
785 %defattr(644,root,root,755)
786 %doc docs/*.spec
787 %if %{with multigl}
788 %attr(755,root,root) %{_libdir}/libGL.so
789 %endif
790 %dir %{_includedir}/GL
791 %{_includedir}/GL/gl.h
792 %{_includedir}/GL/glext.h
793 %{_includedir}/GL/gl_mangle.h
794 %{_includedir}/GL/glx.h
795 %{_includedir}/GL/glxext.h
796 %{_includedir}/GL/glx_mangle.h
797 %dir %{_includedir}/GL/internal
798 %{_includedir}/GL/internal/dri_interface.h
799 %{_pkgconfigdir}/dri.pc
800 %{_pkgconfigdir}/gl.pc
801 %{_mandir}/man3/gl[^uX]*.3gl*
802 %{_mandir}/man3/glX*.3gl*
803
804 %if %{with static}
805 %files libGL-static
806 %defattr(644,root,root,755)
807 %{_libdir}/libGL.a
808 %endif
809
810 %files libGLU
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
814
815 %files libGLU-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libGLU.so
818 %{_includedir}/GL/glu.h
819 %{_includedir}/GL/glu_mangle.h
820 %{_pkgconfigdir}/glu.pc
821 %{_mandir}/man3/glu*.3gl*
822
823 %if %{with static}
824 %files libGLU-static
825 %defattr(644,root,root,755)
826 %{_libdir}/libGLU.a
827 %endif
828
829 %files libGLw
830 %defattr(644,root,root,755)
831 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
832 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
833
834 %files libGLw-devel
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/libGLw.so
837 %{_includedir}/GL/GLwDrawA.h
838 %{_includedir}/GL/GLwDrawAP.h
839 %{_includedir}/GL/GLwMDrawA.h
840 %{_includedir}/GL/GLwMDrawAP.h
841 %{_pkgconfigdir}/glw.pc
842
843 %if %{with static}
844 %files libGLw-static
845 %defattr(644,root,root,755)
846 %{_libdir}/libGLw.a
847 %endif
848
849 %if %{with osmesa}
850 %files libOSMesa
851 %defattr(644,root,root,755)
852 %attr(755,root,root) %{_libdir}/libOSMesa*.so.*.*
853 %attr(755,root,root) %ghost %{_libdir}/libOSMesa*.so.[0-9]
854
855 %files libOSMesa-devel
856 %defattr(644,root,root,755)
857 %attr(755,root,root) %{_libdir}/libOSMesa*.so
858 %{_includedir}/GL/osmesa.h
859
860 %if %{with static}
861 %files libOSMesa-static
862 %defattr(644,root,root,755)
863 %{_libdir}/libOSMesa*.a
864 %endif
865 %endif
866
867 %files utils
868 %defattr(644,root,root,755)
869 %attr(755,root,root) %{_bindir}/glxgears
870 %attr(755,root,root) %{_bindir}/glxinfo
871
872 %files dri-driver-ati-mach64
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
875
876 %files dri-driver-ati-radeon-R100
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
879
880 %files dri-driver-ati-radeon-R200
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
883
884 %files dri-driver-ati-radeon-R300
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
887
888 %files dri-driver-ati-rage128
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
891
892 # sunffb (sparc only)
893 %ifarch sparc sparcv9 sparc64
894 %files dri-driver-ffb
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
897 %endif
898
899 # glint (requires update)
900 %if 0
901 %files dri-driver-glint
902 %defattr(644,root,root,755)
903 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
904 %endif
905
906 %files dri-driver-intel-i810
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
909
910 %files dri-driver-intel-i915
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
913
914 %files dri-driver-intel-i965
915 %defattr(644,root,root,755)
916 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
917
918 %files dri-driver-matrox
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
921
922 %if %{with gallium}
923 %files dri-driver-nouveau
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/xorg/modules/dri/nouveau_dri.so
926 %endif
927
928 %files dri-driver-s3virge
929 %defattr(644,root,root,755)
930 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
931
932 %files dri-driver-savage
933 %defattr(644,root,root,755)
934 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
935
936 %ifarch %{ix86} %{x8664}
937 %files dri-driver-sis
938 %defattr(644,root,root,755)
939 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
940 %endif
941
942 %files dri-driver-swrast
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
945
946 %files dri-driver-tdfx
947 %defattr(644,root,root,755)
948 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
949
950 %files dri-driver-trident
951 %defattr(644,root,root,755)
952 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
953
954 %files dri-driver-via-unichrome
955 %defattr(644,root,root,755)
956 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
957
958 %if %{with demos}
959 %files demos
960 %defattr(644,root,root,755)
961 %{_examplesdir}/%{name}-%{version}
962 %endif
This page took 0.154331 seconds and 3 git commands to generate.