]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- up to 7.4
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 #
5 # Conditional build:
6 %bcond_without  motif   # build static libGLw without Motif interface
7 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
8 #
9 # minimal supported xserver version
10 %define         xserver_ver     1.5.0
11 # glapi version (glapi tables in dri drivers and libglx must be in sync);
12 # set to current Mesa version on ABI break, when xserver tables get regenerated
13 # (until they start to be somehow versioned themselves)
14 %define         glapi_ver       7.1.0
15 #
16 Summary:        Free OpenGL implementation
17 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
18 Name:           Mesa
19 Version:        7.4
20 Release:        1%{?with_multigl:.mgl}
21 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
22 Group:          X11/Libraries
23 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
24 # Source0-md5:  7ecddb341a2691e0dfdb02f697109834
25 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
26 # Source1-md5:  02816f10f30b1dc5e069e0f68c177c98
27 Patch0:         %{name}-realclean.patch
28 URL:            http://www.mesa3d.org/
29 BuildRequires:  expat-devel
30 BuildRequires:  libdrm-devel >= 2.4.5
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool >= 2:1.4d
33 %{?with_motif:BuildRequires:    motif-devel}
34 BuildRequires:  rpmbuild(macros) >= 1.470
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  xorg-lib-libXdamage-devel
37 BuildRequires:  xorg-lib-libXt-devel
38 BuildRequires:  xorg-lib-libXxf86vm-devel
39 BuildRequires:  xorg-proto-dri2proto-devel >= 1.99.3
40 BuildRequires:  xorg-proto-glproto-devel
41 BuildRequires:  xorg-proto-printproto-devel
42 BuildRequires:  xorg-util-makedepend
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Mesa is a 3-D graphics library with an API which is very similar to
47 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
48 syntax or state machine, it is being used with authorization from
49 Silicon Graphics, Inc. However, the author does not possess an OpenGL
50 license from SGI, and makes no claim that Mesa is in any way a
51 compatible replacement for OpenGL or associated with SGI.
52
53 %description -l pl.UTF-8
54 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
55 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
56 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
57 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
58 OpenGL ani powiązana z SGI.
59
60 %package libGL
61 Summary:        Free Mesa3D implementation of libGL OpenGL library
62 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
63 License:        MIT
64 Group:          X11/Libraries
65 Requires:       libdrm >= 2.4.5
66 Provides:       OpenGL = 2.1
67 # reports version 1.3, but supports glXGetProcAddress() from 1.4
68 Provides:       OpenGL-GLX = 1.4
69 Obsoletes:      Mesa
70 Obsoletes:      Mesa-dri
71 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
72 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
73
74 %description libGL
75 Mesa is a 3-D graphics library with an API which is very similar to
76 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
77 syntax or state machine, it is being used with authorization from
78 Silicon Graphics, Inc. However, the author does not possess an OpenGL
79 license from SGI, and makes no claim that Mesa is in any way a
80 compatible replacement for OpenGL or associated with SGI.
81
82 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
83 specifications. It uses DRI for rendering.
84
85 %description libGL -l pl.UTF-8
86 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
87 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
88 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
89 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
90 OpenGL ani powiązana z SGI.
91
92 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
93 GLX 1.4. Używa DRI do renderowania.
94
95 %package libGL-devel
96 Summary:        Header files for Mesa3D libGL library
97 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
98 License:        MIT
99 Group:          X11/Development/Libraries
100 # loose dependency on libGL to use with other libGL binaries
101 Requires:       OpenGL >= 1.5
102 Requires:       xorg-lib-libX11-devel
103 Provides:       OpenGL-devel = 2.1
104 Provides:       OpenGL-GLX-devel = 1.4
105 Obsoletes:      Mesa-devel
106 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
107 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
108 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
109 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
110
111 %description libGL-devel
112 Header files for Mesa3D libGL library.
113
114 %description libGL-devel -l pl.UTF-8
115 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
116
117 %package libGL-static
118 Summary:        Static Mesa3D libGL library
119 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
120 License:        MIT
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-libGL-devel = %{version}-%{release}
123 Provides:       OpenGL-static = 2.1
124 Obsoletes:      Mesa-static
125 Obsoletes:      X11-OpenGL-static < 1:7.0.0
126 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
127
128 %description libGL-static
129 Static Mesa3D libGL library. It uses software renderer.
130
131 %description libGL-static -l pl.UTF-8
132 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
133 renderingu.
134
135 %package libGLU
136 Summary:        SGI implementation of libGLU OpenGL library
137 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
138 License:        SGI Free Software License B v2.0 (MIT-like)
139 Group:          Libraries
140 # loose dependency on libGL.so.1 to use with other libGL binaries
141 Requires:       OpenGL >= 1.2
142 Provides:       OpenGL-GLU = 1.3
143 Obsoletes:      Mesa-devel
144 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
145 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
146
147 %description libGLU
148 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
149 1.3 specifications.
150
151 %description libGLU -l pl.UTF-8
152 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
153 specyfikację OpenGL GLU 1.3.
154
155 %package libGLU-devel
156 Summary:        Header files for SGI libGLU library
157 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
158 License:        SGI Free Software License B v2.0 (MIT-like)
159 Group:          Development/Libraries
160 Requires:       %{name}-libGLU = %{version}-%{release}
161 Requires:       OpenGL-devel >= 1.2
162 Requires:       libstdc++-devel
163 Provides:       OpenGL-GLU-devel = 1.3
164
165 %description libGLU-devel
166 Header files for SGI libGLU library.
167
168 %description libGLU-devel -l pl.UTF-8
169 Pliki nagłówkowe biblioteki SGI libGLU.
170
171 %package libGLU-static
172 Summary:        Static SGI libGLU library
173 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
174 License:        SGI Free Software License B v2.0 (MIT-like)
175 Group:          Development/Libraries
176 Requires:       %{name}-libGLU-devel = %{version}-%{release}
177 Provides:       OpenGL-GLU-static = 1.3
178
179 %description libGLU-static
180 Static SGI libGLU library.
181
182 %description libGLU-static -l pl.UTF-8
183 Statyczna biblioteka SGI libGLU.
184
185 %package libGLw
186 Summary:        SGI OpenGL Xt widgets library
187 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
188 License:        SGI MIT-like
189 Group:          Libraries
190 # loose dependency on libGL.so.1 to use with other libGL binaries
191 Requires:       OpenGL >= 1.1
192 Provides:       OpenGL-GLw
193
194 %description libGLw
195 SGI OpenGL Xt widgets library.
196
197 %description libGLU -l pl.UTF-8
198 Biblioteka SGI widgetów Xt dla OpenGL-a.
199
200 %package libGLw-devel
201 Summary:        Header files for SGI libGLw library
202 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
203 License:        SGI MIT-like
204 Group:          Development/Libraries
205 Requires:       %{name}-libGLw = %{version}-%{release}
206 Requires:       OpenGL-devel >= 1.2
207 Provides:       OpenGL-GLw-devel
208
209 %description libGLw-devel
210 Header files for SGI libGLw library.
211
212 %description libGLw-devel -l pl.UTF-8
213 Pliki nagłówkowe biblioteki SGI libGLw.
214
215 %package libGLw-static
216 Summary:        Static SGI libGLw library
217 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
218 License:        SGI MIT-like
219 Group:          Development/Libraries
220 Requires:       %{name}-libGLw-devel = %{version}-%{release}
221 Provides:       OpenGL-GLw-static
222
223 %description libGLw-static
224 Static SGI libGLw library.
225
226 %description libGLw-static -l pl.UTF-8
227 Statyczna biblioteka SGI libGLw.
228
229 %package libOSMesa
230 Summary:        OSMesa (off-screen renderer) library
231 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
232 License:        MIT
233 Group:          Libraries
234 # doesn't require base
235
236 %description libOSMesa
237 OSMesa (off-screen renderer) library.
238
239 %description libOSMesa -l pl.UTF-8
240 Biblioteka OSMesa (renderująca bitmapy w pamięci).
241
242 %package libOSMesa-devel
243 Summary:        Header file for OSMesa (off-screen renderer) library
244 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
245 License:        MIT
246 Group:          Development/Libraries
247 Requires:       %{name}-libOSMesa = %{version}-%{release}
248 # for <GL/gl.h> only
249 Requires:       OpenGL-devel
250
251 %description libOSMesa-devel
252 Header file for OSMesa (off-screen renderer) library.
253
254 %description libOSMesa-devel -l pl.UTF-8
255 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
256
257 %package libOSMesa-static
258 Summary:        Static OSMesa (off-screen renderer) library
259 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
260 License:        MIT
261 Group:          Development/Libraries
262 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
263 # this static build of OSMesa needs static non-dri Mesa implementation
264 Requires:       %{name}-libGL-static = %{version}-%{release}
265
266 %description libOSMesa-static
267 Static OSMesa (off-screen renderer) library.
268
269 %description libOSMesa-static -l pl.UTF-8
270 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
271
272 %package utils
273 Summary:        OpenGL utilities from Mesa3D
274 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
275 License:        MIT
276 Group:          X11/Applications/Graphics
277 # loose deps on libGL/libGLU
278
279 %description utils
280 OpenGL utilities from Mesa3D: glxgears and glxinfo.
281
282 %description utils -l pl.UTF-8
283 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
284
285 %package demos
286 Summary:        Mesa Demos source code
287 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
288 License:        various (MIT, SGI, GPL - see copyright notes in sources)
289 Group:          Development/Libraries
290 Requires:       OpenGL-devel
291
292 %description demos
293 Demonstration programs for the Mesa libraries in source code form.
294
295 %description demos -l pl.UTF-8
296 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
297
298 %package dri-driver-ati-mach64
299 Summary:        X.org DRI driver for ATI Mach64 card family
300 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
301 License:        MIT
302 Group:          X11/Libraries
303 Requires:       xorg-driver-video-mach64
304 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
305 Requires:       xorg-xserver-server >= %{xserver_ver}
306
307 %description dri-driver-ati-mach64
308 X.org DRI driver for ATI Mach64 card family.
309
310 %description dri-driver-ati-mach64 -l pl.UTF-8
311 Sterownik X.org DRI dla rodziny kart ATI Mach64.
312
313 %package dri-driver-ati-radeon-R100
314 Summary:        X.org DRI driver for ATI R100 card family
315 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
316 License:        MIT
317 Group:          X11/Libraries
318 Requires:       xorg-driver-video-ati
319 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
320 Requires:       xorg-xserver-server >= %{xserver_ver}
321 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
322
323 %description dri-driver-ati-radeon-R100
324 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
325
326 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
327 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
328
329 %package dri-driver-ati-radeon-R200
330 Summary:        X.org DRI driver for ATI R200 card family
331 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
332 License:        MIT
333 Group:          X11/Libraries
334 Requires:       xorg-driver-video-ati
335 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
336 Requires:       xorg-xserver-server >= %{xserver_ver}
337 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
338
339 %description dri-driver-ati-radeon-R200
340 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
341
342 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
343 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
344
345 %package dri-driver-ati-radeon-R300
346 Summary:        X.org DRI driver for ATI R300 card family
347 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
348 License:        MIT
349 Group:          X11/Libraries
350 Requires:       xorg-driver-video-ati
351 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
352 Requires:       xorg-xserver-server >= %{xserver_ver}
353 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
354
355 %description dri-driver-ati-radeon-R300
356 X.org DRI driver for ATI R300 card family.
357
358 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
359 Sterownik X.org DRI dla rodziny kart ATI R300.
360
361 %package dri-driver-ati-rage128
362 Summary:        X.org DRI driver for ATI Rage128 card family
363 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
364 License:        MIT
365 Group:          X11/Libraries
366 Requires:       xorg-driver-video-r128
367 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
368 Requires:       xorg-xserver-server >= %{xserver_ver}
369 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
370
371 %description dri-driver-ati-rage128
372 X.org DRI driver for ATI Rage128 card family.
373
374 %description dri-driver-ati-rage128 -l pl.UTF-8
375 Sterownik X.org DRI dla rodziny kart ATI Rage128.
376
377 %package dri-driver-ffb
378 Summary:        X.org DRI driver for Sun FFB card family
379 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
380 License:        MIT
381 Group:          X11/Libraries
382 Requires:       xorg-driver-video-sunffb
383 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
384 Requires:       xorg-xserver-server >= %{xserver_ver}
385
386 %description dri-driver-ffb
387 X.org DRI driver for SUN Creator3D and Elite3D card family.
388
389 %description dri-driver-ffb -l pl.UTF-8
390 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
391
392 %package dri-driver-glint
393 Summary:        X.org DRI driver for GLINT/Permedia card family
394 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
395 License:        MIT
396 Group:          X11/Libraries
397 Requires:       xorg-driver-video-glint
398 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
399 Requires:       xorg-xserver-server >= %{xserver_ver}
400 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
401
402 %description dri-driver-glint
403 X.org DRI driver for GLINT/Permedia card family.
404
405 %description dri-driver-glint -l pl.UTF-8
406 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
407
408 %package dri-driver-intel-i810
409 Summary:        X.org DRI driver for Intel i810 card family
410 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
411 License:        MIT
412 Group:          X11/Libraries
413 Requires:       xorg-driver-video-intel
414 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
415 Requires:       xorg-xserver-server >= %{xserver_ver}
416 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
417
418 %description dri-driver-intel-i810
419 X.org DRI driver for Intel i810 card family.
420
421 %description dri-driver-intel-i810 -l pl.UTF-8
422 Sterownik X.org DRI dla rodziny kart Intel i810.
423
424 %package dri-driver-intel-i915
425 Summary:        X.org DRI driver for Intel i915 card family
426 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
427 License:        MIT
428 Group:          X11/Libraries
429 Requires:       xorg-driver-video-intel
430 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
431 Requires:       xorg-xserver-server >= %{xserver_ver}
432 Obsoletes:      Mesa-dri-driver-intel-i830
433 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
434
435 %description dri-driver-intel-i915
436 X.org DRI driver for Intel i915 card family.
437
438 %description dri-driver-intel-i915 -l pl.UTF-8
439 Sterownik X.org DRI dla rodziny kart Intel i915.
440
441 %package dri-driver-intel-i965
442 Summary:        X.org DRI driver for Intel i965 card family
443 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
444 License:        MIT
445 Group:          X11/Libraries
446 Requires:       xorg-driver-video-intel
447 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
448 Requires:       xorg-xserver-server >= %{xserver_ver}
449 Obsoletes:      Mesa-dri-driver-intel-i830
450 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
451
452 %description dri-driver-intel-i965
453 X.org DRI driver for Intel i965 card family.
454
455 %description dri-driver-intel-i965 -l pl.UTF-8
456 Sterownik X.org DRI dla rodziny kart Intel i965.
457
458 %package dri-driver-matrox
459 Summary:        X.org DRI driver for Matrox G card family
460 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
461 License:        MIT
462 Group:          X11/Libraries
463 Requires:       xorg-driver-video-mga
464 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
465 Requires:       xorg-xserver-server >= %{xserver_ver}
466 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
467
468 %description dri-driver-matrox
469 X.org DRI drivers for Matrox G card family.
470
471 %description dri-driver-matrox -l pl.UTF-8
472 Sterowniki X.org DRI dla rodziny kart Matrox G.
473
474 %package dri-driver-s3virge
475 Summary:        X.org DRI driver for S3 Virge card family
476 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
477 License:        MIT
478 Group:          X11/Libraries
479 Requires:       xorg-driver-video-s3virge
480 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
481 Requires:       xorg-xserver-server >= %{xserver_ver}
482
483 %description dri-driver-s3virge
484 X.org DRI driver for S3 Virge card family.
485
486 %description dri-driver-s3virge -l pl.UTF-8
487 Sterownik X.org DRI dla rodziny kart S3 Virge.
488
489 %package dri-driver-savage
490 Summary:        X.org DRI driver for S3 Savage card family
491 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
492 License:        MIT
493 Group:          X11/Libraries
494 Requires:       xorg-driver-video-savage
495 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
496 Requires:       xorg-xserver-server >= %{xserver_ver}
497
498 %description dri-driver-savage
499 X.org DRI driver for S3 Savage card family.
500
501 %description dri-driver-savage -l pl.UTF-8
502 Sterownik X.org DRI dla rodziny kart S3 Savage.
503
504 %package dri-driver-sis
505 Summary:        X.org DRI driver for SiS card family
506 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
507 License:        MIT
508 Group:          X11/Libraries
509 Requires:       xorg-driver-video-sis
510 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
511 Requires:       xorg-xserver-server >= %{xserver_ver}
512 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
513
514 %description dri-driver-sis
515 X.org DRI driver for SiS card family.
516
517 %description dri-driver-sis -l pl.UTF-8
518 Sterownik X.org DRI dla rodziny kart SiS.
519
520 %package dri-driver-swrast
521 Summary:        X.org DRI software rasterizer driver
522 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
523 License:        MIT
524 Group:          X11/Libraries
525 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
526 Requires:       xorg-xserver-server >= %{xserver_ver}
527
528 %description dri-driver-swrast
529 X.org DRI software rasterizer driver.
530
531 %description dri-driver-swrast -l pl.UTF-8
532 Sterownik X.org DRI obsługujący rysowanie programowe.
533
534 %package dri-driver-tdfx
535 Summary:        X.org DRI driver for 3DFX Voodoo card family
536 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
537 License:        MIT
538 Group:          X11/Libraries
539 Requires:       Glide3-DRI
540 Requires:       xorg-driver-video-tdfx
541 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
542 Requires:       xorg-xserver-server >= %{xserver_ver}
543 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
544
545 %description dri-driver-tdfx
546 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
547 and Velocity 100/200).
548
549 %description dri-driver-tdfx -l pl.UTF-8
550 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
551 Banshee i Velocity 100/200).
552
553 %package dri-driver-trident
554 Summary:        X.org DRI driver for Trident card family
555 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
556 License:        MIT
557 Group:          X11/Libraries
558 Requires:       xorg-driver-video-trident
559 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
560 Requires:       xorg-xserver-server >= %{xserver_ver}
561
562 %description dri-driver-trident
563 X.org DRI drivers for Trident card family.
564
565 %description dri-driver-trident -l pl.UTF-8
566 Sterowniki X.org DRI dla rodziny kart Trident.
567
568 %package dri-driver-via-unichrome
569 Summary:        X.org DRI driver for VIA Unichrome card family
570 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
571 License:        MIT
572 Group:          X11/Libraries
573 Requires:       xorg-driver-video-openchrome
574 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
575 Requires:       xorg-xserver-server >= %{xserver_ver}
576
577 %description dri-driver-via-unichrome
578 X.org DRI driver for VIA Unichrome card family.
579
580 %description dri-driver-via-unichrome -l pl.UTF-8
581 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
582
583 %prep
584 %setup -q -b1
585 %patch0 -p0
586
587 # fix demos
588 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
589
590 # s3v, sis, trident missing there - don't override list from linux-dri
591 sed -i -e '/^DRI_DIRS/d' configs/linux-dri-x86-64
592
593 # add swrast driver
594 sed -i -e 's/ i810 / swrast i810 /' configs/linux-dri
595
596 %ifnarch sparc sparcv9 sparc64
597 # for sunffb driver - useful on sparc only
598 sed -i -e 's/ ffb\>//' configs/linux-dri
599 %endif
600
601 %ifnarch %{ix86} %{x8664}
602 # sis needs write-memory barrier
603 sed -i -e 's/ sis / /' configs/linux-dri
604 %endif
605
606 %build
607 # use $lib, not %{_lib} as Mesa uses lib64 only for *-x86-64* targets
608 %ifarch %{x8664}
609 targ=-x86-64
610 lib=lib64
611 %else
612 lib=lib
613 %ifarch %{ix86}
614 targ=-x86
615 %else
616 targ=""
617 %endif
618 %endif
619
620 # required for -bc --short-circuit
621 %{__make} realclean
622 # as above - existing directory makes mv move into instead of rename
623 rm -rf lib-{dri,osmesa,static}
624
625 %{__make} linux${targ}-static \
626         CC="%{__cc}" \
627         CXX="%{__cxx}" \
628         OPT_FLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing" \
629         XLIB_DIR=%{_libdir} \
630         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
631         SRC_DIRS="mesa glu glw" \
632         PROGRAM_DIRS=
633 mv -f ${lib} lib-static
634 %{__make} realclean
635
636 %{__make} linux-osmesa \
637         CC="%{__cc}" \
638         CXX="%{__cxx}" \
639         CFLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing -fPIC" \
640         XLIB_DIR=%{_libdir} \
641         SRC_DIRS="mesa" \
642         PROGRAM_DIRS=
643 mv -f lib lib-osmesa
644 %{__make} realclean
645
646 %{__make} linux-dri${targ} \
647         CC="%{__cc}" \
648         CXX="%{__cxx}" \
649         MKDEP=makedepend \
650         OPT_FLAGS="%{rpmcppflags} %{rpmcflags} -fno-strict-aliasing" \
651         XLIB_DIR=%{_libdir} \
652         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
653         SRC_DIRS="glx/x11 mesa glu glw" \
654         PROGRAM_DIRS=
655
656 %{__make} -C progs/xdemos \
657         CC="%{__cc}" \
658         CXX="%{__cxx}" \
659         OPT_FLAGS="%{rpmcppflags} %{rpmcflags}" \
660         XLIB_DIR=%{_libdir} \
661         PROGS="glxgears" \
662         APP_LIB_DEPS="-L../../${lib} -lGL"
663
664 %{__make} -C progs/xdemos \
665         CC="%{__cc}" \
666         CXX="%{__cxx}" \
667         OPT_FLAGS="%{rpmcppflags} %{rpmcflags}" \
668         XLIB_DIR=%{_libdir} \
669         PROGS="glxinfo" \
670         APP_LIB_DEPS="-L../../${lib} -lGL -lGLU"
671
672 mv -f ${lib} lib-dri
673
674 for d in mesa glu glw ; do
675         for f in src/$d/*.pc.in; do
676                 %{__make} -C src/$d `basename $f .in` \
677                         INSTALL_DIR=%{_prefix} \
678                         LIB_DIR=%{_lib}
679         done
680 done
681
682 %install
683 rm -rf $RPM_BUILD_ROOT
684 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL/internal,%{_pkgconfigdir},%{_examplesdir}/%{name}-%{version}}
685 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
686
687 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
688 cp -df lib-osmesa/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
689 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
690 cp -rf include/GL/{gl[!f]*,osmesa.h*} src/glw/GLw*.h src/mesa/drivers/x11/xmesa*.h $RPM_BUILD_ROOT%{_includedir}/GL
691 cp -rf include/GL/internal/dri_interface.h $RPM_BUILD_ROOT%{_includedir}/GL/internal
692 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
693
694 install src/mesa/gl.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
695 install src/mesa/osmesa.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
696 install src/glu/glu.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
697 install src/glw/glw.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
698
699 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
700 # work on copy to keep -bi --short-circuit working
701 rm -rf progs-clean
702 install -d progs-clean
703 for l in demos glsl osdemos redbook samples xdemos ; do
704         cp -a progs/$l progs-clean/$l
705         %{__make} -C progs-clean/$l clean
706         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
707 done
708 rm -rf progs-clean
709 for l in util images ; do
710         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
711 done
712 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
713
714 %if %{with multigl}
715 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
716
717 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
718 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
719
720 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
721 %endif
722
723 %clean
724 rm -rf $RPM_BUILD_ROOT
725
726 %post   libGL -p /sbin/ldconfig
727 %postun libGL -p /sbin/ldconfig
728
729 %post   libGLU -p /sbin/ldconfig
730 %postun libGLU -p /sbin/ldconfig
731
732 %post   libGLw -p /sbin/ldconfig
733 %postun libGLw -p /sbin/ldconfig
734
735 %files libGL
736 %defattr(644,root,root,755)
737 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
738 %if %{with multigl}
739 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
740 %dir %{_libdir}/Mesa
741 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
742 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
743 %else
744 %attr(755,root,root) %{_libdir}/libGL.so.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
746 # symlink for binary apps which fail to conform Linux OpenGL ABI
747 # (and dlopen libGL.so instead of libGL.so.1)
748 %attr(755,root,root) %{_libdir}/libGL.so
749 %endif
750
751 %files libGL-devel
752 %defattr(644,root,root,755)
753 %doc docs/*.spec
754 %if %{with multigl}
755 %attr(755,root,root) %{_libdir}/libGL.so
756 %endif
757 %dir %{_includedir}/GL
758 %{_includedir}/GL/gl.h
759 %{_includedir}/GL/glext.h
760 %{_includedir}/GL/gl_mangle.h
761 %{_includedir}/GL/glx.h
762 %{_includedir}/GL/glxext.h
763 %{_includedir}/GL/glx_mangle.h
764 %dir %{_includedir}/GL/internal
765 %{_includedir}/GL/internal/dri_interface.h
766 %{_pkgconfigdir}/gl.pc
767
768 %files libGL-static
769 %defattr(644,root,root,755)
770 %{_libdir}/libGL.a
771 # x11 (non-dri) Mesa API
772 %{_includedir}/GL/xmesa.h
773 %{_includedir}/GL/xmesa_x.h
774 %{_includedir}/GL/xmesa_xf86.h
775
776 %files libGLU
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
779 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
780
781 %files libGLU-devel
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libGLU.so
784 %{_includedir}/GL/glu.h
785 %{_includedir}/GL/glu_mangle.h
786 %{_pkgconfigdir}/glu.pc
787
788 %files libGLU-static
789 %defattr(644,root,root,755)
790 %{_libdir}/libGLU.a
791
792 %files libGLw
793 %defattr(644,root,root,755)
794 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
795 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
796
797 %files libGLw-devel
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libGLw.so
800 %{_includedir}/GL/GLwDrawA.h
801 %{_includedir}/GL/GLwDrawAP.h
802 %{_includedir}/GL/GLwMDrawA.h
803 %{_includedir}/GL/GLwMDrawAP.h
804 %{_pkgconfigdir}/glw.pc
805
806 %files libGLw-static
807 %defattr(644,root,root,755)
808 %{_libdir}/libGLw.a
809
810 %files libOSMesa
811 %defattr(644,root,root,755)
812 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
813 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.[0-9]
814
815 %files libOSMesa-devel
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libOSMesa.so
818 %{_includedir}/GL/osmesa.h
819 %{_pkgconfigdir}/osmesa.pc
820
821 %files libOSMesa-static
822 %defattr(644,root,root,755)
823 %{_libdir}/libOSMesa.a
824
825 %files utils
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_bindir}/glxgears
828 %attr(755,root,root) %{_bindir}/glxinfo
829
830 %files dri-driver-ati-mach64
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
833
834 %files dri-driver-ati-radeon-R100
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
837
838 %files dri-driver-ati-radeon-R200
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
841
842 %files dri-driver-ati-radeon-R300
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
845
846 %files dri-driver-ati-rage128
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
849
850 # sunffb (sparc only)
851 %ifarch sparc sparcv9 sparc64
852 %files dri-driver-ffb
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
855 %endif
856
857 # glint (requires update)
858 %if 0
859 %files dri-driver-glint
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
862 %endif
863
864 %files dri-driver-intel-i810
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
867
868 %files dri-driver-intel-i915
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
871
872 %files dri-driver-intel-i965
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
875
876 %files dri-driver-matrox
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
879
880 %files dri-driver-s3virge
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
883
884 %files dri-driver-savage
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
887
888 %ifarch %{ix86} %{x8664}
889 %files dri-driver-sis
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
892 %endif
893
894 %files dri-driver-swrast
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
897
898 %files dri-driver-tdfx
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
901
902 %files dri-driver-trident
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
905
906 %files dri-driver-via-unichrome
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
909
910 %files demos
911 %defattr(644,root,root,755)
912 %{_examplesdir}/%{name}-%{version}
This page took 0.189041 seconds and 3 git commands to generate.