]> git.pld-linux.org Git - packages/Mesa.git/blob - Mesa.spec
- added tdfx patch (fixes crash on init and non-existing visuals)
[packages/Mesa.git] / Mesa.spec
1 #
2 # TODO:
3 # - subpackage with non-dri libGL for use with X-servers with missing GLX extension?
4 #
5 # Conditional build:
6 %bcond_without  motif   # build static libGLw without Motif interface
7 %bcond_with     multigl # package libGL in a way allowing concurrent install with nvidia/fglrx drivers
8 %bcond_with     ttm     # enable TTM API
9 #
10 # minimal supported xserver version
11 %define         xserver_ver     1.5.0
12 # glapi version (glapi tables in dri drivers and libglx must be in sync);
13 # set to current Mesa version on ABI break, when xserver tables get regenerated
14 # (until they start to be somehow versioned themselves)
15 %define         glapi_ver       7.1.0
16 Summary:        Free OpenGL implementation
17 Summary(pl.UTF-8):      Wolnodostępna implementacja standardu OpenGL
18 Name:           Mesa
19 Version:        7.1
20 Release:        1.1%{?with_multigl:.mgl}
21 License:        MIT (core), SGI (GLU,libGLw) and others - see license.html file
22 Group:          X11/Libraries
23 Source0:        http://dl.sourceforge.net/mesa3d/%{name}Lib-%{version}.tar.bz2
24 # Source0-md5:  6bff7f532d16f90f944a400c8bd7074d
25 Source1:        http://dl.sourceforge.net/mesa3d/%{name}Demos-%{version}.tar.bz2
26 # Source1-md5:  abfc9775e1462363af8ec160d1feb01f
27 Patch0:         %{name}-realclean.patch
28 Patch1:         %{name}-dri_mm.patch
29 Patch2:         %{name}-tdfx.patch
30 URL:            http://www.mesa3d.org/
31 BuildRequires:  expat-devel
32 BuildRequires:  libdrm-devel >= 2.3.1
33 %{?with_ttm:BuildRequires:      libdrm-devel >= 2.4.0}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool >= 2:1.4d
36 %{?with_motif:BuildRequires:    motif-devel}
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  xorg-lib-libXdamage-devel
39 BuildRequires:  xorg-lib-libXt-devel
40 BuildRequires:  xorg-lib-libXxf86vm-devel
41 BuildRequires:  xorg-proto-dri2proto-devel
42 BuildRequires:  xorg-proto-glproto-devel
43 BuildRequires:  xorg-proto-printproto-devel
44 BuildRequires:  xorg-util-makedepend
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Mesa is a 3-D graphics library with an API which is very similar to
49 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
50 syntax or state machine, it is being used with authorization from
51 Silicon Graphics, Inc. However, the author does not possess an OpenGL
52 license from SGI, and makes no claim that Mesa is in any way a
53 compatible replacement for OpenGL or associated with SGI.
54
55 %description -l pl.UTF-8
56 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
57 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
58 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
59 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
60 OpenGL ani powiązana z SGI.
61
62 %package libGL
63 Summary:        Free Mesa3D implementation of libGL OpenGL library
64 Summary(pl.UTF-8):      Wolnodostępna implementacja Mesa3D biblioteki libGL ze standardu OpenGL
65 License:        MIT
66 Group:          X11/Libraries
67 Requires:       libdrm >= 2.2.0
68 Provides:       OpenGL = 2.1
69 # reports version 1.3, but supports glXGetProcAddress() from 1.4
70 Provides:       OpenGL-GLX = 1.4
71 Obsoletes:      Mesa
72 Obsoletes:      Mesa-dri
73 Obsoletes:      X11-OpenGL-libGL < 1:7.0.0
74 Obsoletes:      XFree86-OpenGL-libGL < 1:7.0.0
75
76 %description libGL
77 Mesa is a 3-D graphics library with an API which is very similar to
78 that of OpenGL(R). To the extent that Mesa utilizes the OpenGL command
79 syntax or state machine, it is being used with authorization from
80 Silicon Graphics, Inc. However, the author does not possess an OpenGL
81 license from SGI, and makes no claim that Mesa is in any way a
82 compatible replacement for OpenGL or associated with SGI.
83
84 This package contains libGL which implements OpenGL 1.5 and GLX 1.4
85 specifications. It uses DRI for rendering.
86
87 %description libGL -l pl.UTF-8
88 Mesa jest biblioteką grafiki 3D z API bardzo podobnym do OpenGL(R). Do
89 tego stopnia, że Mesa używa składni i automatu OpenGL jest używana z
90 autoryzacją Silicon Graphics, Inc. Jednak autor nie posiada licencji
91 OpenGL od SGI i nie twierdzi, że Mesa jest kompatybilnym zamiennikiem
92 OpenGL ani powiązana z SGI.
93
94 Ten pakiet zawiera libGL implementującą specyfikacje OpenGL 1.5 oraz
95 GLX 1.4. Używa DRI do renderowania.
96
97 %package libGL-devel
98 Summary:        Header files for Mesa3D libGL library
99 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libGL z projektu Mesa3D
100 License:        MIT
101 Group:          X11/Development/Libraries
102 # loose dependency on libGL to use with other libGL binaries
103 Requires:       OpenGL >= 1.5
104 Requires:       xorg-lib-libX11-devel
105 Provides:       OpenGL-devel = 2.1
106 Provides:       OpenGL-GLX-devel = 1.4
107 Obsoletes:      Mesa-devel
108 Obsoletes:      X11-OpenGL-devel < 1:7.0.0
109 Obsoletes:      X11-OpenGL-devel-base < 1:7.0.0
110 Obsoletes:      XFree86-OpenGL-devel < 1:7.0.0
111 Obsoletes:      XFree86-OpenGL-devel-base < 1:7.0.0
112
113 %description libGL-devel
114 Header files for Mesa3D libGL library.
115
116 %description libGL-devel -l pl.UTF-8
117 Pliki nagłówkowe biblioteki libGL z projektu Mesa3D.
118
119 %package libGL-static
120 Summary:        Static Mesa3D libGL library
121 Summary(pl.UTF-8):      Statyczna biblioteka libGL z projektu Mesa3D
122 License:        MIT
123 Group:          X11/Development/Libraries
124 Requires:       %{name}-libGL-devel = %{version}-%{release}
125 Provides:       OpenGL-static = 2.1
126 Obsoletes:      Mesa-static
127 Obsoletes:      X11-OpenGL-static < 1:7.0.0
128 Obsoletes:      XFree86-OpenGL-static < 1:7.0.0
129
130 %description libGL-static
131 Static Mesa3D libGL library. It uses software renderer.
132
133 %description libGL-static -l pl.UTF-8
134 Statyczna biblioteka libGL z projektu Mesa3D. Używa programowego
135 renderingu.
136
137 %package libGLU
138 Summary:        SGI implementation of libGLU OpenGL library
139 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
140 License:        SGI Free Software License B v1.1
141 Group:          Libraries
142 # loose dependency on libGL.so.1 to use with other libGL binaries
143 Requires:       OpenGL >= 1.2
144 Provides:       OpenGL-GLU = 1.3
145 Obsoletes:      Mesa-devel
146 Obsoletes:      X11-OpenGL-libs < 1:7.0.0
147 Obsoletes:      XFree86-OpenGL-libs < 1:7.0.0
148
149 %description libGLU
150 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
151 1.3 specifications.
152
153 %description libGLU -l pl.UTF-8
154 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
155 specyfikację OpenGL GLU 1.3.
156
157 %package libGLU-devel
158 Summary:        Header files for SGI libGLU library
159 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
160 License:        SGI Free Software License B v1.1
161 Group:          Development/Libraries
162 Requires:       %{name}-libGLU = %{version}-%{release}
163 Requires:       OpenGL-devel >= 1.2
164 Requires:       libstdc++-devel
165 Provides:       OpenGL-GLU-devel = 1.3
166
167 %description libGLU-devel
168 Header files for SGI libGLU library.
169
170 %description libGLU-devel -l pl.UTF-8
171 Pliki nagłówkowe biblioteki SGI libGLU.
172
173 %package libGLU-static
174 Summary:        Static SGI libGLU library
175 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
176 License:        SGI Free Software License B v1.1
177 Group:          Development/Libraries
178 Requires:       %{name}-libGLU-devel = %{version}-%{release}
179 Provides:       OpenGL-GLU-static = 1.3
180
181 %description libGLU-static
182 Static SGI libGLU library.
183
184 %description libGLU-static -l pl.UTF-8
185 Statyczna biblioteka SGI libGLU.
186
187 %package libGLw
188 Summary:        SGI OpenGL Xt widgets library
189 Summary(pl.UTF-8):      Biblioteka SGI widgetów Xt dla OpenGL-a
190 License:        SGI MIT-like
191 Group:          Libraries
192 # loose dependency on libGL.so.1 to use with other libGL binaries
193 Requires:       OpenGL >= 1.1
194 Provides:       OpenGL-GLw
195
196 %description libGLw
197 SGI OpenGL Xt widgets library.
198
199 %description libGLU -l pl.UTF-8
200 Biblioteka SGI widgetów Xt dla OpenGL-a.
201
202 %package libGLw-devel
203 Summary:        Header files for SGI libGLw library
204 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLw
205 License:        SGI MIT-like
206 Group:          Development/Libraries
207 Requires:       %{name}-libGLw = %{version}-%{release}
208 Requires:       OpenGL-devel >= 1.2
209 Provides:       OpenGL-GLw-devel
210
211 %description libGLw-devel
212 Header files for SGI libGLw library.
213
214 %description libGLw-devel -l pl.UTF-8
215 Pliki nagłówkowe biblioteki SGI libGLw.
216
217 %package libGLw-static
218 Summary:        Static SGI libGLw library
219 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLw
220 License:        SGI MIT-like
221 Group:          Development/Libraries
222 Requires:       %{name}-libGLw-devel = %{version}-%{release}
223 Provides:       OpenGL-GLw-static
224
225 %description libGLw-static
226 Static SGI libGLw library.
227
228 %description libGLw-static -l pl.UTF-8
229 Statyczna biblioteka SGI libGLw.
230
231 %package libOSMesa
232 Summary:        OSMesa (off-screen renderer) library
233 Summary(pl.UTF-8):      Biblioteka OSMesa (renderująca bitmapy w pamięci)
234 License:        MIT
235 Group:          Libraries
236 # doesn't require base
237
238 %description libOSMesa
239 OSMesa (off-screen renderer) library.
240
241 %description libOSMesa -l pl.UTF-8
242 Biblioteka OSMesa (renderująca bitmapy w pamięci).
243
244 %package libOSMesa-devel
245 Summary:        Header file for OSMesa (off-screen renderer) library
246 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci)
247 License:        MIT
248 Group:          Development/Libraries
249 Requires:       %{name}-libOSMesa = %{version}-%{release}
250 # for <GL/gl.h> only
251 Requires:       OpenGL-devel
252
253 %description libOSMesa-devel
254 Header file for OSMesa (off-screen renderer) library.
255
256 %description libOSMesa-devel -l pl.UTF-8
257 Plik nagłówkowy biblioteki OSMesa (renderującej bitmapy w pamięci).
258
259 %package libOSMesa-static
260 Summary:        Static OSMesa (off-screen renderer) library
261 Summary(pl.UTF-8):      Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci)
262 License:        MIT
263 Group:          Development/Libraries
264 Requires:       %{name}-libOSMesa-devel = %{version}-%{release}
265 # this static build of OSMesa needs static non-dri Mesa implementation
266 Requires:       %{name}-libGL-static = %{version}-%{release}
267
268 %description libOSMesa-static
269 Static OSMesa (off-screen renderer) library.
270
271 %description libOSMesa-static -l pl.UTF-8
272 Biblioteka statyczna OSMesa (renderująca bitmapy w pamięci).
273
274 %package utils
275 Summary:        OpenGL utilities from Mesa3D
276 Summary(pl.UTF-8):      Programy narzędziowe OpenGL z projektu Mesa3D
277 License:        MIT
278 Group:          X11/Applications/Graphics
279 # loose deps on libGL/libGLU
280
281 %description utils
282 OpenGL utilities from Mesa3D: glxgears and glxinfo.
283
284 %description utils -l pl.UTF-8
285 Programy narzędziowe OpenGL z projektu Mesa3D: glxgears i glxinfo.
286
287 %package demos
288 Summary:        Mesa Demos source code
289 Summary(pl.UTF-8):      Kod źródłowy programów demonstrujących dla bibliotek Mesa
290 License:        various (MIT, SGI, GPL - see copyright notes in sources)
291 Group:          Development/Libraries
292 Requires:       OpenGL-devel
293
294 %description demos
295 Demonstration programs for the Mesa libraries in source code form.
296
297 %description demos -l pl.UTF-8
298 Kod źródłowy programów demonstracyjnych dla bibliotek Mesa.
299
300 %package dri-driver-ati-mach64
301 Summary:        X.org DRI driver for ATI Mach64 card family
302 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Mach64
303 License:        MIT
304 Group:          X11/Libraries
305 Requires:       xorg-driver-video-mach64
306 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
307 Requires:       xorg-xserver-server >= %{xserver_ver}
308
309 %description dri-driver-ati-mach64
310 X.org DRI driver for ATI Mach64 card family.
311
312 %description dri-driver-ati-mach64 -l pl.UTF-8
313 Sterownik X.org DRI dla rodziny kart ATI Mach64.
314
315 %package dri-driver-ati-radeon-R100
316 Summary:        X.org DRI driver for ATI R100 card family
317 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R100
318 License:        MIT
319 Group:          X11/Libraries
320 Requires:       xorg-driver-video-ati
321 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
322 Requires:       xorg-xserver-server >= %{xserver_ver}
323 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
324
325 %description dri-driver-ati-radeon-R100
326 X.org DRI driver for ATI R100 card family (Radeon 7000-7500).
327
328 %description dri-driver-ati-radeon-R100 -l pl.UTF-8
329 Sterownik X.org DRI dla rodziny kart ATI R100 (Radeon 7000-7500).
330
331 %package dri-driver-ati-radeon-R200
332 Summary:        X.org DRI driver for ATI R200 card family
333 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R200
334 License:        MIT
335 Group:          X11/Libraries
336 Requires:       xorg-driver-video-ati
337 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
338 Requires:       xorg-xserver-server >= %{xserver_ver}
339 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
340
341 %description dri-driver-ati-radeon-R200
342 X.org DRI driver for ATI R200 card family (Radeon 8500-92xx)
343
344 %description dri-driver-ati-radeon-R200 -l pl.UTF-8
345 Sterownik X.org DRI dla rodziny kart ATI R200 (Radeon 8500-92xx).
346
347 %package dri-driver-ati-radeon-R300
348 Summary:        X.org DRI driver for ATI R300 card family
349 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI R300
350 License:        MIT
351 Group:          X11/Libraries
352 Requires:       xorg-driver-video-ati
353 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
354 Requires:       xorg-xserver-server >= %{xserver_ver}
355 Obsoletes:      X11-driver-radeon-dri < 1:7.0.0
356
357 %description dri-driver-ati-radeon-R300
358 X.org DRI driver for ATI R300 card family.
359
360 %description dri-driver-ati-radeon-R300 -l pl.UTF-8
361 Sterownik X.org DRI dla rodziny kart ATI R300.
362
363 %package dri-driver-ati-rage128
364 Summary:        X.org DRI driver for ATI Rage128 card family
365 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart ATI Rage128
366 License:        MIT
367 Group:          X11/Libraries
368 Requires:       xorg-driver-video-r128
369 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
370 Requires:       xorg-xserver-server >= %{xserver_ver}
371 Obsoletes:      X11-driver-r128-dri < 1:7.0.0
372
373 %description dri-driver-ati-rage128
374 X.org DRI driver for ATI Rage128 card family.
375
376 %description dri-driver-ati-rage128 -l pl.UTF-8
377 Sterownik X.org DRI dla rodziny kart ATI Rage128.
378
379 %package dri-driver-ffb
380 Summary:        X.org DRI driver for Sun FFB card family
381 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Sun FFB
382 License:        MIT
383 Group:          X11/Libraries
384 Requires:       xorg-driver-video-sunffb
385 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
386 Requires:       xorg-xserver-server >= %{xserver_ver}
387
388 %description dri-driver-ffb
389 X.org DRI driver for SUN Creator3D and Elite3D card family.
390
391 %description dri-driver-ffb -l pl.UTF-8
392 Sterownik X.org DRI dla rodziny kart SUN Creator3D i Elite3D.
393
394 %package dri-driver-glint
395 Summary:        X.org DRI driver for GLINT/Permedia card family
396 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart GLINT/Permedia
397 License:        MIT
398 Group:          X11/Libraries
399 Requires:       xorg-driver-video-glint
400 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
401 Requires:       xorg-xserver-server >= %{xserver_ver}
402 Obsoletes:      X11-driver-glint-dri < 1:7.0.0
403
404 %description dri-driver-glint
405 X.org DRI driver for GLINT/Permedia card family.
406
407 %description dri-driver-glint -l pl.UTF-8
408 Sterownik X.org DRI dla rodziny kart GLINT/Permedia.
409
410 %package dri-driver-intel-i810
411 Summary:        X.org DRI driver for Intel i810 card family
412 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i810
413 License:        MIT
414 Group:          X11/Libraries
415 Requires:       xorg-driver-video-intel
416 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
417 Requires:       xorg-xserver-server >= %{xserver_ver}
418 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
419
420 %description dri-driver-intel-i810
421 X.org DRI driver for Intel i810 card family.
422
423 %description dri-driver-intel-i810 -l pl.UTF-8
424 Sterownik X.org DRI dla rodziny kart Intel i810.
425
426 %package dri-driver-intel-i915
427 Summary:        X.org DRI driver for Intel i915 card family
428 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i915
429 License:        MIT
430 Group:          X11/Libraries
431 Requires:       xorg-driver-video-intel
432 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
433 Requires:       xorg-xserver-server >= %{xserver_ver}
434 Obsoletes:      Mesa-dri-driver-intel-i830
435 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
436
437 %description dri-driver-intel-i915
438 X.org DRI driver for Intel i915 card family.
439
440 %description dri-driver-intel-i915 -l pl.UTF-8
441 Sterownik X.org DRI dla rodziny kart Intel i915.
442
443 %package dri-driver-intel-i965
444 Summary:        X.org DRI driver for Intel i965 card family
445 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Intel i965
446 License:        MIT
447 Group:          X11/Libraries
448 Requires:       xorg-driver-video-intel
449 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
450 Requires:       xorg-xserver-server >= %{xserver_ver}
451 Obsoletes:      Mesa-dri-driver-intel-i830
452 Obsoletes:      X11-driver-i810-dri < 1:7.0.0
453
454 %description dri-driver-intel-i965
455 X.org DRI driver for Intel i965 card family.
456
457 %description dri-driver-intel-i965 -l pl.UTF-8
458 Sterownik X.org DRI dla rodziny kart Intel i965.
459
460 %package dri-driver-matrox
461 Summary:        X.org DRI driver for Matrox G card family
462 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Matrox G
463 License:        MIT
464 Group:          X11/Libraries
465 Requires:       xorg-driver-video-mga
466 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
467 Requires:       xorg-xserver-server >= %{xserver_ver}
468 Obsoletes:      X11-driver-mga-dri < 1:7.0.0
469
470 %description dri-driver-matrox
471 X.org DRI drivers for Matrox G card family.
472
473 %description dri-driver-matrox -l pl.UTF-8
474 Sterowniki X.org DRI dla rodziny kart Matrox G.
475
476 %package dri-driver-s3virge
477 Summary:        X.org DRI driver for S3 Virge card family
478 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Virge
479 License:        MIT
480 Group:          X11/Libraries
481 Requires:       xorg-driver-video-s3virge
482 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
483 Requires:       xorg-xserver-server >= %{xserver_ver}
484
485 %description dri-driver-s3virge
486 X.org DRI driver for S3 Virge card family.
487
488 %description dri-driver-s3virge -l pl.UTF-8
489 Sterownik X.org DRI dla rodziny kart S3 Virge.
490
491 %package dri-driver-savage
492 Summary:        X.org DRI driver for S3 Savage card family
493 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart S3 Savage
494 License:        MIT
495 Group:          X11/Libraries
496 Requires:       xorg-driver-video-savage
497 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
498 Requires:       xorg-xserver-server >= %{xserver_ver}
499
500 %description dri-driver-savage
501 X.org DRI driver for S3 Savage card family.
502
503 %description dri-driver-savage -l pl.UTF-8
504 Sterownik X.org DRI dla rodziny kart S3 Savage.
505
506 %package dri-driver-sis
507 Summary:        X.org DRI driver for SiS card family
508 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart SiS
509 License:        MIT
510 Group:          X11/Libraries
511 Requires:       xorg-driver-video-sis
512 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
513 Requires:       xorg-xserver-server >= %{xserver_ver}
514 Obsoletes:      X11-driver-sis-dri < 1:7.0.0
515
516 %description dri-driver-sis
517 X.org DRI driver for SiS card family.
518
519 %description dri-driver-sis -l pl.UTF-8
520 Sterownik X.org DRI dla rodziny kart SiS.
521
522 %package dri-driver-swrast
523 Summary:        X.org DRI software rasterizer driver
524 Summary(pl.UTF-8):      Sterownik X.org DRI obsługujący rysowanie programowe
525 License:        MIT
526 Group:          X11/Libraries
527 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
528 Requires:       xorg-xserver-server >= %{xserver_ver}
529
530 %description dri-driver-swrast
531 X.org DRI software rasterizer driver.
532
533 %description dri-driver-swrast -l pl.UTF-8
534 Sterownik X.org DRI obsługujący rysowanie programowe.
535
536 %package dri-driver-tdfx
537 Summary:        X.org DRI driver for 3DFX Voodoo card family
538 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart 3DFX Voodoo
539 License:        MIT
540 Group:          X11/Libraries
541 Requires:       Glide3-DRI
542 Requires:       xorg-driver-video-tdfx
543 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
544 Requires:       xorg-xserver-server >= %{xserver_ver}
545 Obsoletes:      X11-driver-tdfx-dri < 1:7.0.0
546
547 %description dri-driver-tdfx
548 X.org DRI driver for 3DFX Voodoo card family (Voodoo 3,4,5, Banshee
549 and Velocity 100/200).
550
551 %description dri-driver-tdfx -l pl.UTF-8
552 Sterownik X.org DRI dla rodziny kart 3DFX Voodoo. (Voodoo 3,4,5,
553 Banshee i Velocity 100/200).
554
555 %package dri-driver-trident
556 Summary:        X.org DRI driver for Trident card family
557 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart Trident
558 License:        MIT
559 Group:          X11/Libraries
560 Requires:       xorg-driver-video-trident
561 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
562 Requires:       xorg-xserver-server >= %{xserver_ver}
563
564 %description dri-driver-trident
565 X.org DRI drivers for Trident card family.
566
567 %description dri-driver-trident -l pl.UTF-8
568 Sterowniki X.org DRI dla rodziny kart Trident.
569
570 %package dri-driver-via-unichrome
571 Summary:        X.org DRI driver for VIA Unichrome card family
572 Summary(pl.UTF-8):      Sterownik X.org DRI dla rodziny kart VIA Unichrome
573 License:        MIT
574 Group:          X11/Libraries
575 Requires:       xorg-driver-video-via
576 Requires:       xorg-xserver-libglx(glapi) = %{glapi_ver}
577 Requires:       xorg-xserver-server >= %{xserver_ver}
578
579 %description dri-driver-via-unichrome
580 X.org DRI driver for VIA Unichrome card family.
581
582 %description dri-driver-via-unichrome -l pl.UTF-8
583 Sterownik X.org DRI dla rodziny kart VIA Unichrome.
584
585 %prep
586 %setup -q -b1
587 %patch0 -p0
588 %patch1 -p1
589 %patch2 -p1
590
591 # fix demos
592 find progs -type f|xargs sed -i -e "s,\.\./images/,%{_examplesdir}/%{name}-%{version}/images/,g"
593
594 # s3v, sis, trident missing there - don't override list from linux-dri
595 sed -i -e '/^DRI_DIRS/d' configs/linux-dri-x86-64
596
597 # add swrast driver
598 sed -i -e 's/ i810 / swrast i810 /' configs/linux-dri
599
600 %ifnarch sparc sparcv9 sparc64
601 # for sunffb driver - useful on sparc only
602 sed -i -e 's/ ffb\>//' configs/linux-dri
603 %endif
604
605 %ifnarch %{ix86} %{x8664}
606 # sis needs write-memory barrier
607 sed -i -e 's/ sis / /' configs/linux-dri
608 %endif
609
610 %build
611 # use $lib, not %{_lib} as Mesa uses lib64 only for *-x86-64* targets
612 %ifarch %{x8664}
613 targ=-x86-64
614 lib=lib64
615 %else
616 lib=lib
617 %ifarch %{ix86}
618 targ=-x86
619 %else
620 targ=""
621 %endif
622 %endif
623
624 # required for -bc --short-circuit
625 %{__make} realclean
626 # as above - existing directory makes mv move into instead of rename
627 rm -rf lib-{dri,osmesa,static}
628
629 %{__make} linux${targ}-static \
630         CC="%{__cc}" \
631         CXX="%{__cxx}" \
632         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing" \
633         XLIB_DIR=%{_libdir} \
634         GLW_SOURCES="GLwDrawA.c%{?with_motif: GLwMDrawA.c}" \
635         SRC_DIRS="mesa glu glw" \
636         PROGRAM_DIRS=
637 mv -f ${lib} lib-static
638 %{__make} realclean
639
640 %{__make} linux-osmesa \
641         CC="%{__cc}" \
642         CXX="%{__cxx}" \
643         CFLAGS="%{rpmcflags} -fno-strict-aliasing" \
644         XLIB_DIR=%{_libdir} \
645         SRC_DIRS="mesa" \
646         PROGRAM_DIRS=
647 mv -f lib lib-osmesa
648 %{__make} realclean
649
650 %{__make} linux-dri${targ} \
651         CC="%{__cc}" \
652         CXX="%{__cxx}" \
653         MKDEP=makedepend \
654         OPT_FLAGS="%{rpmcflags} -fno-strict-aliasing %{?with_ttm:-DTTM_API}" \
655         XLIB_DIR=%{_libdir} \
656         DRI_DRIVER_SEARCH_DIR=%{_libdir}/xorg/modules/dri \
657         SRC_DIRS="glx/x11 mesa glu glw" \
658         PROGRAM_DIRS=
659
660 %{__make} -C progs/xdemos \
661         CC="%{__cc}" \
662         CXX="%{__cxx}" \
663         OPT_FLAGS="%{rpmcflags}" \
664         XLIB_DIR=%{_libdir} \
665         PROGS="glxgears" \
666         APP_LIB_DEPS="-L../../${lib} -lGL"
667
668 %{__make} -C progs/xdemos \
669         CC="%{__cc}" \
670         CXX="%{__cxx}" \
671         OPT_FLAGS="%{rpmcflags}" \
672         XLIB_DIR=%{_libdir} \
673         PROGS="glxinfo" \
674         APP_LIB_DEPS="-L../../${lib} -lGL -lGLU"
675
676 mv -f ${lib} lib-dri
677
678 for d in mesa glu glw ; do
679         %{__make} -C src/$d `basename src/$d/*.pc.in .in` \
680                 INSTALL_DIR=%{_prefix} \
681                 LIB_DIR=%{_lib}
682 done
683
684 %install
685 rm -rf $RPM_BUILD_ROOT
686 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/GL/internal,%{_pkgconfigdir},%{_examplesdir}/%{name}-%{version}}
687 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
688
689 cp -df lib-static/lib* $RPM_BUILD_ROOT%{_libdir}
690 cp -df lib-osmesa/libOSMesa* $RPM_BUILD_ROOT%{_libdir}
691 cp -df lib-dri/lib* $RPM_BUILD_ROOT%{_libdir}
692 cp -rf include/GL/{gl[!f]*,osmesa.h,xmesa*} src/glw/GLw*.h $RPM_BUILD_ROOT%{_includedir}/GL
693 cp -rf include/GL/internal/dri_interface.h $RPM_BUILD_ROOT%{_includedir}/GL/internal
694 cp -df lib-dri/*_dri.so $RPM_BUILD_ROOT%{_libdir}/xorg/modules/dri
695
696 install src/mesa/gl.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
697 install src/glu/glu.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
698 install src/glw/glw.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
699
700 install progs/xdemos/{glxgears,glxinfo} $RPM_BUILD_ROOT%{_bindir}
701 # work on copy to keep -bi --short-circuit working
702 rm -rf progs-clean
703 install -d progs-clean
704 for l in demos glsl osdemos redbook samples xdemos ; do
705         cp -a progs/$l progs-clean/$l
706         %{__make} -C progs-clean/$l clean
707         cp -Rf progs-clean/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
708 done
709 rm -rf progs-clean
710 for l in util images ; do
711         cp -Rf progs/$l $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$l
712 done
713 rm -rf $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*/{.deps,CVS,Makefile.{BeOS*,win,cygnus,DJ,dja}}
714
715 %if %{with multigl}
716 install -d $RPM_BUILD_ROOT{%{_libdir}/Mesa,%{_sysconfdir}/ld.so.conf.d}
717
718 mv -f $RPM_BUILD_ROOT%{_libdir}/libGL.so.* $RPM_BUILD_ROOT%{_libdir}/Mesa
719 ln -sf Mesa/libGL.so.1 $RPM_BUILD_ROOT%{_libdir}/libGL.so
720
721 echo %{_libdir}/Mesa >$RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/Mesa.conf
722 %endif
723
724 %clean
725 rm -rf $RPM_BUILD_ROOT
726
727 %post   libGL -p /sbin/ldconfig
728 %postun libGL -p /sbin/ldconfig
729
730 %post   libGLU -p /sbin/ldconfig
731 %postun libGLU -p /sbin/ldconfig
732
733 %post   libGLw -p /sbin/ldconfig
734 %postun libGLw -p /sbin/ldconfig
735
736 %files libGL
737 %defattr(644,root,root,755)
738 %doc docs/{*.html,README.{3DFX,GGI,MITS,QUAKE,THREADS},RELNOTES*}
739 %if %{with multigl}
740 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ld.so.conf.d/Mesa.conf
741 %dir %{_libdir}/Mesa
742 %attr(755,root,root) %{_libdir}/Mesa/libGL.so.*.*
743 %attr(755,root,root) %ghost %{_libdir}/Mesa/libGL.so.1
744 %else
745 %attr(755,root,root) %{_libdir}/libGL.so.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libGL.so.1
747 # symlink for binary apps which fail to conform Linux OpenGL ABI
748 # (and dlopen libGL.so instead of libGL.so.1)
749 %attr(755,root,root) %{_libdir}/libGL.so
750 %endif
751
752 %files libGL-devel
753 %defattr(644,root,root,755)
754 %doc docs/*.spec
755 %if %{with multigl}
756 %attr(755,root,root) %{_libdir}/libGL.so
757 %endif
758 %dir %{_includedir}/GL
759 %{_includedir}/GL/gl.h
760 %{_includedir}/GL/glext.h
761 %{_includedir}/GL/gl_mangle.h
762 %{_includedir}/GL/glx.h
763 %{_includedir}/GL/glxext.h
764 %{_includedir}/GL/glx_mangle.h
765 %dir %{_includedir}/GL/internal
766 %{_includedir}/GL/internal/dri_interface.h
767 %{_pkgconfigdir}/gl.pc
768
769 %files libGL-static
770 %defattr(644,root,root,755)
771 %{_libdir}/libGL.a
772 # x11 (non-dri) Mesa API
773 %{_includedir}/GL/xmesa.h
774 %{_includedir}/GL/xmesa_x.h
775 %{_includedir}/GL/xmesa_xf86.h
776
777 %files libGLU
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/libGLU.so.*.*
780 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
781
782 %files libGLU-devel
783 %defattr(644,root,root,755)
784 %attr(755,root,root) %{_libdir}/libGLU.so
785 %{_includedir}/GL/glu.h
786 %{_includedir}/GL/glu_mangle.h
787 %{_pkgconfigdir}/glu.pc
788
789 %files libGLU-static
790 %defattr(644,root,root,755)
791 %{_libdir}/libGLU.a
792
793 %files libGLw
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_libdir}/libGLw.so.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libGLw.so.1
797
798 %files libGLw-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libGLw.so
801 %{_includedir}/GL/GLwDrawA.h
802 %{_includedir}/GL/GLwDrawAP.h
803 %{_includedir}/GL/GLwMDrawA.h
804 %{_includedir}/GL/GLwMDrawAP.h
805 %{_pkgconfigdir}/glw.pc
806
807 %files libGLw-static
808 %defattr(644,root,root,755)
809 %{_libdir}/libGLw.a
810
811 %files libOSMesa
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libOSMesa.so.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libOSMesa.so.[0-9]
815
816 %files libOSMesa-devel
817 %defattr(644,root,root,755)
818 %attr(755,root,root) %{_libdir}/libOSMesa.so
819 %{_includedir}/GL/osmesa.h
820
821 %files libOSMesa-static
822 %defattr(644,root,root,755)
823 %{_libdir}/libOSMesa.a
824
825 %files utils
826 %defattr(644,root,root,755)
827 %attr(755,root,root) %{_bindir}/glxgears
828 %attr(755,root,root) %{_bindir}/glxinfo
829
830 %files dri-driver-ati-mach64
831 %defattr(644,root,root,755)
832 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mach64_dri.so
833
834 %files dri-driver-ati-radeon-R100
835 %defattr(644,root,root,755)
836 %attr(755,root,root) %{_libdir}/xorg/modules/dri/radeon_dri.so
837
838 %files dri-driver-ati-radeon-R200
839 %defattr(644,root,root,755)
840 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r200_dri.so
841
842 %files dri-driver-ati-radeon-R300
843 %defattr(644,root,root,755)
844 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r300_dri.so
845
846 %files dri-driver-ati-rage128
847 %defattr(644,root,root,755)
848 %attr(755,root,root) %{_libdir}/xorg/modules/dri/r128_dri.so
849
850 # sunffb (sparc only)
851 %ifarch sparc sparcv9 sparc64
852 %files dri-driver-ffb
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_libdir}/xorg/modules/dri/ffb_dri.so
855 %endif
856
857 # glint (requires update)
858 %if 0
859 %files dri-driver-glint
860 %defattr(644,root,root,755)
861 %attr(755,root,root) %{_libdir}/xorg/modules/dri/gamma_dri.so
862 %endif
863
864 %files dri-driver-intel-i810
865 %defattr(644,root,root,755)
866 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i810_dri.so
867
868 %files dri-driver-intel-i915
869 %defattr(644,root,root,755)
870 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i915_dri.so
871
872 %files dri-driver-intel-i965
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_libdir}/xorg/modules/dri/i965_dri.so
875
876 %files dri-driver-matrox
877 %defattr(644,root,root,755)
878 %attr(755,root,root) %{_libdir}/xorg/modules/dri/mga_dri.so
879
880 %files dri-driver-s3virge
881 %defattr(644,root,root,755)
882 %attr(755,root,root) %{_libdir}/xorg/modules/dri/s3v_dri.so
883
884 %files dri-driver-savage
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/xorg/modules/dri/savage_dri.so
887
888 %ifarch %{ix86} %{x8664}
889 %files dri-driver-sis
890 %defattr(644,root,root,755)
891 %attr(755,root,root) %{_libdir}/xorg/modules/dri/sis_dri.so
892 %endif
893
894 %files dri-driver-swrast
895 %defattr(644,root,root,755)
896 %attr(755,root,root) %{_libdir}/xorg/modules/dri/swrast_dri.so
897
898 %files dri-driver-tdfx
899 %defattr(644,root,root,755)
900 %attr(755,root,root) %{_libdir}/xorg/modules/dri/tdfx_dri.so
901
902 %files dri-driver-trident
903 %defattr(644,root,root,755)
904 %attr(755,root,root) %{_libdir}/xorg/modules/dri/trident_dri.so
905
906 %files dri-driver-via-unichrome
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_libdir}/xorg/modules/dri/unichrome_dri.so
909
910 %files demos
911 %defattr(644,root,root,755)
912 %{_examplesdir}/%{name}-%{version}
This page took 0.084606 seconds and 3 git commands to generate.