]> git.pld-linux.org Git - packages/Mesa-libGLU.git/blob - Mesa-libGLU.spec
9af09a7346b55d47df8fd813d659169606147509
[packages/Mesa-libGLU.git] / Mesa-libGLU.spec
1 #
2 # Conditional build:
3 %bcond_with     glvnd           # use GLVND as OpenGL provider
4 %bcond_with     osmesa          # use OSMesa as OpenGL provider
5 %bcond_without  static_libs     # static library
6 #
7 %if %{without glvnd} && %{without osmesa}
8 %define with_generic_opengl     1
9 %endif
10 Summary:        SGI implementation of libGLU OpenGL library
11 Summary(pl.UTF-8):      Implementacja SGI biblioteki libGLU ze standardu OpenGL
12 Name:           Mesa-libGLU
13 Version:        9.0.2
14 Release:        1
15 License:        SGI Free Software License B v2.0 (MIT-like)
16 Group:          Libraries
17 Source0:        ftp://ftp.freedesktop.org/pub/mesa/glu/glu-%{version}.tar.xz
18 # Source0-md5:  2b0f13fa5b949bfb3a995927c6e35125
19 URL:            http://www.mesa3d.org/
20 %{?with_osmesa:BuildRequires:   Mesa-libOSMesa-devel}
21 %{?with_generic_opengl:BuildRequires:   OpenGL-devel >= 1.2}
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake
24 %{?with_glvnd:BuildRequires:    libglvnd-libGL-devel}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:2.2
27 BuildRequires:  pkgconfig
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       OpenGL >= 1.2
31 Provides:       OpenGL-GLU = 1.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 SGI implementation of libGLU OpenGL library. It implements OpenGL GLU
36 1.3 specifications.
37
38 %description -l pl.UTF-8
39 Implementacja SGI biblioteki libGLU ze standardu OpenGL. Implementuje
40 specyfikację OpenGL GLU 1.3.
41
42 %package devel
43 Summary:        Header files for SGI libGLU library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki SGI libGLU
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 %{?with_osmesa:Requires:        Mesa-libOSMesa-devel}
48 %{?with_generic_opengl:Requires:        OpenGL-devel >= 1.2}
49 %{?with_glvnd:Requires: libglvnd-libGL-devel}
50 Provides:       OpenGL-GLU-devel = 1.3
51
52 %description devel
53 Header files for SGI libGLU library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki SGI libGLU.
57
58 %package static
59 Summary:        Static SGI libGLU library
60 Summary(pl.UTF-8):      Statyczna biblioteka SGI libGLU
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63 Provides:       OpenGL-GLU-static = 1.3
64
65 %description static
66 Static SGI libGLU library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka SGI libGLU.
70
71 %prep
72 %setup -q -n glu-%{version}
73
74 %build
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__automake}
79 %configure \
80         %{?with_glvnd:--enable-libglvnd} \
81         %{?with_osmesa:--enable-osmesa} \
82         --disable-silent-rules \
83         %{!?with_static_libs:--disable-static}
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # there is pkg-config support; also, traditionally libGLU didn't have .la
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libGLU.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libGLU.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libGLU.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libGLU.so
110 %{_includedir}/GL/glu.h
111 %{_pkgconfigdir}/glu.pc
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libGLU.a
117 %endif
This page took 0.077764 seconds and 3 git commands to generate.