]> git.pld-linux.org Git - packages/Maverik.git/blob - Maverik.spec
f0265ba9f75d656ca6431e7b607eb92db11ca004
[packages/Maverik.git] / Maverik.spec
1 Summary:        A vr micro-Kernel
2 Name:           Maverik
3 Version:        5.1
4 Release:        1
5 Copyright:      GPL
6 Group:          Development/Libraries
7 Vendor:         Advanced Interfaces Group
8 Source0:        ftp://aig.cs.man.ac.uk/pub/aig/Maverik/%{name}-%{version}.tar.gz
9 Source1:        ftp://aig.cs.man.ac.uk/pub/aig/Maverik/%{name}Demos-%{version}.tar.gz
10 Source2:        Maverik-5.1-1.rpm-extras.tgz
11 Patch:          Maverik-5.1-1-linux.patch
12 URL:            http://hegel.cs.man.ac.uk/systems/Maverik/
13 Buildroot:      /tmp/%{name}-%{version}-root
14
15 %description
16 GNU Maverik is a framework and library for developing VR applications (it is
17 not an end-user application). It provides optimised management of graphics
18 and peripheral driving capabilities for a single user. A novel feature of
19 GNU MAVERIK is its direct use of the applications own data structures. This
20 means significant performance benefits can be achieved through application
21 specific optmisations.
22
23 Under GNU/Linux, GNU MAVERIK can use 3DFx VOODOO cards in pairs to drive stereo
24 headsets. See the web pages (http://aig.cs.man.ac.uk) for more detail, and
25 examples of applications written using GNU MAVERIK.
26
27
28 %package demos
29 Summary:        Maverik Demos
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}
32
33 %description demos
34 Maverik demos. AIGLab, EscapeCity and LegibleCity.
35
36 %prep
37 %setup -q
38 %setup -q -T -D -b 1
39 %setup -q -T -D -a 2
40 %patch -p 1
41
42 for i in doc/MFS/man3/*; do
43         if [ -L $i ]; then
44                 echo ".so `ls -l $i | awk '{print $11}'; rm -f $i`" > $i
45         fi
46 done
47
48 %build
49 #export OS_TYPE="Linux"
50 #export MAV_HOME=`pwd`
51 #source setup_env
52 ( ./setup --VRML97 --MESAPATH=/usr/X11R6 ; make ; make clean)
53
54 #export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${RPM_BUILD_DIR}/Maverik-3.0b4/lib/Linux
55 #(cd examples; make)
56
57 # dont make examples they need incl and lib paths setting, and those
58 # are different between our build and the installed build. Fix that
59 # one day. For now a useful test for the user to try.
60 #(cd examples ; make ; make clean)
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}
66 install -d $RPM_BUILD_ROOT/{%{_libdir},%{_includedir}/Maverik,%{_mandir}/man3}
67
68 install -s lib/*.so $RPM_BUILD_ROOT/%{_libdir}/
69 install incl/* $RPM_BUILD_ROOT/%{_includedir}/Maverik/
70
71 cp -a examples/* $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}/
72 cp -a demos $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version}/
73
74 find $RPM_BUILD_ROOT/%{_prefix}/src/examples/%{name}-%{version} -type f \
75         -exec strip --strip-unneeded {} \; || :
76
77 # manual
78 install doc/MFS/man3/* $RPM_BUILD_ROOT/%{_mandir}/man3/
79
80
81
82 gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man3/* README.rpm README FAQ VERSIONS \
83         doc/MPG/ps/mpg.ps doc/MFS/ps/mfs.ps
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(-,root,root,755)
90 %doc {README.rpm,README,FAQ,VERSIONS}.gz
91 %doc doc/MPG/ps/mpg.ps.gz doc/MFS/ps/mfs.ps.gz doc/MFS/html
92 %attr(755, root, root) %{_libdir}/*.so
93 %dir %{_includedir}/Maverik
94 %attr(644, root, root) %{_includedir}/Maverik/*
95 %attr(644, root, root) %{_mandir}/man3/*
96 %dir %{_prefix}/src/examples/%{name}-%{version}
97 %{_prefix}/src/examples/%{name}-%{version}/MPG
98 %{_prefix}/src/examples/%{name}-%{version}/kernel
99 %{_prefix}/src/examples/%{name}-%{version}/misc
100 %{_prefix}/src/examples/%{name}-%{version}/Makefile
101 %{_prefix}/src/examples/%{name}-%{version}/README
102
103 %files demos
104 %defattr(-,root,root,755)
105 %{_prefix}/src/examples/%{name}-%{version}/demos
This page took 0.089008 seconds and 3 git commands to generate.