]> git.pld-linux.org Git - packages/Lunchbox.git/blob - Lunchbox.spec
143bac8dd52e75bd7dec909925a1b4089dd73648
[packages/Lunchbox.git] / Lunchbox.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     mpi             # MPI support
5
6 Summary:        Lunchbox - C++ library for multi-threading programming
7 Summary(pl.UTF-8):      Lunchbox - biblioteka C++ do programowania wielowątkowego
8 Name:           Lunchbox
9 Version:        1.17.0
10 Release:        6
11 License:        LGPL v2.1
12 Group:          Libraries
13 #Source0Download: https://github.com/Eyescale/Lunchbox/releases
14 Source0:        https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  76bcd79003c9b9d58d5f772cfdd812c7
16 Patch0:         cxx.patch
17 Patch1:         nanosleep.patch
18 URL:            http://pogl.wordpress.com/category/lunchbox/
19 BuildRequires:  Eyescale-CMake >= 2018.02
20 BuildRequires:  Servus-devel >= 1.5.0
21 BuildRequires:  avahi-devel
22 BuildRequires:  boost-devel >= 1.41.0
23 BuildRequires:  cmake >= 3.1
24 %{?with_apidocs:BuildRequires:  doxygen}
25 BuildRequires:  hwloc-devel >= 1.3
26 BuildRequires:  hwloc-devel < 2
27 BuildRequires:  libstdc++-devel
28 %{?with_mpi:BuildRequires:      mpi-devel}
29 BuildRequires:  pkgconfig
30 Requires:       Servus >= 1.5.0
31 Requires:       hwloc-libs >= 1.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
36 formerly known as eq::base or co::base, the foundation for the
37 Equalizer parallel rendering framework and the Collage network
38 library. It is intended for all application developers creating
39 high-performance multi-threaded programs.
40
41 %description -l pl.UTF-8
42 Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
43 była znana jako eq::base lub co::base - podstawa szkieletu do
44 renderowania wielowątkowego Equalizer lub biblioteki sieciowej
45 Collage. Biblioteka jest przeznaczona dla wszystkich programistów
46 tworzących wysoko wydajne, wielowątkowe aplikacje.
47
48 %package devel
49 Summary:        Header files for Lunchbox library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lunchbox
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       Servus-devel >= 1.5.0
54 Requires:       boost-devel >= 1.41.0
55 Requires:       libstdc++-devel
56
57 %description devel
58 Header files for Lunchbox library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki Lunchbox.
62
63 %package apidocs
64 Summary:        Lunchbox API documentation
65 Summary(pl.UTF-8):      Dokumentacja API biblioteki Lunchbox
66 Group:          Documentation
67 BuildArch:      noarch
68
69 %description apidocs
70 API documentation for Lunchbox library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki Lunchbox.
74
75 %prep
76 %setup -q
77
78 rmdir CMake/common
79 ln -s %{_datadir}/Eyescale-CMake CMake/common
80
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 install -d build
86 cd build
87 %cmake .. \
88         -DCOMMON_DISABLE_WERROR:BOOL=ON \
89         %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON}
90
91 %{__make}
92
93 %if %{with apidocs}
94 doxygen doc/Doxyfile
95 %endif
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
114 %attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.10
116 %dir %{_datadir}/Lunchbox
117 %{_datadir}/Lunchbox/benchmarks
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libLunchbox.so
122 %{_includedir}/lunchbox
123 %{_datadir}/Lunchbox/CMake
124
125 %if %{with apidocs}
126 %files apidocs
127 %defattr(644,root,root,755)
128 %doc build/doc/html/*
129 %endif
This page took 0.077491 seconds and 2 git commands to generate.